Subject: Fwd: New Version Notification - draft-nottingham-http-link-header-08.txt

From: Mark Nottingham <[email-masked]>
Date: Tue, 2 Mar 2010 10:39:49 +1100

FYI.

Begin forwarded message:

> From: [email-masked]
> Date: 2 March 2010 12:00:01 AM AEDT
> To: [email-masked], [email-masked],[email-masked]
> Subject: New Version Notification - draft-nottingham-http-link-header-08.txt
> 
> New version (-08) has been submitted for draft-nottingham-http-link-header-08.txt.
> http://www.ietf.org/internet-drafts/draft-nottingham-http-link-header-08.txt
> 
> 
> Diff from previous version:
> http://tools.ietf.org/rfcdiff?url2=draft-nottingham-http-link-header-08
> 
> IETF Secretariat.

---

From: Michael Hausenblas <[email-masked]>
Date: Thu, 04 Mar 2010 15:59:33 +0000

Mark,

Would it still be possible to extend the "Link Relation Type registry" [1]
with a rel="meta" value? Use case would be ACLs as described in [2] (see
section 3.2). If this is not possible, what rel value would you advise to
use, instead?

Cheers,
      Michael

[1] 
http://tools.ietf.org/html/draft-nottingham-http-link-header-08#section-6.2
[2] http://dig.csail.mit.edu/2009/Papers/ISWC/rdf-access-control/paper.pdf

-- 
Dr. Michael Hausenblas
LiDRC - Linked Data Research Centre
DERI - Digital Enterprise Research Institute
NUIG - National University of Ireland, Galway
Ireland, Europe
Tel. +353 91 495730
http://linkeddata.deri.ie/
http://sw-app.org/about.html

> From: Mark Nottingham <[email-masked]>
> Date: Tue, 2 Mar 2010 10:39:49 +1100
> To: HTTP Working Group <[email-masked]>
> Subject: Fwd: New Version Notification -
> draft-nottingham-http-link-header-08.txt
> Resent-From: <[email-masked]>
> Resent-Date: Mon, 01 Mar 2010 23:40:36 +0000
> 
> FYI.
> 
> Begin forwarded message:
> 
>> To: [email-masked],
>> [email-masked],[email-masked]
>> New version (-08) has been submitted for
>> draft-nottingham-http-link-header-08.txt.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 9 Mar 2010 21:16:13 +1100

Hi Michael,

The draft is in IESG review at this point, and in any case the idea behind it is to include those relations currently in the registry or in HTML4, rather than be an all-inclusive listing.

So, the best thing to do would be to register a new value; you can start that process now, by starting to write the specification, in anticipation of the draft becoming an RFC.

Regards,

---

From: Michael Hausenblas <[email-masked]>
Date: Tue, 09 Mar 2010 10:33:16 +0000

Mark,

> The draft is in IESG review at this point, and in any case the idea behind it
> is to include those relations currently in the registry or in HTML4, rather
> than be an all-inclusive listing.

Understood. 

> So, the best thing to do would be to register a new value; you can start that
> process now, by starting to write the specification, in anticipation of the
> draft becoming an RFC.

Thanks! 

Just for clarification: I understand that your answer implies that none of
the existing, default rel-values in your draft apply here in our case and
hence it makes sense to register rel=meta, indeed.

Cheers,
      Michael

> Date: Tue, 9 Mar 2010 21:16:13 +1100
> To: Michael Hausenblas <[email-masked]>
> Cc: HTTP Working Group <[email-masked]>, Melvin Carvalho
> <[email-masked]>, Joe Presbrey <[email-masked]>, <[email-masked]>,
> Tim Berners-Lee <[email-masked]>
> Subject: Re: rel=meta and the Link Relation Type registry (was Re: New Version
> Notification -  draft-nottingham-http-link-header-08.txt)
> 
> Hi Michael,
> 
> The draft is in IESG review at this point, and in any case the idea behind it
> is to include those relations currently in the registry or in HTML4, rather
> than be an all-inclusive listing.
> 
> So, the best thing to do would be to register a new value; you can start that
> process now, by starting to write the specification, in anticipation of the
> draft becoming an RFC.
> 
> Regards,
> 
> 
http://www.ietf.org/internet-drafts/draft-nottingham-http-link-header-08.tx>>>>
t

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 9 Mar 2010 21:48:13 +1100

Ah. Good catch.

At first glance, it seems like what you want might be covered by describedby; see <http://www.w3.org/TR/powder-dr/#assoc-linking>. Even if you don't use POWDER itself, another media type might be workable...

Cheers,

--
Mark Nottingham     http://www.mnot.net/

---

From: Michael Hausenblas <[email-masked]>
Date: Tue, 09 Mar 2010 11:00:08 +0000

> At first glance, it seems like what you want might be covered by describedby;
> see <http://www.w3.org/TR/powder-dr/#assoc-linking>. Even if you don't use
> POWDER itself, another media type might be workable...

Interesting. Not totally sure about it, but possibly, yes ...

Will discuss with the DIG folks and come back to you if needed. Anyway,
thanks for your guidance!

Cheers,
      Michael

> From: Mark Nottingham <[email-masked]>
> Date: Tue, 9 Mar 2010 21:48:13 +1100
> To: Mark Nottingham <[email-masked]>
> Cc: Michael Hausenblas <[email-masked]>, HTTP Working Group
> <[email-masked]>, Melvin Carvalho <[email-masked]>, Joe
> Presbrey <[email-masked]>, <[email-masked]>, Tim Berners-Lee <[email-masked]>
> Subject: Re: rel=meta and the Link Relation Type registry (was Re: New
> Version Notification -  draft-nottingham-http-link-header-08.txt)
> 
> Ah. Good catch.
> 
> At first glance, it seems like what you want might be covered by describedby;
> see <http://www.w3.org/TR/powder-dr/#assoc-linking>. Even if you don't use
> POWDER itself, another media type might be workable...
> 
> Cheers,
> 
>