Subject: HTTPbis Range header

From: Nathan <[email-masked]>
Date: Fri, 05 Mar 2010 17:55:50 +0000

Hi All,

A very quick question.. is this valid:

   Range: 0

and if so would it be taken to mean return the entire entity?

Many Regards!

Nathan

---

From: Yves Lafon <[email-masked]>
Date: Sun, 7 Mar 2010 09:27:18 -0500 (EST)

> A very quick question.. is this valid:

No, it's an invalid syntax

> and if so would it be taken to mean return the entire entity?

No, it will ignore it (so in the end it will return the entire entity, but 
not based on the intent).

-- 
Baroula que barouleras, au tiéu toujou t'entourneras.

         ~~Yves

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 9 Mar 2010 20:25:41 +1100

The correct syntax would be
  Range: bytes=0-

Cheers,

--
Mark Nottingham     http://www.mnot.net/