Subject: no-cache response directive

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Mar 2010 16:19:01 +1100

2616's definition of the no-cache response directive <http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec14.9.1> says:

> If the no-cache directive does not specify a field-name, then a cache MUST NOT use the response to satisfy a subsequent request without successful revalidation with the origin server. This allows an origin server to prevent caching even by caches that have been configured to return stale responses to client requests.

This is misleading, because of the fuzzy definition of 'cacheable' in 2616. Our current text is:

>       The no-cache response directive indicates that the response MUST
>       NOT be used to satisfy a subsequent request without successful
>       validation on the origin server.  This allows an origin server to
>       prevent caching even by caches that have been configured to return
>       stale responses.

I propose this clarification:

"""
The no-cache response directive indicates that the response MUST NOT be used to satisfy a subsequent request without successful validation on the origin server. This allows an origin server to prevent a cache from using it to satisfy a request without contacting it, even by caches that have been configured to return stale responses.
"""

Thoughts?

--
Mark Nottingham     http://www.mnot.net/

---

From: Henrik Nordström <[email-masked]>
Date: Wed, 10 Mar 2010 15:36:57 +0100

ons 2010-03-10 klockan 16:19 +1100 skrev Mark Nottingham:

> The no-cache response directive indicates that the response MUST NOT
> be used to satisfy a subsequent request without successful validation
> on the origin server. This allows an origin server to prevent a cache
> from using it to satisfy a request without contacting it, even by
> caches that have been configured to return stale responses.
> """
> 
> Thoughts?

Looks good to me. Makes the purpose description match the rule
definition, which can not be said about the earlier versions..

The first sentence is the rule. The second is just an annotation to
explain the purpose of the rule.

Regards
Henrik