Subject: Re: #197: Effect of CC directives on history lists

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Mar 2010 15:50:24 +1100

I haven't heard anything else about this. Julian, please apply your patch, and I'll close the issue.

Cheers,

On 21/01/2010, at 10:02 AM, Mark Nottingham wrote:

> Yes, I think that's where discussion has lead us. I.e., the text in 2616, while still true to some degree, doesn't tell the whole story, and therefore is somewhat misleading (in that history lists aren't caches, but they also *can* honour cache directives, and sometimes it could be argued that they need to). 
> 
> As such, we're getting completely out of the history-list-specifying business, and only mentioning them in passing. 
> 
> 
> 
> On 20/01/2010, at 5:02 AM, Julian Reschke wrote:
> 
>> Mark Nottingham wrote:
>>> The intent was that it replace the third and forth paragraphs there ('existing text'), but looking at it, I think there's a pretty strong argument to 1) remove the second paragraph, and
>>> 2) remove the note
>>> Thoughts? This isn't a small change, but it does align with current practice, is for purposes of security, and doesn't make any currently conformant implementations non-conformant, AFAICT.
>> 
>> This will reduce Section 4 to:
>> 
>> 4.  History Lists
>> 
>>  User agents often have history mechanisms, such as "Back" buttons and
>>  history lists, that can be used to redisplay an entity retrieved
>>  earlier in a session.
>> 
>>  The freshness model (Section 2.3) does not necessarily apply to
>>  history mechanisms.  I.e., a history mechanism can display a previous
>>  representation even if it has expired.
>> 
>>  This does not prohibit the history mechanism from telling the user
>>  that a view might be stale, or from honoring cache directives (e.g.,
>>  Cache-Control: no-store).
>> 
>> 
>> (see <http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/197/>)
>> 
>> Best regards, Julian
> 
> 
> --
> Mark Nottingham     http://www.mnot.net/
> 
> 

--
Mark Nottingham     http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Wed, 03 Mar 2010 10:20:40 +0100

On 03.03.2010 05:50, Mark Nottingham wrote:
> ...

Done with <http://trac.tools.ietf.org/wg/httpbis/trac/changeset/766>.