Subject: Removing CREDENTIAL

From: "Brian Raymor (MS OPEN TECH)" <[email-masked]>
Date: Thu, 21 Feb 2013 03:06:28 +0000

In the Speed+Mobility draft, we removed CREDENTIAL because:

   CREDENTIAL:  This is removed from HTTP Speed+Mobility because we
      believe it is not compatible with options such as TLS SNI.  For
      this proposal, a session MUST only target one origin as described
      in [RFC6454].

Concerns were also raised in "CREDENTIAL really needed?" (https://groups.google.com/forum/?fromgroups#!searchin/spdy-dev/credential/spdy-dev/WazzPBFbdpk/yayPrNTehYYJ). Based on the responses, it appears that CREDENTIAL was an experimental feature not used in SPDY/3, but intended to be replaced with a different design in the future; therefore, it could safely be deprecated or ignored.

I propose that CREDENTIAL be removed from the HTTP/2.0 draft. Related issue:

https://github.com/http2/http2-spec/issues/39

Brian Raymor
Senior Program Manager
Microsoft Open Technologies, Inc. 
A subsidiary of Microsoft Corporation

---

From: Roberto Peon <[email-masked]>
Date: Wed, 20 Feb 2013 19:30:45 -0800

On Wed, Feb 20, 2013 at 7:06 PM, Brian Raymor (MS OPEN TECH) <
[email-masked]> wrote:

> Concerns were also raised in "CREDENTIAL really needed?" (
> https://groups.google.com/forum/?fromgroups#!searchin/spdy-dev/credential/spdy-dev/WazzPBFbdpk/yayPrNTehYYJ).
> Based on the responses, it appears that CREDENTIAL was an experimental
> feature not used in SPDY/3, but intended to be replaced with a different
> design in the future; therefore, it could safely be deprecated or ignored.
>

Correct.

> https://github.com/http2/http2-spec/issues/39

+1, at least until we get to doing DNS/CERT push, but no need for it today.
-=R

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 21 Feb 2013 20:53:14 +1100

OK, marking it for the editors to do, then.

Regards,

On 21/02/2013, at 2:30 PM, Roberto Peon <[email-masked]> wrote:

> 
> 
> 
> On Wed, Feb 20, 2013 at 7:06 PM, Brian Raymor (MS OPEN TECH) <[email-masked]> wrote:

--
Mark Nottingham   http://www.mnot.net/