Subject: HTTP/2.0 #19: Clarify that max-streams is per-direction [WAS: Outstanding Action Items]

From: William Chan (陈智昌) <[email-masked]>
Date: Sun, 17 Feb 2013 19:30:57 -0800

I'm not one to be very particular about wording, but just to get the ball
rolling...

Proposed new text to clarify directionality:
"""
4 - SETTINGS_MAX_CONCURRENT_STREAMS indicates the maximum number of
concurrent streams which the sender of the SETTINGS frame is willing to
allow the peer to open. Note that this limit is directional. By default
there is no limit.  For implementors it is recommended that this value be
no smaller than 100, so as not to unnecessarily limit parallelism.
"""

Not that it matters, but here's my github commit:
https://github.com/willchan/http2-spec/commit/2fc3db01fd32bd8f20d1f01b3091c513eb40bde6(ignore
the html stuff above, I guess the the html generation tool hasn't
been run since the last changes to the XML).

On Sun, Feb 17, 2013 at 5:57 PM, Mark Nottingham <[email-masked]> wrote:

> Thanks. I've opened this to track:
>   https://github.com/http2/http2-spec/issues/19
>
> On 06/02/2013, at 2:44 PM, William Chan (陈智昌) <[email-masked]>
> wrote:
>
> > <snip>
> >
> >> * Will: double check that spdy's change to directionality for max
> streams has made it into http/2, or raise issue.
> >
> > """
> >
> > 4 - SETTINGS_MAX_CONCURRENT_STREAMS allows the sender to inform
> >         the remote endpoint the maximum number of concurrent streams
> >         which it will allow.  By default there is no limit.  For
> >         implementors it is recommended that this value be no smaller
> >         than 100.
> > """
> >
> > It's the same text as we've had in SPDY/2, and our SPDY/4 draft is the
> > same. This wording is technically correct, but it does not
> > particularly emphasize that the limit is directional. I can imagine
> > first time readers misinterpreting it.
> >
>
> --
> Mark Nottingham   http://www.mnot.net/
>
>
>
>

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 18 Feb 2013 19:39:38 +1100

WFM. If others have suggestions, please say; otherwise I'll put that in the ticket and mark for incorporation.

On 18/02/2013, at 2:30 PM, William Chan (陈智昌) <[email-masked]> wrote:

> I'm not one to be very particular about wording, but just to get the ball rolling...
> 
> 4 - SETTINGS_MAX_CONCURRENT_STREAMS indicates the maximum number of concurrent streams which the sender of the SETTINGS frame is willing to allow the peer to open. Note that this limit is directional. By default there is no limit.  For implementors it is recommended that this value be no smaller than 100, so as not to unnecessarily limit parallelism.
> """
> 
> https://github.com/willchan/http2-spec/commit/2fc3db01fd32bd8f20d1f01b3091c513eb40bde6 (ignore the html stuff above, I guess the the html generation tool hasn't been run since the last changes to the XML).
> 
> On 06/02/2013, at 2:44 PM, William Chan (陈智昌) <[email-masked]> wrote:
> 
> > <snip>
> >
> >> * Will: double check that spdy's change to directionality for max streams has made it into http/2, or raise issue.
> >
> > """
> >