Subject: HTTP 2.0 next steps and TLS next protocol negotiation

From: "Brian Raymor (MS OPEN TECH)" <[email-masked]>
Date: Tue, 12 Feb 2013 00:30:13 +0000

The proposed plan (http://lists.w3.org/Archives/Public/ietf-http-wg/2013JanMar/0577.html) for TLS next protocol negotiation in the HTTP/2.0 implementation draft is to "use NPN (until TLSWG gives us something to replace it with) for TLS connections".

Based on Eric Rescorla's recent message on the TLS mailing list - Confirming Consensus: Negotiating upper layer protocols - (http://www.ietf.org/mail-archive/web/tls/current/msg09176.html)  which states:

	Depending on list discussion and what other proposals appear, we may attempt to select a proposal in Orlando.

I'd like to slightly amend the plan to indicate that the initial HTTP/2.0 implementation draft will use the negotiation proposal selected in Orlando by the TLS WG. If none is selected, then we will use NPN (until TLSWG gives us something to replace it with) for TLS connections.

Comments?

Brian Raymor
Senior Program Manager
Microsoft Open Technologies, Inc. 
A subsidiary of Microsoft Corporation

---

From: Roberto Peon <[email-masked]>
Date: Mon, 11 Feb 2013 16:36:58 -0800

*shrug*
These seem to say the same thing in different words?
-=R

On Mon, Feb 11, 2013 at 4:30 PM, Brian Raymor (MS OPEN TECH) <
[email-masked]> wrote:

> The proposed plan (
> http://lists.w3.org/Archives/Public/ietf-http-wg/2013JanMar/0577.html)
> for TLS next protocol negotiation in the HTTP/2.0 implementation draft is
> to "use NPN (until TLSWG gives us something to replace it with) for TLS
> connections".
>
> Based on Eric Rescorla's recent message on the TLS mailing list -
> Confirming Consensus: Negotiating upper layer protocols - (
> http://www.ietf.org/mail-archive/web/tls/current/msg09176.html)  which
> states:
>
>         Depending on list discussion and what other proposals appear, we
> may attempt to select a proposal in Orlando.
>
> I'd like to slightly amend the plan to indicate that the initial HTTP/2.0
> implementation draft will use the negotiation proposal selected in Orlando
> by the TLS WG. If none is selected, then we will use NPN (until TLSWG gives
> us something to replace it with) for TLS connections.
>
> Comments?
>
> Brian Raymor
> Senior Program Manager

---

From: Yoav Nir <[email-masked]>
Date: Tue, 12 Feb 2013 07:16:21 +0000

> I'd like to slightly amend the plan to indicate that the initial HTTP/2.0 implementation draft will use the negotiation proposal selected in Orlando by the TLS WG. If none is selected, then we will…

Well, as always, nothing will get decided in Orlando. At best there will be a "feel of the room" that will need to be confirmed later on the mailing list. So the earliest date when you might expect "something" from the TLS working group is mid-April.

Yoav