Subject: HeaderDiff specification

From: RUELLAN Herve <[email-masked]>
Date: Fri, 22 Feb 2013 10:50:28 +0000

All,

Here is the detailed specification for our header representation format HeaderDiff.

We have also published an implementation, which can currently be found at:
https://github.com/hruellan/compression-test/tree/HeaderDiff

(I've sent a pull request to have it included in https://github.com/http2/compression-test).

Comments are welcome,

Hervé.

---

From: Roberto Peon <[email-masked]>
Date: Fri, 22 Feb 2013 05:07:31 -0800

Looks good. Merged.
-=R

On Fri, Feb 22, 2013 at 2:50 AM, RUELLAN Herve
<[email-masked]>wrote:

> (I've sent a pull request to have it included in
> https://github.com/http2/compression-test).
>
> Comments are welcome,
>
> Hervé.
>

---

From: Roberto Peon <[email-masked]>
Date: Fri, 22 Feb 2013 08:33:04 -0800

That was meant to be a reply to the git mail., but oh well..
I have checked in a quick fix that makes it run (a function was removed
upstream, and I suspect it hadn't merged before you did the PULL).

I'm getting an error with cookies-- it looks like more than one crumb may
cause problems.

################################################################################
# http1
get /skins/alsacreations/theme.min.css HTTP/1.1^M
accept-language: fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3^M
accept-encoding: gzip, deflate^M
accept: text/css,*/*;q=0.1^M
user-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0)
Gecko/20100101 Firefox/18.0^M
:scheme: http^M
referer: http://forum.alsacreations.com/forum.php^M
cookie: PHPSESSID=qbfo7c1gomj6k6ul3nnjc2lsf3; lv=1358630783^M
host: forum.alsacreations.com^M
^M
# headerdiff
get /skins/alsacreations/theme.min.css HTTP/1.1^M
accept-language: fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3^M
accept-encoding: gzip, deflate^M
accept: text/css,*/*;q=0.1^M
user-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0)
Gecko/20100101 Firefox/18.0^M
:scheme: http^M
referer: http://forum.alsacreations.com/forum.php^M
cookie: lv=1358630783^M
host: forum.alsacreations.com^M
^M
  - mismatch in headerdiff:
Only found in: orig
|-------cookie: PHPSESSID=qbfo7c1gomj6k6ul3nnjc2lsf3

Traceback (most recent call last):
  File
"/usr/local/google/home/fenix/www/compression-test/compare_compressors.py",
line 124, in <module>
    CompressionTester(sys.stdout.write)
  File
"/usr/local/google/home/fenix/www/compression-test/compare_compressors.py",
line 38, in __init__
    self.run()
  File
"/usr/local/google/home/fenix/www/compression-test/compare_compressors.py",
line 50, in run
    self.processors.process_stream(stream)
  File "/home/fenix/www/compression-test/lib/processors.py", line 72, in
process_stream
    results = self.process_message(hdrs, stream.msg_type, host)
  File "/home/fenix/www/compression-test/lib/processors.py", line 146, in
process_message
    raise StandardError()
StandardError

On Fri, Feb 22, 2013 at 5:07 AM, Roberto Peon <[email-masked]> wrote:

> Looks good. Merged.
> -=R
>
>
> On Fri, Feb 22, 2013 at 2:50 AM, RUELLAN Herve <[email-masked]
> > wrote:
>
>> All,
>>

---

From: RUELLAN Herve <[email-masked]>
Date: Mon, 25 Feb 2013 16:35:49 +0000

I've corrected the error with the cookies. While decoding, only the last cookie was kept :-(.

Hervé.

> -----Original Message-----
> From: Roberto Peon [mailto:[email-masked]]
> Sent: vendredi 22 février 2013 17:33
> To: RUELLAN Herve
> Cc: [email-masked]
> Subject: Re: HeaderDiff specification
> 
>   File "/usr/local/google/home/fenix/www/compression-
> test/compare_compressors.py", line 124, in <module>
>   File "/usr/local/google/home/fenix/www/compression-
> test/compare_compressors.py", line 38, in __init__
>     self.run()
>   File "/usr/local/google/home/fenix/www/compression-
> test/compare_compressors.py", line 50, in run
> <[email-masked]> wrote:
> 
> 
> 		All,
>