Subject: Outstanding Action Items

From: Mark Nottingham <[email-masked]>
Date: Tue, 5 Feb 2013 15:20:44 +1100

I see (or, sometimes, infer) the following action items in the minutes:

* Mark: re-ping the TLS WG for NPN status
* Eliot: write text for a registry of opaque strings to identify different things to negotiate for
* Martin: explain use case for weights in the DNS record
* Eliot: revise his RR proposal based upon discussion
* Roberto: revise draft and ship new example code for delta
* Herve: publish draft and ship example code for headerdiff
* Roberto / Will / Hasan: assure that SPDY4 changes are raised as issues for WG to consider, or given to editors if purely editorial
* Mark: raise a new issue for handing Expect/100-continue
* Mark: raise a new issue for negotiation of trailers
* Mark: raise a new issue for indicating the end of a header block
* Mark: raise a new issue about assuring that routing data (e.g., :host, :path, :scheme) appears before headers
* Roberto: make detailed proposal for frame size w/ continuation bit
* Will: make a detailed proposal for sesion-level flow control. Initial values to be 64k.
* Eliot: amend his record to accommodate "initial options"
* Roberto: forward complete proposal from spdy4 for grouping and re-prioritisation
* Hasan: write a proposal for pushpromise; moving associated-to from synstream to it.
* Will: double check that spdy's change to directionality for max streams has made it into http/2, or raise issue.
* Editors: flesh out security considerations for server push, or note in new issue
* Mike B: make proposal on list for security/privacy considerations of settings.
* Eliot + Martin: Start discussion of magic on list.  DONE
* Hasan: Send proposal about metrics to gather during testing to list.
* Mark: Continue discussion of testing / data gathering on list.

Please reply here when you've completed one. And, if I've missed one, please yell.

--
Mark Nottingham   http://www.mnot.net/

---

From: Roberto Peon <[email-masked]>
Date: Tue, 5 Feb 2013 13:29:59 -0800

You also had a request of me to add a flag to the delta stuff to optionally
do or not do... (I forget)
-=R

On Mon, Feb 4, 2013 at 8:20 PM, Mark Nottingham <[email-masked]> wrote:

> * Roberto / Will / Hasan: assure that SPDY4 changes are raised as issues
> for WG to consider, or given to editors if purely editorial

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 6 Feb 2013 08:32:33 +1100

Add a way to control the size of the state kept.

Thanks,

On 06/02/2013, at 8:29 AM, Roberto Peon <[email-masked]> wrote:

> You also had a request of me to add a flag to the delta stuff to optionally do or not do... (I forget)
> -=R
> 
>

---

From: Roberto Peon <[email-masked]>
Date: Tue, 5 Feb 2013 14:29:04 -0800

* Roberto: make detailed proposal for frame size w/ continuation bit:
mailed out.

On Tue, Feb 5, 2013 at 1:32 PM, Mark Nottingham <[email-masked]> wrote:

> > * Will: double check that spdy's change to directionality for max
> streams has made it into http/2, or raise issue.

---

From: William Chan (陈智昌) <[email-masked]>
Date: Wed, 6 Feb 2013 12:44:59 +0900

<snip>

> * Will: double check that spdy's change to directionality for max streams has made it into http/2, or raise issue.

"""

4 - SETTINGS_MAX_CONCURRENT_STREAMS allows the sender to inform
         the remote endpoint the maximum number of concurrent streams
         which it will allow.  By default there is no limit.  For
         implementors it is recommended that this value be no smaller
         than 100.
"""

It's the same text as we've had in SPDY/2, and our SPDY/4 draft is the
same. This wording is technically correct, but it does not
particularly emphasize that the limit is directional. I can imagine
first time readers misinterpreting it.

---

From: Gabriel Montenegro <[email-masked]>
Date: Wed, 6 Feb 2013 20:43:30 +0000

The other point that was mentioned as worth clarifying was, from the minutes, "How to turn to off push (in either direction)", which is done, also from the minutes, by setting "max stream limit to 0 for that endpoint".

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Chan (???)
Sent: Tuesday, 5 February, 2013 19:45
To: Mark Nottingham
Cc: HTTP Working Group
Subject: Re: Outstanding Action Items

<snip>

"""

It's the same text as we've had in SPDY/2, and our SPDY/4 draft is the same. This wording is technically correct, but it does not particularly emphasize that the limit is directional. I can imagine first time readers misinterpreting it.

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 18 Feb 2013 12:57:04 +1100

Thanks. I've opened this to track:
  https://github.com/http2/http2-spec/issues/19

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 18 Feb 2013 12:57:51 +1100

Now https://github.com/http2/http2-spec/issues/20

Cheers,

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 18 Feb 2013 13:14:16 +1100

FYI, am now tracking these here:
  https://github.com/http2/http2-spec/wiki/Action-Items