Subject: Using Github for HTTP2

From: Mark Nottingham <[email-masked]>
Date: Fri, 8 Feb 2013 13:15:24 +1100

For the HTTP/1.1 work, we've used the IETF's infrastructure on tools.ietf.org -- mostly, the SVN repository and the Trac instance for issue tracking.

After briefly discussing it in Tokyo and conferring with the editors and our AD, we've moved the source for the HTTP/2 draft and related issues to Github. 

There are a couple of reasons for this. First of all, we would like to encourage participation from a broader audience, and more implementers have github accounts and are familiar with that workflow, vs. IETF tools accounts. Furthermore, we've had a few requests from people that want to fork the specification for experimentation, to be used as potential input to our work (as pull requests). Finally, our editors have expressed some preference for working with Git over SVN. 

As such, this isn't a problem with the IETF tools themselves (which are well-supported and have been very useful to date); it's more driven by the specific situation we're in.

So, see:
  https://github.com/http2/http2-spec

I'm now in the process of closing the relevant Trac issues and adjusting our wiki to point to the relevant places.

Note that this is itself an experiment; e.g., we may need to establish some process around issue handling, especially, if the input there gets out of hand. 

Also, note that this does NOT affect any of our work on HTTP/1.1; that will remain at the IETF tools site.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: William Chan (陈智昌) <[email-masked]>
Date: Sat, 9 Feb 2013 23:46:23 -0800

OK, I'm a newb at this stuff. Halp? :)

willchan-macbookair:http2-spec willchan$ make -e draft-ietf-httpbis-http2.html
java -classpath ~/java/saxonb8-9-0-4j/saxon8.jar
net.sf.saxon.Transform -novw -l draft-ietf-httpbis-http2.xml
lib/myxml2rfc.xslt > draft-ietf-httpbis-http2.html
Error at xsl:import on line 4 of
file:/Users/willchan/src/github/willchan_chromium/http2-spec/lib/myxml2rfc.xslt:
  XTSE0165: java.io.FileNotFoundException:
  /Users/willchan/src/github/willchan_chromium/http2-spec/rfc2629xslt/rfc2629.xslt
(No such
  file or directory)
Failed to compile stylesheet. 1 error detected.
make: *** [draft-ietf-httpbis-http2.html] Error 2
willchan-macbookair:http2-spec willchan$ ls
Makefile README.md SUBMITTING.md draft-ietf-httpbis-http2.html
draft-ietf-httpbis-http2.xml lib
willchan-macbookair:http2-spec willchan$ ls lib
clean-for-DTD.xslt myxml2rfc.xslt rfc2629.xslt

---

From: Julian Reschke <[email-masked]>
Date: Sun, 10 Feb 2013 10:42:31 +0100

> clean-for-DTD.xslt myxml2rfc.xslt rfc2629.xslt

Seems that github doesn't have all the files you need. See 
<https://svn.tools.ietf.org/svn/wg/httpbis>.

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 10 Feb 2013 21:10:39 +1100

Try now.

Cheers,

---

From: William Chan (陈智昌) <[email-masked]>
Date: Sun, 10 Feb 2013 08:50:25 -0800

Works! Thanks.

On Sun, Feb 10, 2013 at 2:10 AM, Mark Nottingham <[email-masked]> wrote:

> >> For the HTTP/1.1 work, we've used the IETF's infrastructure on
> tools.ietf.org -- mostly, the SVN repository and the Trac instance for
> issue tracking.
> >>
> >> After briefly discussing it in Tokyo and conferring with the editors
> and our AD, we've moved the source for the HTTP/2 draft and related issues
> to Github.
> >>
> >> There are a couple of reasons for this. First of all, we would like to
> encourage participation from a broader audience, and more implementers have
> github accounts and are familiar with that workflow, vs. IETF tools
> accounts. Furthermore, we've had a few requests from people that want to
> fork the specification for experimentation, to be used as potential input
> to our work (as pull requests). Finally, our editors have expressed some
> preference for working with Git over SVN.
> >>
> >> As such, this isn't a problem with the IETF tools themselves (which are
> well-supported and have been very useful to date); it's more driven by the
> specific situation we're in.
> >>
> >> So, see:
> >> I'm now in the process of closing the relevant Trac issues and
> adjusting our wiki to point to the relevant places.
> >>
> >> Note that this is itself an experiment; e.g., we may need to establish
> some process around issue handling, especially, if the input there gets out
> of hand.
> >>

---

From: William Chan (陈智昌) <[email-masked]>
Date: Fri, 22 Feb 2013 09:46:50 -0800

One very minor annoyance I've encountered is working on multiple edits in
parallel (in separate feature branches) and keeping the HTML in sync
(across my branches and merges from upstream). I'm not sure if anyone else
has this problem. My two cents: it'd be nice to ditch the HTML from the
main repo/branch and use https://help.github.com/articles/post-receive-hooks to
process the commits to XML and generate the other formats (TXT+HTML) and
post them somewhere (another repo/branch/website/etc).

That said, it's probably not important since I bet very few folks outside
the editors will make changes here, so as long as it works for them, then
great. Just noting this in case anyone felt it was useful to address.

On Thu, Feb 7, 2013 at 6:15 PM, Mark Nottingham <[email-masked]> wrote:

> After briefly discussing it in Tokyo and conferring with the editors and
> our AD, we've moved the source for the HTTP/2 draft and related issues to
> Github.
>
> I'm now in the process of closing the relevant Trac issues and adjusting
> our wiki to point to the relevant places.
>

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 23 Feb 2013 09:31:22 +1100

I'll see what I can do.

Cheers,

On 23/02/2013, at 4:46 AM, William Chan (陈智昌) <[email-masked]> wrote:

> One very minor annoyance I've encountered is working on multiple edits in parallel (in separate feature branches) and keeping the HTML in sync (across my branches and merges from upstream). I'm not sure if anyone else has this problem. My two cents: it'd be nice to ditch the HTML from the main repo/branch and use https://help.github.com/articles/post-receive-hooks to process the commits to XML and generate the other formats (TXT+HTML) and post them somewhere (another repo/branch/website/etc).
> 
> That said, it's probably not important since I bet very few folks outside the editors will make changes here, so as long as it works for them, then great. Just noting this in case anyone felt it was useful to address.
> 
>

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 25 Feb 2013 13:06:30 +1100

OK, I've got this roughed in; editors, please don't push to the gh-pages branch any more; it'll automatically be generated when you commit to the XML.

Cheers,