Subject: HTTP/1.1 #223: Allowing heuristic caching for new status codes

From: Mark Nottingham <[email-masked]>
Date: Mon, 11 Feb 2013 17:27:40 +1100

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/223>

After some discussion with Roy, we've come to the conclusion that the edits I did when I re-wrote the caching part unnecessarily introduced a new aspect of status codes -- whether or not responses carrying it can have a heuristic applied to determine freshness.

We're currently working through the drafts to pull that back, so that any status code defined as "cacheable" can have a heuristic applied.

We'll review those edits as part of our next round of drafts; just wanted to give people a heads-up. In parallel, I'm going to open another issue regarding *what* status codes are cacheable by default; this came out of the discussion of #223.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 18 Feb 2013 11:01:06 +1100

I haven't seen any feedback on this, so I'm closing as incorporated.