Subject: HTTP Origin and Hop Hints and Prefer Header

From: James M Snell <[email-masked]>
Date: Tue, 12 Feb 2013 08:59:44 -0800

Mark,

The most recent draft looks good. One thing that struck me is that
there seems to be a good alignment between this and the Prefer header.
Currently, there is no way for a client to know whether or not a
server supports Prefer. Hints would be a great way to provide that
information.

For instance...

Async-Responses

   o  Hint Name: pa
   o  Hint Type: origin
   o  Description: When true, indicates that the origin supports
Prefer: respond-async
   o  Value Type: boolean
   o  Contact: [email-masked]

Minimal Responses

   o  Hint Name: pr
   o  Hint Type: origin
   o  Description: When true, indicates that the origin supports
Prefer: return-minimal and return=representation
   o  Value Type: boolean
   o  Contact: [email-masked]

Strict and Lenient Handling

   o  Hint Name: ph
   o  Hint Type: origin
   o  Description: When true, indicates that the origin supports
Prefer: handling=strict and handling=lenient
   o  Value Type: boolean
   o  Contact: [email-masked]

- James

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 13 Feb 2013 07:14:40 +1100

Hey James,

Those things strike me as things that need to be per-resource, not per-origin... which means I need to add some language to the IANA Considerations section... :)

Cheers,

--
Mark Nottingham   http://www.mnot.net/