Subject: iwebpp.io announce - run peer/p2p web service with Node.js

From: tom <[email-masked]>
Date: Thu, 14 Mar 2013 00:29:14 +0800

iwebpp.io - Deliver Peer/P2P Web Service with Node.js.

Features

   - Run http over udp, leverage udp's high data-transfer performance
   - Run web service in peer/p2p style, behind NAT/FW
   - Support both TURN and STUN session with Websocket
   - Expand client/central style web service transparently
   - Easy to use API, reuse existing http/web technologes

for details, please refer to
 https://github.com/InstantWebP2P/iwebpp.io

https://github.com/InstantWebP2P/node-httpp

Appreciate your suggestions and thoughts.

Best regards
  Tom

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 13 Mar 2013 17:27:16 -0400

This is not an announcement list; please don't send messages like this on it.

Thanks,

On 13/03/2013, at 12:29 PM, tom <[email-masked]> wrote:

> 	• Run http over udp, leverage udp's high data-transfer performance
> 	• Run web service in peer/p2p style, behind NAT/FW
> 	• Support both TURN and STUN session with Websocket
> 	• Expand client/central style web service transparently
> 	• Easy to use API, reuse existing http/web technologes

--
Mark Nottingham   http://www.mnot.net/

---

From: tom <[email-masked]>
Date: Thu, 14 Mar 2013 20:38:12 +0800

Mark:

  Thx for your thought.

  And, iwebpp.io is not a product, but a study case that try to run HTTP
over UDP. It's more about how to improve http/web and  bring new ideas.

 Best regards
  Tom

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 14 Mar 2013 08:42:29 -0400

>   Thx for your thought. 

It's not a "thought"; I'm the WG chair, and I can (and will, as some can attest) ban people who post off-topic messages.

>   And, iwebpp.io is not a product, but a study case that try to run HTTP over UDP. It's more about how to improve http/web and  bring new ideas.  

Case studies don't start with lists of features.

---

From: tom <[email-masked]>
Date: Thu, 14 Mar 2013 20:58:16 +0800

Mark:

  I got your idea.

  But, the "feature" is nature, not exaggeration.

Best regards
  Tom

On Thu, Mar 14, 2013 at 8:42 PM, Mark Nottingham <[email-masked]> wrote:

> It's not a "thought"; I'm the WG chair, and I can (and will, as some can
> attest) ban people who post off-topic messages.
>
> >   And, iwebpp.io is not a product, but a study case that try to run
> HTTP over UDP. It's more about how to improve http/web and  bring new ideas.
>