Subject: Re: WGLC issue: token68 in p7

From: "Manger, James H" <[email-masked]>
Date: Thu, 21 Mar 2013 19:36:05 +1100

NTLM and variants send base64 blobs back and forth: in credentials and challenges.

--
James Manger

----- Reply message -----
From: "Julian Reschke" <[email-masked]>
Date: Thu, Mar 21, 2013 6:32 pm
Subject: WGLC issue: token68 in p7
To: "Manger, James H" <[email-masked]>
Cc: "Bjoern Hoehrmann" <[email-masked]>, "Ken Murchison" <[email-masked]>, "[email-masked]" <[email-masked]>

On 2013-03-20 01:46, Manger, James H wrote:
> Björn,
>
> '=' is only allowed at the end to ensure the syntax is unambiguous.
> A token68 value can only be distinguished from an auth-param
> (token = (token / quoted-string)) due to this restriction.
>
> Let's keep token68 as it is.
>
> --
> James Manger
> ...

As far as I can tell, if a given scheme always uses token68 (such as the
Basic credentials), it's not necessary to be able to distinguish.

We added token68 for "Basic". Basic only needs token68 for credentials.
Can somebody recall why we added it for challenges as well?

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Thu, 21 Mar 2013 09:50:41 +0100

> NTLM and variants send base64 blobs back and forth: in credentials and challenges.

Indeed:

<http://tools.ietf.org/html/rfc4559#section-4.2>

Thanks for the reminder.

Best regards, Julian