Subject: Working Group Last Call on the HTTPbis document set

From: Mark Nottingham <[email-masked]>
Date: Mon, 18 Mar 2013 05:51:32 +1100

Since our last Working Group Last Calls on the RFC2616bis documents, there have been a number of substantial changes, brought about both by discussion and the editors' initiative (as discussed in Orlando). 

As such, we're having another (hopefully final) Working Group Last Call on the entire document set:

* Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
  http://tools.ietf.org/html/draft-ietf-httpbis-p1-messaging-22
  Diffs from the previous WGLC: http://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-p1-messaging-22.txt

* Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content
  http://tools.ietf.org/html/draft-ietf-httpbis-p2-semantics-22
  Diffs from the previous WGLC: http://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-p2-semantics-22.txt

* Hypertext Transfer Protocol (HTTP/1.1): Conditional Requests
  http://tools.ietf.org/html/draft-ietf-httpbis-p4-conditional-22
  Diffs from the previous WGLC: http://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-p4-conditional-22.txt

* Hypertext Transfer Protocol (HTTP/1.1): Range Requests
  http://tools.ietf.org/html/draft-ietf-httpbis-p5-range-22
  Diffs from the previous WGLC: http://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-p5-range-22.txt

* Hypertext Transfer Protocol (HTTP/1.1): Caching
  http://tools.ietf.org/html/draft-ietf-httpbis-p6-cache-22
  Diffs from the previous WGLC: http://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-p6-cache-22.txt

* Hypertext Transfer Protocol (HTTP/1.1): Authentication
  http://tools.ietf.org/html/draft-ietf-httpbis-p7-auth-22
  Diffs from the previous WGLC: http://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-p7-auth-22.txt

* Initial Hypertext Transfer Protocol (HTTP) Method Registrations
  http://tools.ietf.org/html/draft-ietf-httpbis-method-registrations-11
  Diffs from the previous WGLC: http://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-method-registrations-11.txt

* Initial Hypertext Transfer Protocol (HTTP) Authentication Scheme Registrations
  http://tools.ietf.org/html/draft-ietf-httpbis-authscheme-registrations-06
  Diffs from the previous WGLC: http://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-authscheme-registrations-06.txt

This WGLC will close on April 30, 2013.

Providing Feedback
----------------

Your input should be sent to this mailing list, clearly marked with "WGLC" and the appropriate part. E.g., with Subject lines such as:

Subject: WGLC review of p1-messaging
Subject: WGLC issue: "foo" in p2

Issues that you believe to be editorial in nature (e.g., typos, suggested re-phrasing) can be grouped together in a single e-mail. Substantive issues (what we call "design" issues) that may need discussion should be sent one per e-mail, with a descriptive subject.

If you disagree with the resolution of a previously discussed issue, you're encouraged to note that at this time.

I'd especially encourage those who review the documents without finding significant issues to say so on the list; one of the challenges we have is to show that the documents have seen adequate review, and this becomes difficult when people are quiet.

Also, please bring these documents to the attention of those HTTP implementers who may not have been following this process closely; they are likely to be the ones that go forward to IETF Last Call, then replacing RFC2616.

Thanks for your efforts,

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Thu, 21 Mar 2013 10:15:46 +0100

On 2013-03-17 19:51, Mark Nottingham wrote:
> ...

Thanks for the feedback so far.

Note that we try to address issues as early as possible, you can see the 
current editor's copy (plus diffs) in the tools.ietf.org SVN and here:

<http://trac.tools.ietf.org/wg/httpbis/trac/wiki/WikiStart#HTTP1.1Deliverables>

(this may be worth checking before reporting editorial issues)

Best regards, Julian