Subject: Framing the proxy discussion

From: Mark Nottingham <[email-masked]>
Date: Mon, 23 Jun 2014 18:20:48 +1000

Everyone,

The proxy discussion is active once again. Please pay attention to the points below in order to make it more productive:

## Catching Up

I see we have had a number of people who are fairly new to the working group (or perhaps just newly active) join the discussion. 

Welcome! Please remember that this mailing list has a very large distribution, and that its primary focus is the identified work items of the group -- which proxies are not *yet* included within. As such, please take the time to read the archives of the mailing list, as well as the working documents, so that you can avoid repeating arguments that have already been made (which is starting to happen).

Here are a few handy links to get you started:
  * http://lists.w3.org/Archives/Public/ietf-http-wg/
  * https://github.com/http2/http2-spec/wiki/Proxy-User-Stories
  * http://tools.ietf.org/html/draft-nottingham-http-proxy-problem
  * http://tools.ietf.org/html/draft-loreto-httpbis-explicitly-auth-proxy
  * https://github.com/httpwg/wg-materials/blob/master/interim-14-03/minutes.md#proxies

Also, a gentle reminder - we make decisions based upon technical arguments ("rough consensus and running code"), not voting. So repeating an argument or "+1-ing" it only adds to noise, it doesn't help your case. Please have a read of <http://tools.ietf.org/html/draft-resnick-on-consensus> if this is new to you.

## Proxies and HTTP/2

I've also seen a few people refer to "doing something about proxies in HTTP/2."

To be clear -- there is nothing in HTTP/2 that is fundamentally different for proxies, and our charter for that effort makes introducing new proxy mechanisms that are specifically bound to HTTP/2 unlikely. 

People are still welcome to make proposals regarding proxies in HTTP/2, but realise that the bar for getting them in will be quite high, both because of the charter and where we're at in our schedule. Discussing proxies *in general* (i.e. as applicable to /2 as well as /1), OTOH, is fine.

Likewise, HTTP/2 does *not* require encryption. While we understand that prevalence of encryption is increasing, and some implementers are making choices about how they deploy HTTP/2 that affect this, it doesn't follow that HTTP/2 and encryption are intrinsically bound, or that we "*have* to do something about it in HTTP/2."

## "Split Browsers"

For *now*, I do not consider "split browsers" in-scope for this Working Group; we cannot control the details of a protocol when it's not HTTP, as this effectively is. I realise that they have a potentially huge impact upon the landscape, but this is **not** the "everything to do with the Web" Working Group. We have more than enough on our plate as it is.

Note that this doesn't mean that discussing "split browsers" is completely verboten; I just don't want them to overshadow other considerations. Please moderate yourselves.

## Toronto

We're currently scheduled for two sessions in Toronto, and I'm planning to devote a significant chunk of one of them to discussing proxies. 

We'll specifically be talking about the proxy-problem draft as well as the proxy user stories; beyond that, we'll talk about what other work items we might attempt. If you would like to suggest a particular topic or make a presentation, please contact me privately.

Please moderate your expectations for this discussion; while we might agree to start work on some exploratory documents (such as proxy-problem), it's unlikely we'll come out with more substantial work items in progress right at the end of this meeting.

Our charter requires Barry and I to agree to new work; from my perspective, I want to see consensus to add a work item and a clear path to achieving its success, which means both broad implementation and successfully navigating the security and privacy requirements of the IETF. We also have to consider what's appropriate for this WG to attempt, and what's best left to other venues.

Given that, the nature of this work and how many different communities it touches, it's unlikely we'll have a good sense of that in the short time we have together this time. However, we can continue the discussion and try to find common ground on how to improve HTTP's handling of proxies.

Thanks for reading this far,

--
Mark Nottingham   https://www.mnot.net/

---

From: <[email-masked]>
Date: Mon, 23 Jun 2014 11:10:21 +0000

On Monday,23 June 2014 10:21, [email-masked]<mailto:[email-masked]> wrote:
> Also, a gentle reminder - we make decisions based upon technical arguments

> ("rough consensus and running code"), not voting. So repeating an argument

> or "+1-ing" it only adds to noise, it doesn't help your case. Please have a read

> of <http://tools.ietf.org/html/draft-resnick-on-consensus> if this is new to you.

That link seems to be broken.  Here's a link to the latest draft I could find [1]. Reading it again was a good reminder for me of the IETF process.

>From Section 6 of [1]: "... you can have rough consensus with issues that have been purposely dismissed, but not ones that have been ignored. ... Even if no particular person is still standing up for an issue, that doesn't mean an issue can be ignored."

What should you do if you feel like a particular issue is being ignored on the mailing list?  Open an issue in the issue tracker?

[1] https://tools.ietf.org/html/draft-resnick-on-consensus-07

This email message is intended only for the use of the named recipient. Information contained in this email message and its attachments may be privileged, confidential and protected from disclosure. If you are not the intended recipient, please do not read, copy, use or disclose this communication to others. Also please notify the sender by replying to this message and then delete it from your system.

---

From: Michael Sweet <[email-masked]>
Date: Mon, 23 Jun 2014 07:31:47 -0400

Mark,

On Jun 23, 2014, at 4:20 AM, Mark Nottingham <[email-masked]> wrote:
> ...

404 not found

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Barry Leiba <[email-masked]>
Date: Mon, 23 Jun 2014 18:25:53 -0400

> Also, a gentle reminder - we make decisions based upon technical
> arguments ("rough consensus and running code"), not voting. So
> repeating an argument or "+1-ing" it only adds to noise, it doesn't
> help your case. Please have a read of
> <http://tools.ietf.org/html/draft-resnick-on-consensus> if this is new
> to you.

And that draft is now, as of today, RFC 7282:
https://datatracker.ietf.org/doc/rfc7282/

Barry

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 24 Jun 2014 10:31:53 +1000

On 23 Jun 2014, at 9:10 pm, [email-masked] wrote:

> On Monday,23 June 2014 10:21, [email-masked] wrote:

Probably because it was transitioning between AUTH48 and being published:
  http://tools.ietf.org/html/rfc7282

> What should you do if you feel like a particular issue is being ignored on the mailing list?  Open an issue in the issue tracker?

That's one way to do it. You can also raise it as an issue in WGLC and/or IETF LC.

Cheers,

---

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 24 Jun 2014 17:34:39 +0900

On 2014/06/24 09:31, Mark Nottingham wrote:
>>>  Please have a read

No, there actually was some outage for drafts on tools.

But it's fixed according to Henrik:

 > Hi Martin,
 >
 >> On 2014-06-23 14:26 Henrik Levkowetz said:
 >> Hi Martin,
 >>
 >> On 2014-06-23 13:17 "Martin J. Dürst" said:
 >>> Dear Webmaster,
 >>>
 >>> I tried to access https://tools.ietf.org/html/draft-duerst-mailto-bis
 >>> from https://tools.ietf.org/html/rfc5322, but this gives me a 404.
 >>> Similar for other drafts.
 >>>
 >>> Hope this can be fixed soon.
 >>
 >> Checking up on this right away.  This may have something to do with a
 >> transition earlier today to redirect to https:// URLs for the tools 
pages.
 >
 > This should be sorted out now.  Sorry for the service interruption!
 >
 >
 > Best regards,
 >
 > 	Henrik

Regards,   Martin.