Subject: OAuth 2.0 - Proxy-Authenticate Bearer

From: Amos Jeffries <[email-masked]>
Date: Sun, 08 Jun 2014 14:46:09 +1200

I have implemented Bearer authentication support in Squid and have found
a noticible lack of support in clients for the 407 status Proxy-Auth*
headers, even where Bearer support is advertized and working via 401
status WWW-Auth*.

Can any of the client implementers (Browsers in particular) please point
out if they do support Bearer login to a proxy and what restrictions
they have on it actually working?

Amos Jeffries
The Squid Software Foundation

---

From: Chris Bentzel <[email-masked]>
Date: Tue, 10 Jun 2014 05:58:56 -0400

Chrome does not currently support this auth scheme.