Subject: RE: Proxies (includes call for adopting new work item, call for input), ## HTTP Proxy Problems

From: <[email-masked]>
Date: Mon, 16 Jun 2014 10:04:50 +0000

Hi Mark,

> So far, the proxy-related work that seems to have some level of consensus to continue upon has been:
>
> ## HTTP Proxy Problems
>
> IRC Julian volunteered to edit this if we choose to adopt it. Julian, is that still the case?
> 
> Do people support adopting this as a WG Draft (with a target of Informational)? If not, please explain why.
>

I support it.
I will provide inputs to Julian.

Regards
Emile

-----Original Message-----
From: Mark Nottingham [mailto:[email-masked]] 
Sent: vendredi 13 juin 2014 20:59
To: Salvatore Loreto
Cc: HTTP Working Group; Julian F. Reschke
Subject: Proxies (includes call for adopting new work item, call for input)

Hi Sal,

On 12 Jun 2014, at 4:28 pm, Salvatore Loreto <[email-masked]> wrote:

> thanks to the productive meeting in NewYork we are almost done with 
> HTTP/2, this is really great.
> 
> As currently we have almost no issues open on HTTP2, perhaps we can 
> take the opportunity to spend some time during the IETF in Toronto (in 
> the case the wg decides to meet in Toronto) to start to talk more 
> about proxies and how to accommodate them in the new reality.

Absolutely. Now that HTTP/1 has shipped and HTTP/2 is moving towards a more quiet phase, we can indeed turn to other things (with the understanding that there's still work to do on HTTP/2 that will take priority when necessary). 

> during the last months there have been several drafts authored by 
> several people describing problems about proxies, listening 
> requirements and some drafting possible solutions; and also good 
> discussions about proxies in this mailing list and during the non 
> official day in London so we should have already enough to discuss and maybe we might also make some good progress at least on the draft describing the proxy problems.

So far, the proxy-related work that seems to have some level of consensus to continue upon has been:

## HTTP Proxy Problems

IIRC Julian volunteered to edit this if we choose to adopt it. Julian, is that still the case?

Do people support adopting this as a WG Draft (with a target of Informational)? If not, please explain why.

## Autoproxy.pac format

There was also significant interest in standardising the autoproxy.pac format, possibly extending or refining it along the way. However, we haven't seen any drafts or discussion of that. Is anyone planning to propose something here?

## UX

Another thing mentioned in the London DTM was the need for UX. We said there (and I still agree) that this is *not* the venue for that discussion, but it needs to happen somewhere, and it's likely to block what we do. Is anyone aware of a place where that is happening (W3C seems like an obvious possibility, but I haven't heard anything from them)?

Beyond that, I think we're still in the discussion phase. Are there other proxy-related work items people have in mind?

Cheers,

--
Mark Nottingham   http://www.mnot.net/

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Amos Jeffries <[email-masked]>
Date: Wed, 18 Jun 2014 18:36:40 +1200

> I will provide inputs to Julian.

I support it. Some polishing needed of course.

Amos