Subject: Major decisions at the NYC Interim

From: Mark Nottingham <[email-masked]>
Date: Mon, 9 Jun 2014 11:46:26 -0400

We had a productive meeting in NYC last week, either closing or documenting a plan for all open issues.

Full details can be found in the minutes <https://github.com/http2/wg_materials/blob/master/interim-14-06/minutes.md>, and each issue’s discussion should be noted on github (usually starting with “Discussed in NYC…”).

For convenience, I’ll highlight the major outcomes below. However, if there’s a specific issue you’re interested in, I’d recommend reading the minutes and issue to be sure you understand the proposed direction.

Absent significant new information, we’ll adopt the resolutions captured in the issues list and move forward (note especially “next steps” below).

## Extensibility

We decided to allow simple hop-by-hop frame extensibility, as well as settings extensibility. They will be managed with an IANA registry.

## Implicit Content-Coding

We decided to remove implicit content-coding support by clients; HTTP/2 now works in the same manner as HTTP/1 regarding content-codings. The main reason for doing this was the interoperability and transparency problems brought about by implicit content encoding.

## Frame Compression

We removed hop-by-hop frame compression, because there wasn’t implementer interest in it, and there were concerns about security, complexity and interoperability. It was noted that compression can be added as an extension, provided that it was implemented.

## TLS Renegotiation

We decided to disallow TLS renegotation with HTTP/2, using a to-be-specified mechanism to direct clients to open a new connection if authentication using TLS client certificates is needed.

## HTTP URIs over TLS

We decided to adopt draft-nottingham-http2-encryption as an Experimental WG product; it will not be referenced from (or required for) HTTP/2, and it will not block publication of that spec (from a WG standpoint).

## Padding

We simplified the padding mechanism.

## Next Steps

We decided to publish a new Implement Draft in approximately one week, and will indicate that it’s a Last Call implementation draft. We intend to let that get implementation and deployment experience for a number of months, and if we get good data and no significant issues are found, that draft will go through WGLC, IETF LC and eventually become HTTP/2.

Because we currently have no issues open, we discussed whether it was necessary to meet in Toronto; that will be decided within the next week.

--
Mark Nottingham   http://www.mnot.net/

---

From: Greg Wilkins <[email-masked]>
Date: Tue, 10 Jun 2014 13:57:11 +0200

On 9 June 2014 17:46, Mark Nottingham <[email-masked]> wrote:

> We decided to publish a new Implement Draft in approximately one week, and
> will indicate that it’s a Last Call implementation draft. We intend to let
> that get implementation and deployment experience for a number of months,
> and if we get good data and no significant issues are found, that draft
> will go through WGLC, IETF LC and eventually become HTTP/2.

Mark,

Jetty-10 just responded to it's first http2 draft 12 request successfully -
albeit from our own test client.    So looking forward to better
participating in the "number of months" evaluations.

Can you add jetty to
https://github.com/http2/http2-spec/wiki/Implementations.  The branch is at
http://git.eclipse.org/c/jetty/org.eclipse.jetty.project.git/tree/?h=jetty-http2
and we support direct and very shortly NPN and ALPN.  Upgrade support will
be coming later.

cheers

-- 
Greg Wilkins <[email-masked]>
http://eclipse.org/jetty HTTP, SPDY, Websocket server and client that scales
http://www.webtide.com  advice and support for jetty and cometd.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 10 Jun 2014 09:58:10 -0400

Done - welcome!

On 10 Jun 2014, at 7:57 am, Greg Wilkins <[email-masked]> wrote:

> Jetty-10 just responded to it's first http2 draft 12 request successfully - albeit from our own test client.    So looking forward to better participating in the "number of months" evaluations.
> 
> Can you add jetty to https://github.com/http2/http2-spec/wiki/Implementations.  The branch is at http://git.eclipse.org/c/jetty/org.eclipse.jetty.project.git/tree/?h=jetty-http2 and we support direct and very shortly NPN and ALPN.  Upgrade support will be coming later.
> 
> cheers
> 
> 
> 
> 
> 
> 
> --