Subject: Issues for discussion in NYC

From: Mark Nottingham <[email-masked]>
Date: Wed, 4 Jun 2014 12:12:48 -0400

I’ve created a rough ordering for discussing the remaining issues; see:
  https://github.com/http2/wg_materials/blob/master/interim-14-06/agenda.md#http2-issues

Suggestions welcome, as always.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: <[email-masked]>
Date: Thu, 5 Jun 2014 02:49:20 +0000

Hi Mark-

A few thoughts wrt the agenda...

1. Under agenda item "Header Compression", will you please give my colleague Chris Brunhuber just a few minutes to explain the basic idea behind the proposal we submitted  earlier in the week [1] [2]? (I realize we didn't get a lot of response, but it also wasn't clear that everybody understood it's just plain old gzip/deflate with some new rules for creating the stream.)

2. Also regarding header compression, and regarding extensibility, I would like to hear the groups thoughts on extensibility for headers & header compression. This would allow experimentation of alternatives to hpack; wouldn't block http/2; yet would allow easily upgrading existing implementations to adopt any new ideas discovered. My only concern is that locking the spec to require HEADERS+CONTINUATION frames to be treated as one entire block, would unnecessarily hamper other ideas for header compression that don't need such a restriction.

3. Regarding "Content Compression & Encoding", I would also like the group's feedback regarding exploring  secure compression algorithms (particularly in cases where provenance is not known). We believe the deflate algorithm we proposed earlier in the week [1] might have application here. Curious to know the groups interest if we were to explore options like this. Would be informative, not normative of course.

Thanks!

-Keith

[1] http://tools.ietf.org/html/draft-morgan-ezflate-00
[2] http://tools.ietf.org/html/draft-morgan-http2-header-compression-00

I’ve created a rough ordering for discussing the remaining issues; see:On Jun 4, 2014, at 12:16, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Cheers,

This email message is intended only for the use of the named recipient. Information contained in this email message and its attachments may be privileged, confidential and protected from disclosure. If you are not the intended recipient, please do not read, copy, use or disclose this communication to others. Also please notify the sender by replying to this message and then delete it from your system.

---

From: Greg Wilkins <[email-masked]>
Date: Thu, 5 Jun 2014 14:49:02 +0200

Mark,

Etherpad link does not appear to be working.    Is there a dialin available
for this meeting ?

regards

-- 
Greg Wilkins <[email-masked]>
http://eclipse.org/jetty HTTP, SPDY, Websocket server and client that scales
http://www.webtide.com  advice and support for jetty and cometd.