Subject: Coalescing #490

From: Martin Thomson <[email-masked]>
Date: Mon, 2 Jun 2014 17:04:14 -0700

In the issue we have for dealing with renegotiation (#363) there have
been a couple of related items that have come up.  One of these is
connection coalescing.

I've raised #490, which tracks whether we want this feature.  I'm sure
that we can come up with reasons both for and against the feature.

Here's what I have been able to come up with briefly:

Pros
* it's much faster to reuse a connection
* SPDY deployments have been successfully doing this for a while
* it's nicer on the network to have fewer connections
* it allows for cross-origin push (with caveats)

Cons
* it's harder to reason about from a security perspective
* it messes with client authentication
* RFC 6066 says we shouldn't
* it provides another advantage to large players

Feel free to stack your arguments on either side in case I've missed anything.

---

From: Patrick McManus <[email-masked]>
Date: Mon, 2 Jun 2014 23:19:03 -0400

pros
 * it plays nicely with legacy sharding. (i.e. it de-shards for http/2
while leaving that hack in place for parallel-challenged protocols like
http/1). without something like this you can't have one set of markup.