Subject: Ops advice

From: Mark Nottingham <[email-masked]>
Date: Fri, 20 Jun 2014 13:45:47 +1000

I've taken the content of the http2-ops draft and put it here:
  https://github.com/http2/http2-spec/wiki/Ops

Will Chan also donated some text from the SPDY wiki, which I've started to incorporate.

Please feel free to tweak, add suggestions, etc. I'll link this from the HTTP/2 home page momentarily.

--
Mark Nottingham   https://www.mnot.net/

---

From: Adrian Cole <[email-masked]>
Date: Sat, 21 Jun 2014 17:04:27 -0700

Great start! Two things came to mind.

First, it still references the AltSvc frame. Should it do that or reference
the header? An example could help reinforce since this practice is new
either way.

Second, there's a suggestion to use reasonable sized frames. With http
frames being 16383, in what scenario is that unreasonably large?

Thanks for the help! I will reference this guide at my http2 talk at
uberconf next weds.

-A

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Jun 2014 16:55:26 +1000

On 22 Jun 2014, at 10:04 am, Adrian Cole <[email-masked]> wrote:

> First, it still references the AltSvc frame. Should it do that or reference the header? An example could help reinforce since this practice is new either way.

Depends on the scenario; if you're already in HTTP/2, the frame is probably preferable (since you don't have to wait for a request).

> Second, there's a suggestion to use reasonable sized frames. With http frames being 16383, in what scenario is that unreasonably large?

AIUI anytime it might potentially block other frames from being delivered. If people who have experimented with this would be willing to talk about their results on the wiki, I'm sure it'd be greatly appreciated.

> Thanks for the help! I will reference this guide at my http2 talk at uberconf next weds.

No worries.

And remember -- it's a wiki! :)