Subject: Fwd: New Version Notification for draft-ietf-httpbis-http2-encryption-00.txt

From: Mark Nottingham <[email-masked]>
Date: Sat, 14 Jun 2014 21:16:30 -0400

FYI. As discussed in NYC and on-list, this is Experimental.

Cheers,

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-ietf-httpbis-http2-encryption-00.txt
> Date: 14 June 2014 9:11:41 pm EDT
> To: "Mark Nottingham" <[email-masked]>, Martin Thomson <[email-masked]>, "Martin Thomson" <[email-masked]>, Mark Nottingham <[email-masked]>
> 
> 
> A new version of I-D, draft-ietf-httpbis-http2-encryption-00.txt
> has been successfully submitted by Martin Thomson and posted to the
> IETF repository.
> 
> Name:		draft-ietf-httpbis-http2-encryption
> Revision:	00
> Title:		Opportunistic Encryption for HTTP URIs
> Document date:	2014-06-12
> Group:		httpbis
> Pages:		9
> URL:            http://www.ietf.org/internet-drafts/draft-ietf-httpbis-http2-encryption-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-httpbis-http2-encryption/
> Htmlized:       http://tools.ietf.org/html/draft-ietf-httpbis-http2-encryption-00
> 
> 
> Abstract:
>   This describes how "http" URIs can be accessed using Transport Layer
>   Security (TLS) to mitigate pervasive monitoring attacks.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: "Martin J. Dürst" <[email-masked]>
Date: Mon, 16 Jun 2014 16:27:20 +0900

Hello Mark,

Reading the title without understanding the context will let people 
guess that this is about encrypting the URIs themselves. What about 
something like "Opportunistic Encryption for Retrieval of HTTP URIs" or so?

Regards,   Martin.

---

From: Martin Thomson <[email-masked]>
Date: Mon, 16 Jun 2014 09:38:48 -0700

On 16 June 2014 00:27, "Martin J. Dürst" <[email-masked]> wrote:
> Reading the title without understanding the context will let people guess
> that this is about encrypting the URIs themselves. What about something like
> "Opportunistic Encryption for Retrieval of HTTP URIs" or so?

A fair comment.  I'd be happier with "Opportunistic Encryption for
HTTP".  It's not like we need to specifically structure the title to
avoid inadvertently saying something about https URIs.

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 16 Jun 2014 17:58:07 +0100

> avoid inadvertently saying something about https URIs.

If bikeshedding on the title, can I suggest opportunistic security
or opportunistic TLS instead of opportunistic encryption? Either
would be more consistent with the terminology being discussed in
uta and saag. Not a huge deal, but someone will undoubtedly bring
it up later for sure if you keep it as is.

Cheers,
S.

---

From: Martin Thomson <[email-masked]>
Date: Mon, 16 Jun 2014 10:00:44 -0700

> it up later for sure if you keep it as is.

Sure.  We probably don't need to re-run that discussion.  I'm sure
that there are good reasons for the name.

...and I honestly don't want to know about them.  I'll just fix the doc.