Subject: [Technical Errata Reported] RFC7231 (4232)

From: RFC Errata System <[email-masked]>
Date: Wed, 14 Jan 2015 15:21:18 -0800 (PST)

The following errata report has been submitted for RFC7231,
"Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7231&eid=4232

--------------------------------------
Type: Technical
Reported by: Christopher Olson <[email-masked]>

Section: 7.1.1.1

Original Text
-------------
GMT

Corrected Text
--------------
+0000

Notes
-----
The text refers to RFC 5322. There Sect 3.3 calls the use timezone abbreviations, like GMT, obsolete. It encourages using a numeric offset such as +0000.

The grammar for dates in 7231 Sect 7.1.1.1 uses GMT. Example dates throughout this RFC and others related to HTTP use GMT. This is inconsistent with 5322.

The RFCs for HTTP need to be modified to match 5322, or 7.1.1.1 needs a note that HTTP deliberately deviates from 5322 with regards to the timezone.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7231 (draft-ietf-httpbis-p2-semantics-26)
--------------------------------------
Title               : Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content
Publication Date    : June 2014
Author(s)           : R. Fielding, Ed., J. Reschke, Ed.
Category            : PROPOSED STANDARD
Source              : Hypertext Transfer Protocol Bis
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: "Roy T. Fielding" <[email-masked]>
Date: Wed, 14 Jan 2015 15:26:08 -0800

REJECTED

This use of GMT is required for backward compatibility, as is
more than adequately explained in the spec.

....Roy