Subject: Editorial pull requests for h2

From: Martin Thomson <[email-masked]>
Date: Sun, 18 Jan 2015 14:40:24 -0800

I've just generated a bunch of small editorial pull requests for
HTTP/2 (and a couple for header compression).  All the open issues now
have proposals.

I'm talking to Mark and Barry about when these might be integrated
into a new revision, but in the meantime, if you have a few minutes,
review would be appreciated.

https://github.com/http2/http2-spec/pulls

They should all be editorial, so leaving comments of github is fine.
Reply on list of you see anything that I've screwed up badly though.
Definitely reply here if you think that any of these shouldn't be
merged.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 20 Jan 2015 11:34:26 +1100

Hi Martin,

I had a look through the issues and their linked pulls; I saw one or two minor typos (pointed out in line notes, you should have received e-mails) but otherwise, looks good to me. 

These are very small changes, but I'd appreciate if other folks had a quick look as well.

Cheers,

> On 19 Jan 2015, at 9:40 am, Martin Thomson <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Willy Tarreau <[email-masked]>
Date: Wed, 21 Jan 2015 09:01:12 +0100

Hi Mark, hi Martin,

On Tue, Jan 20, 2015 at 11:34:26AM +1100, Mark Nottingham wrote:
> Hi Martin,
> 
> I had a look through the issues and their linked pulls; I saw one or two
> minor typos (pointed out in line notes, you should have received e-mails) but
> otherwise, looks good to me. 
> 

I visited several of them with any possible comment in front of them or
"OK" if I have no objection :
  #698 => OK
  #697 => OK
  #696 => maybe "if it cannot decompress a header block" would solve
          the issue instead, as it covers various causes ?
  #694 => OK
  #692 => read 4 of them, seems OK
  #690 (PRI safe & idempotent) => I don't know, I saw there was some debate
        about this between Roy and Amos and I don't know if there was an
        agreement (I missed it).
  #689 => OK
  #688 => OK
  #686 => OK
  #685 => OK
  #684 => OK for both
  #683 => OK
  #679 => OK
  #670 => OK

Willy

---

From: Martin Thomson <[email-masked]>
Date: Wed, 21 Jan 2015 09:27:06 -0800

Thanks for doing that Willy, it's always good to have a sanity check.

>           the issue instead, as it covers various causes ?

I've proposed the following change instead:

https://github.com/http2/http2-spec/pull/699

>         about this between Roy and Amos and I don't know if there was an

I didn't see any agreement either, but it's easier if we have the PR
ready in place.

---

From: Willy Tarreau <[email-masked]>
Date: Wed, 21 Jan 2015 18:34:48 +0100

> Thanks for doing that Willy, it's always good to have a sanity check.

I did it while drinking my coffee :-)

> https://github.com/http2/http2-spec/pull/699

Indeed, looks good this way.

Willy