Subject: draft-ietf-httpbis-http2-latest, "9.1 Connection Management"

From: Julian Reschke <[email-masked]>
Date: Tue, 13 Jan 2015 16:29:45 +0100

<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-http2-16.html#rfc.section.9.1.p.2>:

"Clients SHOULD NOT open more than one HTTP/2 connection to a given host 
and port pair, where host is derived from a URI, a selected alternative 
service [ALT-SVC], or a configured proxy."

Doesn't this make ALT-SVC a normative dependency?

Best regards, Julian

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Jan 2015 10:00:47 -0800

On 13 January 2015 at 07:29, Julian Reschke <[email-masked]> wrote:
> "Clients SHOULD NOT open more than one HTTP/2 connection to a given host and
> port pair, where host is derived from a URI, a selected alternative service
> [ALT-SVC], or a configured proxy."
>

I don't think so.  The normative statement preceding the first comma
could be complete.  The remainder is merely informative.