Subject: Clarification about Alt-Svc

From: Ryan Hamilton <[email-masked]>
Date: Wed, 14 Jan 2015 13:29:37 -0800

Howdy,

I'd like to clarify that if a server would like to advertise two alternate
services with different expirations, it would do so with something like:

    Alt-Svc: h2=":80"; ma=3600, h2="new.example.org:80"; ma=3600

Am I reading that correctly? Section 3 specifies:

    Alt-Svc       = 1#( alternative *( OWS ";" OWS parameter ) )

But I'm not confident that I understand what "1#" means in that line.

Cheers,

Ryan

---

From: Julian Reschke <[email-masked]>
Date: Wed, 14 Jan 2015 22:40:13 +0100

,,,
On 2015-01-14 22:29, Ryan Hamilton wrote:
> Howdy,
>
> I'd like to clarify that if a server would like to advertise two
> alternate services with different expirations, it would do so with
> something like:
>
>      Alt-Svc: h2=":80"; ma=3600, h2="new.example.org:80
> <http://new.example.org:80>"; ma=3600
>

The definition is over here: 
<http://svn.tools.ietf.org/svn/wg/httpbis/specs/rfc7230.html#abnf.extension>

So it could be:

or

   Alt-Svc: ,,,h2=":80";ma=3600,,,,h2="new.example.org:80";ma=3600,,,

or even

  Alt-Svc: h2=":80"; ma=3600
  Alt-Svc: h2="new.example.org:80"; ma=3600

Best regards, Julian

---

From: Ryan Hamilton <[email-masked]>
Date: Wed, 14 Jan 2015 13:52:04 -0800

On Wed, Jan 14, 2015 at 1:40 PM, Julian Reschke <[email-masked]>
wrote:

> The definition is over here: <http://svn.tools.ietf.org/
> svn/wg/httpbis/specs/rfc7230.html#abnf.extension>
>

​AH! Thanks.
​

>  Alt-Svc: h2="new.example.org:80"; ma=3600

​Perfect. Thanks so much.