Subject: Re: draft-ietf-httpbis-client-hints-06

From: Julian Reschke <[email-masked]>
Date: Wed, 19 Sep 2018 18:15:53 +0200

On 8/8/2018 6:52 AM, Ilya Grigorik wrote:
> On Sun, Aug 5, 2018 at 12:46 AM Julian Reschke <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>      >
>      > Mark, Julian: any guidance on this one?
>      >
>      >     |   If <X> occurs in a message more than once, the last value
>      >     |   overrides all previous occurrences.
>      >
>      >     So it should mention that on these header fields also last value
>      >     is used when values are ',' -separated.
>      >
>      >
>      > My understanding is that this is implicit, but if that's not the
>     case,
>      > happy to rework the wording.
>      > ...
> 
>     No, it's not implicit, so yes, a clarification would be good.
> 
>     FWIW, related issue in http-core:
>     <https://github.com/httpwg/http-core/issues/111>
> 
> 
> Ah, interesting. Thanks for the pointer!
> 
> Obvious followup question: do we have any existing, vetted text in other 
> specs that I should be looking at? I can't imagine this is the first 
> instance of this particular problem.

I don't think we have good text yet.

We should discuss over here or in the github issue, and once we have a 
stable proposal, you could steal text from that.

Best regards, Julian

---

From: Ilya Grigorik <[email-masked]>
Date: Sat, 29 Sep 2018 15:29:33 -0700

Opened: https://github.com/httpwg/http-extensions/issues/700