Subject: [Editorial Errata Reported] RFC7838 (6480)

From: RFC Errata System <[email-masked]>
Date: Fri, 12 Mar 2021 15:32:41 -0800 (PST)

The following errata report has been submitted for RFC7838,
"HTTP Alternative Services".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6480

--------------------------------------
Type: Editorial
Reported by: Lucas Pardue <[email-masked]>

Section: 2

Original Text
-------------
Formally, an alternative service is identified by the combination of:

   o  An Application Layer Protocol Negotiation (ALPN) protocol name, as
      per [RFC7301]

Corrected Text
--------------
Formally, an alternative service is identified by the combination of:

   o  An Application-Layer Protocol Negotiation (ALPN) protocol name, as
      per [RFC7301]

Notes
-----
RFC 7301 seems to formally use the hyphenated version. Most relevant to RFC 7838 is the ALPN ID registry, which RFC 7301 states:

   This document establishes a registry for protocol identifiers
   entitled "Application-Layer Protocol Negotiation (ALPN) Protocol IDs"

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7838 (draft-ietf-httpbis-alt-svc-14)
--------------------------------------
Title               : HTTP Alternative Services
Publication Date    : April 2016
Author(s)           : M. Nottingham, P. McManus, J. Reschke
Category            : PROPOSED STANDARD
Source              : HTTP
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: Julian Reschke <[email-masked]>
Date: Sat, 13 Mar 2021 11:21:42 +0100

> "HTTP Alternative Services".

A missing hyphen is, well, an error, but on a severity scale from 0 to 
10 it's clearly very close to 0.

I think "held for document update" is the right status here.

Best regards, Julian

-- 
<green/>bytes GmbH, Hafenweg 16, D-48155 Münster, Germany
Amtsgericht Münster: HRB5782