Subject: Fwd: New Version Notification for draft-cdn-control-header-01.txt

From: Mark Nottingham <[email-masked]>
Date: Thu, 18 Mar 2021 11:56:29 +1100

This update incorporates feedback and discussion to date; instead of being CDN-specific, it's now a framework for targeting Cache-Control directives, with (so far) one predefined targeted header for CDNs.

Cheers,

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-cdn-control-header-01.txt
> Date: 18 March 2021 at 11:53:55 am AEDT
> To: "Mark Nottingham" <[email-masked]>, "Stephen Ludin" <[email-masked]>, "Yuchen Wu" <[email-masked]>
> 
> 
> A new version of I-D, draft-cdn-control-header-01.txt
> has been successfully submitted by Mark Nottingham and posted to the
> IETF repository.
> 
> Name:		draft-cdn-control-header
> Revision:	01
> Title:		Targeted HTTP Response Header Fields for Cache Control
> Document date:	2021-03-17
> Group:		Individual Submission
> Pages:		8
> URL:            https://www.ietf.org/archive/id/draft-cdn-control-header-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-cdn-control-header/
> Html:           https://www.ietf.org/archive/id/draft-cdn-control-header-01.html
> Htmlized:       https://tools.ietf.org/html/draft-cdn-control-header-01
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-cdn-control-header-01
> 
> Abstract:
>   This specification defines a convention for HTTP response header
>   fields that allow directives controlling caching to be targeted at
>   specific caches or classes of caches.  It also defines one such
>   header field, targeted at Content Delivery Network (CDN) caches.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Willy Tarreau <[email-masked]>
Date: Thu, 1 Apr 2021 05:36:29 +0200

Hi Mark,

On Thu, Mar 18, 2021 at 11:56:29AM +1100, Mark Nottingham wrote:
> 
> This update incorporates feedback and discussion to date; instead of being
> CDN-specific, it's now a framework for targeting Cache-Control directives,
> with (so far) one predefined targeted header for CDNs.

I had a look at it and I think it can be useful. Also the idea of keeping
the exact same format will help some simply rename the header fields before
entering their infrastructure and when leaving it. If it takes off maybe
we'll progressively see nicely differentiated headers targetting browsers
and CDNs.

Willy