Subject: Call for Adoption: draft-bdc-something-something-certificate-05

From: Mark Nottingham <[email-masked]>
Date: Thu, 1 Apr 2021 10:26:40 +1100

Hello everyone,

This is a Call for Adoption for 'Client-Cert HTTP Header: Conveying Client Certificate Information from TLS Terminating Reverse Proxies to Origin Server Applications', found at:
  https://www.ietf.org/archive/id/draft-bdc-something-something-certificate-05.html

The intended status of the document would be Informational. Please comment on whether you support adoption of this document. As always, adoption of a document is treated as a starting point, and its contents may change as part of the process.

The Call for Adoption will run until 14 April.

- Mark and Tommy

---

From: Willy Tarreau <[email-masked]>
Date: Thu, 1 Apr 2021 06:38:11 +0200

On Thu, Apr 01, 2021 at 10:26:40AM +1100, Mark Nottingham wrote:
> The intended status of the document would be Informational. Please comment on
> whether you support adoption of this document. As always, adoption of a
> document is treated as a starting point, and its contents may change as part
> of the process.

I think that trying to unify the format and rules around this is needed,
as plenty of intermediaries are involved in TLS offloading, and once
required to pass client-cert, their users do what they think they need
instead of doing something safe and reliable. It's also a pain to implement
in applications since there's no standard nor even guidelines around this.

As such, I do support adoption.

Willy