Subject: Fwd: New Version Notification for draft-nottingham-cache-trailers-00.txt

From: Mark Nottingham <[email-masked]>
Date: Mon, 8 Mar 2021 13:18:21 +1100

Following up on the long thread a few weeks ago, here's a proposal from James and I for allowing a response to update caching policy in trailers.

Cheers,

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-nottingham-cache-trailers-00.txt
> Date: 8 March 2021 at 1:17:02 pm AEDT
> To: "James Snell" <[email-masked]>, "Mark Nottingham" <[email-masked]>
> 
> 
> A new version of I-D, draft-nottingham-cache-trailers-00.txt
> has been successfully submitted by Mark Nottingham and posted to the
> IETF repository.
> 
> Name:		draft-nottingham-cache-trailers
> Revision:	00
> Title:		Updating HTTP Caching Policy in Trailers
> Document date:	2021-03-08
> Group:		Individual Submission
> Pages:		6
> URL:            https://www.ietf.org/archive/id/draft-nottingham-cache-trailers-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-nottingham-cache-trailers/
> Html:           https://www.ietf.org/archive/id/draft-nottingham-cache-trailers-00.html
> Htmlized:       https://tools.ietf.org/html/draft-nottingham-cache-trailers-00
> 
> 
> Abstract:
>   This specification defines how to update caching policy for a
>   response in HTTP trailer fields, after the content has been sent.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 26 Mar 2021 17:23:49 +1100

Did the mega-thread tire people out on this topic?

> On 8 Mar 2021, at 1:18 pm, Mark Nottingham <[email-masked]> wrote:
>

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Fri, 26 Mar 2021 07:02:41 +0000

--------

> Did the mega-thread tire people out on this topic?

I still think it is a fundamentally bad idea to try to solve the
header/trailer consistency problem using the salami-method.

I prefer a simple clear-cut rule which leaved only a single
authoritative instance of any given field.

For instance:

    If a field is present in the header it SHALL be ignored in the trailer.

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.

---

From: Willy Tarreau <[email-masked]>
Date: Fri, 26 Mar 2021 10:08:03 +0100

>     If a field is present in the header it SHALL be ignored in the trailer.

But it does the opposite, it makes two authorities, with one stronger
than the other, and that's exactly what causes issues on implementations
that only handle the part relevant to them.

I'd rather use non-overlapping, independent sets. This way, an
implementation finding a content-type (or whatever) in trailers only
would not face the risk of working differently from one that ignores
trailers and only sees the header is absent.

Willy

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 29 Mar 2021 18:43:43 +1100

> On 26 Mar 2021, at 6:02 pm, Poul-Henning Kamp <[email-masked]> wrote:
> 
> --------
> Mark Nottingham writes:
> 

That's a fundamentally different approach to trailers, and would require a much bigger effort to gain consensus (because it limits *all* trailers). You're concerned about 'salami tactics', I'm concerned about boiling the ocean on a topic where we have limited resources. 

Cheers,