Subject: Re: Call for Adoption: SEARCH method

From: Julian Reschke <[email-masked]>
Date: Wed, 31 Mar 2021 17:48:43 +0200

Am 02.12.2020 um 04:52 schrieb Tommy Pauly:
> Thanks for all of the feedback and detailed discussion on draft-snell-search-method!
>
> Based on the input, we believe that the working group has consensus to adopt this item. Many of the details, including the method name, will continue to be discussed as this is adopted, but the scope of work is to define a method that has the behavior of a GET with a body.
>
> Best,
> Tommy & Mark
> ...

I've been sitting on this until the http-core drafts were finished (for
some value of "finished").

Now that these are out, I'v republished the document that was adopted as
  draft-ietf-httpbis-safe-method-w-body-00:

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the HTTP WG of the IETF.
>
>         Title           : HTTP SEARCH Method
>         Authors         : Julian Reschke
>                           Ashok Malhotra
>                           James M Snell
> 	Filename        : draft-ietf-httpbis-safe-method-w-body-00.txt
> 	Pages           : 8
> 	Date            : 2021-03-31
>
> Abstract:
>    This specification updates the definition and semantics of the HTTP
>    SEARCH request method originally defined by RFC 5323.
>
> Editorial Note
>
>    Discussion of this draft takes place on the HTTP working group
>    mailing list ([email-masked]), which is archived at
>    https://lists.w3.org/Archives/Public/ietf-http-wg/.
>
>    This note is to be removed before publishing as an RFC.
>
>    Working Group information can be found at https://httpwg.org/; source
>    code and issues list for this draft can be found at
>    https://github.com/httpwg/http-extensions/labels/safe-method-w-body.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-httpbis-safe-method-w-body/
>
> There is also an HTML version available at:
> https://www.ietf.org/archive/id/draft-ietf-httpbis-safe-method-w-body-00.html

(note that I have used a draft filename that makes it clear the method
name is really not cast in stone yet)

Best regards, Julian

---

From: Roberto Polli <[email-masked]>
Date: Thu, 1 Apr 2021 08:34:42 +0200

Great work Julian & co!