Subject: Re: [bcp56bis] Using TLS in HTTP API specification

From: Roberto Polli <[email-masked]>
Date: Fri, 12 Mar 2021 14:53:33 +0100

Hi Rich + Mark,

wrt using TLS with HTTP, I just noted that the Editor's copy of  BCP56bis
in the http-extension repo references
the good work made on httpbis-semantics
https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#https.origin

Sadly I noticed just now that the datatracker revision I used  expired on
2020-05
- https://tools.ietf.org/html/draft-ietf-httpbis-bcp56bis-09
and not updated, and still mention RFC 2818
<https://tools.ietf.org/html/rfc2818>.
@Mark Nottingham <[email-masked]> is it possible to publish a new release of
bcp56bis so that all the other folks (eg. oauth, and httpapi) can
refer to the httpbis-semantics for specifying TLS ?

Thanks to everyone and have a nice day,
R.

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 13 Mar 2021 01:01:33 +1100

-10 was published a few days ago.

> On 13 Mar 2021, at 12:53 am, Roberto Polli <[email-masked]> wrote:
> 
> Hi Rich + Mark,
> 
> wrt using TLS with HTTP, I just noted that the Editor's copy of  BCP56bis in the http-extension repo references 
> the good work made on httpbis-semantics https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#https.origin
> 
> Sadly I noticed just now that the datatracker revision I used  expired on 2020-05 
> and not updated, and still mention RFC 2818.
> @Mark Nottingham is it possible to publish a new release of bcp56bis so that all the other folks (eg. oauth, and httpapi) can

--
Mark Nottingham   https://www.mnot.net/

---

From: Roberto Polli <[email-masked]>
Date: Fri, 12 Mar 2021 16:32:58 +0100

Hi!

Il giorno ven 12 mar 2021 alle ore 15:05 Mark Nottingham <[email-masked]> ha
> -10 was published a few days ago.

oops, I thought https://tools.ietf.org/html/ always showed all the
revisions in the header.
You'll never stop learning.

Sorry for the noise and have a nice day,
R.

---

From: Julian Reschke <[email-masked]>
Date: Fri, 12 Mar 2021 16:45:38 +0100

Am 12.03.2021 um 16:32 schrieb Roberto Polli:
> Hi!
>
> Il giorno ven 12 mar 2021 alle ore 15:05 Mark Nottingham <[email-masked]
> <mailto:[email-masked]>> ha scritto:
> oops, I thought https://tools.ietf.org/html/
> <https://tools.ietf.org/html/> always showed all the revisions in the
> header.

It used to, but there are bugs, and AFAIU, it's not getting the
attention anymore that it used to get. Better use
<https://datatracker.ietf.org/doc/draft-ietf-httpbis-bcp56bis/>.

Best regards, Julian