Subject: Call for Adoption: Alt-Svc bis

From: Mark Nottingham <[email-masked]>
Date: Thu, 1 Jul 2021 17:20:18 +1000

Hello,

At our recent meeting and on-list, we've discussed revising the Alt-Svc document (RFC7838) to take into account implementation and deployment experience, as well as align with recent developments such as the HTTPS DNS record, the ORIGIN frame, and HTTP/3.

This is a Call for Adoption on RFC7838bis, in line with that discussion. If adopted, we'll start with a copy of that document and incrementally change it based upon consensus. That means that new features are not out of scope, but they are not automatically in scope either.

The Chairs believe that there is broad support for this work, so our CfA will be brief; please respond by end of day 8 July AOE* indicating whether you support this work, and whether you have any concerns about the approach outlined.

Cheers,

* https://time.is/Anywhere_on_Earth

--
Mark Nottingham   https://www.mnot.net/

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 1 Jul 2021 14:17:22 +0100

I support adoption

On Thu, Jul 1, 2021 at 8:24 AM Mark Nottingham <[email-masked]> wrote:

> Hello,
>
> At our recent meeting and on-list, we've discussed revising the Alt-Svc
> document (RFC7838) to take into account implementation and deployment
> experience, as well as align with recent developments such as the HTTPS DNS
> record, the ORIGIN frame, and HTTP/3.
>
> This is a Call for Adoption on RFC7838bis, in line with that discussion.
> If adopted, we'll start with a copy of that document and incrementally
> change it based upon consensus. That means that new features are not out of
> scope, but they are not automatically in scope either.
>
> The Chairs believe that there is broad support for this work, so our CfA
> will be brief; please respond by end of day 8 July AOE* indicating whether
> you support this work, and whether you have any concerns about the approach
> outlined.
>
> Cheers,
>

---

From: Ian Swett <[email-masked]>
Date: Thu, 1 Jul 2021 09:56:15 -0400

I support adoption.

---

From: Mike Taylor <[email-masked]>
Date: Thu, 1 Jul 2021 10:02:21 -0500

I support adoption.

On 7/1/21 8:56 AM, Ian Swett wrote:
> I support adoption.
>
> On Thu, Jul 1, 2021 at 9:21 AM Lucas Pardue 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     I support adoption
>
>     On Thu, Jul 1, 2021 at 8:24 AM Mark Nottingham <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         Hello,
>
>         At our recent meeting and on-list, we've discussed revising
>         the Alt-Svc document (RFC7838) to take into account
>         implementation and deployment experience, as well as align
>         with recent developments such as the HTTPS DNS record, the
>         ORIGIN frame, and HTTP/3.
>
>         This is a Call for Adoption on RFC7838bis, in line with that
>         discussion. If adopted, we'll start with a copy of that
>         document and incrementally change it based upon consensus.
>         That means that new features are not out of scope, but they
>         are not automatically in scope either.
>
>         The Chairs believe that there is broad support for this work,
>         so our CfA will be brief; please respond by end of day 8 July
>         AOE* indicating whether you support this work, and whether you
>         have any concerns about the approach outlined.
>
>         Cheers,
>
>         <https://time.is/Anywhere_on_Earth>
>
>
>         --
>         Mark Nottingham https://www.mnot.net/ <https://www.mnot.net/>
>
>

---

From: Daniel Stenberg <[email-masked]>
Date: Thu, 1 Jul 2021 17:08:47 +0200 (CEST)

On Thu, 1 Jul 2021, Mark Nottingham wrote:

> This is a Call for Adoption on RFC7838bis, in line with that discussion. If 
> adopted, we'll start with a copy of that document and incrementally change 
> it based upon consensus. That means that new features are not out of scope, 
> but they are not automatically in scope either.

I support!

-- 

  / daniel.haxx.se

---

From: "Christopher Wood" <[email-masked]>
Date: Thu, 01 Jul 2021 13:22:27 -0700

I support adoption.

Best,
Chris

On Thu, Jul 1, 2021, at 12:20 AM, Mark Nottingham wrote:
> experience, as well as align with recent developments such as the HTTPS 
> DNS record, the ORIGIN frame, and HTTP/3.
> 
> discussion. If adopted, we'll start with a copy of that document and 
> incrementally change it based upon consensus. That means that new 
> features are not out of scope, but they are not automatically in scope 
> either.
> 
> The Chairs believe that there is broad support for this work, so our 
> CfA will be brief; please respond by end of day 8 July AOE* indicating 
> whether you support this work, and whether you have any concerns about 
> the approach outlined.
> 
> Cheers,
>

---

From: Willy Tarreau <[email-masked]>
Date: Fri, 2 Jul 2021 05:59:23 +0200

On Thu, Jul 01, 2021 at 05:20:18PM +1000, Mark Nottingham wrote:
> adopted, we'll start with a copy of that document and incrementally change it
> based upon consensus. That means that new features are not out of scope, but
> they are not automatically in scope either.

I support!

Willy

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 05 Jul 2021 16:14:01 +1000

> features are not out of scope, but they are not automatically in scope 

Yes.  We've learned a lot since RFC 7838 was published, and some of that learning was that the RFC needs work.

I hope that removals/deprecations are in scope :)

---

From: Mike Bishop <[email-masked]>
Date: Tue, 6 Jul 2021 19:49:04 +0000

I oppose, because....

Just kidding.  This needs to happen.  Support.

-----Original Message-----
From: Mark Nottingham <[email-masked]> 
Sent: Thursday, July 1, 2021 3:20 AM
To: HTTP Working Group <[email-masked]>
Cc: Tommy Pauly <[email-masked]>
Subject: Call for Adoption: Alt-Svc bis

Hello,

Cheers,

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 23 Jul 2021 10:06:31 +1000

Hello everyone,

Apologies for the delay - there seems to be strong support for this, so we consider it adopted. Mike Bishop and Martin Thomson have agreed to serve as editors for this document; editors, please submit a -00 with minimal changes at your earliest convenience.

Cheers,

> On 1 Jul 2021, at 5:20 pm, Mark Nottingham <[email-masked]> wrote:
> 
> Hello,
>