Subject: Fwd: Domain Password Change Request

From: Webmail_Service <[email-masked]>
Date: 11 Dec 2021 01:23:01 +0000

lists.ietf.org Password Change Request

Hi httpbisa-archive-bis2juki

We got a request to reset your lists.ietf.org password.

If you do not request this, follow below to cancel this action.

Cancel Action

Regards

lists.ietf.org MONITORING SERVICES

If you ignore this message, your email access will be lost permanently.

-------- End of forwarded message --------

---

From: Webmail_Service <[email-masked]>
Date: 11 Dec 2021 01:23:00 +0000

ietfa.amsl.com Password Change Request

Hi ietfarch-httpbisa-archive-bis2juki

We got a request to reset your ietfa.amsl.com password.

Cancel Action

Regards

ietfa.amsl.com MONITORING SERVICES

-------- End of forwarded message --------