Subject: AD review of draft-ietf-httpbis-targeted-cache-control-02

From: Francesca Palombini <[email-masked]>
Date: Thu, 9 Dec 2021 21:46:58 +0000

Thank you for the work on this document.

I only have two minor comments, please address them at the same time as the Last Call comments.

I have opened a github issue with this text: https://github.com/httpwg/http-extensions/issues/1831

Francesca

1. -----

FP: Probably just me missing this conversation, but I was surprised to see that section 2.4 explicitly calls for fields that needs to be registered to use this document as specification document. That surprises me, since for permanent registrations the registration procedure is specification required, and so a specification going into detail for that field should be provided. Maybe what this document meant to say was that draft-ietf-httpbis-targeted-cache-control should be *one of* the specifications for new registrations?

2. -----

FP: Section 3.1 Examples should have a sentence specifying what the target list for those examples is.

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 10 Dec 2021 14:50:57 +1100

Hi Francesca,

> On 10 Dec 2021, at 8:46 am, Francesca Palombini <[email-masked]> wrote:
> 

This specification contains all of the necessary details to parse, serialise, understand and apply the semantics of those headers -- the only thing it lacks is the target for the semantics. In most cases, that will be obvious based upon the context -- e.g., Akamai-Cache-Control with a reference to this document is pretty clear about its semantics, and in a pinch Akamai can add some information in its local documentation (perhaps meriting an additional link or note in the registry).

> FP: Section 3.1 Examples should have a sentence specifying what the target list for those examples is.

See:
  https://github.com/httpwg/http-extensions/commit/d0e95724e9

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Francesca Palombini <[email-masked]>
Date: Fri, 10 Dec 2021 14:11:53 +0000

Hi Mark,

Thanks for the quick reply. Ok, I understand, and I guess what I was thinking was that (to continue with your example) it would make sense to list both this document and the link to the documentation as specifications for the registry, if documentation exists – i.e. not limit the reference to only this document. But again this is minor, so I am happy with your answer, and making sure it was considered.

Thanks for adding the one line about the target list.

Francesca

From: Mark Nottingham <[email-masked]>
Date: Friday, 10 December 2021 at 04:51
To: Francesca Palombini <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: AD review of draft-ietf-httpbis-targeted-cache-control-02
Hi Francesca,

> I have opened a github issue with this text: https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-10bdb25e4641dca9&q=1&e=0-b7953d35ae4b06b56c683a662649000c&u=https%3A%2F%2Fgithub.com%2Fhttpwg%2Fhttp-extensions%2Fissues%2F1831
>
> Francesca
>
> 1. -----
>

> FP: Section 3.1 Examples should have a sentence specifying what the target list for those examples is.

See:
  https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-4a95773f8705c6c6&q=1&e=0-b7953d35ae4b06b56c683a662649000c&u=https%3A%2F%2Fgithub.com%2Fhttpwg%2Fhttp-extensions%2Fcommit%2Fd0e95724e9

Cheers,

--
Mark Nottingham   https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-f789ee25791b0a49&q=1&e=0-b7953d35ae4b06b56c683a662649000c&u=https%3A%2F%2Fwww.mnot.net%2F

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 13 Dec 2021 15:14:01 +1100

Ah, I see what you're saying. How about this?
  https://github.com/httpwg/http-extensions/commit/f3c890955e

Cheers,

> On 11 Dec 2021, at 1:11 am, Francesca Palombini <[email-masked]> wrote:
> 
> Hi Mark,
>  
> Cc: [email-masked] <[email-masked]>, [email-masked]<[email-masked]>

---

From: Francesca Palombini <[email-masked]>
Date: Mon, 13 Dec 2021 09:16:52 +0000

That addresses my comments, thanks Mark!

Francesca

From: Mark Nottingham <[email-masked]>
Date: Monday, 13 December 2021 at 05:14
To: Francesca Palombini <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: AD review of draft-ietf-httpbis-targeted-cache-control-02
Ah, I see what you're saying. How about this?
  https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-6a1791b6b2e59e85&q=1&e=a5c1ea1c-cdc4-4e2a-af7a-6f8a0b33a037&u=https%3A%2F%2Fgithub.com%2Fhttpwg%2Fhttp-extensions%2Fcommit%2Ff3c890955e

Cheers,

--
Mark Nottingham   https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-f789ee25791b0a49&q=1&e=a5c1ea1c-cdc4-4e2a-af7a-6f8a0b33a037&u=https%3A%2F%2Fwww.mnot.net%2F