Subject: Re: [Technical Errata Reported] RFC7230 (6890)

From: Julian Reschke <[email-masked]>
Date: Mon, 21 Mar 2022 09:52:53 +0100

Am 21.03.2022 um 09:50 schrieb RFC Errata System:
> The following errata report has been submitted for RFC7230,
> "Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing".
> ...

I believe this is a duplicate of 
<https://www.rfc-editor.org/errata/eid4189>.

Best regards, Julian

---

From: RFC Errata System <[email-masked]>
Date: Mon, 21 Mar 2022 01:50:24 -0700 (PDT)

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6890

--------------------------------------
Type: Technical
Reported by: Tim Düsterhus <[email-masked]>

Section: 3.2

Original Text
-------------
     field-content  = field-vchar [ 1*( SP / HTAB ) field-vchar ]

Corrected Text
--------------
     field-content  = field-vchar [ 1*( SP / HTAB / field-vchar ) field-vchar ]

Notes
-----
The ABNF currently rejects "1 2 3" as a valid header value, as the field-content production either matches a single character or two characters separated by whitespace. Thus it consumes the "1 2", leaving "<space>3" which does not match field-value.

This error is already fixed in https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#rfc.section.5.5

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7230 (draft-ietf-httpbis-p1-messaging-26)
--------------------------------------
Title               : Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
Publication Date    : June 2014
Author(s)           : R. Fielding, Ed., J. Reschke, Ed.
Category            : PROPOSED STANDARD
Source              : Hypertext Transfer Protocol Bis APP
Area                : Applications
Stream              : IETF
Verifying Party     : IESG