Subject: Proposed HTTP field name registry updates - feedback solicited

From: Mark Nottingham <[email-masked]>
Date: Thu, 31 Mar 2022 15:08:49 +1100

Hi everyone,

Wearing my hat as IANA Expert for the HTTP Field Name registry (and CC:ing my co-expert for his feedback):

I've been doing a pass through the registry to assure that entries are up-to-date, and am planning a few changes that I'd like community input on. Please say if you have any concerns or other feedback about the proposed changes below.

1. The following header fields are all registered as 'provisional', are based upon Internet-Drafts that expired a long time ago, and have not seen any recent deployment to the best of my knowledge. The proposal is to remove them from the registry.

  - Optional, Resolution-Hint, Resolver-Location: draft-girod-w3-id-res-ext 
  - Compliance, Non-Compliance: Mogul, J., Cohen, J., and S. Lawrence, "Specification of HTTP/1.1 OPTIONS messages
  - SubOK, Subst: Mogul, J. and A. van Hoff, "Duplicate Suppression in HTTP"
  - UA-Color, UA-Media, UA-Pixels, UA-Resolution, UA-Windowpixels: Masinter, L., Montulli, L., and A. Mutz, "User-Agent Display Attributes Headers"

2. RFC2068 defined "URI" and "Public", but 2616 obsoleted it without carrying them forward. They are currently registered as 'permanent'; the proposal is to mark them as 'obsoleted'.

3. Similarly, 2068 defined "Content-Version" and "Derived-From" for use with PATCH, but they were not carried into RFC5789. The proposal is to mark them as 'obsoleted'; they are currently 'permanent'.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 30 Mar 2022 21:32:14 -0700

These updates all sound good. Thanks, Mark!

Tommy  

> On Mar 30, 2022, at 9:12 PM, Mark Nottingham <[email-masked]> wrote:
> 
> Hi everyone,
>

---

From: Willy Tarreau <[email-masked]>
Date: Thu, 31 Mar 2022 08:57:14 +0200

Hi Mark,

On Thu, Mar 31, 2022 at 03:08:49PM +1100, Mark Nottingham wrote:
> 1. The following header fields are all registered as 'provisional', are based
> upon Internet-Drafts that expired a long time ago, and have not seen any
> recent deployment to the best of my knowledge. The proposal is to remove them
> from the registry.
> 
>   - Compliance, Non-Compliance: Mogul, J., Cohen, J., and S. Lawrence,
>     "Specification of HTTP/1.1 OPTIONS messages
>   - UA-Color, UA-Media, UA-Pixels, UA-Resolution, UA-Windowpixels: Masinter,
>     L., Montulli, L., and A. Mutz, "User-Agent Display Attributes Headers"
> 
> 2. RFC2068 defined "URI" and "Public", but 2616 obsoleted it without carrying
> them forward. They are currently registered as 'permanent'; the proposal is
> to mark them as 'obsoleted'.
> 
> 3. Similarly, 2068 defined "Content-Version" and "Derived-From" for use with
> PATCH, but they were not carried into RFC5789. The proposal is to mark them
> as 'obsoleted'; they are currently 'permanent'.

I wasn't even aware of these and do not remember having ever met any of
them. No concern from me!

Cheers,
Willy

---

From: Roberto Polli <[email-masked]>
Date: Thu, 31 Mar 2022 15:54:54 +0200

Hi Mark,

FWIW I'm ok with that.

Have a nice day,
R:

Il giorno gio 31 mar 2022 alle ore 09:00 Willy Tarreau <[email-masked]> ha