Subject: An informational+individual RFC for migrating from Digest?

From: Roberto Polli <[email-masked]>
Date: Tue, 22 Mar 2022 13:02:28 +0100

Dear Mark & co,

since the new Digest introduced Structured Fields,
and the new syntax is not backward compatible,
it would be helpful for implementers to be guided in the transition.

iiuc this detailed guide is out of scope
for a standard RFC like this one.
Do you think that an individual, informative one
could be a better place for this kind of information?

Have a nice day,
R.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 23 Mar 2022 08:15:46 +1100

Hi Roberto,

My personal .02 - publishing this on the Independent stream will cause confusion, because the RFC Series will be seeming to recommend two paths forward at the same time. We discussed the status of the old constructs extensively and came to consensus that the best thing to do was to encourage uniform use of the new constructs' semantics and syntax consistently. 

I think that the best thing to do is wait and see how the new specification is taken up -- that will take some time, of course. 

Cheers,

> On 22 Mar 2022, at 11:02 pm, Roberto Polli <[email-masked]> wrote:
> 
> Dear Mark & co,
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 22 Mar 2022 14:25:04 -0700

Another option, if this is just a migration guide for implementations, is to write something up as a blog post / online article / wiki. This could be something that would helpful to the implementers you’re concerned about, and also clearly point to the new standard as the official definition of the protocol.

I agree with Mark that there shouldn’t be an Internet Draft / RFC for this. 

Tommy

> On Mar 22, 2022, at 2:19 PM, Mark Nottingham <[email-masked]> wrote:
> 
> Hi Roberto,
>

---

From: Roberto Polli <[email-masked]>
Date: Wed, 23 Mar 2022 19:25:14 +0100

Hi all,

thanks for your time and sorry for bringing again the thread, but I had to
:)

Have a nice day,
R:

Il giorno mar 22 mar 2022 alle ore 22:25 Tommy Pauly <[email-masked]> ha
scritto:

> Another option, if this is just a migration guide for implementations, is
> to write something up as a blog post / online article / wiki. This could be
> something that would helpful to the implementers you’re concerned about,
> and also clearly point to the new standard as the official definition of
> the protocol.
>
> > My personal .02 - publishing this on the Independent stream will cause
> confusion, because the RFC Series will be seeming to recommend two paths
> forward at the same time. We discussed the status of the old constructs
> extensively and came to consensus that the best thing to do was to
> encourage uniform use of the new constructs' semantics and syntax
> consistently.
> >
> > I think that the best thing to do is wait and see how the new
> specification is taken up -- that will take some time, of course.
> >
> > Cheers,
> >
> >