Subject: [Hubmib] IEEE Interim Meeting - WG Last Call for Power Ethernet MIB

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 13 Jan 2003 14:52:38 +0200

I attended last week one of the sessions of the IEEE 802.3af (Power Ethernet) interim meeting. I gave a short presentation focused on a outline of the last Power Ethernet MIB, which is now in WG Last Call. I received several comments which I would like to bring to the attention of the WG, and be considered as comments to the last call. At the same time I would like to re-iterate the invitation made to the IEEE 802.3af participants to have another read of the document (http://www.ietf.cnri.reston.va.us/internet-drafts/draft-ietf-hubmib-power-ethernet-mib-04.txt) and send their comments to [email-masked]. The Last Call expires in two days.

Here are the IEEE folks comments:

1. Align the enumerated names for pethPsePortPowerPairs with the terminology used in the IEEE draft - alternativeA, alternativeB instead of spare, signal.
2. The capability to performed control of detection has been removed of the mandatory clauses of the IEEE standard, thus the object pethPsePortPowerDetectionControl should be removed.
3. The state test(7) in pethPsePortDetectionStatus needs to be removed
4. Typo in the enumerated of pethPsePortPowerMaintenanceStatus - it is meant to be overCurrent, and not underCurrent
5. Recommend a separate conformance clause for pethMainPseTable, which is a 'high-end' feature
6. For power management, it was suggested that the usage threshold comparison be made not with the measured, but rather with the consumption-based estimated usage, as devices may have a temporary usage below the power allowed by their class. 

After the meeting I learnt about another important change, which will impact the MIB:
7. The PD group is no longer mandatory - this actually means that the pethPfPortTable can be taken out of the MIB
Regards,

Dan

---

From: "C. M. Heard" <[email-masked]>
Date: Mon, 13 Jan 2003 15:01:17 -0800 (PST)

On Mon, 13 Jan 2003, Romascanu, Dan (Dan) wrote:

> I attended last week one of the sessions of the IEEE 802.3af (Power
> Ethernet) interim meeting.  I gave a short presentation focused on a
> outline of the last Power Ethernet MIB, which is now in WG Last Call.
> I received several comments which I would like to bring to the
> attention of the WG, and be considered as comments to the last call.

It is good to get these comments.

> Here are the IEEE folks comments:
[ ... ]
> 5. Recommend a separate conformance clause for pethMainPseTable, which

Note that pethCompliance already does this by making pethMainPseGroup
conditionally required:

           GROUP   pethMainPseGroup
           DESCRIPTION
               "The pethMainPseGroup is mandatory for systems which
               implement main power supply within a PSE Device."

since pethMainPseGroup includes all the accessible columns in
the pethMainPseTable.

Thus, if my previous suggestion to eliminate pethPseCompliance and
pethPdCompliance in favor of pethPseCompliance is accepted, then
this comment will be addressed, too.  (The alternative is to eliminate
pethCompliance and make more specific compliance statements;  that's
not as simple, but it's OK.  There shouldn't be any redundant
compliance statements, however.)

> 7. The PD group is no longer mandatory - this actually means that the
> pethPfPortTable can be taken out of the MIB

Comment:  there is one accessible column in pethPdPortTable, namely 
pethPdPortAdminEnable, and if this goes then pethPdPortGroup goes
with it.  That would eliminate the corresponding GROUP clause of
pethCompliance (and would completely eliminate pethPdCompliance).

Mike

_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: "C. M. Heard" <[email-masked]>
Date: Mon, 13 Jan 2003 15:01:17 -0800 (PST)

[ ... ]

           GROUP   pethMainPseGroup
           DESCRIPTION

Mike