Subject: RE: [Hubmib] RE: EFM PHY status for 2BASE-TL

From: "Edward Beili" <[email-masked]>
Date: Wed, 14 Jul 2004 20:29:29 +0300

I will do that by the end of the week, after collecting more comments, and of course will do the OID edit. In the mean time here's the latest version of EFM-CU-MIB.
 
Regards,
-E.

	-----Original Message----- 
	From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
	Sent: Wed 7/14/2004 8:08 PM 
	To: C. M. Heard; Edward Beili 
	Cc: [email-masked] 
	Subject: RE: [Hubmib] RE: EFM PHY status for 2BASE-TL

	Edward,
	
	Please submit without too much delay, and make the OID edit recommended by Mike.
	
	Regards,
	
	Dan

	> -----Original Message-----
	> From: [email-masked]
	> [mailto:[email-masked]]On Behalf Of C. M. Heard
	> Sent: 14 July, 2004 7:31 PM
	> To: Edward Beili
	> Cc: [email-masked]
	> Subject: Re: [Hubmib] RE: EFM PHY status for 2BASE-TL
	>
	>
	> On Wed, 23 Jun 2004, Edward Beili wrote:
	> > I've attached the latest version of EFM CU MIB.
	> ...
	> [ snip pre-submission version of draft-ietf-hubmib-efm-cu-mib-01.txt ]
	>
	> The I-D repository still has the -00 version.  The -01 version needs
	> to be submitted soon, since the final cutoff for I-D submission for
	> the upcoming 60th IETF meeting is Monday, Jul 19, 0900 EDT (when it
	> is submitted you need to replace { mib-2 160 } with ( mib-2 YYY }).
	>
	> Regards,
	>
	> Mike Heard
	>
	>
	>
	> _______________________________________________
	> Hubmib mailing list
	> [email-masked]
	> https://www1.ietf.org/mailman/listinfo/hubmib
	>

_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: "C. M. Heard" <[email-masked]>
Date: Wed, 14 Jul 2004 21:17:59 -0700 (PDT)

Edward,

As long as you are still collecting comments I decided to run the
MIB module through smilint.  Here is what it reported:

 This command (smilint 0.4.3-pre1, as of Fri Jul 09 15:59:34 2004)
 has been processed to get the following results:
 smilint -m -s -l 9 -i namelength-32 efm-cu-mib.mib

 efm-cu-mib.mib:93: [1] {} unknown object identifier label `mib-2'
 efm-cu-mib.mib:778: [5] {notification-not-reversible} warning:
 notification `efmCuLowBandwidth' is not reverse mappable
 efm-cu-mib.mib:1422: [5] {notification-not-reversible} warning:
 notification `efmCuPmeLineAtnCrossing' is not reverse mappable
 efm-cu-mib.mib:1436: [5] {notification-not-reversible} warning:
 notification `efmCuPmeSnrMgnCrossing' is not reverse mappable
 efm-cu-mib.mib:1449: [5] {notification-not-reversible} warning:
 notification `efmCuPmeDeviceFault' is not reverse mappable
 efm-cu-mib.mib:1460: [5] {notification-not-reversible} warning:
 notification `efmCuPmeConfigInitFailure' is not reverse mappable
 efm-cu-mib.mib:1474: [5] {notification-not-reversible} warning:
 notification `efmCuPmeProtocolInitFailure' is not reverse mappable

The first message means that you did not import the descriptor
`mib-2'.  That is easily fixed:

*** 2,8 ****

    IMPORTS
      MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE, Integer32,
!     Unsigned32, Counter32
        FROM SNMPv2-SMI   -- [RFC2578]
      TEXTUAL-CONVENTION, TruthValue, RowStatus, PhysAddress,
      DisplayString
--- 2,8 ----

    IMPORTS
      MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE, Integer32,
!     Unsigned32, Counter32, mib-2
        FROM SNMPv2-SMI   -- [RFC2578]
      TEXTUAL-CONVENTION, TruthValue, RowStatus, PhysAddress,
      DisplayString
 
The other messages mean that the OIDs assigned to the notifications
don't have a next-to-last subidentifier of zero.  See RFC 3584 for
why this is a bad thing.  There are several ways to fix this.  One
would be to reorganize the OIDs as suggested in the MIB review
guidelines draft.  Another would be to keep the same structure, but
change the last sub-IDs of efmCuPortNotifications and
efmCuPortNotifications as follows:

***************
*** 773,779 ****
  
    -- Port Notifications Group
  
!    efmCuPortNotifications OBJECT IDENTIFIER ::= { efmCuPort 4 }
     
     efmCuLowBandwidth NOTIFICATION-TYPE
       OBJECTS {
--- 773,779 ----
  
    -- Port Notifications Group
  
!    efmCuPortNotifications OBJECT IDENTIFIER ::= { efmCuPort 0 }
     
     efmCuLowBandwidth NOTIFICATION-TYPE
       OBJECTS {
***************
*** 1406,1412 ****
  
    -- PME Notifications Group
  
!    efmCuPmeNotifications OBJECT IDENTIFIER ::= { efmCuPme 4 }
     
     -- EdNote: Should I add more notifications here, for example
     --      efmCuPmePerfES,
--- 1406,1412 ----
  
    -- PME Notifications Group
  
!    efmCuPmeNotifications OBJECT IDENTIFIER ::= { efmCuPme 0 }
     
     -- EdNote: Should I add more notifications here, for example
     --      efmCuPmePerfES,

which might be easier in this case.

I have not had time to do a detailed MIB doctor review, but I do
notice that you import DisplayString, which has been deprecated for
most purposes.  See the MIB review guidelines for more information.

All the best,

Mike Heard

-----Original Message-----
From: Edward Beili [mailto:[email-masked]] 
Sent: Wednesday, July 14, 2004 11:26 AM
To: Romascanu, Dan (Dan); C. M. Heard
Cc: [email-masked]
Subject: RE: [Hubmib] RE: EFM PHY status for 2BASE-TL

I will do that by the end of the week, after collecting more
comments, and of course will do the OID edit. In the mean time
here's the latest version of EFM-CU-MIB.

Regards,
-E.

-----Original Message----- 
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Wed 7/14/2004 8:08 PM 
To: C. M. Heard; Edward Beili 
Cc: [email-masked] 
Subject: RE: [Hubmib] RE: EFM PHY status for 2BASE-TL

Edward,

Please submit without too much delay, and make the OID edit
recommended by Mike.

Regards,

Dan