Subject: Re: IETF solution for pairing cellular hosts

From: "Pars Mutaf" <[email-masked]>
Date: Wed, 3 Oct 2007 18:13:04 +0200

Hello,

I agree with you that a solution has two components:

1. naming and discovery of the target cell phone
2. pairing (the proposed solution)

Should we deal with naming in this mailing list?
Naming should be based on DNS? I'm not sure how
human names (especially colliding ones) are represented
in infrastructure DNS.

I know that multicast DNS can handle collisions.
It allows scanning a target name. One can scan
all John Smiths in range (in a large WiMax cell, or
WiFi network), choose the John Smith he is looking
for, and get paired with John Smith's cell phone.

But a multicast-based solution would be limited
to local scope.

Any thoughts from list members?

pars

On 9/27/07, Virendra Gandhi <[email-masked]> wrote:
>
> True but thank god this is not the case here, cause if it was then
> imagine the problems for pairing cellular hosts, but that's neither
> here nor there. The point is Naming has to be in place (to my mind
> above all else) to enable a lot of things.
>
> Virendra Gandhi
>
>
> On 9/26/07, IETF member Dave Aronson <[email-masked]> wrote:
> > Virendra Gandhi [mailto:[email-masked]] writes:
> >
> >  > This is the classic John Smith problem,
> >
> > As an interesting (at least to me) side note:  The most common *given*
> name in the world is Mohammed.  The most common *family* name in the world
> is Chang.  This does *not* mean that Mohammed Chang is a common name....
> >
> > :-)
> >
> > --
> > Dave Aronson
> > "Specialization is for insects."  -Heinlein
> > Work: http://www.davearonson.com/
> > Play: http://www.davearonson.net/
> >
> >
> >
> > _______________________________________________
> > Ietf mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ietf
> >
>
> _______________________________________________
> humanresolvers mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/humanresolvers
>
_______________________________________________
humanresolvers mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/humanresolvers

---

From: "Pars Mutaf" <[email-masked]>
Date: Mon, 8 Oct 2007 11:23:45 +0200

Hi Viendra,

You are suggesting that a cell phone can also be used
for searching services, the nearest gas station etc.
(why not the nearest chinese restaurant in this case), i.e.
not only people's phone numbers.

Personally I'm not sure we can prove this kind of use cases.
People can always suggest using Google?
(i.e. finding gas station locations on a Google map).

The cell phone pairing problem is more obvious to me.
You don't want to publish your phone number. Because
it is private.
(and other problems like the difficulty of manually exchanging
SIP URIs, Mobile IPv6 home addresses etc.)

Comments?

pars

PS: Thanks. Could we stay focused on the problem statement,
and talk about naming solutions later?

On 10/6/07, Virendra Gandhi <[email-masked]> wrote:
>
> I have been working on visualizing such scenarios and to me too, the
> best options are,  first as suggested by Pars to allow the target by
> pushing the yes button (presuming that the query mentioned in the 3rd
> point will be a 'short message' stating the purpose for which qurier
> wants to interact, second as suggested by Dean, by enabling the qurier
> to forward the message to the Naming /Directory service for onward
> forwarding to the target clearly cutting off the contact details of
> the target as the listing of all John Smiths will just state relevant
> details and not contact details, this (forwarding of the quriers
> message by the naming service to the target) should be automated and
> instant to avoid delays, which in turn when received by the target can
> act on it as he deems fit. Also as suggested by Pars this should not
> be a SIP based solution.
>
> Another scenario could go as mentioned in this article from The
> Economist titled "The beast of complexity". Talking to Stuart Feldman
> the director of IBM's Institute for Advanced Commerce Quote "Imagine,
> says the man from IBM, that you are running on empty and want to know
> the cheapest open petrol station within a mile. You speak into your
> cellphone, and seconds later you get the answer on the display. This
> sounds simple, but it requires a combination of a multitude of
> electronic services, including a voice-recognition and
> natural-language service to figure out what you want, a location
> service to find the open petrol stations near you and a
> comparison-shopping service to pick the cheapest one. Unquote
>
> In this scenario let us for the time being forget the oice-recognition
> and natural-language service to figure out what is wanted, the
> location service will be the Naming service which I am talking about
> (some people use the term Platform) the services mentioned in this
> example would require a platform a sort of a clearing house clearly
> defining colliding name, pseudonyms, domains and the choice of
> interaction, whether audio, video interaction, broadcasting, pod
> casting data transfers (like comparison shopping service), and last
> but not the least, this would also require a new software for the cell
> phones.
>
> Any suggestions on this scenario mentioned?
>
> Virndra Gandhi
>
>
>
>
>
> On 10/4/07, Pars Mutaf <[email-masked]> wrote:
> > Hi Viendra,
> >
> > I understand your points. I was just trying to open a
> > discussion, or rather continue the discussion you
> > kindly opened. Please stay and please do not hesitate proposing
> > solutions, questioning my introductory arguments
> > (which I had to present to start some discussion, that's all :-).
> >
> > My role is limited to list managing, getting more people
> > and starting discussion.
> >
> > Thanks!
> > pars
> >
> >
> >
> >  On 10/4/07, Virendra Gandhi <[email-masked]> wrote:
> > > Hello,
> > > I have a feeling that DNS structure is also lacking in this. Naming
> > > needs to be delt with because it has to be universal otherwise how
> > > will the target be identified which the qurier wants which is not
> > > local. I am not an expert and my work is limited to Naming only but
> > > still all John Smiths will have to be further distinguished for the
> > > target to be identified, without which pairing will not be possible,
> > > further I also believe that this will not be possible through the DNS
> > > structure but could be through a netbased service, hence I joined
> > > mailing list, I can exit if the members feel that naming is not
> > > required for pairing.
> > > I could also quote an example of a multiple convergence requirement
> > > which could be only be possible with/after pairing.
> > > Virendra Gandhi
> > >
> > > On 10/3/07, Pars Mutaf <[email-masked]> wrote:
> > > > Hello,
> > > >
> > > > > On 9/26/07, IETF member Dave Aronson < [email-masked]>
> > wrote:
> > > > > > Virendra Gandhi [mailto: [email-masked]] writes:
> > > > > >