Subject: [hybi] HYBI recording available

From: "[email-masked]" <[email-masked]>
Date: Wed, 30 Mar 2011 19:48:17 +0200

Dear all,the full recording (synchronized video, audio, slides and jabber room) of yesterday's HYBI session is available at the following URL:http://ietf.conf.meetecho.comWe apologize for the bad audio quality on the first 20 minutes of the recording.We were not able to attach to the main audio stream before that time (the first minutes are taken live from the room speakers).In case of problems with the playout, just drop an e-mail to [email-masked],Meetecho Team

---

From: Adam Barth <[email-masked]>
Date: Thu, 31 Mar 2011 11:19:18 -0700

I was excited to watch this recording but then I was sad that doing so
required granting full access to my machine to your web site.  Why
can't you just play the video in a web browser as is common on the
Internet?

Adam

On Wed, Mar 30, 2011 at 10:48 AM, [email-masked] <[email-masked]> wrote:
> Dear all,
>
> the full recording (synchronized video, audio, slides and jabber room)
> of yesterday's HYBI session is available at the following URL:
>
> http://ietf.conf.meetecho.com
>
> We apologize for the bad audio quality on the first 20 minutes of the
> recording.
> We were not able to attach to the main audio stream before that time (the
> first minutes are taken live from the room speakers).
>
> In case of problems with the playout, just drop an e-mail to
> [email-masked].
>
> Cheers,
> Meetecho Team
>
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>
>

---

From: Willy Tarreau <[email-masked]>
Date: Thu, 31 Mar 2011 20:34:51 +0200

> can't you just play the video in a web browser as is common on the

Ah now I understand why it required me to download a .jnlp file
which I supposed was for a plugin. I did not notice there was a
specific client.

I'm realizing that later there might exist a less demanding client
making use of WebSocket for the same service ;-)

Cheers,
Willy

---

From: Lorenzo Miniero <[email-masked]>
Date: Thu, 31 Mar 2011 21:04:25 +0200

Dear Adam and Willy,

about the full access, that's a security policy notification that is common to all JNLP-based applications. Similar messages are also shown for applets, for instance. JNLP is just a simple way to get Java applications started from the network, taking care of library dependencies and the like automatically.

We can just reassure you that the only thing the application does is retrieve the SMIL description file, i.e. a standard way to describe a synchronized view of all the involved media, and in turn download the media content itself. After that, the playout starts allowing you to seek.

An ad-hoc player was needed since our approach towards the SMIL description at the moment slightly differs from the standard in a few parts: you can also try and directly play the SMIL file yourself using any compliant player (there are a few around), but the presentation may not be perfect.

For what concerns the WebSocket approach, we're actually already working on a completely web-based player of the recordings, which would exploit the same functionality already made available by the WebLite client (the one that was used to allow folks to attend IETF sessions using our system), but it isn't available yet.

Hoping this isn't a dealbreaker for you :)

Cheers,
Lorenzo

On Thu, 31 Mar 2011 20:34:51 +0200

-- 
Lorenzo Miniero, COB

Meetecho s.r.l.
Web Conferencing and Collaboration Tools
http://www.meetecho.com

---

From: Adam Barth <[email-masked]>
Date: Thu, 31 Mar 2011 15:15:44 -0700

It is a dealbreaker for me, but I look forward to being able to watch
the videos on your web site without needing to trust you with the
privilege to execute arbitrary code on my machine.

Adam

---

From: Simone Bordet <[email-masked]>
Date: Fri, 1 Apr 2011 00:30:36 +0200

Hi,

On Thu, Mar 31, 2011 at 21:04, Lorenzo Miniero <[email-masked]> wrote:
> Dear Adam and Willy,
>
> about the full access, that's a security policy notification that is common to all JNLP-based applications.

Not exactly true, as not all JNLP application needs
java.security.AllPermission to run.

> We can just reassure you that the only thing the application does is retrieve the SMIL description file, i.e. a standard way to describe a synchronized view of all the involved media, and in turn d…

The player uses native libraries, which requires all permissions, so
there is no easy way out (unless of course you change the player).

Would it be possible to convert the video to some other format that
only requires a browser to see, as per Adam's suggestion ?

> Hoping this isn't a dealbreaker for you :)

It is for me also. We're in 2011 and JNLP requiring AllPermission
looks soooo 2000s.

I could watch it in a virtual machine, but it's a lot more complicated
than it needs to.

Simon
-- 
http://bordet.blogspot.com
---
Finally, no matter how good the architecture and design are,
to deliver bug-free software with optimal performance and reliability,
the implementation technique must be flawless.   Victoria Livschitz