Subject: Re: [hybi] Interface for Large Frames

From: "Bob Gezelter" <[email-masked]>
Date: Wed, 22 Jun 2011 15:26:37 -0700

Andy and Willy,

Agreed. I just wanted to explicitly mention the critical efficiency
issue. Since frames can be extremely large, perhaps it would be
appropriate to designate a term for some sub-frame quantum to be
handled. Such a quantum (e.g., a segment) would be small enough to be
processed with reasonable resources.

- Bob Gezelter, http://www.rlgsc.com

---

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 23 Jun 2011 07:15:33 +0800

> processed with reasonable resources.

Such a concept might be useful within an API, but the protocol can (and should) remain ignorant of such details.

To some extent, it depends on how capable you want your API to be.  I can easily imagine a simple API that passes frames whole and rejects frames larger than it wants to handle.  For a lot of applications, I imagine that this would be sufficient.  A generic API doesn't have that luxury, so I'll be interested to see how it is solved.

--Martin