Subject: [hybi] hybi 10 ---- server to client masking

From: "Andy W. Song" <[email-masked]>
Date: Wed, 20 Jul 2011 14:27:31 +0800

Hi,

A question about server to client masking. In section 4.1 it states
that "Frames
sent from the server to the client are not masked." Does it mean server to
client masking is optional or MUST NOT?

Client to server is clear as "MUST" though.

Thanks
Andy

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Wed, 20 Jul 2011 11:26:22 +0200

2011/7/20 Andy W. Song <[email-masked]>:
> A question about server to client masking. In section 4.1 it states that
> "Frames sent from the server to the client are not masked." Does it mean
> server to client masking is optional or MUST NOT?

"are not masked" means that they MUST NOT be masked.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: "Arman Djusupov" <[email-masked]>
Date: Wed, 20 Jul 2011 13:14:04 +0300

> > that "Frames sent from the server to the client are not masked." 
> > Does it mean server to client masking is optional or MUST NOT?

I don't think you are correct. As far as I understand the discussions in the group over masking, the server to client masking is optional (server MAY MASK). Otherwise we would not need a masking flag in the frame header since client-to-server frames would always be masked and server-to-client frames would never be masked.

> <[email-masked]>

With best regards,
Arman

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Wed, 20 Jul 2011 12:30:01 +0200

> I don't think you are correct. As far as I understand the discussions in the group over masking, the server to client masking is optional (server MAY MASK). Otherwise we would not need a masking fl…

Does the spec state somewhere that the client MUST be ready to receive
masked frames from the server? or is it just an interpretation due the
existence of such masking flag?

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: John Tamplin <[email-masked]>
Date: Wed, 20 Jul 2011 10:18:18 -0400

On Wed, Jul 20, 2011 at 6:14 AM, Arman Djusupov <[email-masked]> wrote:

> I don't think you are correct. As far as I understand the discussions in
> the group over masking, the server to client masking is optional (server MAY
> MASK). Otherwise we would not need a masking flag in the frame header since
> client-to-server frames would always be masked and server-to-client frames
> would never be masked.
>

The flag was requested so intermediaries (including packet sniffers) could
interpret the frame without knowing the context (ie, which direction the
packet is going or negotiated extensions, etc).

-- 
John A. Tamplin
Software Engineer (GWT), Google

---

From: David Endicott <[email-masked]>
Date: Wed, 20 Jul 2011 14:11:15 -0400

So the flag is the truth, and either end must be prepared to process masking
based on the frame's flag?

On Wed, Jul 20, 2011 at 10:18 AM, John Tamplin <[email-masked]> wrote:

> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>
>