Subject: [hybi] consensus call on not specifying DNS SRV as mandatory to implement

From: Gabriel Montenegro <[email-masked]>
Date: Sat, 30 Jul 2011 03:40:22 +0000

At the meeting and on the mailing list leading up to it, the chairs did not see consensus for the following action:

                Specify DNS SRV as mandatory to implement in the websocket protocol specification.

We're confirming on the mailing list, and will declare this consensus call final by next Friday Aug 5.

Thanks,

Gabriel and Salvatore
HyBi co-chairs

---

From: Greg Wilkins <[email-masked]>
Date: Sat, 30 Jul 2011 17:13:35 +1000

-1.  DNS SRV should not be mandatory.    I think it should be
considered again if we ever have a non HTTP handshake.

On 30 July 2011 13:40, Gabriel Montenegro
<[email-masked]> wrote:
> We’re confirming on the mailing list, and will declare this consensus call
> final by next Friday Aug 5.
>
>
>
> Thanks,
>
>
>
> Gabriel and Salvatore
>
> HyBi co-chairs
>
>
>
>
>
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>
>

---

From: John Tamplin <[email-masked]>
Date: Sat, 30 Jul 2011 03:16:52 -0400

> considered again if we ever have a non HTTP handshake.

Note "did not see consensus".

-- 
John A. Tamplin
Software Engineer (GWT), Google

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 1 Aug 2011 02:07:16 +0200

> final by next Friday Aug 5.

I was proposing it, but after long discussions in the maillist I've
understood that mandating DNS SRV in WS clients would break too much
assumptions in HTTP world (which commonly just sees above HTTP layer
and not below).

The existence of HTTP proxies is also a big handicap since those
proxies should be upgraded/modified in order to perform DNS SRV
resolution *just* in case the HTTP request is a WebSocket handshake.
This last argument is enough to not mandate SRV resolution.

So I see two options (for the future):

1) As Greg says: consider again DNS SRV if we ever have a non HTTP handshake.

2) Introduce SRV (optional of course) in HTTP protocol (WS would just
inherit it automatically).

Regards.

-- 
Iñaki Baz Castillo
<[email-masked]>