Subject: Re: [hybi] draft-ietf-hybi-thewebsocketprotocol-09.txt

From: Alexey Melnikov <[email-masked]>
Date: Thu, 07 Jul 2011 18:40:47 +0100

Hi,

Willy Tarreau wrote:

>Hi,
>
>On Wed, Jun 15, 2011 at 01:39:41PM -0700, Dan Adkins wrote:  
>
>>Comment:
>>
>>Sec 1.3. Opening Handshake
>>
>>   Headers in the handshake are sent by the client in a random order;
>>   the order is not meaningful.
>>
>>Saying "random order" here is misleading; it implies that the client
>>must shuffle the headers (I understand old versions of the protocol
>>required this.)  If the order is not meaningful, then it is perfectly
>>fine for an implementation to always send them in the same order.    
>>
>
>Good point.
>  
>
>>I think the wording from RFC 2616 (HTTP/1.1) is clearer:
>>
>>   The order in which header fields with differing field names are
>>   received is not significant.
>>    
>>
>
>Or maybe a mix of both, something around this ?
>  
>
>     Headers in the handshake may be sent by the client in any order,
>     so the order in which header fields with differing field names
>     are received is not significant.
>
I've used a slightly modified version of this text:

    In compliance with RFC 2616, header fields in the handshake may be 
sent by
    the client in any order, so the order in which different header fields
    are received is not significant.

>The same point is valid for the response format BTW.
>  
>
Right.

---

From: Willy Tarreau <[email-masked]>
Date: Thu, 7 Jul 2011 21:15:46 +0200

Hi Alexey,

>    are received is not significant.

This looks perfect to me.

Thanks,
Willy