Subject: [hybi] Neither Firefox 8 and Chrome 15 close connection if WS protocol in 101 mismatches

From: Iñaki Baz Castillo <[email-masked]>
Date: Wed, 24 Aug 2011 22:14:56 +0200

Testing in both Firefox 8 and Chrome 15:

- The webbrowser sends the HTTP GET with:
    Sec-WebSocket-Protocol: aaa, bbb

- The server replies 101 with:
    Sec-WebSocket-Protocol: ccc

- The browser does not send a close frame at all.

As per the spec, the browser should close the connection. The WS API
states the same:

http://dev.w3.org/html5/websockets/#the-websocket-interface
------------------
The connection will only be established if the server reports that it
has selected one of these subprotocols.
------------------

Ok ok, this is an issue within those browsers but, *why* have they
decide not to respect the spec in this point?

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Wed, 24 Aug 2011 22:37:30 +0200

> decide not to respect the spec in this point?

Also, Chrome 15 does neither respect the WS API for the close() function:

  void close([Clamp] optional unsigned short code, optional DOMString reason);

Even if JavaScript calls:

  webSocket.close(1000, "Bye Bye");

Chrome 15 sends a close frame with empty body.

In the other side Firefox 8 does it correctly. Hello Google?

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Sylvain Hellegouarch <[email-masked]>
Date: Wed, 24 Aug 2011 22:44:56 +0200

> In the other side Firefox 8 does it correctly. Hello Google?

I think it'd be more useful to report those issues to the browser vendors
directly rather than here :)

-- 
- Sylvain
http://www.defuze.org
http://twitter.com/lawouach

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Wed, 24 Aug 2011 23:46:04 +0200

> directly rather than here :)

Sure, I should do it, but perhaps some Mozilla/Google developer read
this mail :)

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Tobias Oberstein <[email-masked]>
Date: Wed, 24 Aug 2011 15:46:49 -0700

for FF I think it was fixed here: https://bugzilla.mozilla.org/show_bug.cgi?id=674716
which states milestone FF8, which would fit your observation
FF8 just moved to Aurora channel ..

On 24.08.11 22:37, "Iñaki Castillo" <[email-masked]> wrote:

--
Iñaki Baz Castillo
<[email-masked]>
_______________________________________________
hybi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/hybi