Subject: Re: [hybi] Binary/Text Distinction (Hybi Volume 30, Number 63, et al)

From: "Bob Gezelter" <[email-masked]>
Date: Mon, 22 Aug 2011 11:24:30 -0700

Stephen,

I was responding to an earlier message.

My point was that while all UTF-8 can be sent as binary, not all binary
can be sent as UTF-8 without appropriate wrapping/encoding.

As I have said in other postings, my strong preference is:

- a single message type
- the protocol be defined as 8-bit transparent octets
- a trivial WSAPI-WSAPI protocol be defined that is either pure UTF-8 or
message-by-message UTF-8/binary.

This little impact on performance, and has significant advantages in
clarity. While I do not have a sample WSAPI implementation handy, I do
not see how moving the "data" meaning layer up a notch has any
significant negative impact. In most cases, I would expect the impact to
be a handful of lines in WSAPI.

- Bob Gezelter, http://www.rlgsc.com

---

From: Stephen Williams <[email-masked]>
Date: Mon, 22 Aug 2011 13:42:11 -0700

> message-by-message UTF-8/binary.

We should acknowledge that we're just finally reimplementing BEEP (BXXP originally) in the web world.  While we're wiser now, and 
the current level of agreement is nicely concise, BEEP was a direct precursor to WS in some sense and might suggest some ideas or 
features.

I would want to suggest that, regardless of the binary/text message tagging, that we strongly suggest the use of UTF-8 for text as a 
default.

> - Bob Gezelter, http://www.rlgsc.com

sdw