Subject: Re: [hybi] consensus call on not specifying DNS SRV as mandatory to implement

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 01 Aug 2011 08:51:11 -0600

On 7/31/11 6:07 PM, Iñaki Baz Castillo wrote:
> 2011/7/30 Gabriel Montenegro <[email-masked]>:
>> At the meeting and on the mailing list leading up to it, the chairs did not
>> see consensus for the following action:
>>
>>                 Specify DNS SRV as mandatory to implement in the websocket
>> protocol specification.
>>
>> We’re confirming on the mailing list, and will declare this consensus call
>> final by next Friday Aug 5.
> 
> 
> I was proposing it, but after long discussions in the maillist I've
> understood that mandating DNS SRV in WS clients would break too much
> assumptions in HTTP world (which commonly just sees above HTTP layer
> and not below).
> 
> The existence of HTTP proxies is also a big handicap since those
> proxies should be upgraded/modified in order to perform DNS SRV
> resolution *just* in case the HTTP request is a WebSocket handshake.
> This last argument is enough to not mandate SRV resolution.
> 
> So I see two options (for the future):
> 
> 1) As Greg says: consider again DNS SRV if we ever have a non HTTP handshake.

IMHO that's possible but unlikely.

> 2) Introduce SRV (optional of course) in HTTP protocol (WS would just
> inherit it automatically).

That's been tried, but it failed:

https://datatracker.ietf.org/doc/draft-jennings-http-srv/

It was a nice idea, though. :)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Gabriel Montenegro <[email-masked]>
Date: Fri, 5 Aug 2011 21:42:54 +0000

Hi,

We're confirming this point, namely:

                Lack of consensus to specify DNS SRV as mandatory to implement in the websocket protocol specification.

Thanks,

Chairs

From: [email-masked] [mailto:[email-masked]] On Behalf Of Gabriel Montenegro
Sent: Friday, July 29, 2011 23:40
To: Server-Initiated HTTP
Subject: [hybi] consensus call on not specifying DNS SRV as mandatory to implement

At the meeting and on the mailing list leading up to it, the chairs did not see consensus for the following action:

                Specify DNS SRV as mandatory to implement in the websocket protocol specification.

We're confirming on the mailing list, and will declare this consensus call final by next Friday Aug 5.

Thanks,

Gabriel and Salvatore
HyBi co-chairs