Subject: Re: [hybi] Binary/Text Distinction

From: "Bob Gezelter" <[email-masked]>
Date: Tue, 16 Aug 2011 07:21:29 -0700

> -------- Original Message --------
> Subject: Re: [hybi] Binary/Text Distinction
> From: John Tamplin <[email-masked]>
> Date: Tue, August 16, 2011 7:16 am
> To: Bob Gezelter <[email-masked]>
> Cc: Bjoern Hoehrmann <[email-masked]>, [email-masked]
> 
...... [repeat of earlier exchanged suppressed for brevity]
> 
> Which is exactly why binary frames are supported.
> 
> -- 
> John A. Tamplin
> Software Engineer (GWT), Google

John,

My objection to the distinction is that it does not, IMHO, belong in the
WebSocket protocol, it belongs in the next layer above the basic
WebSocket protocol transport layer.

- Bob Gezelter, http://www.rlgsc.com

---

From: John Tamplin <[email-masked]>
Date: Tue, 16 Aug 2011 10:24:26 -0400

> WebSocket protocol transport layer.

Then you have to provide some way for JS apps to serialize/deserialize
arbitrary mixes of text and binary data to a binary frame to send in WS.  It
might be possible to standardize on such a thing and make sure it is robust
against hostile JS, but given how long WS has been in development it seems
prudent to avoid making such a mechanism a blocker for deploying WS.