Subject: [hybi] Call for Consensus: draft-tyoshino-hybi-websocket-perframe-deflate as WG Item

From: Salvatore Loreto <[email-masked]>
Date: Tue, 28 Feb 2012 09:42:32 +0200

Hi there,

the first optimization/extension (or milestone if you prefer)
in the new approved HyBi charter (see 
http://tools.ietf.org/wg/hybi/charters )
is about:

    A per-frame compression extension to improve bandwidth
    usage

Takeshi Yoshino has been working on a draft proposal since April 2011.
The draft has been discussed extensively in the mailing list,
it  has already received comments, suggestions and feedback;
and  Takeshi has produced several new versions to address the raised issues.

The current version is:
http://tools.ietf.org/html/draft-tyoshino-hybi-websocket-perframe-deflate-05

Gabriel and I, as chairs, want to check the consensus to adopt the draft as
baseline for the working group item that will fulfill the first Goal in 
the current charter:

   Feb 2012 - Adopt a WG item for the per-frame compression extension

This consensus call will run until Monday March 12th, 2012.

Ciao
Salvatore and Gabriel

-- 
Salvatore Loreto
www.sloreto.com

---

From: John Tamplin <[email-masked]>
Date: Tue, 28 Feb 2012 09:05:53 -0500

On Tue, Feb 28, 2012 at 2:42 AM, Salvatore Loreto <
[email-masked]> wrote:

>  <http://tools.ietf.org/html/draft-noel-soc-overload-rate-control-02>
> I think it needs some significant changes (in particular, if it is going
to allocate a reserved frame bit it needs to be extensible to other
compression algorithms, which also implies renaming it to compress-frame or
similar), but I think it is a fine starting point.

-- 
John A. Tamplin
Software Engineer (GWT), Google

---

From: Greg Wilkins <[email-masked]>
Date: Wed, 29 Feb 2012 10:10:25 +1100

+1 to have it adopted as a base line for further discussion and refinement.

I share Johns concern about the allocation of a reserved bit to the
extension and think that we should go through a process of exhaustively
considering all the alternatives before allocation of such a scarce
resource.

cheers

On 28 February 2012 18:42, Salvatore Loreto
<[email-masked]>wrote:

> Salvatore Loretowww.sloreto.com
>
>
>
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>
>

---

From: Willy Tarreau <[email-masked]>
Date: Wed, 29 Feb 2012 00:53:30 +0100

> considering all the alternatives before allocation of such a scarce

+1, same here :-)

Willy

---

From: Brian <[email-masked]>
Date: Tue, 28 Feb 2012 16:23:22 -0800

+1  :-D

Brian

On Tue, Feb 28, 2012 at 3:10 PM, Greg Wilkins <[email-masked]> wrote:

> On 28 February 2012 18:42, Salvatore Loreto <[email-masked]
> > wrote:
>
>>  Hi there,
>>