Subject: [hybi] WS Test Suite - Update

From: Tobias Oberstein <[email-masked]>
Date: Wed, 21 Mar 2012 14:27:15 -0700

There is a new version of the Autobahn WS Testsuite and test reports avail:

 * test reports updated for new browser versions + IE10 and WebKit Nightly (Safari)

 * test suite now comes completely packaged, easy install/use, no fuss

 * test suite now includes 12 modes

The modes: 2 are the known "fuzzing" modes to produce WS impl. reports (client+server)

New modes: echo, broadcast, testee, .. additional handy tools for WS implementors/devs.

And in particular:

We have started collaborating with the WebSocket++ project (Peter Thorson) to build a
distributed WS load generator / performance testing tool.

In one mode it will allow: running multiple instances of the "wsperf" load generator/probe
distributed both in LAN and WAN.

The probe will produce load / tests onto a testee target WS server. "wstest": will act as a
controller for the probes, aggregate results, produce web UI, ..

This thing is preliminary / still in the cooking .. but I think it has the potential to take
"WS testing" to the next level.

http://autobahn.ws/testsuite
http://www.zaphoyd.com/wsperf

\Tobias

---

From: Brian <[email-masked]>
Date: Wed, 21 Mar 2012 15:05:02 -0700

This is awesome!  I can't wait to try wsperf out!

Brian

On Wed, Mar 21, 2012 at 2:27 PM, Tobias Oberstein <
[email-masked]> wrote:

> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>