Subject: [hybi] I-D Action: draft-ietf-hybi-websocket-perframe-compression-04.txt

From: [email-masked]
Date: Tue, 22 May 2012 03:20:10 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the BiDirectional or Server-Initiated HTTP Working Group of the IETF.

	Title           : WebSocket Per-frame Compression
	Author(s)       : Takeshi Yoshino
	Filename        : draft-ietf-hybi-websocket-perframe-compression-04.txt
	Pages           : 17
	Date            : 2012-05-22

   This specification defines a WebSocket extension that adds per-frame
   compression functionality to the WebSocket Protocol.  It compresses
   the "Application data" portion of WebSocket data frames using
   specified compression algorithm.  One reserved bit RSV1 in the
   WebSocket frame header is allocated to control application of
   compression for each frame.  This specification provides one
   compression method available for the extension using DEFLATE.

   Please send feedback to the [email-masked] mailing list.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-hybi-websocket-perframe-compression-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-hybi-websocket-perframe-compression-04.txt

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-ietf-hybi-websocket-perframe-compression/

---

From: Takeshi Yoshino <[email-masked]>
Date: Tue, 22 May 2012 19:26:18 +0900

Hi,

I've published a new draft -04 of compression spec.

Diff:
http://tools.ietf.org/rfcdiff?url2=draft-ietf-hybi-websocket-perframe-compression-04.txt

Changes
- clarified that listing multiple descriptions with the same name is allowed
- now the server echoes back the requested parameters
- max_window_size and no_context _takeover are renamed to ones with
prefixes s2c_ and c2s_ to clarify which direction they are applied