Subject: [hybi] WAMP subprotocol registration

From: Tobias Oberstein <[email-masked]>
Date: Sun, 8 Jul 2012 15:56:54 -0700

Hi all,

How do I register a WebSocket subprotocol?

We would like to register

WAMP - The WebSocket Application Messaging Protocol
http://wamp.ws/

WAMP is an open WebSocket subprotocol that provides two asynchronous messaging patterns: RPC and PubSub.

There are already a number of implementations:

http://wamp.ws/implementations

According to

http://tools.ietf.org/html/rfc6455#section-11.5

there is an "IANA registry" for such things. How? Where?

The subprotocol is:

Subprotocol Identifier: "wamp"
Subprotocol Common Name: "The WebSocket Application Messaging Protocol"
Subprotocol Definition: http://wamp.ws/spec

[Note: the informal spec still needs some improvement and we plan to write up a proper RFC ..]

Cheers,

Tobias

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 08 Jul 2012 21:05:17 -0600

> there is an "IANA registry" for such things. How? Where?

The policy is first come, first served. That means you can contact IANA
about it directly:

http://www.iana.org/cgi-bin/assignments.pl

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Salvatore Loreto <[email-masked]>
Date: Mon, 9 Jul 2012 08:41:18 +0200

> http://www.iana.org/cgi-bin/assignments.pl

the Iana WebSocket Protocol Registries is here:
http://www.iana.org/assignments/websocket/websocket.xml#subprotocol-name

Salvatore

-- 
Salvatore Loreto, PhD
www.sloreto.com

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Mon, 09 Jul 2012 08:44:34 +0200

>there is an "IANA registry" for such things. How? Where?

http://www.iana.org/assignments/websocket has all the registries.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/