Subject: Re: [hybi] "Cache-Control: no-cache" may improve handshake success rate

From: Gabriel Montenegro <[email-masked]>
Date: Fri, 12 Oct 2012 23:10:28 +0000

Thanks, Takeshi, this is potentially low hanging fruit to obtain some improvement.  BTW, is there any number about how much improvement has been observed or could be expected?

Thanks,

Gabriel

From: [email-masked] [mailto:[email-masked]] On Behalf Of Takeshi Yoshino
Sent: Sunday, 30 September, 2012 22:33
To: [email-masked]
Subject: [hybi] "Cache-Control: no-cache" may improve handshake success rate

It seems adding the Cache-Control header to the WebSocket handshake improves success rate for some environment.

We've investigated one bug report [1] for Chrome, and found that there're some caches deployed in Thailand which corrupt server's opening handshakes by replacing the value in the Connection header with close.

This doesn't happen if Firefox is used. Some tests using reduced header set indicated that it's because Firefox puts the Cache-Control and Pragma header like this:

Pragma: no-cache
Cache-Control: no-cache

in its WebSocket client's handshakes while Chrome does not send such headers.

I guess that the proxy is caching server's opening handshake and sending the cached data but after overwriting the Connection header ignoring the meaning of "Connection: Upgrade".

Basically, we want Upgrade non-compliant proxies to be replaced with new ones rather than taking work around, but don't have much reluctance to use of the headers.

----

[1] http://code.google.com/p/chromium/issues/detail?id=148908 . Thanks bangkokmaco.

---

From: Takeshi Yoshino <[email-masked]>
Date: Sat, 13 Oct 2012 13:44:03 +0900

Hi,

On Sat, Oct 13, 2012 at 8:10 AM, Gabriel Montenegro <
[email-masked]> wrote:

>  Thanks, Takeshi, this is potentially low hanging fruit to obtain some
> improvement.  BTW, is there any number about how much improvement has been
> observed or could be expected?
>

Yes. I want statistics, but for now the Chromium bug entry is the only
report we have.

When we run some live experiment next time, I'll consider adding some items
to check that.

---

From: Takeshi Yoshino <[email-masked]>
Date: Mon, 15 Oct 2012 18:11:55 +0900

Introduced to WebKit.
https://bugs.webkit.org/show_bug.cgi?id=98000

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 24 Oct 2012 12:50:03 +0300

On 10/13/12 7:44 AM, Takeshi Yoshino wrote:
> Hi,
>
> On Sat, Oct 13, 2012 at 8:10 AM, Gabriel Montenegro 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Thanks, Takeshi, this is potentially low hanging fruit to obtain
>     some improvement.  BTW, is there any number about how much
>     improvement has been observed or could be expected?
>
>
> When we run some live experiment next time, I'll consider adding some 
> items to check that.
Thanks, Takeshi for reporting this to the HyBi mailing list.
Maybe at some point if someone has the energy to do it we can start to 
document all this information
and possible ways to obtain some improvements in a draft (i.e. a sort of 
miscellaneous draft)
or even just on the wiki of the HyBi wg

br
/Salvatore

-- 
Salvatore Loreto, PhD
www.sloreto.com

---

From: Takeshi Yoshino <[email-masked]>
Date: Mon, 29 Oct 2012 17:52:19 +0900

>  or even just on the wiki of the HyBi wg

Created a page on the wiki.
http://trac.tools.ietf.org/wg/hybi/trac/wiki/ReportFromImplementers

Thanks