Subject: Re: [hybi] Artart last call review of draft-ietf-core-coap-tcp-tls-07

From: Carsten Bormann <[email-masked]>
Date: Wed, 19 Apr 2017 21:22:05 +0200

On Apr 10, 2017, at 06:07, Mark Nottingham <[email-masked]> wrote:
> 
> Section 7.4 shows how to convert a "coap+ws://" URI into a "wss://"
> URI, using a well-known URI in the "wss" scheme. However, "wss" is not
> defined to use well-known URIs, so this is an invalid use.

Clearly, this is a bug in draft-ietf-core-coap-tcp-tls-07.

I have argued that underlying this is an omission in RFC 6455:

ws:/wss: URIs are translated into http:/https: URIs, and the well-known space is already reserved in the latter, so it would be nonsensical to try to use RFC 5785 /.well-known for something else in the ws:/wss: URI schemes.

Maybe there wasn’t a use case for well-known URIs in WebSockets before, but there is one now, and we would like to remedy this omission in the procedurally simplest possibly way.

So I am proposing to add RFC 5785’s well-known URI mechanism to these URI schemes in the document that needs it, draft-ietf-core-coap-tcp-tls, which by that updates RFC 6455.

Are there any objections to this procedure?

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 19 Apr 2017 21:32:37 +0200

> So I am proposing to add RFC 5785’s well-known URI mechanism to these URI schemes in the document that needs it, draft-ietf-core-coap-tcp-tls, which by that updates RFC 6455.

Forgot to add the pointer to the simple fix text:

https://github.com/core-wg/coap-tcp-tls/pull/128/files

Grüße, Carsten