Subject: [I2nsf] Request for WG Adoption of draft-merged-i2nsf-framework

From: John Strassner <[email-masked]>
Date: Wed, 16 Mar 2016 15:59:53 -0700

Dear chairs,

with the most recent release of this draft, on behalf of the authors, I
would like to request a Call for Adoption by the I2NSF WG.

For those of you in the WG that have not had the chance to read this
important document, it is available at:

URL:
https://www.ietf.org/internet-drafts/draft-merged-i2nsf-framework-05.txt
Status:
https://datatracker.ietf.org/doc/draft-merged-i2nsf-framework/
Htmlized:       https://tools.ietf.org/html/draft-merged-i2nsf-framework-05
Diff:
https://www.ietf.org/rfcdiff?url2=draft-merged-i2nsf-framework-05

-- 
regards,
John

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 16 Mar 2016 23:11:56 -0000

Thanks John,
 
When this document was discussed in Yokohama (IIRCC) we agreed:
1. we would adopt a framework draft
2. this looked like a good candidate
3. there were some changes needed
4. we wanted a separate terminology document
5. we needed the framework to be consistent with the terminology doc
 
1 and 2 are good
For 3, although we can all run rfcdiff, maybe you could send a summary of the changes to the list
4 has a candidate I-D from you (thanks)
For 5 see 3
 
I'll be looking at your new revision over the next few days.
 
Thanks for the work,
Adrian
 
From: John Strassner [mailto:[email-masked]] 
Sent: 16 March 2016 23:00
To: [email-masked]
Cc: Linda Dunbar; Adrian Farrel
Subject: Request for WG Adoption of draft-merged-i2nsf-framework
 
Dear chairs,
 
with the most recent release of this draft, on behalf of the authors, I would like to request a Call for Adoption by the I2NSF WG.
 
For those of you in the WG that have not had the chance to read this important document, it is available at:
 
URL:            https://www.ietf.org/internet-drafts/draft-merged-i2nsf-framework-05.txt
Status:         https://datatracker.ietf.org/doc/draft-merged-i2nsf-framework/
Htmlized:       https://tools.ietf.org/html/draft-merged-i2nsf-framework-05
Diff:           https://www.ietf.org/rfcdiff?url2=draft-merged-i2nsf-framework-05

-- 
regards,
John

---

From: John Strassner <[email-masked]>
Date: Thu, 17 Mar 2016 20:41:38 -0700

Hi Adrian,

you're right, I'm traveling but will try and address this asap (definitely
before the week ends). Sorry I'm running between airports...

regards,
John

On Wed, Mar 16, 2016 at 4:11 PM, Adrian Farrel <[email-masked]> wrote:

> *From:* John Strassner [mailto:[email-masked]]
> *Sent:* 16 March 2016 23:00
> *To:* [email-masked]
> *Cc:* Linda Dunbar; Adrian Farrel
> *Subject:* Request for WG Adoption of draft-merged-i2nsf-framework
>
>
>
> Dear chairs,
>
>
>
> Htmlized:
> https://tools.ietf.org/html/draft-merged-i2nsf-framework-05
> Diff:

-- 
regards,
John

---

From: John Strassner <[email-masked]>
Date: Tue, 22 Mar 2016 17:11:40 -0700

Hi Adrian,

sorry for the delay. You asked me to summarize the changes; here is
my view of the main points that were changed.

  - Generic Changes
    - clarification of purpose of I2NSF
    - clarified packet- and flow-based processing (e.g., "This draft
      proposes that a rule provisioning interface to NSFs can be
      developed on a packet- or flow-based paradigm.")
    -  alignment with terminology draft

  - Specific Changes
    - change from subject-object-action-function to ECA policy rules
    - stating that packet- and flow-based NSFs can be standardized
      by using Event - Condition - Action (ECA) policy rule sets
    - definition of what an event, condition, and action mean in the
      context of policy rules, with examples
    - definition of what a policy rule is, and how it is used in I2NSF
    - clarifying that the rule sets and software interfaces of I2NSF
      aim to standardize the form and function of profile and signature
      files while supporting vendor-specific functions of each
    - more detail on the NSF Facing (Capability Layer) Interface
    - clarification of vendor facing interface
    - specification of additional security requirements
    - more detail about vendor registration of their NSFs

regards,
John

-- 
regards,
John