Subject: [I2nsf] Starting to think about an agenda for I2NSF in Berlin

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 20 Jun 2016 18:00:36 +0100

Hi working group,

Linda and I have been thinking about the agenda for Berlin. We think that we
should continue to focus on our charter and deliverables doing what is necessary
to advance our milestones. Broadly we could split our 2 hours as:

30 minutes status of WG and progress of WG documents
30 minutes requirements for and selection of protocols (and security
considerations)
30 minutes information model discussion
30 minutes other drafts and discussions

We'd like to hear your proposals for things that need to be discussed in these
categories so that we can start to put a detailed agenda together.

Thanks,
Adrian and Linda

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 21 Jun 2016 10:25:55 +0900

Hi Adrian and Linda,
My group are preparing for three new drafts as follows:
- Data Modeling for Capability Layer Interface
- Data Modeling for Service Layer Interface
- SFC-enabled I2NSF-Architecture for Security Services

We will post our drafts before the initial draft cut-off date.

I hope these drafts will be good input for our i2nsf WG.
I think 10 minutes will be fine for the presentation and Q&A.

Thanks.

Best Regards,
Paul

On Tue, Jun 21, 2016 at 2:00 AM, Adrian Farrel <[email-masked]> wrote:

> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 22 Jun 2016 13:33:56 +0000

Paul,

For the Data modeling for the Capability Layer interface, there is already a draft “draft-xia-i2nsf-capability-interface-im-06”, is your data model aligned with this Information Model?
If not, can you provide comments/suggestions to the existing Information model to make the current one more comprehensive, so that I2NSF only has one single Data Model.

What do you think?

Linda

From: Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
Sent: Monday, June 20, 2016 8:26 PM
To: Adrian Farrel; Linda Dunbar
Cc: [email-masked]; JungSoo Park; Prof. Hyoungshick Kim; Hoon Ko; 현상원 박사님; 김진용; [email-masked]; Mr. Jaehoon Paul Jeong
Subject: Re: [I2nsf] Starting to think about an agenda for I2NSF in Berlin

Hi Adrian and Linda,

Thanks.

Best Regards,
Paul

On Tue, Jun 21, 2016 at 2:00 AM, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:
Hi working group,

Thanks,
Adrian and Linda

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 22 Jun 2016 22:42:52 +0900

Hi Linda,
Our Data Model is aligned with the current Information Model:
https://tools.ietf.org/html/draft-xia-i2nsf-capability-interface-im-05

In our drafts, we will be preparing for data models for VoIP, Firewall, and
DDoS Mitigation.

This meeting we will provide i2nsf WG with initial data models along with
clarified information models for the above security services.

Thanks.

Best Regards,
Paul

On Wed, Jun 22, 2016 at 10:33 PM, Linda Dunbar <[email-masked]>
wrote:

> Paul,
>
>
>
> For the Data modeling for the Capability Layer interface, there is already
> a draft “draft-xia-i2nsf-capability-interface-im-06”, is your data model
> aligned with this Information Model?
>
> If not, can you provide comments/suggestions to the existing Information
> model to make the current one more comprehensive, so that I2NSF only has
> one single Data Model.
>
>
>
> What do you think?
>
>
>
> Linda
>
>
>
> *From:* Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
> *Sent:* Monday, June 20, 2016 8:26 PM
> *To:* Adrian Farrel; Linda Dunbar
> *Cc:* [email-masked]; JungSoo Park; Prof. Hyoungshick Kim; Hoon Ko; 현상원
> 박사님; 김진용; [email-masked]; Mr. Jaehoon Paul Jeong
> *Subject:* Re: [I2nsf] Starting to think about an agenda for I2NSF in
> Berlin
>
>
>
> Hi Adrian and Linda,
>

---

From: John Strassner <[email-masked]>
Date: Wed, 22 Jun 2016 17:12:34 -0700

Hi Paul,

ok. Why are you doing a VoIP model? What security capabilities are you
expecting to see for this model?

regards,
John

On Wed, Jun 22, 2016 at 5:04 PM, Mr. Jaehoon Paul Jeong <
[email-masked]> wrote:

> Hi John,
> My logistics is that we will work on data model based on the current
> information model and
> then reflect the revised information model on our data model later when
> the revised draft is available.
> As you know, the initial I-D cut-off date for IETF 96 is July 4, 2016.
> When the information model revision is available, we will modify the data
> model accordingly and
> present our model this IETF meeting.
>
> Thanks for your guidance.
>
> Best Regards,
> Paul
>
>
> On Thu, Jun 23, 2016 at 1:59 AM, John Strassner <[email-masked]>
> wrote:
>
>> Hello,
>>
>> we are currently significantly revising the information model. For
>> example, the class hierarchy has changed. I would suggest that you wait
>> until the new draft is finished (hopefully in a week).
>>
>> regards,
>> John
>>
>> On Wed, Jun 22, 2016 at 6:42 AM, Mr. Jaehoon Paul Jeong <
>> [email-masked]> wrote:
>>
>>> Hi Linda,
>>> In our drafts, we will be preparing for data models for VoIP, Firewall,
>>> and DDoS Mitigation.
>>>
>>> This meeting we will provide i2nsf WG with initial data models along
>>> with clarified information models for the above security services.
>>>
>>> Thanks.
>>>
>>> Best Regards,
>>> Paul
>>>
>>>
>>>> For the Data modeling for the Capability Layer interface, there is
>>>> already a draft “draft-xia-i2nsf-capability-interface-im-06”, is your
>>>> data model aligned with this Information Model?
>>>>
>>>> If not, can you provide comments/suggestions to the existing
>>>> Information model to make the current one more comprehensive, so that I2NSF
>>>> only has one single Data Model.
>>>>
>>>>
>>>>
>>>> What do you think?
>>>>
>>>>
>>>>
>>>> Linda
>>>>
>>>>
>>>>
>> regards,
>> John

-- 
regards,
John

---

From: John Strassner <[email-masked]>
Date: Wed, 22 Jun 2016 09:59:29 -0700

Hello,

we are currently significantly revising the information model. For example,
the class hierarchy has changed. I would suggest that you wait until the
new draft is finished (hopefully in a week).

regards,
John

-- 
regards,
John

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 23 Jun 2016 09:04:41 +0900

Hi John,
My logistics is that we will work on data model based on the current
information model and
then reflect the revised information model on our data model later when the
revised draft is available.
As you know, the initial I-D cut-off date for IETF 96 is July 4, 2016.
When the information model revision is available, we will modify the data
model accordingly and
present our model this IETF meeting.

Best Regards,
Paul

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 23 Jun 2016 09:34:31 +0900

John,
For VoIP, we will prepare for the security service for VoIP/VoLTE, such as
firewall blocking for malicious users through mirroring.
The procedure for VoIP/VoLTE securty system is described in our previous
draft:
Software-Defined Networking Based Security Services using Interface to
Network Security Functions:
(draft-jeong-i2nsf-sdn-security-services-04)
https://tools.ietf.org/html/draft-jeong-i2nsf-sdn-security-services-04

However, for our data model, we are assuming the general architecture for
I2NSF rather than
SDN-based network.

Thanks for your clarification question.

Best Regards,
Paul

On Thu, Jun 23, 2016 at 9:12 AM, John Strassner <[email-masked]> wrote:

>>>> On Wed, Jun 22, 2016 at 10:33 PM, Linda Dunbar <[email-masked]
>>>> > wrote:
>>>>
>>>>> Paul,
>>>>>
>>>>>
>>>>>
>>>>> *Cc:* [email-masked]; JungSoo Park; Prof. Hyoungshick Kim; Hoon Ko;
>>>>> 현상원 박사님; 김진용; [email-masked]; Mr. Jaehoon Paul Jeong

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 23 Jun 2016 20:33:48 +0000

Hi,

Though I have not been able to update the attestation draft (and the framework one in accordance) I am reasonably sure I will be able to do so before the cut-off date, so I’d ask for 5-10 minutes to talk about these updates, under requirements and protocols,.

Be goode,

On 20 Jun 2016, at 19:00 , Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:

Hi working group,

Thanks,
Adrian and Linda

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Susan Hares" <[email-masked]>
Date: Sat, 25 Jun 2016 06:36:29 -0400

Linda and Adrian: 

I request status update for (7 minutes total) 

1) draft-ietf-i2nsf-problem-and-use-cases-00
2) draft-ietf-i2nsf-gap-analysis-01
3) draft-ietf-i2nsf-terminology 

I request 10+ minutes to discuss thoughts on Yang Data models from 

- Capability Yang Data Model (based on
draft-xia-i2nsf-capability-interface-im-05
- DDoS yang Data model (inter-Cloud Carrier DDoS) (Client-Server model)
  and DDoS Yang Model Cloud Provider (user) to I2NSF manger 
  Based on  draft-fang-i2nsf-inter-cloud-ddos-mitigation-api-01

These data model encompasses the simple firewall case.  I hope to 
merge my ideas with Aldo's, and I hope to publish early next week. 

I request 5 minutes to provide updates: 

- Status of I2RS requirements + I2NSF requirements 
  
   I2RS should complete WG LC on all requirements documents by IETF 96. 
   This will provide updates on NETCONF/RESTCONF, netmod and the I2RS
   ephemeral, pub/sub, and security environments, and make suggestions on 
   what gaps remain for I2NSF. 

Sue Hares 

-----Original Message-----
From: I2nsf [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Monday, June 20, 2016 1:01 PM
To: [email-masked]
Cc: 'Linda Dunbar'
Subject: [I2nsf] Starting to think about an agenda for I2NSF in Berlin

Hi working group,

Linda and I have been thinking about the agenda for Berlin. We think that we
should continue to focus on our charter and deliverables doing what is
necessary to advance our milestones. Broadly we could split our 2 hours as:

We'd like to hear your proposals for things that need to be discussed in
these categories so that we can start to put a detailed agenda together.

Thanks,
Adrian and Linda

---

From: John Strassner <[email-masked]>
Date: Wed, 29 Jun 2016 21:21:23 -0700

I will try and help Jianjie update the UAGP draft.
Diego, I'm happy to help with your attestation draft if you need it.

best regards,
John

On Thu, Jun 23, 2016 at 1:33 PM, Diego R. Lopez <
[email-masked]> wrote:

> Hi,
>
> Though I have not been able to update the attestation draft (and the
> framework one in accordance) I am reasonably sure I will be able to do so
> before the cut-off date, so I’d ask for 5-10 minutes to talk about these
> updates, under requirements and protocols,.
>
> Be goode,
>
> On 20 Jun 2016, at 19:00 , Adrian Farrel <[email-masked]> wrote:
>
> Hi working group,
>
> necessary
> these
> ------------------------------
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
>

-- 
regards,
John