Subject: [I2nsf] Definition for "Consumer" in I2NSF terminology , in the context of "Client Facing Interface"

From: Linda Dunbar <[email-masked]>
Date: Mon, 17 Oct 2016 20:22:47 +0000

John,

There are two types of interface described in I2NSF framework:

-        one is NSF facing interface, over which  rules  or policies can be expressed based on ports/IP addresses for packets traversing through a NSF;

-        another is the interface for Clients, users, tenants, to express/query rules that are expressed in users own ID, address domains, etc. Commonly called "Client facing interface".

You have suggested to use "Consumer facing Interface". But the definition of "Consumer" in I2NSF Terminology -01, doesn't really reflect the idea of rules being expressed from the perspective of clients or users.

If we use this terminology, "Consumer" interface can also face NSFs as well.

  Consumer:  A Consumer is a Role that is assigned to an I2NSF
      Component that can receive information from another I2NSF
      Component.  See also:  Provider, Role.

Can you clarify ?

Thanks, Linda

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 17 Oct 2016 20:28:35 +0000

John,

Maybe we should call it "customer-facing-interface" instead of "consumer-facing-interface"?

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Monday, October 17, 2016 3:23 PM
To: John Strassner <[email-masked]>
Cc: [email-masked]
Subject: [I2nsf] Definition for "Consumer" in I2NSF terminology , in the context of "Client Facing Interface"

John,

Can you clarify ?

Thanks, Linda

---

From: "Diego R. Lopez" <[email-masked]>
Date: Mon, 17 Oct 2016 21:35:53 +0000

And what about “tenant or “user" rather than “customer”?

Be goode,

On 17 Oct 2016, at 22:28 , Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:

John,

Maybe we should call it “customer-facing-interface” instead of “consumer-facing-interface”?

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Monday, October 17, 2016 3:23 PM
To: John Strassner <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [I2nsf] Definition for "Consumer" in I2NSF terminology , in the context of "Client Facing Interface"

John,

There are two types of interface described in I2NSF framework:
-        one is NSF facing interface, over which  rules  or policies can be expressed based on ports/IP addresses for packets traversing through a NSF;
-        another is the interface for Clients, users, tenants, to express/query rules that are expressed in users own ID, address domains, etc. Commonly called “Client facing interface”.

You have suggested to use “Consumer facing Interface”. But the definition of “Consumer” in I2NSF Terminology -01, doesn’t really reflect the idea of rules being expressed from the perspective of clients or users.

If we use this terminology, “Consumer” interface can also face NSFs as well.

Can you clarify ?

Thanks, Linda
_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 17 Oct 2016 21:50:24 +0000

The I2NSF framework currently uses “client-facing –interface”.
Either “Tenant-facing-interface” or “User-facing-interface” would be equivalent.

Linda
From: Diego R. Lopez [mailto:[email-masked]]
Sent: Monday, October 17, 2016 4:36 PM
To: Linda Dunbar <[email-masked]>
Cc: John Strassner <[email-masked]>; [email-masked]
Subject: Re: [I2nsf] Definition for "Consumer" in I2NSF terminology , in the context of "Client Facing Interface"

Be goode,

John,

Linda

John,

Can you clarify ?

Thanks, Linda

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: John Strassner <[email-masked]>
Date: Tue, 18 Oct 2016 04:16:50 +0000

Hi Linda,

I'm happy to change the definition of Consumer if you like - I wrote it to be as generic as possible. However, since you are asking, please compare the definitions from three sources for consumer vs. client, and then tell me if you really want to change consumer to client.

I for one do not - as explained in the last IETF, it connotes "client-server" computing, and my implementation will be distributed. Plus, client generally means customer, which is fine for **users** but not fine for other types of entities (e.g., agents, intermediaries, etc.).

If you do want to change consumer, then I would propose adding a simple explanatory line, such as:

Consumer:  A Consumer is a Role that is assigned to an I2NSF
      Component that can receive information from another I2NSF
      Component.  Examples include end-users and agents.
      See also:  Provider, Role.

Wikipedia's definition of consumer:

A consumer is a person or organization that uses economic services<https://en.wikipedia.org/wiki/Service_(economics)> or commodities<https://en.wikipedia.org/wiki/Commodity>.[1]<https://en.wikipedia.org/wiki/Consumer#cite_note-1>

Merriam-Webster's definition of consumer:

*         : a person who buys goods and services

Dictionary.com's definition of consumer:
1.
a person or thing that consumes<http://www.dictionary.com/browse/consume>.
2.
Economics. a person or organization that uses a commodity or service.

The same three definitions for **client**

Wikipedia's definition of client:

  *   Client (computing)<https://en.wikipedia.org/wiki/Client_(computing)>, hardware or software that accesses a remote service on another computer
  *   Customer<https://en.wikipedia.org/wiki/Customer> or client, a recipient of goods or services in return for monetary or other valuable considerations

Merriam-Webster's definition of client:
Full Definition of client

1.      1 :  one that is under the protection of another :  dependent<http://www.merriam-webster.com/dictionary/dependent>

2.      2 a :  a person who engages the professional advice or services of another <a lawyer's clients> b :  customer<http://www.merriam-webster.com/dictionary/customer> <hotel clients> c :  a person served by or utilizing the services of a social agency <a welfare client> d :  a computer in a network that uses the services (as access to files or shared peripherals) provided by a server

Dictionary.com's definition of client:

noun
1.
a person or group that uses the professional advice or services of a lawyer, accountant, advertising agency, architect, etc.
2.
a person who is receiving the benefits, services, etc., of a social welfare agency, a government bureau, etc.
3.
a customer.
4.
anyone under the patronage of another; a dependent.
5.
Computers. a computer or an application on a computer that communicates with a remote server:

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Monday, October 17, 2016 1:23 PM
To: John Strassner <[email-masked]>
Cc: [email-masked]
Subject: [I2nsf] Definition for "Consumer" in I2NSF terminology , in the context of "Client Facing Interface"

John,

Can you clarify ?

Thanks, Linda

---

From: John Strassner <[email-masked]>
Date: Tue, 18 Oct 2016 04:27:45 +0000

Well, no it wouldn’t.

Please see my earlier email with respect to client-facing interface. I don’t like “client”, it has the wrong connotations for modern software.
A consumer is an entity that is using something (data, services, etc.) that is given to it. Which is exactly what this interface is doing.
Tenant has other connotations, and we have not yet designed the framework to be truly multi-tenant.
Customer is not appropriate for other reasons (is an agent a customer?).

We had already decided on this before, why is it being brought up again?

Regards,
John

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Monday, October 17, 2016 2:50 PM
To: Diego R. Lopez <[email-masked]>
Cc: [email-masked]; John Strassner <[email-masked]>
Subject: Re: [I2nsf] Definition for "Consumer" in I2NSF terminology , in the context of "Client Facing Interface"

Linda
From: Diego R. Lopez [mailto:[email-masked]]
Sent: Monday, October 17, 2016 4:36 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Cc: John Strassner <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [I2nsf] Definition for "Consumer" in I2NSF terminology , in the context of "Client Facing Interface"

Be goode,

John,

Linda

John,

Can you clarify ?

Thanks, Linda

Dr Diego R. Lopez
Telefonica I+D