Subject: Re: [I2nsf] Process discussion on draft-kumar-i2nsf-client-facing-interface-req-00

From: "Diego R. Lopez" <[email-masked]>
Date: Mon, 3 Oct 2016 07:31:05 +0000

Hi Adrian,

I must admit that, more often that I’d like to, I tend to be too brief in how I explain my points (becoming even terse in many cases) and if you add this to the different meanings carried by what seem synonymic words in different languages, you have a good base for lack of understanding. Let me try to explain my points regarding the adoption call for this draft.

First, regarding the unusual adoption of a -00 draft, my point was not trying to invoke process correctness. I don’t consider myself an expert in IETF processes and, most important, I think hiding behind process trivia is one of the worst strategies you can follow in seeking consensus.  What I wanted to do was to express my surprise about the authors asking for adoption. My consistent experience in the IETF is that authors introduce -00 drafts as an initial contribution to the community, collect initial inputs from the community, and at least produce a -01 (or higher) that goes in the direction of these initial contributions. This is done irrespectively of the draft in question being technically sound, well aligned with the charter, or addressing a relevant issue. I can hardly understand the reasons why the authors have decided to go for adoption of -00, without considering any of the comments that were made both on the list and at the meeting in Berlin. Furthermore, I don’t see any urgency for immediate adoption. All comments I have seen so far (including mine) acknowledge the relevance of the matter considered in the draft, and the fact the document is headed in what seems the right direction, and therefore the interest of the community is confirmed, and an eventual adoption (once the concerns expressed are addressed) can be considered highly probable, to avoid terms around the word “sure”...

Second, when I used the word “maturity” I was referring to the fact that the text did not address at all any of the concerns expressed when the draft was first introduced. Probably something like “adequately reflecting group discussion” would be a much better way of expressing it. While some of these comments are more related to terminology aspects and could be solved later on during the draft lifecycle, others address the structure and contents of the document, what I think we all agree is something we should consider before adopting the draft. So I am not talking about completeness or a requirement of sufficient stability by any means, but simply asking for a common understanding of what a document on requirements for the client-facing interface should contain.

I hope this helps in making my position clearer. Let me insist: I am not against considering the work in this direction, and I agree this draft is a very relevant first step, but I would like to see a more detailed discussion of some specific aspects of the draft (among them, its contents) before considering it ready for adoption. And I cannot see why we have such an urgent need for adoption either.

Be goode,

On 30 Sep 2016, at 14:14 , Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:

Hi Diego,

I find myself in a difficult position: the I-D in question is authored by people who are paid by Juniper, and I am sponsored as co-chair by Juniper.
Therefore, I don't want to go into details on this particular I-D.

However, on this thread you have twice made comments about process that I take issue with.
1. It is unusual to adopt a 00 draft
2. The draft is not mature enough to be adopted

For the first point there is "usual" meaning "done most often" and there is "usual" meaning "not supported by process". I think there is nothing in the process that speaks against adoption of a 00 draft in any way. In fact, some I-Ds are created as WG I-Ds without a 00 individual I-D. Others are adopted from 00.  Of course, the most frequent situation is that an individual I-D has several revisions as the authors develop it and attract support in the WG, but the fact of what happens most frequently should not be used as an argument for or against adopting a specific document.

For the second point, I don't think "maturity" is a relevant or quantifiable thing for a draft.
Does it mean "a high revision number"? If so, the authors could quickly spin 5 revisions without changing the content.
Does it mean "no substantial sections left empty"?
Does it mean "has been round for more than 6 months"?
Or does it mean "has been discussed in 27 different email discussions"?
Surely it does not mean "substantially complete and close to being last called for publication".

What seems (to me) to be important is:
- Does the WG want to work on this topic?
- Is it in scope for the WG charter?
- Do the chairs believe that the WG can work on this document?

The chairs often (although they are not required to) use a poll of the WG to judge answers to these questions.
You may find the slides used in WG chair training to be helpful https://www.ietf.org/edu/documents/IETF78-WGchairs-Adrian-Farrel.pdf

I would add one more important point:
When an I-D is a WG I-D, the WG controls the content. The editors are obliged to address issues raised by the WG (either updating the document or rejecting raised concerns) under the principle of consensus.
When an I-D is an individual I-D, the authors can include or exclude whatever they like.
Thus, when a WG wants to work on a topic my view is that it is good to get the document into the care of the WG as soon as possible.

But I will leave further discussion of progressing this document under the care of my co-chair.

Cheers,
Adrian

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 3 Oct 2016 09:42:51 +0100

Good. Thanks. Then we understand each other.
 
To be fair to the authors, I don't think they requested adoption: this was chair-driven.
Anyway, the authors have indicated that they are building a new revision collecting comments from a number of sources, so all is good.
 
Thanks,
Adrian
 
From: Diego R. Lopez [mailto:[email-masked]] 
Sent: 03 October 2016 08:31
To: [email-masked]
Cc: [email-masked]
Subject: Re: Process discussion on draft-kumar-i2nsf-client-facing-interface-req-00
 
Hi Adrian, 

 

Be goode,

On 30 Sep 2016, at 14:14 , Adrian Farrel <[email-masked]> wrote:
 
Hi Diego,

 

 
The chairs often (although they are not required to) use a poll of the WG to judge answers to these questions.
You may find the slides used in WG chair training to be helpful  <https://www.ietf.org/edu/documents/IETF78-WGchairs-Adrian-Farrel.pdf> https://www.ietf.org/edu/documents/IETF78-WGchairs-Adrian-Farrel.pdf

 
Cheers,
Adrian

Dr Diego R. Lopez
Telefonica I+D

---

From: "Diego R. Lopez" <[email-masked]>
Date: Mon, 3 Oct 2016 08:45:55 +0000

Good to see we are in converging tracks!

Be goode,

On 3 Oct 2016, at 10:42 , Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Adrian

From: Diego R. Lopez [mailto:[email-masked]]
Sent: 03 October 2016 08:31
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: Process discussion on draft-kumar-i2nsf-client-facing-interface-req-00

Hi Adrian,

Be goode,

Hi Diego,

Cheers,
Adrian

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

Dr Diego R. Lopez
Telefonica I+D