Subject: [I2nsf] Info models and draft-zhang-i2nsf-info-model-monitoring

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 14 Oct 2016 10:54:42 +0100

Thanks, all, for the useful comments about this document.

It seems clear that there is support for developing this work and producing a
data model for monitoring.

Two points:

1. As noted by Sue, there is a BoF/WG planned for IETF-98 on "Security Events".
I suggest you go to that. I will also make sure the AD is aware of the potential
overlap/interaction.

2. It seems reasonable to me that producing an information model (such as in
draft-zhang-i2nsf-info-model-monitoring) is a useful step toward producing a
data model. I have no objection to using a structured approach. However, my
question about "publication" could be phrased as follows:
- Suppose we decide we want a data model for monitoring
- Suppose we use draft-zhang-i2nsf-info-model-monitoring to guide
   our work on that data model
- Suppose that we push ahead with the data model quite soon so
   that it starts to catch up with the info model
If all of those things apply, why would we need to publish an RFC that captures
the information model given that we will be publishing a data model shortly
afterwards?
Presumably, once the data model is published, no one will ever read the
information model.
So the information model would be a valuable document working document in which
the WG would capture its thoughts and consensus, but would be discarded once the
work to make the data model was complete.

Or am I wrong?

Thanks,
Adrian

> -----Original Message-----
> From: Susan Hares [mailto:[email-masked]]
> Sent: 13 October 2016 14:49
> To: [email-masked]; [email-masked]
> Subject: RE: [I2nsf] Thoughts on draft-zhang-i2nsf-info-model-monitoring
> 
> Adrian:
> 
> Why: Monitoring is a key component to I2NSF for monitoring NSF devices.
> Monitoring is not the same as NSF devices sending notifications - which is a
> push from the NSF devices.  Monitoring may encompasses specific requests to
> the device.   Monitoring is different than the DOTS - "help me" cry from a
> device under attack.
> While I see the security ADs are proposing Security event, it is important
> that the I2NSF create monitoring concepts that work with all of the
> functions (e.g. querying capabilities, sending/receiving notification, and
> events).
> 
> Data model versus Information model:  Since we do not seem to have a clear
> idea of what the data model should be, it is important to create the
> informational models.
> 
> The content of the draft is a good first step.
> 
> Sue Hares
> 
> 
> 
> -----Original Message-----
> From: I2nsf [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Tuesday, October 11, 2016 5:22 PM
> To: [email-masked]
> Subject: [I2nsf] Thoughts on draft-zhang-i2nsf-info-model-monitoring
> 
> Working Group,
> 
> Linda and I would like to hear some more from you about
> draft-zhang-i2nsf-info-model-monitoring.
> 
> Is it something you think we should be working on?
> Should we have a separate YANG module for it or fold it into other modules?
> If we produce a YANG module, do we still need to publish the information
> model?
> 
> And, most important, what do you think of the content of the draft?
> 
> Thanks,
> Adrian
> 
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sat, 22 Oct 2016 11:29:54 +0000

Hi Adrian,

Agree: it is a useful tool but should not be a separate publication. The only reason for publishing the information model could be to do so in the same document as the data model, as rationale supporting it, and even giving the opportunity for alternate data models using other data representations (TOSCA, for example, very much in fashion in cloudspace).

Be goode,

On 14 Oct 2016, at 11:54 , Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:

Two points:

Or am I wrong?

Thanks,
Adrian

-----Original Message-----
From: Susan Hares [mailto:[email-masked]]
Sent: 13 October 2016 14:49
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [I2nsf] Thoughts on draft-zhang-i2nsf-info-model-monitoring

Adrian:

Sue Hares

-----Original Message-----
From: I2nsf [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Tuesday, October 11, 2016 5:22 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [I2nsf] Thoughts on draft-zhang-i2nsf-info-model-monitoring

Working Group,

Thanks,
Adrian

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: John Strassner <[email-masked]>
Date: Wed, 26 Oct 2016 08:40:59 -0700

Hi all,

The main reason for publishing an information model is to support multiple
data models that are derived from it.

I realize that the IETF is worried mainly about YANG data models. That is
perfectly well and good. However, security controllers will need to
interface with compute, storage, and other systems that have poor (if any)
YANG coverage. As soon as I go into a data center or a cloud, YANG is
simply not used for compute and storage solutions.

This means that we can either ignore that, and build a silo, or take it
into account, or not.

   If we choose to ignore, there is no reason to publish the info model.
   If we choose not to ignore, and want to support other data models, then
we SHOULD publish the info model as well. Even if we only have 1 data model
now.

Hence, I personally would prefer two publications - one for the info model,
and one for the YANG data model.

best,
John

On Sat, Oct 22, 2016 at 4:29 AM, Diego R. Lopez <
[email-masked]> wrote:

> Hi Adrian,
>
> Agree: it is a useful tool but should not be a separate publication. The
> only reason for publishing the information model could be to do so in the
> same document as the data model, as rationale supporting it, and even
> giving the opportunity for alternate data models using other data
> representations (TOSCA, for example, very much in fashion in cloudspace).
>
> Be goode,
>
> On 14 Oct 2016, at 11:54 , Adrian Farrel <[email-masked]> wrote:
>
> From: Susan Hares [mailto:[email-masked] <[email-masked]>]
> From: I2nsf [mailto:[email-masked] <[email-masked]>] On
> Behalf Of Adrian Farrel

-- 
regards,
John

---

From: Rakesh Kumar <[email-masked]>
Date: Wed, 26 Oct 2016 20:30:44 +0000

I also prefer that we have two separate publications based on RFC3444 guidelines.

1.       Information model --> plain text is enough to describe managed objects and their relationship

2.       Data model --> YANG or some other representation

Thanks & Regards,
Rakesh
From: I2nsf <[email-masked]> on behalf of John Strassner <[email-masked]>
Date: Wednesday, October 26, 2016 at 8:40 AM
To: "Diego R. Lopez" <[email-masked]>, John Strassner <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [I2nsf] Info models and draft-zhang-i2nsf-info-model-monitoring

Hi all,

The main reason for publishing an information model is to support multiple data models that are derived from it.

I realize that the IETF is worried mainly about YANG data models. That is perfectly well and good. However, security controllers will need to interface with compute, storage, and other systems that have poor (if any) YANG coverage. As soon as I go into a data center or a cloud, YANG is simply not used for compute and storage solutions.

This means that we can either ignore that, and build a silo, or take it into account, or not.

   If we choose to ignore, there is no reason to publish the info model.
   If we choose not to ignore, and want to support other data models, then we SHOULD publish the info model as well. Even if we only have 1 data model now.

Hence, I personally would prefer two publications - one for the info model, and one for the YANG data model.

best,
John

On Sat, Oct 22, 2016 at 4:29 AM, Diego R. Lopez <[email-masked]<mailto:[email-masked]>> wrote:
Hi Adrian,

Be goode,

Two points:

Or am I wrong?

Thanks,
Adrian

-----Original Message-----
From: Susan Hares [mailto:[email-masked]]
Sent: 13 October 2016 14:49
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [I2nsf] Thoughts on draft-zhang-i2nsf-info-model-monitoring

Adrian:

Sue Hares

-----Original Message-----
From: I2nsf [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Tuesday, October 11, 2016 5:22 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [I2nsf] Thoughts on draft-zhang-i2nsf-info-model-monitoring

Working Group,

Thanks,
Adrian

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:%2B34%20913%20129%20041>
Mobile: +34 682 051 091<tel:%2B34%20682%20051%20091>
----------------------------------

--
regards,
John

---

From: "Natale, Bob" <[email-masked]>
Date: Wed, 26 Oct 2016 22:11:36 +0000

I agree with John on both points: (1) I2nsf should not ignore non-YANG domains and (2) therefore, a separate info model document makes very good sense.

Avanti,
BobN

From: I2nsf [mailto:[email-masked]] On Behalf Of John Strassner
Sent: Wednesday, October 26, 2016 11:41 AM
To: Diego R. Lopez <[email-masked]>; John Strassner <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [I2nsf] Info models and draft-zhang-i2nsf-info-model-monitoring

Hi all,

best,
John

Be goode,

Two points:

Or am I wrong?

Thanks,
Adrian

-----Original Message-----
From: Susan Hares [mailto:[email-masked]]
Sent: 13 October 2016 14:49
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [I2nsf] Thoughts on draft-zhang-i2nsf-info-model-monitoring

Adrian:

Sue Hares

-----Original Message-----
From: I2nsf [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Tuesday, October 11, 2016 5:22 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [I2nsf] Thoughts on draft-zhang-i2nsf-info-model-monitoring

Working Group,

Thanks,
Adrian

Dr Diego R. Lopez
Telefonica I+D

--
regards,
John

---

From: "Kepeng Li" <[email-masked]>
Date: Mon, 31 Oct 2016 16:21:00 +0800

+1 on separate information model publication.

Kind Regards
Kepeng

发件人:  I2nsf <[email-masked]> on behalf of "Natale, Bob"
<[email-masked]>
日期:  Thursday, 27 October 2016 at 6:11 AM
至:  John Strassner <[email-masked]>, "Diego R. Lopez"
<[email-masked]>
抄送:  "[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>
主题:  Re: [I2nsf] Info models and draft-zhang-i2nsf-info-model-monitoring

I agree with John on both points: (1) I2nsf should not ignore non-YANG
domains and (2) therefore, a separate info model document makes very good
sense.
 
Avanti,
BobN
 
To: Diego R. Lopez <[email-masked]>; John Strassner
<[email-masked]>

Hi all,

I realize that the IETF is worried mainly about YANG data models. That is
perfectly well and good. However, security controllers will need to
interface with compute, storage, and other systems that have poor (if any)
YANG coverage. As soon as I go into a data center or a cloud, YANG is simply
not used for compute and storage solutions.

This means that we can either ignore that, and build a silo, or take it into
account, or not.

 

best,

John

On Sat, Oct 22, 2016 at 4:29 AM, Diego R. Lopez
<[email-masked]> wrote:
> 
> Hi Adrian, 
> 
>  
> 
> Agree: it is a useful tool but should not be a separate publication. The only
> reason for publishing the information model could be to do so in the same
> document as the data model, as rationale supporting it, and even giving the
> opportunity for alternate data models using other data representations (TOSCA,
> for example, very much in fashion in cloudspace).
> 
>  
> 
> Be goode,
> 
>  
> 
> Tel:    +34 913 129 041 <tel:%2B34%20913%20129%20041>
> Mobile: +34 682 051 091 <tel:%2B34%20682%20051%20091>

-- 

regards,

John
_______________________________________________ I2nsf mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/i2nsf