Subject: Re: [I2nsf] Call for WG adoption of draft-kumar-i2nsf-client-facing-interface-req

From: John Strassner <[email-masked]>
Date: Sun, 2 Oct 2016 23:42:59 -0700

I think that this draft has good, promising work in it. However, I do
not think that it is ready, at this moment in time, for WG adoption.
Here are some specific points focused on just the Abstract that I
think the authors should work on to improve this draft:

DRAFT:
   This document provides a framework ...
<jcs>
I am missing how this framework relates to the framework draft;
this needs to be covered.
</jcs>

DRAFT:
   ...and information model for the definition of northbound
   interfaces for a security controller.
<jcs>
I could not find an information model in this draft. While I don't
expect a detailed model at this stage, I don't even see proposed
classes or the beginning of a class hierarchy.
</jcs>

DRAFT
   The interfaces are based on user-intent instead of vendor-specific
   or device-centric approaches...
<jcs>
There are too many subjects that are attempted to be covered!
User-intent is a subject by itself - a big one. There isn't even a
definition in I2NSF of this term, let alone in the industry . I would
strongly recommend that this be moved into a separate draft.
</jcs>

DRAFT
   The document identifies the
   common interfaces needed to enforce the user-intent based policies
   onto network security functions (NSFs) irrespective of how those
   functions are realized.
<jcs>
How can you define a set of interfaces when there is no definition of
user-intent based policies? I'm not even sure what a "user-intent
based policy is",
</jcs>

best regards,
John

On Wed, Sep 21, 2016 at 10:54 AM, Linda Dunbar <[email-masked]>
wrote:

> Dear WG:
>
>
>
> This email serves as a call for WG adoption of draft-kumar-i2nsf-client-facing-interface-req
> as a WG document. The call for adoption will run for 2 weeks ending Oct 5,
> 2016.
>
> The requirement document is one of the key deliverables specified by the
>  I2NSF charter.
>
>
>
> Please note that this is a call for adoption, and not a last call for
> content of the document. Adopting a WG document simply means that the WG
> will focus its efforts on that particular draft going forward, and use that
> document for resolving open issues and documenting the WG’s decisions.
>
>
>
> Please indicate whether you support adoption for not, and if not why.
> Issues you have with the current document itself can also be raised, but
> they should be raised in the context of what should be changed in the
> document going forward, rather than a pre-condition for adoption.
>
>
>
> Finally, now is also a good time to poll for knowledge of any IPR that
> applies to this draft, in line with the IPR disclosure obligations for WG
> participants (see RFCs 3979, 4879, 3669 and 5378 for more details). If you
> are listed as a document author please respond to this email (to the
> chairs) whether or not you are aware of any relevant IPR
>
> https://tools.ietf.org/id/draft-kumar-i2nsf-client-
> facing-interface-req-00.txt
>
>
>
>
>
> Authors: there are some editorial changes needed to comply with the I2NSF
> terminologies that the WG has agreed, in particular:
>
> -        Abstract: needs to change the starting sentence to “This
> document provides a framework and requirement ….”
>
> -        Change all reference of “North Bound Interface” to
> “Client/consumer facing interface”.
>
>
>
> Thank you,
>
>
>
> Linda & Adrian
>
>
>
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>
>

-- 
regards,
John

---

From: Rakesh Kumar <[email-masked]>
Date: Mon, 3 Oct 2016 17:42:43 +0000

Hi John,

Thanks a lot for the review. Please see my answers inline with [rakesh] and we would try to address these comments in next revision (hopefully should be out this week).

Regards,
Rakesh

From: I2nsf <[email-masked]> on behalf of John Strassner <[email-masked]>
Date: Sunday, October 2, 2016 at 11:42 PM
To: Linda Dunbar <[email-masked]>, John Strassner <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [I2nsf] Call for WG adoption of draft-kumar-i2nsf-client-facing-interface-req

DRAFT:

[rakesh] We would call this a requirement document, actually we meant requirement framework for client interface. We will look into this

DRAFT:

[rakesh] It would come in separate draft. This was primary to capture only requirements.

DRAFT

[rakesh] The “user-intent” is one of the fundamental desire/requirement to abstract interfaces so that client does not have deal with vendor specific feature/functionality. But I agree with you that it needs clear and precise definition. I have discussed with few folks and would define the concept and ideas behind this so that we can clearly articulate our point.

DRAFT

[rakesh] As stated above, we would work on to include this in the draft.

best regards,
John

On Wed, Sep 21, 2016 at 10:54 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Dear WG:

This email serves as a call for WG adoption of draft-kumar-i2nsf-client-facing-interface-req as a WG document. The call for adoption will run for 2 weeks ending Oct 5, 2016.
The requirement document is one of the key deliverables specified by the  I2NSF charter.

Please note that this is a call for adoption, and not a last call for content of the document. Adopting a WG document simply means that the WG will focus its efforts on that particular draft going forward, and use that document for resolving open issues and documenting the WG’s decisions.

Please indicate whether you support adoption for not, and if not why. Issues you have with the current document itself can also be raised, but they should be raised in the context of what should be changed in the document going forward, rather than a pre-condition for adoption.

Finally, now is also a good time to poll for knowledge of any IPR that applies to this draft, in line with the IPR disclosure obligations for WG participants (see RFCs 3979, 4879, 3669 and 5378 for more details). If you are listed as a document author please respond to this email (to the chairs) whether or not you are aware of any relevant IPR
https://tools.ietf.org/id/draft-kumar-i2nsf-client-facing-interface-req-00.txt

Authors: there are some editorial changes needed to comply with the I2NSF terminologies that the WG has agreed, in particular:

-        Abstract: needs to change the starting sentence to “This document provides a framework and requirement ….”

-        Change all reference of “North Bound Interface” to “Client/consumer facing interface”.

Thank you,

Linda & Adrian

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
regards,
John