Subject: Re: [I2nsf] just to want to reiterate the conclusion of today's interim:

From: Linda Dunbar <[email-masked]>
Date: Fri, 14 Oct 2016 02:39:51 +0000

Paul,

As the result of Sept 13 Interim meeting, we have decided to use the following term, i.e. “Capability” Defines a set of features which  can be queried on both NSF Facing interface and Client Facing interface.

The NSF facing data model is on attributes and rules that are implementable by NSFs. The Client Facing Data Model can use more abstract rules (as long as those rules can be translated to the implementable rules with the assistance of category or database)

OLD:
   Capability:  Defines a set of features that are available from a
      managed entity (see also I2NSF Capability). Examples of "managed
      entities" are NSFs and Controllers, where NSF Capabilities and
      Controller Capabilities define functionality of an NSF and about
      Controller, respectively. These functions may, but do not have
      to, be used. All Capabilities are announced through the
      Registration Interface.

   Capability Interface:  An interface dedicated to requesting,
      receiving, editing, and deleting capability information.
NEW:
   Capability:  Defines a set of features that are available from a
      managed entity (see also I2NSF Capability). Examples of "managed
      entities" are NSFs and Controllers, where NSF Capabilities and
      Controller Capabilities define functionality of an NSF and about
      Controller, respectively. These functions may, but do not have
      to, be used. All Capabilities are announced through the
      Registration Interface and are communicated through either
      the Consumer-Facing Interface or the NSF-Facing Interface.

Capability Interface would then be deleted.

Linda

From: Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
Sent: Thursday, October 13, 2016 8:11 PM
To: Linda Dunbar <[email-masked]>
Cc: Susan Hares <[email-masked]>; Jaehoon (Paul) Jeong <[email-masked]>; John Strassner <[email-masked]>
Subject: Re: just to want to reiterate the conclusion of today's interim:

Hi Linda and John,
Could you respond to my previous question on data models?

After your comments, Susan and I will work on the data models.

Thanks.

Best Regards,
Paul

On Mon, Oct 10, 2016 at 11:34 PM, Mr. Jaehoon Paul Jeong <[email-masked]<mailto:[email-masked]>> wrote:
Hi Linda and John,
Could you clarify capability data model and NSF facing data model?

As I understand, the capability data model describes security services in NSFs,
such as network security (e.g., firewall), content security (e.g., DPI), and attack mitigation (e.g., DDoS-attack mitigator).

How is NSF facing data model different from Capability data model?

Thanks.

Best Regards,
Paul

On Thu, Oct 6, 2016 at 7:41 AM, Mr. Jaehoon Paul Jeong <[email-masked]<mailto:[email-masked]>> wrote:

Linda,
I agree on your suggestion.
I will discuss with Sue how to merge two drafts and split them.

Thanks.

Best Regards,
Paul

2016. 10. 5. 오후 6:30에 "Linda Dunbar" <[email-masked]<mailto:[email-masked]>>님이 작성:

Sue and Paul,

Thank you very much for revising the drafts.
Want to reiterate what you have agreed:

you are going to merge the two drafts below, and split into "draft-xx-i2nsf-capability-data-model" and "draft-xx-i2nsf-NSF-facing-data-model"
•        –draft-hares-i2nsf-capability-yang-01
•        –draft-jeong-i2nsf-capability-interface-yang-03

Thank you very much.

Linda

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 17 Oct 2016 09:45:07 +0900

Linda,
Thanks for your kind answers.

I will work on the new definition of Capability.

Thanks.

Best Regards,
Paul

On Fri, Oct 14, 2016 at 11:39 AM, Linda Dunbar <[email-masked]>
wrote:

> Paul,
>
>
>
> As the result of Sept 13 Interim meeting, we have decided to use the
> following term, i.e. “Capability” Defines a set of features which  can be
> queried on both NSF Facing interface and Client Facing interface.
>
>
>
> The NSF facing data model is on attributes and rules that are
> implementable by NSFs. The Client Facing Data Model can use more abstract
> rules (as long as those rules can be translated to the implementable rules
> with the assistance of category or database)
>
>
>
> OLD:
>
> *From:* Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
> *Sent:* Thursday, October 13, 2016 8:11 PM
> *To:* Linda Dunbar <[email-masked]>
> *Cc:* Susan Hares <[email-masked]>; Jaehoon (Paul) Jeong <
> [email-masked]>; John Strassner <[email-masked]>
> *Subject:* Re: just to want to reiterate the conclusion of today's
> interim:
>
>
>
> Hi Linda and John,
>
> On Mon, Oct 10, 2016 at 11:34 PM, Mr. Jaehoon Paul Jeong <
> [email-masked]> wrote:
>
> Hi Linda and John,
>
> such as network security (e.g., firewall), content security (e.g., DPI),
> and attack mitigation (e.g., DDoS-attack mitigator).
>
>
>
> On Thu, Oct 6, 2016 at 7:41 AM, Mr. Jaehoon Paul Jeong <
> [email-masked]> wrote:
>
> Linda,
> 2016. 10. 5. 오후 6:30에 "Linda Dunbar" <[email-masked]>님이 작성:
>
>
>
> Sue and Paul,
>
>
>
> you are going to merge the two drafts below, and split into
> "draft-xx-i2nsf-capability-data-model" and "draft-xx-i2nsf-NSF-facing-
> data-model"
>
> ·        –draft-hares-i2nsf-capability-yang-01
>
> ·        –draft-jeong-i2nsf-capability-interface-yang-03
>
>
>
> Thank you very much.
>
>
>
> Linda
>
>
>
>
>
>
>
>
>
> --
>
> Email: [email-masked], [email-masked]
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
> <http://cpslab.skku.edu/people-jaehoon-jeong.php>
>
>
>
>
>
> --
>
> Email: [email-masked], [email-masked]
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
> <http://cpslab.skku.edu/people-jaehoon-jeong.php>
>

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>