Subject: [I2nsf] I-D Action: draft-ietf-i2nsf-client-facing-interface-req-02.txt

From: [email-masked]
Date: Mon, 03 Jul 2017 14:39:48 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Interface to Network Security Functions of the IETF.

        Title           : Requirements for Client-Facing Interface to Security Controller
        Authors         : Rakesh Kumar
                          Anil Lohiya
                          Dave Qi
                          Nabil Bitar
                          Senad Palislamovic
                          Liang Xia
	Filename        : draft-ietf-i2nsf-client-facing-interface-req-02.txt
	Pages           : 24
	Date            : 2017-07-03

Abstract:
   This document captures requirements for Client-Facing interface to
   the Security Controller as defined by [I-D.ietf-i2nsf-framework].
   The interface is expressed using objects and constructs understood by
   Security Admin as opposed to vendor or device specific expressions
   associated with individual product and feature.  This document
   identifies a broad set of requirements needed to express Security
   Policies based on User-constructs which are well understood by the
   User Community.  This gives ability to decouple policy definition
   from policy enforcement on a specific security functional element, be
   it a physical or virtual.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-client-facing-interface-req/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-i2nsf-client-facing-interface-req-02
https://datatracker.ietf.org/doc/html/draft-ietf-i2nsf-client-facing-interface-req-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2nsf-client-facing-interface-req-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Rakesh Kumar <[email-masked]>
Date: Mon, 3 Jul 2017 21:42:11 +0000

Hi,

I updated number of sections based on past feedback and added/updated few sections based on customer interaction in industry forums (ONUG).

Thanks
Rakesh

On 7/3/17, 2:39 PM, "I2nsf on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>I2nsf mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/i2nsf

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 4 Jul 2017 07:07:14 +0900

Hi Rakesh,
when you will post your updated  information model later, I will update our
data model correspondingly.

Thanks.

Best Regards,
Paul

2017. 7. 4. 오전 6:42에 "Rakesh Kumar" <[email-masked]>님이 작성:

Hi,

I updated number of sections based on past feedback and added/updated few
sections based on customer interaction in industry forums (ONUG).

Thanks
Rakesh

---

From: Rakesh Kumar <[email-masked]>
Date: Mon, 3 Jul 2017 22:09:39 +0000

HI Paul,

I plan to do soon (few hours).

Thanks
Rakesh

From: "Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 3, 2017 at 3:07 PM
To: Rakesh Kumar <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [I2nsf] I-D Action: draft-ietf-i2nsf-client-facing-interface-req-02.txt

Hi Rakesh,
when you will post your updated  information model later, I will update our data model correspondingly.

Thanks.

Best Regards,
Paul

2017. 7. 4. 오전 6:42에 "Rakesh Kumar" <[email-masked]<mailto:[email-masked]>>님이 작성:
Hi,

Thanks
Rakesh

On 7/3/17, 2:39 PM, "I2nsf on behalf of [email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

>until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>
>[email-masked]<mailto:[email-masked]>
_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

---

From: Rakesh Kumar <[email-masked]>
Date: Tue, 4 Jul 2017 00:46:06 +0000

Hi,

I did not realize that time has passed for IETF upload. I think it was end of business day PST but it looks like UTC :-(.

I will upload once it opens.

Thanks
Rakesh

From: I2nsf <[email-masked]<mailto:[email-masked]>> on behalf of Rakesh Kumar <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 3, 2017 at 3:09 PM
To: "Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [I2nsf] I-D Action: draft-ietf-i2nsf-client-facing-interface-req-02.txt

HI Paul,

Thanks
Rakesh

Hi Rakesh,

Thanks.

Best Regards,
Paul

Thanks
Rakesh

---

From: Rakesh Kumar <[email-masked]>
Date: Tue, 4 Jul 2017 00:47:48 +0000

I am attaching the latest draft which I could not upload.

Thanks
Rakesh

From: I2nsf <[email-masked]<mailto:[email-masked]>> on behalf of Rakesh Kumar <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 3, 2017 at 5:46 PM
To: "Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [I2nsf] I-D Action: draft-ietf-i2nsf-client-facing-interface-req-02.txt

Hi,

Thanks
Rakesh

HI Paul,

Thanks
Rakesh

Hi Rakesh,

Thanks.

Best Regards,
Paul

Thanks
Rakesh

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 4 Jul 2017 11:43:26 +0900

Rakesh,
Could you send us the txt file because I cannot compile your xml file into
a txt file?

Thanks.

Paul

On Tue, Jul 4, 2017 at 9:47 AM, Rakesh Kumar <[email-masked]> wrote:

> From: I2nsf <[email-masked]> on behalf of Rakesh Kumar <
> [email-masked]>
> To: "Mr. Jaehoon Paul Jeong" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>
> I did not realize that time has passed for IETF upload. I think it was end
> of business day PST but it looks like UTC :-(.
>
> From: I2nsf <[email-masked]> on behalf of Rakesh Kumar <
> [email-masked]>
> To: "Mr. Jaehoon Paul Jeong" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>
> From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
> To: Rakesh Kumar <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>, "[email-masked]" <[email-masked]>

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>