Subject: [I2nsf] need some work to improve the consistency of I2NSF Information and data model: maybe a design team?

From: Linda Dunbar <[email-masked]>
Date: Fri, 14 Jul 2017 16:27:55 +0000

Thanks to many people contributions. We now have many drafts on the information model and data model for I2NSF:

Information model:
draft-xibassnez-i2nsf-capability-02
draft-zhang-i2nsf-info-model-monitoring-04
draft-hyun-i2nsf-registration-interface-im-02
draft-kumar-i2nsf-client-facing-interface-im-03
draft-xia-i2nsf-security-policy-object-01

Data Model:
draft-hares-i2nsf-capability-data-model-03
draft-jeong-i2nsf-consumer-facing-interface-dm-02
draft-kim-i2nsf-nsf-facing-interface-data-model-02
draft-hyun-i2nsf-registration-interface-dm-01

But the problem is that they are not all consistent.  Extra work is needed to improve the consistency for I2NSF information and data models for both Client/Consumer facing and NSF facing interfaces.
So we are going to form a design team to work on it.

If you are interested in participate, please click on this doodle poll: https://doodle.com/poll/4ryrcw3993fbf7ca

For people not in Prague, we can set up a Webex for you to call in.

Thank you very much for the contribution.

Linda & Adrian

---

From: John Strassner <[email-masked]>
Date: Sun, 16 Jul 2017 10:36:27 -0700

I cannot attend Prague due to family health issues.

That being said, I agree with Linda. I see three major problems:

   1) There should be one, and only one, information model.
        a) It is great to have multiple contributions, but those
contributions MUST be written to enhance the existing model, not propose a
new one
   2) In general, some of the info models are not really **models** per se,
but rather, requirements for models.
   3) In general, I cannot trace data model work back to the info model
work.
       a) This is especially true for drafts that are trying to use or
define policies

I propose that draft-xibassnez is used for our info model. This means that
the other info model drafts SHOULD be restructured to add to that draft.

I propose that we wait on further data model draft definition until some
people (I will help) on the design team can formulate guidelines and
perhaps examples to properly derive data models from our info model.

regards,
John

On Fri, Jul 14, 2017 at 9:27 AM, Linda Dunbar <[email-masked]>
wrote:

> Thanks to many people contributions. We now have many drafts on the
> information model and data model for I2NSF:
>
>
>
> Information model:
>
> But the problem is that they are not all consistent.  Extra work is needed
> to improve the consistency for I2NSF information and data models for both
> Client/Consumer facing and NSF facing interfaces.
>
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>
>

-- 
regards,
John

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sun, 16 Jul 2017 23:20:40 +0000

Hi,

I agree with John, and would propose that we keep a single draft for the info model (by adding to draft-xibassnez) and another one for the data model, that could refer to several YANG model descriptions, and make them available on the YANG catalog (https://yangcatalog.org)

If this sounds too heavy, I’d propose to define a core (information and data) model, focus on it, and let other models extend it in the future.

Be goode,

On 16 Jul 2017, at 19:36 , John Strassner <[email-masked]<mailto:[email-masked]>> wrote:

   1) There should be one, and only one, information model.
        a) It is great to have multiple contributions, but those contributions MUST be written to enhance the existing model, not propose a new one
   2) In general, some of the info models are not really **models** per se, but rather, requirements for models.
   3) In general, I cannot trace data model work back to the info model work.
       a) This is especially true for drafts that are trying to use or define policies

I propose that draft-xibassnez is used for our info model. This means that the other info model drafts SHOULD be restructured to add to that draft.

I propose that we wait on further data model draft definition until some people (I will help) on the design team can formulate guidelines and perhaps examples to properly derive data models from our info model.

regards,
John

On Fri, Jul 14, 2017 at 9:27 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Thanks to many people contributions. We now have many drafts on the information model and data model for I2NSF:

Information model:

Data Model:

Linda & Adrian

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
regards,
John
_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 17 Jul 2017 04:52:09 -0400

John: 

Let me propose something different.  There are 2 priorities: 

1)      Priority 1 – something that fits the market, and provides easy reading by users 

2)      Priority 2 – something that is architecturally clean

I understand you feel your base model is architecturally perfect.  Feedback from product groups are that your model are difficult to understand.   The models from the teams that have worked on the hackathon have been understood and worked on by the teams. 

We should work toward both. An attitude that says “my model’s perfect” does not align with the yang model’s readably .

Just my 2 cents. 

Sue Hares 

From: I2nsf [mailto:[email-masked]] On Behalf Of John Strassner
Sent: Sunday, July 16, 2017 1:36 PM
To: Linda Dunbar; John Strassner
Cc: [email-masked]
Subject: Re: [I2nsf] need some work to improve the consistency of I2NSF Information and data model: maybe a design team?

regards,

John

On Fri, Jul 14, 2017 at 9:27 AM, Linda Dunbar <[email-masked]> wrote:

Information model:

Data Model:

 

Linda & Adrian

-- 

regards,

John

---

From: John Strassner <[email-masked]>
Date: Mon, 17 Jul 2017 10:29:38 -0700

Wow.

I have NEVER said that "my" (and it is NOT just mine!) model is
architecturally perfect. I am offended by that statement. Am I the ONLY
author on this draft?

Rather than denigrate the efforts of the team that is building the model,
it would be much more helpful to provide specifics. For example, what
specifically is "too hard to understand"? How are we supposed to fix
something given only vague comments like this?

I also object to your statement "Feedback from product groups are that your
model are difficult to understand." I have worked with people inside and
**outside** of Huawei on understanding and implementing the model. None
have said that it is "too difficult to understand".

I have no idea what "something that fits the market, and provides easy
reading by users" actually means. Saying that the YANG is "readable" is a
matter of opinion. I note that, for example, there is no ability of the
current YANG models to provide reflection or introspection. That impacts
usability.

Providing insults and no alternative suggestions is not helpful.

On Mon, Jul 17, 2017 at 1:52 AM, Susan Hares <[email-masked]> wrote:

> I understand you feel your base model is architecturally perfect.
> Feedback from product groups are that your model are difficult to
> understand.   The models from the teams that have worked on the hackathon
> have been understood and worked on by the teams.
>
>
>
> We should work toward both. An attitude that says “my model’s perfect”
> does not align with the yang model’s readably .
>
>
>
> Just my 2 cents.
>
>
>
> Sue Hares
>
>
>
> *From:* I2nsf [mailto:[email-masked]] *On Behalf Of *John
> Strassner
> *Sent:* Sunday, July 16, 2017 1:36 PM
> *To:* Linda Dunbar; John Strassner
> *Cc:* [email-masked]
> *Subject:* Re: [I2nsf] need some work to improve the consistency of I2NSF
> Information and data model: maybe a design team?
>
>
>

-- 
regards,
John

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 17 Jul 2017 23:36:44 -0400

John: 

I’m sorry John if this statement seemed harsh.  It was not my intent.  I apologize to you and all the co-authors.  I’m not sleeping as much as I should due to the time-zone shift from the US to Europe.  My “Ok” in the next email was me trying to take my foot out of my mouth while sleepy.  Again – I’m sorry if I offend.  

The concept and structure of the capabilities modules is strong, but it is not obvious to the newcomer.   In a similar way, the structure of a routing protocol such as an SPF is strong, but not obvious.  Justifiably, these structures may be close to perfect to those who have worked to attain this work.  The thought of “being perfect in your eyes” – was simply to acknowledge you and your co-authors have reason to be proud of you structure. However, we are in a catch-22.   These yang models must be adopted by newcomers who will not implement something that is does not seem reasonably easy to work.  

My alternative solution was to suggest we could refactor the yang modules into basic + augments.  There is a continuum – most efficient architecture --- to most obvious.  I was wondering if we could agree on the first principles of trying to refactor for readability.  If we could try to move toward the middle of the continuum then perhaps we could can the adoption.  In a second suggestion – I want to suggest we have the following types of things:  nsf client information, capability, monitoring, nsf device information.  We could group modules into a set in the Yang catalog.   

These are higher-level principles to discuss before we start reworking pieces.   I need your help to consider if we can consider these alternative in order to increase adoption of these good principles. 

Sue Hares 

From: I2nsf [mailto:[email-masked]] On Behalf Of John Strassner
Sent: Monday, July 17, 2017 1:30 PM
To: Susan Hares; John Strassner
Cc: [email-masked]; Linda Dunbar
Subject: Re: [I2nsf] need some work to improve the consistency of I2NSF Information and data model: maybe a design team?

Wow.

I have NEVER said that "my" (and it is NOT just mine!) model is architecturally perfect. I am offended by that statement. Am I the ONLY author on this draft?

Rather than denigrate the efforts of the team that is building the model, it would be much more helpful to provide specifics. For example, what specifically is "too hard to understand"? How are we supposed to fix something given only vague comments like this?

I also object to your statement "Feedback from product groups are that your model are difficult to understand." I have worked with people inside and **outside** of Huawei on understanding and implementing the model. None have said that it is "too difficult to understand".

I have no idea what "something that fits the market, and provides easy reading by users" actually means. Saying that the YANG is "readable" is a matter of opinion. I note that, for example, there is no ability of the current YANG models to provide reflection or introspection. That impacts usability.

John: 

Just my 2 cents. 

Sue Hares 

regards,

John

Information model:

Data Model:

 

Linda & Adrian

-- 

regards,

John

-- 

regards,

John