Subject: [I2nsf] Framework Draft, section 6.2

From: John Strassner <[email-masked]>
Date: Sun, 2 Jul 2017 18:26:40 -0700

Section 6.2 says:

   o  When multiple instantiations of one single NSF appear as one
      single entity to the Security Controller, the policy provisioning
      has to be sent to the NSF Manager, which in turn disseminates the
      polices to the corresponding instantiations of the NSF, as shown
      in Figure 2 below.

<jcs>
I have no idea what an "NSF Manager" is. It is not defined in the
Terminology draft. The closest term in the terminology draft is
"I2NSF Management System".

However, for some reason, this reminds me of the VNFM in ETSI NFV.
If that is true, then I2NSF Management System is NOT the same thing.

I think that "NSF Manager" could be an EMS, as well as other types of
management engines. It is NOT the "I2NSF Management system".
However, I don't know what to call it, so I made the following
temporary hack:

   o  When multiple instantiations of one single NSF appear as one
      single entity to the Security Controller, the Security Controller
      may need to either get assistance from other entities in the
      I2NSF Management System, and/or delegate the provisioning of the
      multiple instantiations of the (single) NSF to other entities in
      the I2NSF Management System. This is shown in Figure 2 below.

-- 
regards,
John

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 5 Jul 2017 21:21:31 +0000

I fully agree with this, John. It is important we avoid mixing concepts in both domains.

Be goode,

On 3 Jul 2017, at 03:26 , John Strassner <[email-masked]<mailto:[email-masked]>> wrote:

Section 6.2 says:

<jcs>

--
regards,
John
_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener informaci?n privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilizaci?n, divulgaci?n y/o copia sin autorizaci?n puede estar prohibida en virtud de la legislaci?n vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma v?a y proceda a su destrucci?n.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinat?rio, pode conter informa??o privilegiada ou confidencial e ? para uso exclusivo da pessoa ou entidade de destino. Se n?o ? vossa senhoria o destinat?rio indicado, fica notificado de que a leitura, utiliza??o, divulga??o e/ou c?pia sem autoriza??o pode estar proibida em virtude da legisla??o vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destrui??o

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 5 Jul 2017 21:46:19 +0000

John,

Thanks for clarify the wording. It is much clearer and consistent with the terminology document.

One question to the following wording (I see it is already in the 06 version):

When multiple instantiations of one single NSF appear as one single entity to the "Security Controller", the policies from the "Security Controller" has to be passed to "another entity" that can disseminates the polices to the appropriate instantiation(s) of the NSF. Does the "I2NSF Management System" represent the "another entity"? or something different?

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Diego R. Lopez
Sent: Wednesday, July 05, 2017 4:22 PM
To: John Strassner <[email-masked]>
Cc: [email-masked]
Subject: Re: [I2nsf] Framework Draft, section 6.2

Be goode,

Section 6.2 says:

<jcs>

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 6 Jul 2017 03:34:01 +0000

Hi Linda,

I’d say the I2NSF Management System would host that or those entity(ies), abstracting it from the Controller, as they are out of scope for I2NSF…

Be goode,

On 5 Jul 2017, at 23:46 , Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:

John,

When multiple instantiations of one single NSF appear as one single entity to the “Security Controller”, the policies from the “Security Controller” has to be passed to “another entity” that can disseminates the polices to the appropriate instantiation(s) of the NSF. Does the “I2NSF Management System” represent the “another entity”? or something different?

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Diego R. Lopez
Sent: Wednesday, July 05, 2017 4:22 PM
To: John Strassner <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [I2nsf] Framework Draft, section 6.2

Be goode,

Section 6.2 says:

<jcs>

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

---

From: John Strassner <[email-masked]>
Date: Wed, 5 Jul 2017 21:27:30 -0700

Hi Linda,

IMHO, the I2NSF Management System subsumes the (security) Controller. Put
another way, the I2NSF Management System includes the (security)
Controller, but may also include other entities that have lower-level
visibility than the Controller. Such entities are, in my reading of our
charter, out of scope. However, they are needed to disambiguate different
instances of an NSF.

best,
John

On Wed, Jul 5, 2017 at 2:46 PM, Linda Dunbar <[email-masked]>
wrote:

> *o  When multiple instantiations of one single NSF appear as one
> single entity to the Security Controller, the Security Controller       may
> need to either get assistance from other entities in the       I2NSF
> Management System, and/or delegate the provisioning of the       multiple
> instantiations of the (single) NSF to other entities in       the I2NSF
> Management System. This is shown in Figure 2 below.*
>
>
>
>
>
> When multiple instantiations of one single NSF appear as one single entity
> to the “Security Controller”, the policies from the “Security Controller”
> has to be passed to “another entity” that can disseminates the polices to
> the appropriate instantiation(s) of the NSF. Does the “I2NSF Management
> System” represent the “another entity”? or something different?
>
>
>
> Linda
>
>
>
>
>
> *From:* I2nsf [mailto:[email-masked]] *On Behalf Of *Diego R.
> Lopez
> *Sent:* Wednesday, July 05, 2017 4:22 PM
> *To:* John Strassner <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [I2nsf] Framework Draft, section 6.2
>
>
>
> On 3 Jul 2017, at 03:26 , John Strassner <[email-masked]> wrote:
>
>
>
> Section 6.2 says:
>
>
>
> [email-masked]
> Tel:    +34 913 129 041 <+34%20913%2012%2090%2041>
> Mobile: +34 682 051 091 <+34%20682%2005%2010%2091>
> ------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
>

-- 
regards,
John

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 6 Jul 2017 15:00:47 +0000

John,

Thanks for the explanation. Can you add your explanation to the draft?

Linda

From: John Strassner [mailto:[email-masked]]
Sent: Wednesday, July 05, 2017 11:28 PM
To: Linda Dunbar <[email-masked]>; John Strassner <[email-masked]>
Cc: Diego R. Lopez <[email-masked]>; [email-masked]
Subject: Re: [I2nsf] Framework Draft, section 6.2

Hi Linda,

IMHO, the I2NSF Management System subsumes the (security) Controller. Put another way, the I2NSF Management System includes the (security) Controller, but may also include other entities that have lower-level visibility than the Controller. Such entities are, in my reading of our charter, out of scope. However, they are needed to disambiguate different instances of an NSF.

best,
John

On Wed, Jul 5, 2017 at 2:46 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
John,

Linda

From: I2nsf [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Diego R. Lopez

Be goode,

Section 6.2 says:

<jcs>

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:+34%20913%2012%2090%2041>
Mobile: +34 682 051 091<tel:+34%20682%2005%2010%2091>
----------------------------------

--
regards,
John