Subject: Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

From: [email-masked]
Date: Tue, 06 Feb 2018 11:47:34 -0500

Yes, I support this draft, and thank the authors for their effort!
Cheers!
Ed Lopez

On 1/26/2018 at 6:23 PM, "Linda Dunbar"  wrote:      
	The authors of I2NSF Consumer-Facing Interface YANG Data Model 

	https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

	Have requested working group adoption of this draft.   
	Please bear in mind that WG Adoption doesn’t mean that the draft
current content is ready, WG Adoption only means that it is a good
basis for a working group to work on. 
	While all feedback is helpful, comments pro or con with explanations
are much more helpful than just "yes please" or "no thank you". 
	Thank you.  
	Linda & Yoav

---

From: John Strassner <[email-masked]>
Date: Tue, 6 Feb 2018 15:46:47 -0800

IMHO, the purpose of a WG adopting a draft is to acknowledge that the draft
is a good starting point for the work that WG wants to accomplish. To be
perfectly clear, I am NOT objecting on the completeness of the document.
Rather, I am objecting on the technical correctness of the starting point.

I do NOT feel that the proposed documents represent a good starting point.
Ignoring things that can be easily fixed (e.g., grammar), there are a host
of problems, such as:
   - what, exactly, is this draft trying to do? I thought I would see YANG
for policy rules sent over the Consumer-Facing Interface.
     Instead, I see the name of the interface, whose first element is
multi-tenancy, that also contains policies? Policies do not care
     about multi-tenancy. They do care about domains. The organization of
the YANG is incorrect.
   - sec 4: in the ieft-i2nsf-cf-interface module
      - why is multi-tenancy at the top of the tree? Shouldn't a DOMAIN be
able to have multiple tenants?
      - why does a domain have an authentication-method? First, multiple
such methods should be able to be used. Second, how would a domain know
what an authentication method even is?
      - why is tenant a sibling of domain, and not a child?
      - why is domain a leaf within policy-tenant? This should be a
reference, and why doesn't domain have a reference to policy-tenant?
      - policy roles have nothing to do with multi-tenancy - why are they
here?

 I could go on, but even the above means that the rest of the YANG will be
wrong.

Therefore, the document is NOT a good starting point, and will NOT
accelerate the path to getting a good RFC.

regards,
John

On Fri, Jan 26, 2018 at 3:23 PM, Linda Dunbar <[email-masked]>
wrote:

> Please bear in mind that WG Adoption doesn’t mean that the draft current
> content is ready, WG Adoption only means that it is a good basis for a
> working group to work on.
>
>
>
> While all feedback is helpful, comments pro or con with explanations are
> much more helpful than just "yes please" or "no thank you".
>
>
>
> Thank you.
>
>
>
> Linda & Yoav
>
>
>
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>
>

-- 
regards,
John

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 7 Feb 2018 09:04:58 +0900

Hi John,
Thanks for your constructive suggestions on our draft. :-)
We authors will clarify your suggestions on the next revision.

You can give us your advice on our next revision.

Thanks.

Best Regards,
Paul

On Wed, Feb 7, 2018 at 8:46 AM, John Strassner <[email-masked]> wrote:

> IMHO, the purpose of a WG adopting a draft is to acknowledge that the
> draft is a good starting point for the work that WG wants to accomplish. To
> be perfectly clear, I am NOT objecting on the completeness of the document.
>       - why is multi-tenancy at the top of the tree? Shouldn't a DOMAIN
> be able to have multiple tenants?

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 8 Feb 2018 20:55:52 +0000

Questions to the Authors:

Is the “+--rw multi-tenancy” branch the attribute profile for “one tenant”? or list of multiple “tenants” with the attributes listed for one tenant?

Thank you very much.

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Mr. Jaehoon Paul Jeong
Sent: Tuesday, February 06, 2018 6:05 PM
To: John Strassner <[email-masked]>
Cc: Rakesh Kumar <[email-masked]>; [email-masked]; SecCurator_Team <[email-masked]>; Linda Dunbar <[email-masked]>; Xialiang (Frank) <[email-masked]>; Brian Kim <[email-masked]>; Susan Hares <[email-masked]>
Subject: Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

Hi John,

Thanks.

Best Regards,
Paul

On Wed, Feb 7, 2018 at 8:46 AM, John Strassner <[email-masked]<mailto:[email-masked]>> wrote:
IMHO, the purpose of a WG adopting a draft is to acknowledge that the draft is a good starting point for the work that WG wants to accomplish. To be perfectly clear, I am NOT objecting on the completeness of the document. Rather, I am objecting on the technical correctness of the starting point.

I do NOT feel that the proposed documents represent a good starting point. Ignoring things that can be easily fixed (e.g., grammar), there are a host of problems, such as:
   - what, exactly, is this draft trying to do? I thought I would see YANG for policy rules sent over the Consumer-Facing Interface.
     Instead, I see the name of the interface, whose first element is multi-tenancy, that also contains policies? Policies do not care
     about multi-tenancy. They do care about domains. The organization of the YANG is incorrect.
   - sec 4: in the ieft-i2nsf-cf-interface module
      - why is multi-tenancy at the top of the tree? Shouldn't a DOMAIN be able to have multiple tenants?
      - why does a domain have an authentication-method? First, multiple such methods should be able to be used. Second, how would a domain know what an authentication method even is?
      - why is tenant a sibling of domain, and not a child?
      - why is domain a leaf within policy-tenant? This should be a reference, and why doesn't domain have a reference to policy-tenant?
      - policy roles have nothing to do with multi-tenancy - why are they here?

 I could go on, but even the above means that the rest of the YANG will be wrong.

Therefore, the document is NOT a good starting point, and will NOT accelerate the path to getting a good RFC.

regards,
John

On Fri, Jan 26, 2018 at 3:23 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:

Please bear in mind that WG Adoption doesn’t mean that the draft current content is ready, WG Adoption only means that it is a good basis for a working group to work on.

While all feedback is helpful, comments pro or con with explanations are much more helpful than just "yes please" or "no thank you".

Thank you.

Linda & Yoav

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
regards,
John

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Seil Jeon" <[email-masked]>
Date: Mon, 12 Feb 2018 12:21:50 +0900

I think the draft is at a good start, based on a running code, so I support
this draft for WG draft adoption.

Regards,

Seil Jeon

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Saturday, January 27, 2018 8:24 AM
To: [email-masked]
Subject: [I2nsf] WG Adoption call for
https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-0
4

https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-0
4

Please bear in mind that WG Adoption doesn't mean that the draft current
content is ready, WG Adoption only means that it is a good basis for a
working group to work on.

Thank you. 

Linda & Yoav

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 12 Feb 2018 17:55:49 +0900

Hi Linda,
Here is my clarification on your question.

> Is the “+--rw multi-tenancy” branch the attribute profile for “one
> tenant”? or list of multiple “tenants” with the attributes listed for
> one tenant?

Yes, the "+--rw multi-tenancy” branch represents a list of multiple
"tenants".
In the list, a policy-domain represents a single domain distinguished by
policy-domain-id,
which is an organization (e.g., enterprise).
Note that each domain can have multiple tenants that are actual customers
in the domain,
such as departments (e.g., Human Resources, Finance, and Legal Department).

According to Section 4 (Information Model for Multi-Tenancy) of
draft-kumar-i2nsf-client-facing-interface-im-04,
which is the information model of the I2NSF Consumer-Facing Interface,
a tenant is an entity within an organization (e.g., enterprise and
university),
such as a customer or department (e.g., Human Resources, Finance, and Legal
Department).
It could have its own security policies within the organization.

For clarification in the data model tree,
I think that policy-tenant should be a child node of policy-domain as below.

       |  +--rw policy-domain* [policy-domain-id]
       |  |  +--rw policy-domain-id*        uint16
       |  |  +--rw name                     string
       |  |  +--rw address?                 string
       |  |  +--rw contact                  string
       |  |  +--rw date                     yang:date-and-time
       |  |  +--rw policy-tenant* [policy-tenant-id]
       |  |     +--rw policy-tenant-id*   uint16
       |  |     +--rw name                string
       |  |     +--rw date                yang:date-and-time
       |  |     +--rw domain              ->
/ietf-i2nsf-consumer-facing-interface/
       |  |
multi-tenancy/policy-domain/
       |  |                                            policy-domain-id

In the next revision, we will reflect this one.

If you have further questions, please let me know.

Thanks.

Best Regards,
Paul

On Fri, Feb 9, 2018 at 5:55 AM, Linda Dunbar <[email-masked]>
wrote:

> Is the “+--rw multi-tenancy” branch the attribute profile for “one
> tenant”? or list of multiple “tenants” with the attributes listed for one
> tenant?
>
>
>
> Thank you very much.
>
>
>
> Linda
>
>
>
>
>
> *From:* I2nsf [mailto:[email-masked]] *On Behalf Of *Mr. Jaehoon
> Paul Jeong
> *Sent:* Tuesday, February 06, 2018 6:05 PM
> *To:* John Strassner <[email-masked]>
> *Cc:* Rakesh Kumar <[email-masked]>; [email-masked];
> SecCurator_Team <[email-masked]>; Linda Dunbar <
> [email-masked]>; Xialiang (Frank) <[email-masked]>;
> Brian Kim <[email-masked]>; Susan Hares <[email-masked]>
> *Subject:* Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/dr
> aft-jeong-i2nsf-consumer-facing-interface-dm-04
>
>
>
> Hi John,
>

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 12 Feb 2018 16:59:18 +0000

Paul,

Thank you very much for the explanation.

So the “Policy Domain” in your document is about a “Family (or group) of Tenants”, correct?

Linda

From: Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
Sent: Monday, February 12, 2018 2:56 AM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]; John Strassner <[email-masked]>; Rakesh Kumar <[email-masked]>; Xialiang (Frank) <[email-masked]>; Brian Kim <[email-masked]>; Susan Hares <[email-masked]>; SecCurator_Team <[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]>
Subject: Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

Hi Linda,

> tenant”? or list of multiple “tenants” with the attributes listed for

Yes, the "+--rw multi-tenancy” branch represents a list of multiple "tenants".
In the list, a policy-domain represents a single domain distinguished by policy-domain-id,
which is an organization (e.g., enterprise).
Note that each domain can have multiple tenants that are actual customers in the domain,
such as departments (e.g., Human Resources, Finance, and Legal Department).

According to Section 4 (Information Model for Multi-Tenancy) of draft-kumar-i2nsf-client-facing-interface-im-04,
which is the information model of the I2NSF Consumer-Facing Interface,
a tenant is an entity within an organization (e.g., enterprise and university),
such as a customer or department (e.g., Human Resources, Finance, and Legal Department).
It could have its own security policies within the organization.

       |  +--rw policy-domain* [policy-domain-id]
       |  |  +--rw policy-domain-id*        uint16
       |  |  +--rw name                     string
       |  |  +--rw address?                 string
       |  |  +--rw contact                  string
       |  |  +--rw date                     yang:date-and-time
       |  |  +--rw policy-tenant* [policy-tenant-id]
       |  |     +--rw policy-tenant-id*   uint16
       |  |     +--rw name                string
       |  |     +--rw date                yang:date-and-time
       |  |     +--rw domain              -> /ietf-i2nsf-consumer-facing-interface/
       |  |                                            multi-tenancy/policy-domain/
       |  |                                            policy-domain-id

Thanks.

Best Regards,
Paul

On Fri, Feb 9, 2018 at 5:55 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Questions to the Authors:

Thank you very much.

Linda

From: I2nsf [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mr. Jaehoon Paul Jeong
Sent: Tuesday, February 06, 2018 6:05 PM
To: John Strassner <[email-masked]<mailto:[email-masked]>>
Cc: Rakesh Kumar <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; SecCurator_Team <[email-masked]<mailto:[email-masked]>>; Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Xialiang (Frank) <[email-masked]<mailto:[email-masked]>>; Brian Kim <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>
Subject: Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

Hi John,

Thanks.

Best Regards,
Paul

regards,
John

Thank you.

Linda & Yoav

--
regards,
John

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 13 Feb 2018 07:46:58 +0900

Linda,
Yes, you are right.
We will clarify this in the revision.

Thanks.

Best Regards,
Paul

2018. 2. 13. 오전 1:59에 "Linda Dunbar" <[email-masked]>님이 작성:

Paul,

So the “Policy Domain” in your document is about a “Family (or group) of
Tenants”, correct?

Linda

*From:* Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
*Sent:* Monday, February 12, 2018 2:56 AM
*To:* Linda Dunbar <[email-masked]>
*Cc:* [email-masked]; John Strassner <[email-masked]>; Rakesh Kumar <
[email-masked]>; Xialiang (Frank) <[email-masked]>;
Brian Kim <[email-masked]>; Susan Hares <[email-masked]>;
SecCurator_Team <[email-masked]>; Mr. Jaehoon Paul
Jeong <[email-masked]>

*Subject:* Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/
draft-jeong-i2nsf-consumer-facing-interface-dm-04

Hi Linda,

       |  |  +--rw name                     string

       |  |  +--rw contact                  string

       |  |     +--rw name                string

       |  |     +--rw domain              -> /ietf-i2nsf-consumer-facing-
interface/

       |  |

       |  |                                            policy-domain-id

Thanks.

Best Regards,

Paul

Is the “+--rw multi-tenancy” branch the attribute profile for “one tenant”?
or list of multiple “tenants” with the attributes listed for one tenant?

Thank you very much.

Linda

*From:* I2nsf [mailto:[email-masked]] *On Behalf Of *Mr. Jaehoon
Paul Jeong
*Sent:* Tuesday, February 06, 2018 6:05 PM
*To:* John Strassner <[email-masked]>
*Cc:* Rakesh Kumar <[email-masked]>; [email-masked];
SecCurator_Team <[email-masked]>; Linda Dunbar <
[email-masked]>; Xialiang (Frank) <[email-masked]>;
Brian Kim <[email-masked]>; Susan Hares <[email-masked]>
*Subject:* Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/
draft-jeong-i2nsf-consumer-facing-interface-dm-04

Hi John,

Thanks.

Best Regards,

Paul

regards,

John

https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-
facing-interface-dm-04

Thank you.

Linda & Yoav

-- 

regards,

John

-- 

--

---

From: Yoav Nir <[email-masked]>
Date: Thu, 15 Feb 2018 21:14:24 +0200

Thanks to all who participated.

We believe that there is rough consensus to adopt this document as a starting point for the group to work on.

Authors, please resubmit this document as a working group document with the name draft-ietf-i2nsf-consumer-facing-interface-dm-00.

Yoav
(on behalf of the WG chairs)

> On 27 Jan 2018, at 1:23, Linda Dunbar <[email-masked]> wrote:
> 
>  
>  
> https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04 <https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04>
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/i2nsf <https://www.ietf.org/mailman/listinfo/i2nsf>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 20 Feb 2018 10:41:51 +0900

Hi Yoav,
We authors will address the comments on the new WG document
on Consumer-Facing Interface Data Model and submit it before the I-D due.

Thanks.

Best Regards,
Paul

On Fri, Feb 16, 2018 at 4:14 AM, Yoav Nir <[email-masked]> wrote:

> Authors, please resubmit this document as a working group document with
> the name draft-ietf-i2nsf-consumer-facing-interface-dm-00.
>
> Yoav