Subject: [I2nsf] what does the term "Policy Domain" commonly refer to? (was RE: WG Adoption call for https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

From: Linda Dunbar <[email-masked]>
Date: Thu, 8 Feb 2018 22:59:06 +0000

John,

Since you are the policy expert, what does “Policy Domain” commonly refer to?
Can “Policy domain” be one policy applying to a set of tenants? Or one policy applying to a set of geographic regions? Or Policy domain being a set of policies?

Thank you.
Linda

From: John Strassner [mailto:[email-masked]]
Sent: Tuesday, February 06, 2018 5:47 PM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]
Subject: Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

IMHO, the purpose of a WG adopting a draft is to acknowledge that the draft is a good starting point for the work that WG wants to accomplish. To be perfectly clear, I am NOT objecting on the completeness of the document. Rather, I am objecting on the technical correctness of the starting point.

I do NOT feel that the proposed documents represent a good starting point. Ignoring things that can be easily fixed (e.g., grammar), there are a host of problems, such as:
   - what, exactly, is this draft trying to do? I thought I would see YANG for policy rules sent over the Consumer-Facing Interface.
     Instead, I see the name of the interface, whose first element is multi-tenancy, that also contains policies? Policies do not care
     about multi-tenancy. They do care about domains. The organization of the YANG is incorrect.
   - sec 4: in the ieft-i2nsf-cf-interface module
      - why is multi-tenancy at the top of the tree? Shouldn't a DOMAIN be able to have multiple tenants?
      - why does a domain have an authentication-method? First, multiple such methods should be able to be used. Second, how would a domain know what an authentication method even is?
      - why is tenant a sibling of domain, and not a child?
      - why is domain a leaf within policy-tenant? This should be a reference, and why doesn't domain have a reference to policy-tenant?
      - policy roles have nothing to do with multi-tenancy - why are they here?

 I could go on, but even the above means that the rest of the YANG will be wrong.

Therefore, the document is NOT a good starting point, and will NOT accelerate the path to getting a good RFC.

regards,
John

On Fri, Jan 26, 2018 at 3:23 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:

The authors of I2NSF Consumer-Facing Interface YANG Data Model
https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

Have requested working group adoption of this draft.

Please bear in mind that WG Adoption doesn’t mean that the draft current content is ready, WG Adoption only means that it is a good basis for a working group to work on.

While all feedback is helpful, comments pro or con with explanations are much more helpful than just "yes please" or "no thank you".

Thank you.

Linda & Yoav

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
regards,
John

---

From: John Strassner <[email-masked]>
Date: Thu, 8 Feb 2018 16:08:22 -0800

A "Policy Domain" is an administrative domain in which a set of Policies
are used to ensure that managed entities in that domain behave in a desired
manner. Policies can be used for configuration, monitoring, access control,
and other behavior.

Note that this is a standard term in the academic literature.

regards,
John

On Thu, Feb 8, 2018 at 2:59 PM, Linda Dunbar <[email-masked]>
wrote:

> Can “Policy domain” be one policy applying to a set of tenants? Or one
> policy applying to a set of geographic regions? Or Policy domain being a
> set of policies?
>
>
>
> Thank you.
>
> Linda
>
>
>
> *From:* John Strassner [mailto:[email-masked]]
> *Sent:* Tuesday, February 06, 2018 5:47 PM
> *To:* Linda Dunbar <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/
> draft-jeong-i2nsf-consumer-facing-interface-dm-04
>
>
>
> IMHO, the purpose of a WG adopting a draft is to acknowledge that the
> draft is a good starting point for the work that WG wants to accomplish. To
> be perfectly clear, I am NOT objecting on the completeness of the document.
> Rather, I am objecting on the technical correctness of the starting point.
>
>
> I do NOT feel that the proposed documents represent a good starting point.
> Ignoring things that can be easily fixed (e.g., grammar), there are a host
> of problems, such as:
>
>    - what, exactly, is this draft trying to do? I thought I would see YANG
> for policy rules sent over the Consumer-Facing Interface.
>      Instead, I see the name of the interface, whose first element is
> multi-tenancy, that also contains policies? Policies do not care
>       - why does a domain have an authentication-method? First, multiple
> such methods should be able to be used. Second, how would a domain know
> what an authentication method even is?
>
>       - why is domain a leaf within policy-tenant? This should be a
> reference, and why doesn't domain have a reference to policy-tenant?
>
> Therefore, the document is NOT a good starting point, and will NOT
> accelerate the path to getting a good RFC.
>
>
>
> regards,
>
> John
>
>
>
> On Fri, Jan 26, 2018 at 3:23 PM, Linda Dunbar <[email-masked]>
> wrote:
>
>
>
>
>
> Please bear in mind that WG Adoption doesn’t mean that the draft current
> content is ready, WG Adoption only means that it is a good basis for a
> working group to work on.
>
>
>
> While all feedback is helpful, comments pro or con with explanations are
> much more helpful than just "yes please" or "no thank you".
>
>
>
> Thank you.
>
>
>
> Linda & Yoav
>
>
>
>
> [email-masked]
> [email-masked]

-- 
regards,
John

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 12 Feb 2018 17:05:50 +0000

John,

Thank you very much for the interpretation of “Policy Domain”.

Based on the reply from Paul, the term “Policy Domain” in their draft is about a “Family (or a group) of Tenants”.
Is it a proper to use “Policy domain” as a term referring to the domain applying to a family or a group of tenants? Say a group of Departments (tenants) belonging under one organization?

If not, can you suggest a better term?

Thank you.

Linda

From: John Strassner [mailto:[email-masked]]
Sent: Thursday, February 08, 2018 6:08 PM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]
Subject: Re: [I2nsf] what does the term "Policy Domain" commonly refer to? (was RE: WG Adoption call for https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

A "Policy Domain" is an administrative domain in which a set of Policies are used to ensure that managed entities in that domain behave in a desired manner. Policies can be used for configuration, monitoring, access control, and other behavior.

regards,
John

On Thu, Feb 8, 2018 at 2:59 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
John,

Thank you.
Linda

From: John Strassner [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, February 06, 2018 5:47 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

regards,
John

Thank you.

Linda & Yoav

--
regards,
John

--
regards,
John

---

From: John Strassner <[email-masked]>
Date: Mon, 12 Feb 2018 15:22:24 -0800

It is hard to tell due to lack of specificity, but likely it is NOT a
correct use of the term.
The relationship is backwards - a tenant does NOT control policies. Rather,
an
admin domain (i.e., a policy domain) control policies, and tenants exist in
an
admin domain.

This is what I meant in my brief comment.

regards,
John

On Mon, Feb 12, 2018 at 9:05 AM, Linda Dunbar <[email-masked]>
wrote:

> Based on the reply from Paul, the term “Policy Domain” in their draft is
> about a “Family (or a group) of Tenants”.
>
> Is it a proper to use “Policy domain” as a term referring to the domain
> applying to a family or a group of tenants? Say a group of Departments
> (tenants) belonging under one organization?
>
>
>
> *Sent:* Thursday, February 08, 2018 6:08 PM
> *Subject:* Re: [I2nsf] what does the term "Policy Domain" commonly refer
> to? (was RE: WG Adoption call for https://tools.ietf.org/html/

-- 
regards,
John

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 13 Feb 2018 11:43:59 +0900

John,
Thanks for your clear explanation.
We authors will reflect your comments in our revision.

Best Regards,
Paul

On Tue, Feb 13, 2018 at 8:22 AM, John Strassner <[email-masked]> wrote:

> The relationship is backwards - a tenant does NOT control policies.
> Rather, an
> admin domain (i.e., a policy domain) control policies, and tenants exist
> in an
> admin domain.
>
>> to? (was RE: WG Adoption call for https://tools.ietf.org/html/dr
>> aft-jeong-i2nsf-consumer-facing-interface-dm-04
>>
>>
>>
>> *Subject:* Re: [I2nsf] WG Adoption call for
>> I do NOT feel that the proposed documents represent a good starting
>> point. Ignoring things that can be easily fixed (e.g., grammar), there are
>> a host of problems, such as:
>>
>>    - what, exactly, is this draft trying to do? I thought I would see
>> YANG for policy rules sent over the Consumer-Facing Interface.

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 13 Feb 2018 23:31:59 +0000

John,

Do you mean the term “Admin-Domain” can be used to represent a group of Tenants? For example: “Admin Domain” can be a company, and each Tenant can be a department within the company?  One “Admin Domain” has many “Tenants”?

Thank you.

Linda

From: John Strassner [mailto:[email-masked]]
Sent: Monday, February 12, 2018 5:22 PM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]
Subject: Re: [I2nsf] what does the term "Policy Domain" commonly refer to? (was RE: WG Adoption call for https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

It is hard to tell due to lack of specificity, but likely it is NOT a correct use of the term.
The relationship is backwards - a tenant does NOT control policies. Rather, an
admin domain (i.e., a policy domain) control policies, and tenants exist in an
admin domain.

regards,
John

On Mon, Feb 12, 2018 at 9:05 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
John,

Thank you.

Linda

regards,
John

Thank you.
Linda

regards,
John

Thank you.

Linda & Yoav

--
regards,
John

--
regards,
John

--
regards,
John

---

From: John Strassner <[email-masked]>
Date: Tue, 13 Feb 2018 16:03:26 -0800

Yes,

I am objecting to a tenant owning a policy. That is backwards. Policies are
owned by Administrative Domains.

Yes, an organization could be an Administrative Domain. More likely, an
Organization has multiple groups (OUs in the X.500/LDAP world, departments
in English) that are each Administrative Domains. In this situation,
policies are hierarchical (higher controls lower, lower cannot conflict
with higher). So each Administrative Domain applies its set of policies (if
any) to a tent (typically a person or OU).

regards,
John

On Tue, Feb 13, 2018 at 3:31 PM, Linda Dunbar <[email-masked]>
wrote:

> John,
>
>
>
> Do you mean the term “Admin-Domain” can be used to represent a group of
> Tenants? For example: “Admin Domain” can be a company, and each Tenant can
> be a department within the company?  One “Admin Domain” has many “Tenants”?
>
>
>
> Thank you.
>
>
>
> Linda
>
>
>
>
>
>
>
>
>
> *Sent:* Monday, February 12, 2018 5:22 PM

-- 
regards,
John

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 14 Feb 2018 00:37:43 +0000

John,

So “tenant” is an object that Administrator can apply a set of policies to, correct?

Linda

From: John Strassner [mailto:[email-masked]]
Sent: Tuesday, February 13, 2018 6:03 PM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]
Subject: Re: [I2nsf] what does the term "Policy Domain" commonly refer to? (was RE: WG Adoption call for https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

Yes,

I am objecting to a tenant owning a policy. That is backwards. Policies are owned by Administrative Domains.

Yes, an organization could be an Administrative Domain. More likely, an Organization has multiple groups (OUs in the X.500/LDAP world, departments in English) that are each Administrative Domains. In this situation, policies are hierarchical (higher controls lower, lower cannot conflict with higher). So each Administrative Domain applies its set of policies (if any) to a tent (typically a person or OU).

regards,
John

On Tue, Feb 13, 2018 at 3:31 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
John,

Thank you.

Linda

regards,
John

Thank you.

Linda

regards,
John

Thank you.
Linda

regards,
John

Thank you.

Linda & Yoav

--
regards,
John

--
regards,
John

--
regards,
John

--
regards,
John