Subject: Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-04

From: "Susan Hares" <[email-masked]>
Date: Tue, 6 Feb 2018 07:56:39 -0500

Linda and I2NSF WG:

I believe this drafts is ready for adoption.   I have followed this draft
since -00.txt.  This draft has sound implementation experience behind it.  

Cheerily, Susan Hares 

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Friday, January 26, 2018 6:22 PM
To: [email-masked]
Subject: [I2nsf] WG Adoption call for
https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-
04

The authors of I2NSF Network Security Functions-Facing Interface YANG Data
Model

<https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model
-04>
https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-
04

Have requested working group adoption of this draft.  

Please bear in mind that WG Adoption doesn't mean that the draft current
content is ready, WG Adoption only means that it is a good basis for a
working group to work on.

While all feedback is helpful, comments pro or con with explanations are
much more helpful than just "yes please" or "no thank you".

Thank you. 

Linda & Yoav

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Tue, 6 Feb 2018 21:59:29 +0900

Hi, all 

I support the adoption of this draft.

Cheers.
--
Jong-Hyouk Lee, living somewhere between /dev/null and /dev/random
Protocol Engineering Lab., Sangmyung University

#email: [email-masked]
#webpage: https://sites.google.com/site/hurryon

> 2018. 2. 6. 21:56, Susan Hares <[email-masked]> 작성:
> 
> Linda and I2NSF WG:
>  
> I believe this drafts is ready for adoption.   I have followed this draft since -00.txt.  This draft has sound implementation experience behind it.  
>  
> Cheerily, Susan Hares 
>  
> From: I2nsf [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Linda Dunbar
> To: [email-masked] <mailto:[email-masked]>
> Subject: [I2nsf] WG Adoption call for https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-04 <https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-04>
>  
>  
> The authors of I2NSF Network Security Functions-Facing Interface YANG Data Model
> https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-04 <https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-04>
>  
> Please bear in mind that WG Adoption doesn’t mean that the draft current content is ready, WG Adoption only means that it is a good basis for a working group to work on.
>  
> While all feedback is helpful, comments pro or con with explanations are much more helpful than just "yes please" or "no thank you".
>  
> Thank you. 
>  
> Linda & Yoav
>  
> _______________________________________________
> I2nsf mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/i2nsf <https://www.ietf.org/mailman/listinfo/i2nsf>

---

From: [email-masked]
Date: Tue, 06 Feb 2018 11:46:42 -0500

Yes, I support this draft, and thank the authors for their effort!
Cheers!Ed Lopez

On 1/26/2018 at 6:21 PM, "Linda Dunbar"  wrote:      
	The authors of I2NSF Network Security Functions-Facing Interface YANG
Data Model 

	https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-04

	Have requested working group adoption of this draft.   
	Please bear in mind that WG Adoption doesn’t mean that the draft
current content is ready, WG Adoption only means that it is a good
basis for a working group to work on. 
	While all feedback is helpful, comments pro or con with explanations
are much more helpful than just "yes please" or "no thank you". 
	Thank you.  
	Linda & Yoav

---

From: John Strassner <[email-masked]>
Date: Tue, 6 Feb 2018 15:31:58 -0800

IMHO, the purpose of a WG adopting a draft is to acknowledge that the draft
is a good starting point for the work that WG wants to accomplish. To be
perfectly clear, I am NOT objecting on the completeness of the document.
Rather, I am objecting on the technical correctness of the starting point.

I do NOT feel that the proposed documents represent a good starting point.
Ignoring things that can be easily fixed (e.g., grammar), there are a host
of problems, such as:

   - sec 4: it is unclear what is meant by "Objectives", see below
      - sec 4.1 does NOT define what an I2NSF SecurityPolicyRule is, or
what its objective is
      - secs 4.2 and 4.3 do provide definitions of events and conditions
(though their grammar needs improvement)
      - sec 4.4 provides a superficial definition of an action that needs
tightening up

The above are troublesome, as all definitions are clearly defined in the
terminology draft. For a long time now... :-( And I really don't understand
why this section is labeled "Objectives". Objectives of what? An event? of
the data model? something else?

   - sec 5.1:  I don't understand the design of the YANG module at all
     - the ietf-i2nsf-nsf-facing-interface module appears to describe a
policy rule, but is given the name of an interface. In addition, why
does generic-nsf
contain a policy (i2nsf-security-policy)? Put another way, the name of the
module is the name of an interface, but doesn't describe an interface, and
more importantly,
        NSFs do NOT contain policy rules - they are sent policy rules by
the policy engine
     - Worse, why are the event, condition, and action containers NOT
inside the policy rule?
   - Same problem for figures 5.2-5.4, plus other problems (e.g., why is
the resolution strategy NOT a part of the policy???)
   - the design of the condition clause is not scalable. In an OO design,
one does NOT simply list a hundred attributes in a class. We decided that
the YANG module would be designed in an OO style.
   - same problem for the action clause

Given the above, the rest of the YANG will be wrong.

Therefore, the document is NOT a good starting point, and will NOT
accelerate the path to getting a good RFC.

regards,
John

On Fri, Jan 26, 2018 at 3:21 PM, Linda Dunbar <[email-masked]>
wrote:

> Please bear in mind that WG Adoption doesn’t mean that the draft current
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>
>

-- 
regards,
John

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 7 Feb 2018 08:42:25 +0900

Hi John,
Thanks for your good suggestions on our draft. :-)
We authors will clarify your suggestions on the next revision except the OO
design for the YANG data model.
The OO design takes time, so we will try to address it later.

You can suggest the good OO design based on our next revision.

Thanks.

Best Regards,
Paul

On Wed, Feb 7, 2018 at 8:31 AM, John Strassner <[email-masked]> wrote:

> IMHO, the purpose of a WG adopting a draft is to acknowledge that the
> draft is a good starting point for the work that WG wants to accomplish. To
> be perfectly clear, I am NOT objecting on the completeness of the document.
> policy rule, but is given the name of an interface. In addition, why does generic-nsf
> contain a policy (i2nsf-security-policy)? Put another way, the name of
> the module is the name of an interface, but doesn't describe an interface,
> and more importantly,

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 8 Feb 2018 20:44:40 +0000

Authors of draft-kim-i2nsf-nsf-facing-interface-data-data-model:

Clarification questions:

-        Is Section 4 more on the “Structure of I2nsf Policy Rules”? instead of “Objectives”?

-        Is the “+--rw generic-nsf” branch more for the “property” of the policy (lack of better words)? More for describing the policy’s priority in relate to others and the resolution strategy if there is any conflict?

Thanks, Linda

From: Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
Sent: Tuesday, February 06, 2018 5:42 PM
To: John Strassner <[email-masked]>
Cc: [email-masked]; Linda Dunbar <[email-masked]>; Jingyong (Tim) Kim <[email-masked]>; Susan Hares <[email-masked]>; SecCurator_Team <[email-masked]>
Subject: Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-04

Hi John,
Thanks for your good suggestions on our draft. :-)
We authors will clarify your suggestions on the next revision except the OO design for the YANG data model.
The OO design takes time, so we will try to address it later.

Thanks.

Best Regards,
Paul

On Wed, Feb 7, 2018 at 8:31 AM, John Strassner <[email-masked]<mailto:[email-masked]>> wrote:
IMHO, the purpose of a WG adopting a draft is to acknowledge that the draft is a good starting point for the work that WG wants to accomplish. To be perfectly clear, I am NOT objecting on the completeness of the document. Rather, I am objecting on the technical correctness of the starting point.

I do NOT feel that the proposed documents represent a good starting point. Ignoring things that can be easily fixed (e.g., grammar), there are a host of problems, such as:

   - sec 4: it is unclear what is meant by "Objectives", see below
      - sec 4.1 does NOT define what an I2NSF SecurityPolicyRule is, or what its objective is
      - secs 4.2 and 4.3 do provide definitions of events and conditions (though their grammar needs improvement)
      - sec 4.4 provides a superficial definition of an action that needs tightening up

The above are troublesome, as all definitions are clearly defined in the terminology draft. For a long time now... :-( And I really don't understand why this section is labeled "Objectives". Objectives of what? An event? of the data model? something else?

   - sec 5.1:  I don't understand the design of the YANG module at all
     - the ietf-i2nsf-nsf-facing-interface module appears to describe a policy rule, but is given the name of an interface. In addition, why does generic-nsf contain a policy (i2nsf-security-policy)? Put another way, the name of the module is the name of an interface, but doesn't describe an interface, and more importantly,
        NSFs do NOT contain policy rules - they are sent policy rules by the policy engine
     - Worse, why are the event, condition, and action containers NOT inside the policy rule?
   - Same problem for figures 5.2-5.4, plus other problems (e.g., why is the resolution strategy NOT a part of the policy???)
   - the design of the condition clause is not scalable. In an OO design, one does NOT simply list a hundred attributes in a class. We decided that the YANG module would be designed in an OO style.
   - same problem for the action clause

Therefore, the document is NOT a good starting point, and will NOT accelerate the path to getting a good RFC.

regards,
John

On Fri, Jan 26, 2018 at 3:21 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:

Thank you.

Linda & Yoav

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
regards,
John

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 13 Feb 2018 00:36:55 +0900

Hi Linda,

> - Is Section 4 more on the “Structure of I2nsf Policy Rules”? instead of
“Objectives”?

=>  Yes, you are right.
Actually, this section is intended to show the structure of a security
policy
(having security rules for a given security policy)  and to explain the
objectives of its components.
In the next revision, we will replace "Objectives" with "The Structure and
Objective
of I2NSF Security Policy" for the title of Section 4.

> - Is the “+--rw generic-nsf” branch more for the “property” of the policy
(lack of better words)?
> More for describing the policy’s priority in relate to others and the
resolution strategy if there is any conflict?

=> A "generic-nsf" branch represents a list of security policies
whose security rules are specified as "eca-policy-rules" branches.
Among multiple security rules for a security policy, rule-priority is used
to determines the priorities of the rules, and a resolution strategy of
the security rules is used to resolve the conflicts of the rules in the
same security policy.

Since generic-nsf may be misleading, we will use
"i2nsf-security-policy" branch directly without using the "generic-nsf"
branch.
That is, we will remove the "generic-nsf" branch and will put
the i2nsf-security-policy on the place of the "generic-nsf" branch.

If you have further questions, plesse let me know.

Thanks.

Best Regards,
Paul

On Fri, Feb 9, 2018 at 5:44 AM, Linda Dunbar <[email-masked]>
wrote:

> -        Is the “+--rw generic-nsf” branch more for the “property” of the
> policy (lack of better words)? More for describing the policy’s priority in
> relate to others and the resolution strategy if there is any conflict?
>
>
>
>
>
> Thanks, Linda
>
>
>
> *From:* Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
> *Sent:* Tuesday, February 06, 2018 5:42 PM
> *To:* John Strassner <[email-masked]>
> *Cc:* [email-masked]; Linda Dunbar <[email-masked]>; Jingyong
> (Tim) Kim <[email-masked]>; Susan Hares <[email-masked]>;
> SecCurator_Team <[email-masked]>
> *Subject:* Re: [I2nsf] WG Adoption call for https://tools.ietf.org/html/
> draft-kim-i2nsf-nsf-facing-interface-data-model-04
>
>
>
> Hi John,
>

---

From: Hyoungshick Kim <[email-masked]>
Date: Tue, 13 Feb 2018 23:10:40 +0900

Hi Linda and all,

 I am Hyoungshick Kim from Sungkyunkwan University.

I would like to support the WG adoption of this draft, “I2NSF
Consumer-Facing Interface YANG Data Model”.
Many use cases will covered by this interface.

Best regards,

Hyoung

-- 
_______________________________
Hyoungshick (Hyoung) Kim,

Department of Software
College of Software
Office 27324, 2066 Seobu-Ro, Jangan-gu, Suwon, Gyeonggi-do 440-746, Korea
+82-31-299-4324 (mobile: +82-10-5557-3081)
[email-masked]
http://seclab.skku.edu/people/hyoungshick-kim/

---

From: Yoav Nir <[email-masked]>
Date: Thu, 15 Feb 2018 21:14:25 +0200

Thanks to all who participated.

We believe that there is rough consensus to adopt this document as a starting point for the group to work on.

Authors, please resubmit this document as a working group document with the name draft-ietf-i2nsf-nsf-facing-interface-dm-00.

Yoav
(on behalf of the WG chairs)

> On 27 Jan 2018, at 1:21, Linda Dunbar <[email-masked]> wrote:
> 
>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 20 Feb 2018 10:42:25 +0900

Hi Yoav,
We authors will address the comments on the new WG document
on NSF-Facing Interface Data Model and submit it before the I-D due.

Thanks.

Best Regards,
Paul

On Fri, Feb 16, 2018 at 4:14 AM, Yoav Nir <[email-masked]> wrote:

> Authors, please resubmit this document as a working group document with
> the name draft-ietf-i2nsf-nsf-facing-interface-dm-00.
>
> Yoav

---

From: Yoav Nir <[email-masked]>
Date: Tue, 20 Feb 2018 06:54:16 +0200

Thanks.

Yoav

(and this goes for the other thread too)

> On 20 Feb 2018, at 3:42, Mr. Jaehoon Paul Jeong <[email-masked]> wrote:
> 
> Hi Yoav,
> On Fri, Feb 16, 2018 at 4:14 AM, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
>> On 27 Jan 2018, at 1:21, Linda Dunbar <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
> Email: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php <http://cpslab.skku.edu/people-jaehoon-jeong.php>