Subject: [I2nsf] FW: New Version Notification for draft-xia-i2nsf-sec-object-dm-00.txt

From: "Linqiushi (Jessica, CSPL)" <[email-masked]>
Date: Mon, 2 Jul 2018 06:50:09 +0000

Dear all,

We just submitted a new draft on I2NSF policy object data model. Object based rule configuration provides reusability and is widely adopted in NSFs. This document defines several commonly used policy objects, e.g. address object, service object, etc.

Besides,  this data model draft is aligned with the previous information model draft. The policy objects are defined as groupings to be reused in different rules.

Your comments and suggestions are warmly welcome.

Best Regards,

Qiushi (Jessica) Lin

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2018年7月2日 14:46
收件人: Linqiushi (Jessica, CSPL) <[email-masked]>; Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]>; Linqiushi (Jessica, CSPL) <[email-masked]>; Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]>
主题: New Version Notification for draft-xia-i2nsf-sec-object-dm-00.txt

A new version of I-D, draft-xia-i2nsf-sec-object-dm-00.txt

has been successfully submitted by Qiushi Lin and posted to the IETF repository.

Name:             draft-xia-i2nsf-sec-object-dm

Revision:          00

Title:                I2NSF Security Policy Object YANG Data Model

Document date:          2018-07-01

Group:             Individual Submission

Pages:              41

URL:            https://www.ietf.org/internet-drafts/draft-xia-i2nsf-sec-object-dm-00.txt

Status:         https://datatracker.ietf.org/doc/draft-xia-i2nsf-sec-object-dm/

Htmlized:       https://tools.ietf.org/html/draft-xia-i2nsf-sec-object-dm-00

Htmlized:       https://datatracker.ietf.org/doc/html/draft-xia-i2nsf-sec-object-dm

Abstract:

   This document describes a set of policy objects which are reusable

   and can be referenced by variable I2NSF policy rules.  And the YANG

   data models of these policy objects are provided.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Linqiushi (Jessica, CSPL)" <[email-masked]>
Date: Wed, 11 Jul 2018 07:32:05 +0000

Hi all,

As we mentioned in draft-xia-i2nsf-sec-object-dm-00, attribute based policy rule configuration is repetitive when creating new policy rules and is hard to maintain consistency when making modification.
We propose to introduce the “object” concept in I2NSF policy rule to provide re-usability and simplicity, and define commonly used policy objects.
Taking address attribute as an example, address object and address group object are defined. The YANG tree structure of address object is as follows.
grouping addr-objects:
+--rw addr-object* [name]
    +--rw name      address-set-name
    +  ...
    +--rw elements*  [elem-id]
        +--rw elem-id uint16
        +--rw (object-items)
            +--: (ipv4)
            |  ...
            +--: (ipv6)
            |  ...
            +--: (mac)
            |  ...
            +--: (ipv4-range)
            |  ...
            +--: (ipv6-range)
            ...

For other policy objects, please review the draft: https://tools.ietf.org/html/draft-xia-i2nsf-sec-object-dm-00.

We want to solicit comments from I2NSF WG. Would the WG like to adopt “policy object” in I2NSF policy rule? Is an individual draft needed? Or just incorporating it into the existing drafts?

Thanks.

Best Regards,
Qiushi (Jessica) Lin

发件人: Linqiushi (Jessica, CSPL)
发送时间: 2018年7月2日 14:49
收件人: [email-masked]
抄送: Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]>
主题: FW: New Version Notification for draft-xia-i2nsf-sec-object-dm-00.txt

Dear all,

Best Regards,

Qiushi (Jessica) Lin

-----邮件原件-----
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2018年7月2日 14:46
收件人: Linqiushi (Jessica, CSPL) <[email-masked]<mailto:[email-masked]>>; Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]<mailto:[email-masked]>>; Linqiushi (Jessica, CSPL) <[email-masked]<mailto:[email-masked]>>; Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]<mailto:[email-masked]>>
主题: New Version Notification for draft-xia-i2nsf-sec-object-dm-00.txt

Revision:          00

Pages:              41

Abstract:

The IETF Secretariat

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 11 Jul 2018 21:44:33 +0000

Hi,

The proposal sounds in principle reasonable, as a useful artifact to simplify policy expressions. My only concern is whether this could cause some distortion in the capability model: I don’t see any, but I’d like to know the opinion of the other capability model perpetrators (well, Aldo’s and John’s. I guess Frank would be in. agreement…)

And I’d propose to include this in the capability data model document.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 11/07/2018, 09:32, "I2nsf on behalf of Linqiushi (Jessica, CSPL)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Thanks.

Best Regards,
Qiushi (Jessica) Lin

Dear all,

Best Regards,

Qiushi (Jessica) Lin

-----邮件原件-----
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2018年7月2日 14:46
收件人: Linqiushi (Jessica, CSPL) <[email-masked]<mailto:[email-masked]>>; Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]<mailto:[email-masked]>>; Linqiushi (Jessica, CSPL) <[email-masked]<mailto:[email-masked]>>; Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]<mailto:[email-masked]>>
主题: New Version Notification for draft-xia-i2nsf-sec-object-dm-00.txt

Revision:          00

Pages:              41

Abstract:

The IETF Secretariat

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Linqiushi (Jessica, CSPL)" <[email-masked]>
Date: Mon, 16 Jul 2018 13:33:56 +0000

Hi Diego,

Thanks for your support and considerations.
Currently we didn't find conflict with the capability model draft. We’ll contact the authors of the draft to get their opinions.

Best regards,
Qiushi (Jessica) Lin

发件人: Diego R. Lopez [mailto:[email-masked]]
发送时间: 2018年7月12日 5:45
收件人: Linqiushi (Jessica, CSPL) <[email-masked]>; [email-masked]
抄送: Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]>
主题: Re: [I2nsf] New Version Notification for draft-xia-i2nsf-sec-object-dm-00.txt

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi all,

Thanks.

Best Regards,
Qiushi (Jessica) Lin

发件人: Linqiushi (Jessica, CSPL)
发送时间: 2018年7月2日 14:49
收件人: [email-masked]<mailto:[email-masked]>
抄送: Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]<mailto:[email-masked]>>
主题: FW: New Version Notification for draft-xia-i2nsf-sec-object-dm-00.txt

Dear all,

Best Regards,

Qiushi (Jessica) Lin

-----邮件原件-----
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2018年7月2日 14:46
收件人: Linqiushi (Jessica, CSPL) <[email-masked]<mailto:[email-masked]>>; Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]<mailto:[email-masked]>>; Linqiushi (Jessica, CSPL) <[email-masked]<mailto:[email-masked]>>; Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]<mailto:[email-masked]>>
主题: New Version Notification for draft-xia-i2nsf-sec-object-dm-00.txt

Revision:          00

Pages:              41

Abstract:

The IETF Secretariat