Subject: Re: [I2nsf] Hi, I2NSF chairs. Request time slots for 2 data model drafts:

From: "Panwei (William)" <[email-masked]>
Date: Thu, 1 Nov 2018 09:17:29 +0000

Hi Linda,

The draft-ietf-i2nsf-nsf-facing-interface-dm defines a ECA-way I2NSF Policy Rule data model, and its focus is the architecture of the NSF-Facing Interface.
Our drafts focus on some concrete functions and attributes, they are the additional enhancement and supplement to the draft-ietf-i2nsf-nsf-facing-interface-dm. For example, the draft-dong-i2nsf-asf-config is trying to define the configuration data model of some common advance security functions which are just part of the ACTION in draft-ietf-i2nsf-nsf-facing-interface-dm.
In addition, the data model of our drafts can be not only used for NSF, but also can be used as customer-facing interface.

So from our points of view, the focus between our drafts and draft-ietf-i2nsf-nsf-facing-interface-dm is different. And separating them may be the effective way to keep their work without affecting each other. The other enhancement with different focus of the draft can also be separated. Besides, if we merge our drafts into draft-ietf-i2nsf-nsf-facing-interface-dm, the size of the draft may be too large.

Best Regards
Wei Pan

发件人: Linda Dunbar
发送时间: 2018年11月1日 5:47
收件人: Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]>; Yoav Nir <[email-masked]>
抄送: Linqiushi (Jessica, CSPL) <[email-masked]>; Panwei (William) <[email-masked]>; [email-masked]
主题: RE: Hi, I2NSF chairs. Request time slots for 2 data model drafts:

Frank,

Can you please explain why it is necessary to have additional two data model drafts? Instead of merging into draft-ietf-i2nsf-nsf-facing-interface-dm?
When you present to I2NSF WG session, can you please highlight how it is aligned with the draft-ietf-i2nsf-nsf-facing-interface-dm and the reasons for separating them.

Thank you.

Linda Dunbar

From: Xialiang (Frank, Network Integration Technology Research Dept)
Sent: Tuesday, October 23, 2018 9:24 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Yoav Nir <[email-masked]<mailto:[email-masked]>>
Cc: Linqiushi (Jessica, CSPL) <[email-masked]<mailto:[email-masked]>>; Panwei (William) <[email-masked]<mailto:[email-masked]>>
Subject: Hi, I2NSF chairs. Request time slots for 2 data model drafts:

Hi Linda and Yoav,
We have updated two individual drafts about the data model for I2NSF policy object and application layer security functions, which we’d like to request the time slots for presentation:
                   Draft                                              presenter                            time
draft-xia-i2nsf-sec-object-dm-01              Qiushi Lin                   15 minutes
draft-dong-i2nsf-asf-config-01                   Wei Pan                      15 minutes

Thanks a lot!

B.R.
Frank

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sat, 3 Nov 2018 15:20:08 +0000

Hi,

Does draft-ietf-i2nsf-nsf-facing-interface-dm describe how extensions or additions should be made? In the first case, separate documents could make sense. If not, I’d prefer to see the whole model specified in a single document.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 01/11/2018, 10:18, "I2nsf on behalf of Panwei (William)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi Linda,

The draft-ietf-i2nsf-nsf-facing-interface-dm defines a ECA-way I2NSF Policy Rule data model, and its focus is the architecture of the NSF-Facing Interface..
Our drafts focus on some concrete functions and attributes, they are the additional enhancement and supplement to the draft-ietf-i2nsf-nsf-facing-interface-dm. For example, the draft-dong-i2nsf-asf-config is trying to define the configuration data model of some common advance security functions which are just part of the ACTION in draft-ietf-i2nsf-nsf-facing-interface-dm.
In addition, the data model of our drafts can be not only used for NSF, but also can be used as customer-facing interface.

Best Regards
Wei Pan

发件人: Linda Dunbar
发送时间: 2018年11月1日 5:47

Frank,

Thank you.

Linda Dunbar

From: Xialiang (Frank, Network Integration Technology Research Dept)
Sent: Tuesday, October 23, 2018 9:24 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Yoav Nir <[email-masked]<mailto:ynir.ietf@gmail..com>>
Cc: Linqiushi (Jessica, CSPL) <[email-masked]<mailto:linqiushi@huawei..com>>; Panwei (William) <[email-masked]<mailto:[email-masked]>>
Subject: Hi, I2NSF chairs. Request time slots for 2 data model drafts:

Hi Linda and Yoav,

Thanks a lot!

B.R.
Frank

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Panwei (William)" <[email-masked]>
Date: Sun, 4 Nov 2018 04:02:16 +0000

Hi Diego,

Thanks for your opinion, it’s a good question, I think you have pointed out another improvement.
In the draft-ietf-i2nsf-nsf-facing-interface-dm, it says “The objects of event/condition/action clauses can be extended according to specific vendor event/condition/action features.”, but it doesn’t include how extensions should be made yet. I think the guidelines or principles of the extensions should be considered and be added to draft-ietf-i2nsf-nsf-facing-interface-dm. Making the rules of extensions can help the draft be suitable for the occurrence of new things and the changes to current things.
Above all are my personal opinions, discussions and corrections are very welcome.

Best Regards
Wei Pan

发件人: Diego R. Lopez [mailto:[email-masked]]
发送时间: 2018年11月3日 22:20
收件人: Panwei (William) <[email-masked]>; Linda Dunbar <[email-masked]>; Yoav Nir <[email-masked]>
抄送: Linqiushi (Jessica, CSPL) <[email-masked]>; [email-masked]; Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]>
主题: Re: [I2nsf] Hi, I2NSF chairs. Request time slots for 2 data model drafts:

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi Linda,

Best Regards
Wei Pan

发件人: Linda Dunbar
发送时间: 2018年11月1日 5:47
收件人: Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]<mailto:[email-masked]>>; Yoav Nir <[email-masked]<mailto:[email-masked]>>
抄送: Linqiushi (Jessica, CSPL) <[email-masked]<mailto:[email-masked]>>; Panwei (William) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
主题: RE: Hi, I2NSF chairs. Request time slots for 2 data model drafts:

Frank,

Thank you.

Linda Dunbar

Hi Linda and Yoav,

Thanks a lot!

B.R.
Frank