Subject: [I2nsf] Does it mean all "UDP" traffic are "BYPASS with the enum "UDP" is described as "BYPASS"

From: Linda Dunbar <[email-masked]>
Date: Wed, 5 Dec 2018 17:46:52 +0000

Gabriel and Rafa,

On Page 34 (Appendix A), you have the following typedef

typedef ipsec-next-layer-proto {
type enumeration {
enum TCP { description "PROTECT the traffic with IPsec"; }
enum UDP { description "BYPASS the traffic"; }
enum SCTP { description "PROTECT the traffic with IPsec";}
enum DCCP { description "PROTECT the traffic with IPsec";}
enum ICMP { description "PROTECT the traffic with IPsec";}
enum IPv6-ICMP { description "PROTECT the traffic with IPsec";}
enum MH {description "PROTECT the traffic with IPsec";}
enum GRE {description "PROTECT the traffic with IPsec";}
}
description "Next layer proto on top of IP";
}

With the following definition, does it mean all UDP traffic are "BYPASS"?
enum UDP { description "BYPASS the traffic"; }

Thanks, Linda

---

From: Rafa Marin-Lopez <[email-masked]>
Date: Wed, 5 Dec 2018 19:17:49 +0100

Hi Linda:

No, it does not. In fact, we should fix the description associated to each value.

Thank you.

Best Regards.

> El 5 dic 2018, a las 18:46, Linda Dunbar <[email-masked]> escribió:
> 
>  
> Gabriel and Rafa,
>  
> With the following definition, does it mean all UDP traffic are “BYPASS”?

-------------------------------------------------------
Rafa Marin-Lopez, PhD
Dept. Information and Communications Engineering (DIIC)
Faculty of Computer Science-University of Murcia
30100 Murcia - Spain
Telf: +34868888501 Fax: +34868884151 e-mail: [email-masked]
-------------------------------------------------------