Subject: [i2rs] Comment: draft-ietf-i2rs-yang-dc-fabric-network-topology-10

From: Rodney Cummings <[email-masked]>
Date: Tue, 10 Jul 2018 19:52:33 +0000

Hello,

This module does not provide sufficient description/reference text. For example:
- What is a "VLAN ID"?
- What is a "TRILL Nickname"?
- What is a "VxLAN Network Indentifier"?
- What is "QinQ"?
- What is a "Shared Risk Link Group"?
- Where does "Maximum frame size" begin and end for a given media?

If the author prefers to avoid a description, at least a reference should be provided so that the normative definition can be determined.

Rodney Cummings

> -----Original Message-----
> From: i2rs <[email-masked]> On Behalf Of [email-masked]
> Sent: Saturday, June 30, 2018 1:42 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [i2rs] I-D Action: draft-ietf-i2rs-yang-dc-fabric-network-
> topology-10.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Interface to the Routing System WG of the
> IETF.
> 
>         Title           : A YANG Data Model for Fabric Topology in Data
> Center Networks
>         Authors         : Yan Zhuang
>                           Danian Shi
>                           Rong Gu
>                           Hariharan Ananthakrishnan
> 	Filename        : draft-ietf-i2rs-yang-dc-fabric-network-topology-
> 10.txt
> 	Pages           : 31
> 	Date            : 2018-06-29
> 
> Abstract:
>    This document defines a YANG data model for fabric topology in Data
>    Center Networks and it represents only one possible view of the dc
>    fabric.
> 
> 
> The IETF datatracker status page for this draft is:
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Di2rs-2Dyang-2Ddc-2Dfabric-
> 2Dnetwork-
> 2Dtopology_&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=WA71s
> f2o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXrZxVqdjLasoOipHncAKuqGUfD2kq
> wLcFvl1LCQ&s=5KeG_ktaOS0i19WXvTOI7-RaxvPaqEBPLfbbgVmG2kU&e=
> 
> There are also htmlized versions available at:
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dietf-2Di2rs-2Dyang-2Ddc-2Dfabric-
> 2Dnetwork-2Dtopology-
> 2D10&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=WA71sf2o7Dw7
> CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXrZxVqdjLasoOipHncAKuqGUfD2kqwLcFvl1
> LCQ&s=CpJ_HIpLfLkm5-HURpFJKC1bqM1AWPtszuKAwdNIidU&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Di2rs-2Dyang-2Ddc-
> 2Dfabric-2Dnetwork-2Dtopology-
> 2D10&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=WA71sf2o7Dw7
> CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXrZxVqdjLasoOipHncAKuqGUfD2kqwLcFvl1
> LCQ&s=dyGSo6awEuTk8aQbdivXhqPLUxI0QsgNlIcY6B-As10&e=
> 
> A diff from the previous version is available at:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-
> 3Furl2-3Ddraft-2Dietf-2Di2rs-2Dyang-2Ddc-2Dfabric-2Dnetwork-2Dtopology-
> 2D10&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=WA71sf2o7Dw7
> CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXrZxVqdjLasoOipHncAKuqGUfD2kqwLcFvl1
> LCQ&s=GHNC2CIMrdSIJw2tGGNYLfLyYuGAi1ksMDTdACFFjYQ&e=
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-
> 2Ddrafts_&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=WA71sf2
> o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXrZxVqdjLasoOipHncAKuqGUfD2kqwL
> cFvl1LCQ&s=M8kA1HnOmBSXJrPQ6MqjSRoNjCQEeIQtFA60b5NAGOw&e=
> 
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_i2rs&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2
> uzI1jjZZuIPelcSjixA&r=WA71sf2o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXr
> ZxVqdjLasoOipHncAKuqGUfD2kqwLcFvl1LCQ&s=uyOF3fKCGnKH585erExEsj0Kn8DNGL50wS
> RfPDxfxrw&e=

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Thu, 12 Jul 2018 00:26:12 +0000

Hi Rodney,

Thank you for the comments. We will provide those description/reference texts in next version.

Best Regards,

Yan
________________________________________
发件人: i2rs [[email-masked]] 代表 Rodney Cummings [[email-masked]]
发送时间: 2018年7月11日 3:52
收件人: [email-masked]
主题: [i2rs] Comment: draft-ietf-i2rs-yang-dc-fabric-network-topology-10

Hello,

Rodney Cummings

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Rodney Cummings <[email-masked]>
Date: Thu, 12 Jul 2018 00:28:51 +0000

Hello all,

I just realized that I included the wrong I-D in my subject line. I intended this comment for:
	draft-ietf-i2rs-yang-l2-network-topology
and not
	draft-ietf-i2rs-yang-dc-fabric-network-topology

I apologize for the mistake.

Rodney Cummings

> From: i2rs <[email-masked]> On Behalf Of Rodney Cummings
> Sent: Tuesday, July 10, 2018 2:53 PM
> To: [email-masked]
> Subject: [i2rs] Comment: draft-ietf-i2rs-yang-dc-fabric-network-topology-
> 10
> 
> Hello,
> 
> If the author prefers to avoid a description, at least a reference should
> be provided so that the normative definition can be determined.
> 
> Rodney Cummings
> 
> 3A__www.ietf.org_rfcdiff-
> uzI1jjZZuIPelcSjixA&r=WA71sf2o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=uHJl9g
> 1JzmS5_Nx0vHkV-wleuIcfvpMqD2DuJABcsxc&s=ymkR-
> kmkPUDFH1N7wA7LidU6_aFCez7nB7W2mQHkIsw&e=

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 12 Jul 2018 14:41:23 +0000

Hi Rodney, 

Thanks for your comments. We will provide some reference/description in next revision.

Best regards,
Jie

> -----邮件原件-----
> 发件人: i2rs [mailto:[email-masked]] 代表 Rodney Cummings
> 发送时间: 2018年7月12日 8:29
> 收件人: [email-masked]
> 主题: Re: [i2rs] Comment: draft-ietf-i2rs-yang-dc-fabric-network-topology-10
> 
> Hello all,
> 
> > Subject: [i2rs] Comment:
> > draft-ietf-i2rs-yang-dc-fabric-network-topology-
> > 10
> >
> > Hello,
> >
> > This module does not provide sufficient description/reference text.
> > For
> > example:
> > - What is a "VLAN ID"?
> > If the author prefers to avoid a description, at least a reference
> > should be provided so that the normative definition can be determined.
> >
> > Rodney Cummings
> >
> > > This draft is a work item of the Interface to the Routing System WG
> > > of
> > the
> > > IETF.
> > >
> 2Dtopology_&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=
> W
> > A71s
> > >
> >
> f2o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXrZxVqdjLasoOipHncAK
> uqGUf
> > D2kq
> 2D10&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=WA71sf2
> o
> > 7Dw7
> > >
> >
> CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXrZxVqdjLasoOipHncAKuqGUfD
> 2kqwLc
> > Fvl1
> 2D10&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=WA71sf2
> o
> > 7Dw7
> > >
> >
> CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXrZxVqdjLasoOipHncAKuqGUfD
> 2kqwLc
> > Fvl1
> 2D10&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=WA71sf2
> o
> > 7Dw7
> > >
> >
> CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXrZxVqdjLasoOipHncAKuqGUfD
> 2kqwLc
> > Fvl1
> > > submission until the htmlized version and diff are available at
> > > tools.ietf.org.
> > >
> 2Ddrafts_&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=WA
> 7
> > 1sf2
> > >
> >
> o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=WwQYXrZxVqdjLasoOipHncAKu
> qGUfD2
> > kqwL
> 3A__www.ietf.org_mailman_listinfo_i2rs&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6
> Y
> > CiE2
> > >
> >
> uzI1jjZZuIPelcSjixA&r=WA71sf2o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=
> Ww
> > QYXr
> > >
> >
> ZxVqdjLasoOipHncAKuqGUfD2kqwLcFvl1LCQ&s=uyOF3fKCGnKH585erExEsj0Kn8D
> NGL
> > 50wS
> > > RfPDxfxrw&e=
> >
> 3A__www.ietf.org_mailman_listinfo_i2rs&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6
> Y
> > CiE2
> >
> uzI1jjZZuIPelcSjixA&r=WA71sf2o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=
> uH
> > Jl9g