Subject: Re: [Ibnemo] 答复: 答复: How to group/reuse definitions

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Fri, 13 Nov 2015 11:30:43 +0000

Comments inline

De: "zhangyali (D)" <[email-masked]<mailto:[email-masked]>>
Fecha: viernes, 13 de noviembre de 2015, 10:59
Para: paag <[email-masked]<mailto:[email-masked]>>, Zhoutianran <[email-masked]<mailto:[email-masked]>>, "Bert Wijnen (IETF)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: 答复: 答复: [Ibnemo] How to group/reuse definitions

[Yali] Our expressions of new DMZ are similar, except you omit parameter lists. And firewall and l2-group(L2Switch in your expression, I think) are predefined node types, so I omit them.

    A key point/difference is how to express the connection/connectivity between the two nodes. I think resource is a essential element to allow the communication between nodes no matter where it is, that is, if there is not "real" connection between nodes, they will not be connected.

Sorry, but I would distinguish a ‘logical patch panel’ implemented in an Open VirtualSwitch inside a server blade or even inside a data centre supporting SDN, NFV, etc. from a real link (i..e. my second example). Why? Because these connections have no specific characteristics, while a "connection over a cable” has characteristics like Bandwidth etc.

    And what if user wants to assign a bandwidth in this connection? So I am not sure if the "Connect" includes enough information.

The Connect is used when I have no specific requirements. In an example related more to ETSI/NFV, I could see the Connect as the logical connection between Virtual Network Function Components (VNFCs) inside a VNF.

My .02 cents, /PA

---
Dr. Pedro A. Aranda Gutiérrez

Technology Exploration -
Network Innovation & Virtualisation
email: pedroa d0t aranda At telefonica d0t com
Telefónica, Investigación y Desarrollo
C/ Zurbarán,12
28010 Madrid, Spain

Fragen sind nicht da, um beantwortet zu werden.
Fragen sind da, um gestellt zu werden.
Georg Kreisler

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "zhangyali (D)" <[email-masked]>
Date: Mon, 16 Nov 2015 10:11:28 +0000

Thanks Pedro. I think our understanding for “connection” and “connect/connectivity” is different. This topic has been discussed in our team many times. It’s really helpful for us to listen your views.

First of all, I want to clarify the meaning of connection. It refers to a kind of resources to allow the communication.  It’s not a physical link, but a abstraction of objects depended on communication. For example, a tunnel can be seen as a connection. For each of connection, user could assign bandwidth on it or not.

In your expression, “connect” refers to “connectivity” which specifies the communication rules or logic connection rather than resources depended on. (Please point it out if my understanding is wrong.)

In fact, we have considered if we need a new keyword to express connectivity, but there are some questions we need further consideration.

1.       If connection does not have bandwidth parameter, do the connection and connectivity have the same meaning?

2.       If the keyword of connectivity exists, when use the connectivity and when use connection?

3.       If user have to express connection before expressing connectivity? If not, do users know there are resources supporting for the connectivity?

Looking forward to your opinions.

Yali
发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
发送时间: 2015年11月13日 19:31
收件人: zhangyali (D); Zhoutianran; Bert Wijnen (IETF); [email-masked]
主题: Re: 答复: 答复: [Ibnemo] How to group/reuse definitions

Comments inline

My .02 cents, /PA

---

Technology Exploration -

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Wed, 18 Nov 2015 11:23:31 +0200

For me to better understand and form an opinion on the discussion,
I would appreciate a few clear definitions for:

connection
   Is it that there is a physical or logical connection between 2 nodes?
   Is it only one of these, or can it be bother
connectivity
   Is it direct connectivity or possibly via some other nodes/subnetwork
   Or a logical connectivity?

I have hear people say that "connection" means that connectivity is allowed.
Not necessarily that there is a phyisical or logical connection between 2 nodes/subnets
So if we have
    node n1
    node n2
    node n3

and we have
    connect n1 to n2
    connect n2 to n3

then in my understanding n1 is physically/logically connected to n2
and n2 is physically/logically connected to n3

but in my view,n1 would be able to communicate with n3
But I have also heard that in order to do that, one would have to
    connect n1 to n3
And that would not necessarily mean that a physical/logical connection
between n1 and n3 would be created, but just that it would allow n1
to communicate with n3 (routed via n2 of course).

I think it would be good to write down the exact definitions
of what thinks like "Connection", "connect", "connectivity", etc mean

I think that can help teh discussion (at least for me, and possibly for
some other who are not involved in implementations).

Thanks,
Bert

On 16/11/15 12:11, zhangyali (D) wrote:
>
> Thanks Pedro. I think our understanding for “connection” and “connect/connectivity” is different. This topic has been discussed in 
> our team many times. It’s really helpful for us to listen your views.
>
> First of all, I want to clarify the meaning of connection. It refers to a kind of resources to allow the communication.  It’s not 
> a physical link, but a abstraction of objects depended on communication. For example, a tunnel can be seen as a connection. For 
> each of connection, user could assign bandwidth on it or not.
>
> In your expression, “connect” refers to “connectivity” which specifies the communication rules or logic connection rather than 
> resources depended on. (Please point it out if my understanding is wrong.)
>
> 1.If connection does not have bandwidth parameter, do the connection and connectivity have the same meaning?
>
> 2.If the keyword of connectivity exists, when use the connectivity and when use connection?
>
> 3.If user have to express connection before expressing connectivity? If not, do users know there are resources supporting for the 
> connectivity?
>
> *发件人:*PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
> *发送时间:*2015年11月13日19:31
> *收件人:*zhangyali (D); Zhoutianran; Bert Wijnen (IETF); [email-masked]
> *主题:*Re: 答复: 答复: [Ibnemo] How to group/reuse definitions
>
> Comments inline
>
> *De: *"zhangyali (D)" <[email-masked] <mailto:[email-masked]>>
> *Fecha: *viernes, 13 de noviembre de 2015, 10:59
> *Para: *paag <[email-masked] <mailto:[email-masked]>>, Zhoutianran <[email-masked] 
> <mailto:[email-masked]>>, "Bert Wijnen (IETF)" <[email-masked] <mailto:[email-masked]>>, "[email-masked] 
> <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> *Asunto: *答复: 答复: [Ibnemo] How to group/reuse definitions
>
>     _[Yali] Our expressions of new DMZ are similar, except you omit parameter lists. And firewall and l2-group(L2Switch in your
>     expression, I think) are predefined node types, so I omit them._
>
>     _    A key point/difference is how to express the connection/connectivity between the two nodes. I think resource is a
>     essential element to allow the communication between nodes no matter where it is, that is, if there is not "real" connection
>     between nodes, they will not be connected._
>
> Sorry, but I would distinguish a ‘logical patch panel’implemented in an Open VirtualSwitch inside a server blade or even inside a 
> data centre supporting SDN, NFV, etc. from a real link (i..e. my second example). Why? Because these connections have no specific 
> characteristics, while a "connection over a cable”has characteristics like Bandwidth etc.
>
>     _    And what if user wants to assign a bandwidth in this connection? So I am not sure if the "Connect" includes enough
>     information._
>
> The Connect is used when I have no specific requirements. In an example related more to ETSI/NFV, I could see the Connect as the 
> logical connection between Virtual Network Function Components (VNFCs) inside a VNF.
>
> My .02 cents, /PA
>
> ---
>
> ------------------------------------------------------------------------------------------------------------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y 
> es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la 
> lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha 
> recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.
>
> The information contained in this transmission is privileged and confidential information intended only for the use of the 
> individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any 
> dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in 
> error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e 
> épara uso exclusivo da pessoa ou entidade de destino. Se não évossa senhoria o destinatário indicado, fica notificado de que a 
> leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta 
> mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
>

---

From: Xiayinben <[email-masked]>
Date: Thu, 19 Nov 2015 02:01:14 +0000

Hi Bert,

Thanks for initiating this topic, it is really interesting and important.
I think the key point of this topic is about the meaning of two word's and usage method:
"connection" and "connectivity"

In my understanding
"connection" stands for connected resource(physical or virtual), it is a real object. "connectivity" stands for reachability, it is a kind of status or policy. 
"connection" can implicitly expresses the existing of two points "connectivity". When user doesn't point out bandwidth of connection clearly, user uses connection as connectivity.

In your example,
	Node n1,n2,n3
	Connection n1,n2
	Connection n2,n3
Is there a "connectivity" between n1 and n3?
I think it depends on whether n2 can do transfer traffic for the other nodes, which is node's transfer property.
So the "connectivity" is decided by "connection" and middle node's transfer property.
But it also raises a problem that the "connectivity" is not intuitive.

Therefore, we also discussed should we separate "connection" and "connectivity" as two keyword in NEMO language.
But this letting the intent description becomes long-winded.
For example, a enterprise have tens branches, which need connect to headquarter and communication with each other.
If we express connectivity by connection and node's transfer property, user only need to describe tens connections between headquarter and branches.
If we separate connection and connectivity, user also need to describe hundreds full mesh connectivity between branches.

So far, we don't separate the connection and connectivity. 
Look forwarding to your opinions.

Best regards,
Yinben 

-----邮件原件-----
发件人: Ibnemo [mailto:[email-masked]] 代表 Bert Wijnen (IETF)
发送时间: 2015年11月18日 17:24
收件人: zhangyali (D); PEDRO ANDRES ARANDA GUTIERREZ; Zhoutianran; [email-masked]
主题: Re: [Ibnemo] 答复: 答复: 答复: How to group/reuse definitions

For me to better understand and form an opinion on the discussion, I would appreciate a few clear definitions for:

connection
   Is it that there is a physical or logical connection between 2 nodes?
   Is it only one of these, or can it be bother connectivity
   Is it direct connectivity or possibly via some other nodes/subnetwork
   Or a logical connectivity?

I have hear people say that "connection" means that connectivity is allowed.
Not necessarily that there is a phyisical or logical connection between 2 nodes/subnets So if we have
    node n1
    node n2
    node n3

and we have
    connect n1 to n2
    connect n2 to n3

then in my understanding n1 is physically/logically connected to n2 and n2 is physically/logically connected to n3

but in my view,n1 would be able to communicate with n3 But I have also heard that in order to do that, one would have to
    connect n1 to n3
And that would not necessarily mean that a physical/logical connection between n1 and n3 would be created, but just that it would allow n1 to communicate with n3 (routed via n2 of course).

I think it would be good to write down the exact definitions of what thinks like "Connection", "connect", "connectivity", etc mean

I think that can help teh discussion (at least for me, and possibly for some other who are not involved in implementations).

Thanks,
Bert

On 16/11/15 12:11, zhangyali (D) wrote:
>
> Thanks Pedro. I think our understanding for “connection” and 
> “connect/connectivity” is different. This topic has been discussed in our team many times. It’s really helpful for us to listen your views.
>
> First of all, I want to clarify the meaning of connection. It refers 
> to a kind of resources to allow the communication.  It’s not a 
> physical link, but a abstraction of objects depended on communication. For example, a tunnel can be seen as a connection. For each of connection, user could assign bandwidth on it or not.
>
> In your expression, “connect” refers to “connectivity” which specifies 
> the communication rules or logic connection rather than resources 
> depended on. (Please point it out if my understanding is wrong.)
>
> In fact, we have considered if we need a new keyword to express 
> connectivity, but there are some questions we need further consideration.
>
> 3.If user have to express connection before expressing connectivity? 
> If not, do users know there are resources supporting for the connectivity?
>
> *Para: *paag <[email-masked] 
> <mailto:[email-masked]>>, Zhoutianran 
> <[email-masked] <mailto:[email-masked]>>, "Bert Wijnen 
> (IETF)" <[email-masked] <mailto:[email-masked]>>, 
> "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
> Sorry, but I would distinguish a ‘logical patch panel’implemented in 
> an Open VirtualSwitch inside a server blade or even inside a data 
> centre supporting SDN, NFV, etc. from a real link (i..e. my second example). Why? Because these connections have no specific characteristics, while a "connection over a cable”has characteristics like Bandwidth etc.
>
> The Connect is used when I have no specific requirements. In an 
> example related more to ETSI/NFV, I could see the Connect as the logical connection between Virtual Network Function Components (VNFCs) inside a VNF.
>
> My .02 cents, /PA
>
> ---
>
> ----------------------------------------------------------------------
> --------------------------------------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su 
> destinatario, puede contener información privilegiada o confidencial y 
> es para uso exclusivo de la persona o entidad de destino. Si no es 
> usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.
>
> The information contained in this transmission is privileged and 
> confidential information intended only for the use of the individual 
> or entity named above. If the reader of this message is not the 
> intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu 
> destinatário, pode conter informação privilegiada ou confidencial e 
> épara uso exclusivo da pessoa ou entidade de destino. Se não évossa 
> senhoria o destinatário indicado, fica notificado de que a leitura, 
> utilização, divulgação e/ou cópia sem autorização pode estar proibida 
> em virtude da legislação vigente. Se recebeu esta mensagem por erro, 
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e 
> proceda a sua destruição
>

_______________________________________________
Ibnemo mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ibnemo

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Thu, 19 Nov 2015 10:30:32 +0200

Thanks and inline

> But it also raises a problem that the "connectivity" is not intuitive.
My view is that if we have two concepts (connection and connectivity), that it would be best
to use 2 commands/keywords for that and not just one. It indeed means that we have one extra
command in the language, but it does make things clearer and (in my view) easier to express
correctly.
> If we separate connection and connectivity, user also need to describe hundreds full mesh connectivity between branches.
In normal internet setups, I would think that if n1 is IP connected to n2 and n2 is IP conencted
to n3, then they all 3 have connectivity. So In my view, there would be no need to state that
n1 and n3 have connectivity. That is (in my view) inherent to IP networks. So I would say
that the default is that there is connectivity, and if you want to dis-allow connectivity for
some nodes, then I would suggest that we must users to specify that. I would think it is rare
that that is needed. But I am used to OPEN systems, so maybe I am biased.

> Look forwarding to your opinions.
I would certainly sepate it, because in my understanding they are quite
different concepts. Using just one command to express both most probably
causes confusion as to what exactly the user intended.

Bert

---

From: Xiayinben <[email-masked]>
Date: Thu, 19 Nov 2015 09:00:55 +0000

I agree with you. To separate the two key words to express these two concepts is more accurate and clear.
But you also mentioned, in normal internet setups, IP connectivity is default when there is a path can reach.
So when user describes network connection(resource), they don't need describe connectivity again.

If we provide two key words for connection and connectivity, we need provide a clear guide to let user know when need describe connectivity and when don't need it.

Best regards,
Yinben 

-----邮件原件-----
发件人: Bert Wijnen (IETF) [mailto:[email-masked]] 
发送时间: 2015年11月19日 16:31
收件人: Xiayinben; zhangyali (D); PEDRO ANDRES ARANDA GUTIERREZ; Zhoutianran; [email-masked]
主题: Re: 答复: [Ibnemo] 答复: 答复: 答复: How to group/reuse definitions

Thanks and inline

> But it also raises a problem that the "connectivity" is not intuitive.
My view is that if we have two concepts (connection and connectivity), that it would be best to use 2 commands/keywords for that and not just one. It indeed means that we have one extra command in the language, but it does make things clearer and (in my view) easier to express correctly.
> If we separate connection and connectivity, user also need to describe hundreds full mesh connectivity between branches.
In normal internet setups, I would think that if n1 is IP connected to n2 and n2 is IP conencted to n3, then they all 3 have connectivity. So In my view, there would be no need to state that
n1 and n3 have connectivity. That is (in my view) inherent to IP networks. So I would say that the default is that there is connectivity, and if you want to dis-allow connectivity for some nodes, then I would suggest that we must users to specify that. I would think it is rare that that is needed. But I am used to OPEN systems, so maybe I am biased.

> Look forwarding to your opinions.
I would certainly sepate it, because in my understanding they are quite different concepts. Using just one command to express both most probably causes confusion as to what exactly the user intended.

Bert
> I think it would be good to write down the exact definitions of what 
> thinks like "Connection", "connect", "connectivity", etc mean
>
>> In your expression, “connect” refers to “connectivity” which 
>> specifies the communication rules or logic connection rather than 
>> <[email-masked] <mailto:[email-masked]>>, "Bert 
>> Wijnen (IETF)" <[email-masked] <mailto:[email-masked]>>, 
>> destinatario, puede contener información privilegiada o confidencial 
>> y es para uso exclusivo de la persona o entidad de destino. Si no es