Subject: Re: [Ibnemo] Configured service models

From: Benoit Claise <[email-masked]>
Date: Sun, 1 Nov 2015 21:21:10 +0900

Dear all,

IIRC, I said that there are two aspects that make such work proposal at 
risk at the IETF.
1. we go up in the layers (within the API world) with this work, outside 
of the comfort zone of the IETF.
2. the industry will not wait for 2 years to have standardized 
primitives, specifically for a domain specific set of primitives.
This is why I mentioned that opensource is IMO is the best way for such 
a project. There are already several  projects: NIC, Group Based Policy, 
NEMO, Congress. The market will tell us which one will impose itself in 
the end. And, if a RFC is needed then, ISE is there. Ex: ovsdb (RFC 7047).

Regards, Benoit
> During our bar-bof at IETF93, Benoit asked/stated:
>
> Configured service models are outside the scope of the IETF.
>
> We're not sure what Benoit meant here.
> Benoit, can you elaborate?
>
> If others have views/opinions, pleas make them know to this list.
>
> Bert
>
> _______________________________________________
> Ibnemo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ibnemo
> .
>

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Sun, 1 Nov 2015 22:09:04 +0900

Thanks Benoit. I know understand what you mean.

Yet, I have heard various people (operators) tell us that they want/need to be able to do this as well.
So I expect that implementation work will happen in ODL and at IETF Hackatons. So we'll see how
well that goes, and if it does go well and we hear from operators that they want that capability
standardized in an Intent Expresssion Language, I guess we can then talk again. I basically see
the Open Source work and the work at the Hackatons as implementation work to test and
figure out what we can and need to standardize on.

Bert

On 01/11/15 21:21, Benoit Claise wrote:
> Dear all,
>
> IIRC, I said that there are two aspects that make such work proposal at risk at the IETF.
> 1. we go up in the layers (within the API world) with this work, outside of the comfort zone of the IETF.
> 2. the industry will not wait for 2 years to have standardized primitives, specifically for a domain specific set of primitives.
> This is why I mentioned that opensource is IMO is the best way for such a project. There are already several  projects: NIC, Group 
> Based Policy, NEMO, Congress. The market will tell us which one will impose itself in the end. And, if a RFC is needed then, ISE 
> is there. Ex: ovsdb (RFC 7047).
>
> Regards, Benoit