Subject: [iccrg] Comments on LISA

From: Pasi Sarolahti <[email-masked]>
Date: Sat, 3 Dec 2016 12:37:29 +0200

Hi,

I sent the following comments about LISA to Michael some time ago, and he asked me to pass them also to the list for discussion, so here they are.

---

Wouldn’t it be better to follow similar rationale in sharing the bandwidth between subflows both in slow-start and steady state? And therefore document the congestion control algorithms for both states in a single document?

Perhaps a bit related to single rationale, wouldn’t it be possible to specify something roughly similiar as a single formula, possibly based on some parameters for adaptation, without the if…else…else branching, without relying on particular threshold values that are based on the current specifications (of which IW10 is Experimental)? At least I would use variables (such as alpha/beta in RTO algorithm) to represent the threshold values, in case they need to be adjusted over time.

In definitions:
"old_subflow.CWND --  Congestion Window of the subflow having largest sending rate"

instead of “sending rate” I think it would be clearer to use TCP’s variables or terminology. Perhaps this is subflow with largest congestion window? Or with most unacknowledged packets in pipe?

Also definition of “Inflight” is a little unclear. Is it number of unacknowledged packets in pipe for a particular subflow?

- Pasi

---

From: Michael Welzl <[email-masked]>
Date: Tue, 6 Dec 2016 19:24:08 +0100

Hi Pasi!

Thanks a lot for your comments!

> On Dec 3, 2016, at 11:37 AM, Pasi Sarolahti <[email-masked]> wrote:
> 
> Hi,
> 

I agree it would make sense - I’d be happy to see LISA integrated in an update of the MPTCP congestion control RFC.
However, I think it may be procedurally hard right now, in particular as congestion control isn’t currently on the MPTCP charter.

> Perhaps a bit related to single rationale, wouldn’t it be possible to specify something roughly similiar as a single formula, possibly based on some parameters for adaptation, without the if…else…e…

Makes sense to me; we’ll think it through (replacing the “if…else… else..” branching with a formula).
As for replacing the constants with variables - absolutely, that's a very good suggestion too.

> instead of “sending rate” I think it would be clearer to use TCP’s variables or terminology. Perhaps this is subflow with largest congestion window? Or with most unacknowledged packets in pipe?

Agreed, will fix.

> Also definition of “Inflight” is a little unclear. Is it number of unacknowledged packets in pipe for a particular subflow?

From the top of my head I’ll say yes, that’s what it is. Will fix that definition too.

Thanks so much, all o these comments are very useful!

Cheers,
Michael