Subject: [iccrg] Stepping down from chairing ICCRG

From: Michael Welzl <[email-masked]>
Date: Thu, 23 Nov 2017 09:54:03 +0100

Dear ICCRGers,

With this email I’d like to announce that I’m stepping down as a chair of ICCRG.

There is no reason in particular - just that after 11 years of ICCRG’ing, maybe it’s time to do something else and to give this seat to someone else. Thanks folks for all the entertainment - I had a lot of fun chairing this group!

Me being me, I can’t get myself to make such an announcement without a “good-bye statement”, sharing my view on the current state of congestion control in general.

I’ll give this the title…

*~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-*
The Unrecognized Renaissance
*~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-*

Clearly, after the high-speed-congestion-control days (I’ll just say "Cubic vs. HTCP” - this was so much fun to watch!), interest in congestion control, and the Internet’s transport layer in general declined.
Basically, people began to look at it as a “solved problem” (which I could never understand), and thus academic workshops, special sessions at conferences, and, above all, funding disappeared.

Then came what I thought to be a renaissance:  people discovered that lower latency is the new “high speed”, and started to work on ways to reduce latency. In the beginning of this wave, we had things like SPDY and IW10, and the “Bufferbloat” name was invented for large buffers. Heck, we even got new AQM algorithms: most prominently, CoDel, PIE and FQ_CoDel. Bufferbloat is a community in its own right, with its own mailing list and much activity; Google, having discovered that reducing latency is really important to them, started adding heaps of interesting stuff to TCP - TLP, RACK, BBR, you name it. Apple is deploying MPTCP and beating the drum for ECN, and the L4S folks beat it very loudly for even lower latency via ECN.

So much activity!  So much noise!  So much loud beating!  Real problems being solved, big industry players getting active, everything! These should be very exciting times!

Now, if I look at the European H2020 work programme, or special tracks in conferences, special issues of journals, workshops, it seems like NOTHING has happened. Still, the transport layer problem is “solved” and not interesting, and it seems that folks like us need to stretch quite a bit to explain to funding bodies why what they do is relevant at all.

I just don’t get it. Sure, rather than complaining, I can blame myself for not having filled out these questionnaires that the EC shares to provide inputs on new topics, but I think there’s something bigger missing here: societal impact, industry relevance... is transport layer research (e.g., to reduce latency) really not relevant for anyone but the big players? I struggle to believe that - is it a matter of showing that the problems are real, to the right people?  (hasn’t Jim Gettys done enough?)

I’ll conclude this with a final request as a chair to the group: please think about these things, and if you have the right kind of network, and agree with me that it’s high time for this renaissance to become recognized, then please talk to folks out there and make them understand that things should change. Let the light shine on the transport layer, I say!

Okay, enough rambling. Anyway, I’m not “leaving” in any real way, just ending the chair role and using the opportunity to make a statement.

Cheers,
Michael

---

From: Yuchung Cheng <[email-masked]>
Date: Mon, 27 Nov 2017 09:46:39 -0800

Thank you for your service to iccrg and IETF!

On Thu, Nov 23, 2017 at 12:54 AM, Michael Welzl <[email-masked]> wrote:

> There is no reason in particular - just that after 11 years of ICCRG’ing,
> maybe it’s time to do something else and to give this seat to someone else.
> Thanks folks for all the entertainment - I had a lot of fun chairing this
> group!
>
>
> Me being me, I can’t get myself to make such an announcement without a
> “good-bye statement”, sharing my view on the current state of congestion
> control in general.
>
>
> Clearly, after the high-speed-congestion-control days (I’ll just say
> "Cubic vs. HTCP” - this was so much fun to watch!), interest in congestion
> control, and the Internet’s transport layer in general declined.
> Basically, people began to look at it as a “solved problem” (which I could
> never understand), and thus academic workshops, special sessions at
> conferences, and, above all, funding disappeared.
>
> Then came what I thought to be a renaissance:  people discovered that
> lower latency is the new “high speed”, and started to work on ways to
> reduce latency. In the beginning of this wave, we had things like SPDY and
> IW10, and the “Bufferbloat” name was invented for large buffers. Heck, we
> even got new AQM algorithms: most prominently, CoDel, PIE and FQ_CoDel.
> Bufferbloat is a community in its own right, with its own mailing list and
> much activity; Google, having discovered that reducing latency is really
> important to them, started adding heaps of interesting stuff to TCP - TLP,
> RACK, BBR, you name it. Apple is deploying MPTCP and beating the drum for
> ECN, and the L4S folks beat it very loudly for even lower latency via ECN.
>
> So much activity!  So much noise!  So much loud beating!  Real problems
> being solved, big industry players getting active, everything! These should
> be very exciting times!
>
> Now, if I look at the European H2020 work programme, or special tracks in
> conferences, special issues of journals, workshops, it seems like NOTHING
> has happened. Still, the transport layer problem is “solved” and not
> interesting, and it seems that folks like us need to stretch quite a bit to
> explain to funding bodies why what they do is relevant at all.
>
> I just don’t get it. Sure, rather than complaining, I can blame myself for
> not having filled out these questionnaires that the EC shares to provide
> inputs on new topics, but I think there’s something bigger missing here:
> societal impact, industry relevance... is transport layer research (e.g.,
> to reduce latency) really not relevant for anyone but the big players? I
> struggle to believe that - is it a matter of showing that the problems are
> real, to the right people?  (hasn’t Jim Gettys done enough?)
>
> I’ll conclude this with a final request as a chair to the group: please
> think about these things, and if you have the right kind of network, and
> agree with me that it’s high time for this renaissance to become
> recognized, then please talk to folks out there and make them understand
> that things should change. Let the light shine on the transport layer, I
> say!
>
>
> Okay, enough rambling. Anyway, I’m not “leaving” in any real way, just
> ending the chair role and using the opportunity to make a statement.
>
> Cheers,
> Michael
>
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg
>

---

From: Allison Mankin <[email-masked]>
Date: Mon, 27 Nov 2017 12:54:46 -0500

Dear Michael,

The group and the IRTF is grateful for your long time chairing, and looking
forward to your future participation as a contributor.  Thank you!

Dear ICCRG,

Please send a message to me (to [email-masked]) if you'd like to be
considered for a co-chair of ICCRG stepping in for Michael (or want to
recommend someone). Give us a couple sentences about why you or they would
be a good choice; consider talking about how you would address the
challenge that Michael has made in his email). The IRSG and I will discuss
your suggestions and give Jana a co-chair as soon as possible.

Allison
IRTF Chair

---

From: Neal Cardwell <[email-masked]>
Date: Mon, 27 Nov 2017 13:07:03 -0500

Indeed, Michael, thank you for all your many years of work for the ICCRG!

neal

On Mon, Nov 27, 2017 at 12:46 PM, Yuchung Cheng <[email-masked]> wrote:

>> Basically, people began to look at it as a “solved problem” (which I
>> could never understand), and thus academic workshops, special sessions at
>> I just don’t get it. Sure, rather than complaining, I can blame myself
>> for not having filled out these questionnaires that the EC shares to
>> provide inputs on new topics, but I think there’s something bigger missing
>> here: societal impact, industry relevance... is transport layer research
>> (e.g., to reduce latency) really not relevant for anyone but the big
>> players? I struggle to believe that - is it a matter of showing that the
>> problems are real, to the right people?  (hasn’t Jim Gettys done enough?)
>>

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 27 Nov 2017 10:53:40 -0800

(Damn it, I wasn't the first to respond!)

Thank you Michael, for your years of service, and for your fearless
leadership of the ICCRG. Eleven years as chair is quite a long time -- my
son, who is in 6th grade now, was born when you became chair -- and I hope
NOT to follow in your footsteps :-)

Thank you again, and I look forward to your engagement in the rg!
- jana

---

From: Michael Welzl <[email-masked]>
Date: Mon, 27 Nov 2017 21:08:36 +0100

Gee, thanks, y’all -  wasn’t such a big deal, really!  Just long  :-)   but I got paid off with lots and lots of beautiful dinners!

More in line below:

> On Nov 27, 2017, at 7:53 PM, Jana Iyengar <[email-masked]> wrote:
> 
> Thank you Michael, for your years of service, and for your fearless leadership of the ICCRG.

“Fearless" made me laugh  :-)

> Eleven years as chair is quite a long time -- my son, who is in 6th grade now, was born when you became chair -- and I hope NOT to follow in your footsteps :-)
> 

Thanks to you - and speaking of engagement in the RG, I’ll probably want to ask for one or even two slots at the next meeting if possible … given the sharp recent increase of general activity, my recommendation would be to ask for an even longer slot for London (or maybe even divide into two slots).  Time was a little short at the last meeting, yet it was filled with stuff that I really wouldn’t have wanted to say “no" to!

Cheers,
Michael