Subject: [Ice] ICEbis: RTP no-op keep-alives

From: Christer Holmberg <[email-masked]>
Date: Thu, 24 Mar 2016 12:26:03 +0000

Hi,

5245bis still defines RTP no-op as a mechanism for doing keep-alives. However, AFAIK, the work on no-op has stopped, and the associated draft will not be published as an RFC.

So, we need to remove the reference from 5245bis.

The question is whether we want to replace it with something else, or whether STUN is the only defined mechanism for doing keep-alives.

My suggestion is that 5245bis only defines the usage of STUN for keep-alives.

Regards,

Christer

---

From: Roman Shpount <[email-masked]>
Date: Thu, 24 Mar 2016 10:00:47 -0400

On Thu, Mar 24, 2016 at 8:26 AM, Christer Holmberg <
[email-masked]> wrote:

>
> 5245bis still defines RTP no-op as a mechanism for doing keep-alives.
> However, AFAIK, the work on no-op has stopped, and the associated draft
> will not be published as an RFC.
>
> The question is whether we want to replace it with something else, or
> whether STUN is the only defined mechanism for doing keep-alives.
>
I agree that RTP no-op should be removed as a keep-alive mechanism and only
STUN should be left. We should also reference
draft-ietf-rtcweb-stun-consent-freshness in conjunction with STUN
keep-alives.
_____________
Roman Shpount