Subject: [Ice] Do we currently need functionality for removing candidates?

From: Thomas Stach <[email-masked]>
Date: Fri, 23 Sep 2016 14:47:06 +0200

All,

in preparation of WGLC for draft-ietf-mmusic-trickle-ice-sip in MMUSIC a 
question came up, if we need functionality for removing candidates.

 From list discussion in ICE, the minutes of the Berlin IETF and due to 
the lack of corresponding text in draft-ietf-ice-trickle-04, I have the 
impression that this is currently not in scope of the Trickle ICE work.

Could anybody confirm that this impression is correct?

If yes, we would be about ready for WGLC of 
draft-ietf-mmusic-trickle-ice-sip.

Regards

Thomas

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 23 Sep 2016 23:52:51 +0100

I believe that removing candidates is very useful. Let me give an example. With TURN mobility, it is possible to retain pairs involving TURN candidates across interface changes. So if you leave a building and WLAN host candidates become unavailable, if you have cellular connectivity you can use TURN mobility to keep media flowing while looking for a better candidate pair. To avoid loss of consent that would invalidate Pairs involving the WLAN candidates, it is desirable to remove (and perhaps later, renominate) the WLAN host and srvflx candidates.

The package of TURN mobility, removal, renomination and aspects of passive-aggressive nomination therefore enables efficient and effective ICE mobility.

Code is available for inspection in ORTC Lib (http://ortclib.org/)

> On Sep 23, 2016, at 1:47 PM, Thomas Stach <[email-masked]> wrote:
> 
> All,
> 
> in preparation of WGLC for draft-ietf-mmusic-trickle-ice-sip in MMUSIC a question came up, if we need functionality for removing candidates.
> 
> From list discussion in ICE, the minutes of the Berlin IETF and due to the lack of corresponding text in draft-ietf-ice-trickle-04, I have the impression that this is currently not in scope of the Trickle ICE work.
> 
> If yes, we would be about ready for WGLC of draft-ietf-mmusic-trickle-ice-sip.
> 
> 
> Regards
> 
> Thomas
> 
> 
> 
> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice