Subject: [Ice] I-D Action: draft-ietf-ice-dualstack-fairness-05.txt

From: [email-masked]
Date: Tue, 20 Sep 2016 05:14:34 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Interactive Connectivity Establishment of the IETF.

        Title           : ICE Multihomed and IPv4/IPv6 Dual Stack Fairness
        Authors         : Paal-Erik Martinsen
                          Tirumaleswar Reddy
                          Prashanth Patil
	Filename        : draft-ietf-ice-dualstack-fairness-05.txt
	Pages           : 10
	Date            : 2016-09-20

Abstract:
   This document provides guidelines on how to make Interactive
   Connectivity Establishment (ICE) conclude faster in multihomed and
   IPv4/IPv6 dual-stack scenarios where broken paths exist.  The
   provided guidelines are backwards compatible with the original ICE
   specification.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ice-dualstack-fairness/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-ice-dualstack-fairness-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ice-dualstack-fairness-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Tue, 20 Sep 2016 12:31:08 +0000

Hi all,

This addresses almost all the discusses from: https://datatracker.ietf.org/doc/draft-ietf-ice-dualstack-fairness/ballot/

Mirja Kühlewinds DISCUSS is only partly addressed. The missing point is:
"- How do I measure/track that an interface has connectitivy problems: connectivity failed once, or twice, or X-times? How long do I keep this track: 1h, one day, one week, forever?”

I think this should remain an implementation detail. I have no advise or recommendation to provide, and my guess it that it will be very implementation dependant anyway. This will cause no iterop problems. Input from the WG is much appreciated. 

Changes:

Renamed draft to: ICE Multihomed and DualStack Guidelines     (A glitch in the XML file, I edited the abbrev instead of the real title, will be fixed in -06)
Fixed wording in document to accommodate the title change. 

Added text to section 4:
"A simple formula to calculate how many IPv6 addresses to put before
any IPv4 addresses could look like:

                Hi = (N_4 + N_6) / N_4

                Where Hi  = Head start before intermingling starts
                         N_4 = Number of IPv4 addresses
                        N_6 = Number of IPv6 addresses

If a host have 2 IPv4 addresses and 6 IPv6 addresses, it will insert
an IP4 address after 4 IPv6 addresses by choosing the appropriate
local preference values when calculating the pair priorities.”

.-.
Pål-Erik

> On 20 Sep 2016, at 14:14, [email-masked] wrote:
> 
> 
> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice