Subject: [icnrg] Benefit of information centric network (ICN) compared to DTN in wireless communication

From: Ngoc Thanh Dinh <[email-masked]>
Date: Fri, 14 Sep 2012 15:07:44 +0900

Dear Every one,

We are discussing about the benefit of ICN and DTN in global future
internet conference these days.
I am researching in ICN and DTN in vehicular network. There are some papers
in both topics for vehicular network,
both of them support naming, caching, store-and-forward,...while DTN has a
longer history than ICN
Could you give me your opinions about what is benefit of ICN compared to
DTN?
Did anyone make a comparison between ICN and DTN?

Thank you very much!

-- 
Dinh Ngoc Thanh | PhD candidate
Soongsil university - Seoul Korea
M: (+82) 010 4197 1879

---

From: Pedro Martínez Juliá <[email-masked]>
Date: Fri, 14 Sep 2012 13:42:55 +0200

> Did anyone make a comparison between ICN and DTN?

Conceptually, they have very different objectives. However, ICN can cover some 
(or even many) DTN use cases. The main difference is that ICN manages named or 
uniquely identified information while DTN is concentrated in the 
communication. For example, and correct me if I'm wrong, ICN permits to 
deliver the same information piece to different clients requesting it without 
involving the information source but in DTN is the sender who decides the 
destination of a message.

> Thank you very much!

Regards,
Pedro

-- 
Pedro Martinez-Julia
Department of Communication and Information Engineering
Faculty of Computer Science
University of Murcia
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: Dirk Trossen <[email-masked]>
Date: Fri, 14 Sep 2012 12:51:04 +0100

Let me bring back DY's email from a few days ago, pointing at Kevin Fall's presentation (I included the link again, DY also sent the presentation itself):

   http://fif.kr/gfi-summit/11/program.htm

It shows that there's more to ICN and DTN commonalities than one might think originally

Dirk

On 14 Sep 2012, at 12:42, Pedro Martínez Juliá wrote:

> Conceptually, they have very different objectives. However, ICN can cover some (or even many) DTN use cases. The main difference is that ICN manages named or uniquely identified information while DTN is concentrated in the communication. For example, and correct me if I'm wrong, ICN permits to deliver the same information piece to different clients requesting it without involving the information source but in DTN is the sender who decides the destination of a message.
> 
>> Thank you very much!
>> 
> 
> Regards,
> Pedro
> 
> -- 
> Pedro Martinez-Julia

---

From: Ngoc Thanh Dinh <[email-masked]>
Date: Fri, 14 Sep 2012 21:17:24 +0900

Thank you very much!
Yes. I think so, ICN could cover many scenarios of DTN.
But to compare them in one experiment to show which one is better in the
ad-hocvehicular environment, it seems many consideration.
Do you have any opinion to compare performance of two approaches? on delay,
network resource consumption, overhead or other one?
I want to show that ICN is better one in the vehicular environment. but in
the partition case or in high density case, it still seems confusing to
compare.
Hope to have your discussion!!!

thank you very much!

2012/9/14 Dirk Trossen <[email-masked]>

> Let me bring back DY's email from a few days ago, pointing at Kevin Fall's
> presentation (I included the link again, DY also sent the presentation
> itself):
>
> > Conceptually, they have very different objectives. However, ICN can
> cover some (or even many) DTN use cases. The main difference is that ICN
> manages named or uniquely identified information while DTN is concentrated
> in the communication. For example, and correct me if I'm wrong, ICN permits
> to deliver the same information piece to different clients requesting it
> without involving the information source but in DTN is the sender who
> decides the destination of a message.
> >
> >> Thank you very much!
> >>
> >
> > Regards,
> > Pedro
> >
> > --
> > Pedro Martinez-Julia

---

From: Dirk Trossen <[email-masked]>
Date: Fri, 14 Sep 2012 13:29:19 +0100

Kevin's pointed nicely at some of the differences in ICN approaches, which matter when looking at some aspects. For instance, you can have packet-level identification (a difference to DTNs) or object-level identification (as some ICN approaches provide), which brings them closer to DTN. Also, the used forwarding solution matters in any comparison. 

Generally, I would argue that DTN and ICN are both very well suited for vehicular comms but the real difference in performance comes from the differences in particular design choices made. That is where it gets harder.

Dirk
On 14 Sep 2012, at 13:17, Ngoc Thanh Dinh wrote:

> But to compare them in one experiment to show which one is better in the ad-hocvehicular environment, it seems many consideration.
> Do you have any opinion to compare performance of two approaches? on delay, network resource consumption, overhead or other one?
> I want to show that ICN is better one in the vehicular environment. but in the partition case or in high density case, it still seems confusing to compare.

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Fri, 14 Sep 2012 07:33:37 -0500

DTN and ICN may be complementary.  DTN is not ICN.  DTN is to move information over, in some cases, long propagation delays, and in other cases, systems that are normally disconnected, or both.  There is a thought that, because DTNs have to store content, that same storage could be used by the ICN.  However, trying to combine the two, IMHO, will complicate matters for both ICN and DTN and hold back both.  But, that is just my opinion.

Regardless, I don't think you can compare "which one is better in the ad hoc vehicular environment" because they are designed to do two different things.  Perhaps the better question is "Do I need DTN for ad hoc vehicular networks or will ICN suffice?"  What is your concept of operations?  Are you operating where 4G connectivity is available?  Do i have a multi-hop DTN?  If not, DTN is likely to buy you nothing.

- Will

On Sep 14, 2012, at 8:17 AM, Ngoc Thanh Dinh wrote:

Thank you very much!

thank you very much!

2012/9/14 Dirk Trossen <[email-masked]<mailto:[email-masked]>>
Let me bring back DY's email from a few days ago, pointing at Kevin Fall's presentation (I included the link again, DY also sent the presentation itself):

Dirk

On 14 Sep 2012, at 12:42, Pedro Martínez Juliá wrote:

> Email: [email-masked]<mailto:[email-masked]>

******************************
William D. Ivancic
Phone 216-433-3494
Fax 216-433-8705
Networking Lab 216-433-2620
Mobile 440-503-4892
http://roland.grc.nasa.gov/~ivancic

---

From: Ngoc Thanh Dinh <[email-masked]>
Date: Fri, 14 Sep 2012 21:52:31 +0900

Yes. DTN could be a scenario which could be covered in ICN.
I am analyzing on the case of exchanging information among vehicles in the
ad-hoc vehicular network scenarios without infrastructure.
in case of long delay or disruption (main purpose of DTN), i think the same
performance could be implement based on information object and caching of
ICN.
but in the high density and high mobility case of vehicle, do you think DTN
will achieve a lower performance? (e.g. higher delay)

I want to listen your discussion about the points that

class 1: for information service which delayed or lost information does not
compromise safety or render the application useless (e.g. weather
reports,...) --> DTN capabilities can improve the quality in this case by
increasing the message delivery and reducing delays in challenging
scenarios.
And with ICN, we could also achieve this improvement, even more, based on
naming object, not destination host.

class 2: for delayed information may compromise safety, application may
require realtime communication --> DTN may not improve the quality of this
case.
But ICN may make an improvement? (based on information object caching)

Listen to your discussion and thank you very much!!!

2012/9/14 Ivancic, William D. (GRC-RHN0) <[email-masked]>

> DTN and ICN may be complementary.  DTN is not ICN.  DTN is to move
> information over, in some cases, long propagation delays, and in other
> cases, systems that are normally disconnected, or both.  There is a thought
> that, because DTNs have to store content, that same storage could be used
> by the ICN.  However, trying to combine the two, IMHO, will complicate
> matters for both ICN and DTN and hold back both.  But, that is just my
> opinion.
>
>
> Regardless, I don't think you can compare "which one is better in the ad
> hoc vehicular environment" because they are designed to do two different
> things.  Perhaps the better question is "Do I need DTN for ad hoc vehicular
> networks or will ICN suffice?"  What is your concept of operations?  Are
> you operating where 4G connectivity is available?  Do i have a multi-hop
> DTN?  If not, DTN is likely to buy you nothing.
>
> - Will
>
>
>
> Do you have any opinion to compare performance of two approaches? on
> delay, network resource consumption, overhead or other one?
>> Let me bring back DY's email from a few days ago, pointing at Kevin
>> Fall's presentation (I included the link again, DY also sent the
>> presentation itself):
>>

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Fri, 14 Sep 2012 08:02:03 -0500

DTN, as is, only temporarily caches a bundle until it passes it on (in general, but is implementation  and routing specific).  DTN, as is, does not know what is inside the bundle (although, one could come up with something special to enable this).   ICN ensures that the information is cached at the appropriate places and is available for ICN users to obtain. DTN could be used to get the information to the ICN cache (complementary).  But, for DTN to be used as ICN, you have to basically design ICN into DTN. DTN, as is, is complicated enough.

- Will

On Sep 14, 2012, at 8:52 AM, Ngoc Thanh Dinh wrote:

Yes. DTN could be a scenario which could be covered in ICN.
I am analyzing on the case of exchanging information among vehicles in the ad-hoc vehicular network scenarios without infrastructure.
in case of long delay or disruption (main purpose of DTN), i think the same performance could be implement based on information object and caching of ICN.
but in the high density and high mobility case of vehicle, do you think DTN will achieve a lower performance? (e.g. higher delay)

class 1: for information service which delayed or lost information does not compromise safety or render the application useless (e.g. weather reports,...) --> DTN capabilities can improve the quality in this case by increasing the message delivery and reducing delays in challenging scenarios.
And with ICN, we could also achieve this improvement, even more, based on naming object, not destination host.

class 2: for delayed information may compromise safety, application may require realtime communication --> DTN may not improve the quality of this case.
But ICN may make an improvement? (based on information object caching)

2012/9/14 Ivancic, William D. (GRC-RHN0) <[email-masked]<mailto:[email-masked]>>
DTN and ICN may be complementary.  DTN is not ICN.  DTN is to move information over, in some cases, long propagation delays, and in other cases, systems that are normally disconnected, or both.  There is a thought that, because DTNs have to store content, that same storage could be used by the ICN.  However, trying to combine the two, IMHO, will complicate matters for both ICN and DTN and hold back both.  But, that is just my opinion.

- Will

Thank you very much!

thank you very much!

Dirk

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Fri, 14 Sep 2012 15:25:15 +0200

DTN vs ICN was a specific topic discussed last week during the Dagstuhl
seminar and the group´s discussion was eloquently summarized by Kevin Fall
in a small presentation that included table contrasting key similarities
and differences. Unfortunately the material does not seem to be online
(yet). We may try to ask Kevin to share the material:
http://www.dagstuhl.de/mat/index.en.phtml?12361

-Christian

On Fri, Sep 14, 2012 at 3:02 PM, Ivancic, William D. (GRC-RHN0) <
[email-masked]> wrote:

> DTN, as is, only temporarily caches a bundle until it passes it on (in
> general, but is implementation  and routing specific).  DTN, as is, does
> not know what is inside the bundle (although, one could come up with
> something special to enable this).   ICN ensures that the information is
> cached at the appropriate places and is available for ICN users to obtain.
> DTN could be used to get the information to the ICN cache (complementary).
>  But, for DTN to be used as ICN, you have to basically design ICN into DTN.
> DTN, as is, is complicated enough.
>
> - Will
>
> in case of long delay or disruption (main purpose of DTN), i think the
> same performance could be implement based on information object and caching
> of ICN.
> but in the high density and high mobility case of vehicle, do you think
> DTN will achieve a lower performance? (e.g. higher delay)
>
> class 1: for information service which delayed or lost information does
> not compromise safety or render the application useless (e.g. weather
>> I want to show that ICN is better one in the vehicular environment. but
>> in the partition case or in high density case, it still seems confusing to
>> compare.
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>
>

-- 
Christian

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 14 Sep 2012 14:43:49 +0100

On 09/14/2012 02:02 PM, Ivancic, William D. (GRC-RHN0) wrote:
> DTN, as is, only temporarily caches a bundle until it passes it on (in general, but is implementation  and routing specific).  DTN, as is, does not know what is inside the bundle (although, one could come up with something special to enable this).

That's been done. A few times I think.

Our variant is documented in draft-irtf-dtnrg-bpq and the code
(or some of it, would have to check) is in the latest DTN2.

S.

---

From: Ngoc Thanh Dinh <[email-masked]>
Date: Fri, 14 Sep 2012 23:02:51 +0900

Thank you very much!
That is one reason we want to implement ICN in ad-hoc vehicular network.
but we have to demonstrate it, before implementation, we have to make a
clear benefits.

In high density, high mobility case, and constraint information (delay time
and location), do you think that DTN will give a not good performance?
(even increase delay compared to other). and ICN may be better because ICN
could support automatic ifnormation searching and distributtion (matching
interest and data) ?

We should make a clear benefit to select which one is more suitable for
this scenario.
Hope to have your discussion and thank you very much!

---

From: <[email-masked]>
Date: Fri, 14 Sep 2012 14:48:25 +0000

Envoyé depuis mon HTC Touch Pro2 d'Orange

________________________________
De: Ngoc Thanh Dinh <[email-masked]>
Env: vendredi 14 septembre 2012 14:52
À: Ivancic, William D. (GRC-RHN0) <[email-masked]>; Dirk Trossen <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Objet: Re: [icnrg] Benefit of information centric network (ICN) compared to DTN in wireless communication

- Will

Thank you very much!

thank you very much!

Dirk

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Fall, Kevin" <[email-masked]>
Date: Fri, 14 Sep 2012 15:06:38 +0000

Here's a copy of the (very brief) presentation.
Note that although I presented this material, this was a group effort.

One caution when thinking about the DTN and ICN architectures— please think of DTN in terms of 4838 or the architectural papers from SIGCOMM or JSAC.  The current implementation doesn't do all the things originally envisioned for the architectural approach.
Indeed, extended naming was envisioned early on.  However, it (along with multicast) hasn't received much work or refinement within the DTN community IMHO.

I think the ICN-related ideas are helping to clarify the thinking (for me at least) on what DTN multicast should be capable of.
I should probably add that the table wasn't without discussion (in particular, Lixia made a few comments from the NDN perspective).
Regards,

  *   Kevin

From: Christian Esteve Rothenberg <[email-masked]<mailto:[email-masked]>>
Date: Friday, September 14, 2012 6:25 AM PDT
To: "Ivancic, William D. (GRC-RHN0)" <[email-masked]<mailto:[email-masked]>>
Cc: Ngoc Thanh Dinh <[email-masked]<mailto:[email-masked]>>, Dirk Trossen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [icnrg] Benefit of information centric network (ICN) compared to DTN in wireless communication

DTN vs ICN was a specific topic discussed last week during the Dagstuhl seminar and the group´s discussion was eloquently summarized by Kevin Fall in a small presentation that included table contrasting key similarities and differences. Unfortunately the material does not seem to be online (yet). We may try to ask Kevin to share the material: http://www.dagstuhl.de/mat/index.en.phtml?12361

-Christian

On Fri, Sep 14, 2012 at 3:02 PM, Ivancic, William D. (GRC-RHN0) <[email-masked]<mailto:[email-masked]>> wrote:
DTN, as is, only temporarily caches a bundle until it passes it on (in general, but is implementation  and routing specific).  DTN, as is, does not know what is inside the bundle (although, one could come up with something special to enable this).   ICN ensures that the information is cached at the appropriate places and is available for ICN users to obtain. DTN could be used to get the information to the ICN cache (complementary).  But, for DTN to be used as ICN, you have to basically design ICN into DTN. DTN, as is, is complicated enough.

- Will

- Will

Thank you very much!

thank you very much!

Dirk

--
Dinh Ngoc Thanh | PhD candidate
Soongsil university - Seoul Korea
M: (+82) 010 4197 1879<tel:%28%2B82%29%20010%204197%201879>

******************************
William D. Ivancic
Phone 216-433-3494<tel:216-433-3494>
Fax 216-433-8705<tel:216-433-8705>
Networking Lab 216-433-2620<tel:216-433-2620>
Mobile 440-503-4892<tel:440-503-4892>
http://roland.grc.nasa.gov/~ivancic<http://roland.grc.nasa.gov/%7Eivancic>

--
Dinh Ngoc Thanh | PhD candidate
Soongsil university - Seoul Korea
M: (+82) 010 4197 1879<tel:%28%2B82%29%20010%204197%201879>

******************************
William D. Ivancic
Phone 216-433-3494<tel:216-433-3494>
Fax 216-433-8705<tel:216-433-8705>
Networking Lab 216-433-2620<tel:216-433-2620>
Mobile 440-503-4892<tel:440-503-4892>
http://roland.grc.nasa.gov/~ivancic<http://roland.grc.nasa.gov/%7Eivancic>

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

--
Christian

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 14 Sep 2012 16:22:12 +0000

Yes, that was a good discussion, and this presentation captures the outcome quite nicely.

I believe the key thing is really the different service model and network primitives (push vs. pull) - that were certainly prominent in the initial designs. It's true that you can add the missing semantics to the respective approaches.

Many other aspects (object granularity), dealing with disruptions, time-scales, state-keeping requirements seem to be based on conventions - you could build the systems in different ways.

We discussed whether todays ICN would survive powering off and on again the whole network (the assumption is that many DTNs would). I am now less convinced that this necessarily has to be pathological for ICNs. In an ICN that is on the same scale as most DTN deployments (i.e., not talking about global scale), there would not be a need for large name-resolution databases etc.  Name-based routing in a local domain could re-build state at routers and request for named data objects can be re-sent by the requestors.

Best regards,
Dirk

From: [email-masked] [mailto:[email-masked]] On Behalf Of Fall, Kevin
Sent: Freitag, 14. September 2012 17:07
To: Christian Esteve Rothenberg; Ivancic, William D. (GRC-RHN0)
Cc: Ngoc Thanh Dinh; Dirk Trossen; [email-masked]; [email-masked]
Subject: Re: [icnrg] Benefit of information centric network (ICN) compared to DTN in wireless communication

One caution when thinking about the DTN and ICN architectures- please think of DTN in terms of 4838 or the architectural papers from SIGCOMM or JSAC.  The current implementation doesn't do all the things originally envisioned for the architectural approach.
Indeed, extended naming was envisioned early on.  However, it (along with multicast) hasn't received much work or refinement within the DTN community IMHO.

  *   Kevin

-Christian

- Will

- Will

Thank you very much!

thank you very much!

Dirk

--
Christian

---

From: "George Xylomenos" <[email-masked]>
Date: Fri, 14 Sep 2012 22:03:37 +0300

I would add one thing that came up after the presentation, during the wrap
up: there was a discussion on whether storage is an integral part of ICN
architectures or not, after which Kevin said that he should probably revise
the third line of the table (use storage), especially the “persistent” part.
Since each ICN architecture is different and opinions may differ even within
a project, here is a specific example: PSIRP/PURSUIT does not have an entity
equivalent to a “custodian” in DTN, although ICN applications could be built
to provide this feature, and I think that this is the case also for CCN/NDN.

In the vehicular communication example, in DTN a vehicle that is
intermittently connected could perform custody transfer to a roadside node
that would accept it (an obliging P node), and then the roadside node would
try hard to deliver the message to the destination. In PSIRP/PURSUIT and (I
think) in CCN/NDN, a roadside node may become a source for data from a
vehicle (not in an obvious manner, see below) but it does not really
undertake the responsibility to deliver that data. So in DTN the vehicle
will push the data and expect it to be delivered; in PSIRP/PURSUIT and
CCN/NDN the data will have to be somehow pulled and then the roadside node
would have to store them until somebody asks for them and then forward them,
therefore some application will have to provide this service – it’s
relatively easy to do this as ICN allows having many sources for data.

George Xylomenos

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Fall, Kevin
Sent: Friday, September 14, 2012 6:07 PM
To: Christian Esteve Rothenberg; Ivancic, William D. (GRC-RHN0)
Cc: Ngoc Thanh Dinh; Dirk Trossen; [email-masked]; [email-masked]
Subject: Re: [icnrg] Benefit of information centric network (ICN) compared
to DTN in wireless communication

One caution when thinking about the DTN and ICN architectures— please think
of DTN in terms of 4838 or the architectural papers from SIGCOMM or JSAC.
The current implementation doesn't do all the things originally envisioned
for the architectural approach.

Indeed, extended naming was envisioned early on.  However, it (along with
multicast) hasn't received much work or refinement within the DTN community
IMHO.

I think the ICN-related ideas are helping to clarify the thinking (for me at
least) on what DTN multicast should be capable of.

I should probably add that the table wasn't without discussion (in
particular, Lixia made a few comments from the NDN perspective).  

Regards,

*	Kevin

From: Christian Esteve Rothenberg <[email-masked]>
Date: Friday, September 14, 2012 6:25 AM PDT
To: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Cc: Ngoc Thanh Dinh <[email-masked]>, Dirk Trossen
<[email-masked]>, "[email-masked]" <[email-masked]>,
"[email-masked]" <[email-masked]>
Subject: Re: [icnrg] Benefit of information centric network (ICN) compared
to DTN in wireless communication

DTN vs ICN was a specific topic discussed last week during the Dagstuhl
seminar and the group´s discussion was eloquently summarized by Kevin Fall
in a small presentation that included table contrasting key similarities and
differences. Unfortunately the material does not seem to be online (yet). We
may try to ask Kevin to share the material:
http://www.dagstuhl.de/mat/index.en.phtml?12361

-Christian

On Fri, Sep 14, 2012 at 3:02 PM, Ivancic, William D. (GRC-RHN0)
<[email-masked]> wrote:

DTN, as is, only temporarily caches a bundle until it passes it on (in
general, but is implementation  and routing specific).  DTN, as is, does not
know what is inside the bundle (although, one could come up with something
special to enable this).   ICN ensures that the information is cached at the
appropriate places and is available for ICN users to obtain. DTN could be
used to get the information to the ICN cache (complementary).  But, for DTN
to be used as ICN, you have to basically design ICN into DTN. DTN, as is, is
complicated enough.   

- Will

DTN and ICN may be complementary.  DTN is not ICN.  DTN is to move
information over, in some cases, long propagation delays, and in other
cases, systems that are normally disconnected, or both.  There is a thought
that, because DTNs have to store content, that same storage could be used by
the ICN.  However, trying to combine the two, IMHO, will complicate matters
for both ICN and DTN and hold back both.  But, that is just my opinion. 

Regardless, I don't think you can compare "which one is better in the ad hoc
vehicular environment" because they are designed to do two different things.
Perhaps the better question is "Do I need DTN for ad hoc vehicular networks
or will ICN suffice?"  What is your concept of operations?  Are you
operating where 4G connectivity is available?  Do i have a multi-hop DTN?
If not, DTN is likely to buy you nothing.

- Will

Thank you very much!

thank you very much!

It shows that there's more to ICN and DTN commonalities than one might think
originally

Dirk

On 14 Sep 2012, at 12:42, Pedro Martínez Juliá wrote:

> Conceptually, they have very different objectives. However, ICN can cover
some (or even many) DTN use cases. The main difference is that ICN manages
named or uniquely identified information while DTN is concentrated in the
communication. For example, and correct me if I'm wrong, ICN permits to
deliver the same information piece to different clients requesting it
without involving the information source but in DTN is the sender who
decides the destination of a message.

-- 
Dinh Ngoc Thanh | PhD candidate
Soongsil university - Seoul Korea
M: (+82) 010 4197 1879 <tel:%28%2B82%29%20010%204197%201879> 

******************************
William D. Ivancic
Phone 216-433-3494
Fax 216-433-8705
Networking Lab 216-433-2620
Mobile 440-503-4892
http://roland.grc.nasa.gov/~ivancic <http://roland.grc.nasa.gov/%7Eivancic> 

-- 
Dinh Ngoc Thanh | PhD candidate
Soongsil university - Seoul Korea
M: (+82) 010 4197 1879 <tel:%28%2B82%29%20010%204197%201879> 

******************************
William D. Ivancic
Phone 216-433-3494
Fax 216-433-8705
Networking Lab 216-433-2620
Mobile 440-503-4892
http://roland.grc.nasa.gov/~ivancic <http://roland.grc.nasa.gov/%7Eivancic> 

-- 
Christian

---

From: Elwyn Davies <[email-masked]>
Date: Fri, 14 Sep 2012 23:14:22 +0100

> (or some of it, would have to check) is in the latest DTN2.
Yes..  essentially all of it (and a few extras) is in DTN2 v2.9.0 (with 
Oasys 1.6.0).

More will be coming shortly.

/Elwyn

---

From: Elwyn Davies <[email-masked]>
Date: Sat, 15 Sep 2012 00:59:41 +0100

The US Army was (and as far as I know still are) very interested in DTN 
as a way to improve throughput in what is essentially a vehicular ad-hoc 
network.  Some years ago there were trials of the BBN-lead DARPA DTN 
projects (SPINDLE) involving vehicles driving round a track and 
comparing the performance of DTN and basic TCP. At one point in time 
there was a comprehensive presentation (by Preston Marshall if my memory 
is correct) of the results of this trial available on the web, but it 
seems to have been withdrawn - I failed to keep a copy of it and 
attempts to get it again have drawn a blank.  There is some discussion 
of this work in the state of the art document that I wrote for the N4C 
project about three years ago.  This can be downloaded from
http://www.n4c.eu/Download/n4c-wp2-012-state-of-the-art-101.pdf.

A Google search for something like 'us army dtn tcp vehicles' throws up 
a whole raft of interesting references including mentions of the CONDOR 
project and other stuff that is going on in vehicular ad hoc 
networking.  There is brief mention of CCN related topics.  An 
interesting report of more recent and complex trials can be found in
http://trs-new.jpl.nasa.gov/dspace/bitstream/2014/41752/1/JPL%20Pub%20D-65838.pdf

There is also an interestng perspective on combining ICN and DTN in this 
talk...
http://rajesh-krishnan.com/talks/rkrishnan-coin-neu07.pdf

Regards,
Elwyn

On 14/09/12 15:02, Ngoc Thanh Dinh wrote:
> Thank you very much!
> That is one reason we want to implement ICN in ad-hoc vehicular 
> network. but we have to demonstrate it, before implementation, we have 
> to make a clear benefits.
>
> In high density, high mobility case, and constraint information (delay 
> time and location), do you think that DTN will give a not good 
> performance? (even increase delay compared to other). and ICN may be 
> better because ICN could support automatic ifnormation searching and 
> distributtion (matching interest and data) ?
>
>
> We should make a clear benefit to select which one is more suitable 
> for this scenario.
>     DTN, as is, only temporarily caches a bundle until it passes it on
>     (in general, but is implementation  and routing specific).  DTN,
>     as is, does not know what is inside the bundle (although, one
>     could come up with something special to enable this).   ICN
>     ensures that the information is cached at the appropriate places
>     and is available for ICN users to obtain. DTN could be used to get
>     the information to the ICN cache (complementary).  But, for DTN to
>     be used as ICN, you have to basically design ICN into DTN. DTN, as
>     is, is complicated enough.
>
>     - Will
>
>>     I am analyzing on the case of exchanging information among
>>     vehicles in the ad-hoc vehicular network scenarios without
>>     infrastructure.
>>     in case of long delay or disruption (main purpose of DTN), i
>>     think the same performance could be implement based on
>>     information object and caching of ICN.
>>     but in the high density and high mobility case of vehicle, do you
>>     think DTN will achieve a lower performance? (e.g. higher delay)
>>
>>     class 1: for information service which delayed or lost
>>     information does not compromise safety or render the application
>>     useless (e.g. weather reports,...) --> DTN capabilities can
>>     improve the quality in this case by increasing the message
>>     delivery and reducing delays in challenging scenarios.
>>     And with ICN, we could also achieve this improvement, even more,
>>     based on naming object, not destination host.
>>
>>     class 2: for delayed information may compromise safety,
>>     application may require realtime communication --> DTN may not
>>     improve the quality of this case.
>>     2012/9/14 Ivancic, William D. (GRC-RHN0)
>>     <[email-masked] <mailto:[email-masked]>>
>>
>>         DTN and ICN may be complementary.  DTN is not ICN.  DTN is to
>>         move information over, in some cases, long propagation
>>         delays, and in other cases, systems that are normally
>>         disconnected, or both.  There is a thought that, because DTNs
>>         have to store content, that same storage could be used by the
>>         ICN.  However, trying to combine the two, IMHO, will
>>         complicate matters for both ICN and DTN and hold back both.
>>          But, that is just my opinion.
>>
>>
>>         Regardless, I don't think you can compare "which one is
>>         better in the ad hoc vehicular environment" because they are
>>         designed to do two different things.  Perhaps the better
>>         question is "Do I need DTN for ad hoc vehicular networks or
>>         will ICN suffice?"  What is your concept of operations?  Are
>>         you operating where 4G connectivity is available?  Do i have
>>         a multi-hop DTN?  If not, DTN is likely to buy you nothing.
>>
>>         - Will
>>
>>
>>
>>>         But to compare them in one experiment to show which one is
>>>         better in the ad-hocvehicular environment, it seems many
>>>         consideration.
>>>         Do you have any opinion to compare performance of two
>>>         approaches? on delay, network resource consumption, overhead
>>>         or other one?
>>>         I want to show that ICN is better one in the vehicular
>>>         environment. but in the partition case or in high density
>>>         case, it still seems confusing to compare.
>>>             Let me bring back DY's email from a few days ago,
>>>             pointing at Kevin Fall's presentation (I included the
>>>             link again, DY also sent the presentation itself):
>>>
>>>             > Conceptually, they have very different objectives.
>>>             However, ICN can cover some (or even many) DTN use
>>>             cases. The main difference is that ICN manages named or
>>>             uniquely identified information while DTN is
>>>             concentrated in the communication. For example, and
>>>             correct me if I'm wrong, ICN permits to deliver the same
>>>             information piece to different clients requesting it
>>>             without involving the information source but in DTN is
>>>             the sender who decides the destination of a message.
>>>             >
>>>             >> Thank you very much!
>>>             >>
>>>             >
>>>             > Regards,
>>>             > Pedro
>>>             >
>>>             > --
>>>             > Pedro Martinez-Julia
>>>             > Email: [email-masked] <mailto:[email-masked]>
>>         <http://roland.grc.nasa.gov/%7Eivancic>
>>
>>
>>
>>
>>     -- 
>     <http://roland.grc.nasa.gov/%7Eivancic>
>
>
>
>
> --

---

From: <[email-masked]>
Date: Mon, 17 Sep 2012 18:42:54 +0000

Having worked on "all-of-the-above" I can say that the differences are not
big.  I currently advise Preston and Rajesh on CBMEN (Content-Based Mobile
Edge Networks) for DARPA, and I Worked on adding ICN capabilities to
SPINDLE.

The differences between the two "architectures" are becoming
smaller/fewer.    Kevin's slides from Dagstuhl summarize what the group
talked about in terms of ICN/DTN.

One thing to note is that to some degree, both ICN and DTN refer to a
group of projects or general architectures.  From my point of view, the
DTN community is relatively unified in the sense that it follows a few
standards/conventions  (RFC 5050?).  From the ICN perspective we have a
situation where we're not unified at all. The different projects have made
different tradeoffs.

Due to this it is probably better to compare DTN to NetInf, PURSUIT, CCN,
etc.   Depending on your application you might find that more than one has
the features that you want.  Potentially you might want to choose one due
to code maturity/production-level  or  due to future expandability.

I would suggest that you think of the problem you're trying to solve,
figure out the must-have and nice-to-have features and see which
architecture/project works best for you based on:

* what is currently implement in the code (alpha, beta, production)
* what is the planned features in the short, medium and long-term
* what is technically possible with the architecture   (that might never
get done unless you do it yourself)

After all, you can do everything over IP given enough services on top.

Nacho

-- 
Ignacio Solis
Networking Area Manager
Palo Alto Research Center
+1(650)812-4458

On 9/14/12 4:59 PM, "Elwyn Davies" <[email-masked]> wrote:

>projects (SPINDLE) involving vehicles driving
> round a track and comparing the performance of DTN and basic TCP. At one
>point in time there was a comprehensive presentation (by Preston Marshall
>if my memory is correct) of the results of this trial available on the
>web, but it seems to have been withdrawn
> - I failed to keep a copy of it and attempts to get it again have drawn
>a blank.  There is some discussion of this work in the state of the art
>document that I wrote for the N4C project about three years ago.  This
>can be downloaded from
>A Google search for something like 'us army dtn tcp vehicles' throws up a
>whole raft of interesting references including mentions of the CONDOR
>project and other stuff that is going on in vehicular ad hoc networking.
>There is brief mention of CCN related topics.
> An interesting report of more recent and complex trials can be found in
>better because ICN could support automatic ifnormation
> searching and distributtion (matching interest and data) ?
>
>
><[email-masked]>
>
>something
> special to enable this).   ICN ensures that the information is cached at
>the appropriate places and is available for ICN users to obtain. DTN
>could be used to get the information to the ICN cache (complementary).
>But, for DTN to be used as ICN, you have to
> basically design ICN into DTN. DTN, as is, is complicated enough.
>
>- Will
>
>I am analyzing on the case of exchanging information among vehicles in
>the ad-hoc vehicular network scenarios without infrastructure.
>same performance could be implement based on information object and
>caching of ICN.
>increasing the message delivery and reducing
> delays in challenging scenarios.
>require realtime communication --> DTN may not improve the quality of
>this case.
><[email-masked]>
>
>cases, systems that are normally disconnected, or both.  There is a
>thought that, because
> DTNs have to store content, that same storage could be used by the ICN.
>However, trying to combine the two, IMHO, will complicate matters for
>both ICN and DTN and hold back both.  But, that is just my opinion.
>
>
>things.  Perhaps the better question is "Do I need DTN for ad hoc
>vehicular networks or will ICN suffice?"
>  What is your concept of operations?  Are you operating where 4G
>connectivity is available?  Do i have a multi-hop DTN?  If not, DTN is
>likely to buy you nothing.
>
>- Will
>
>
>
>in the partition case or in high density case, it still seems confusing
>to compare.
>>manages named or uniquely identified information while DTN is
> correct me if I'm wrong, ICN permits to deliver the same information
>piece to different clients requesting it without involving the
>information source but in DTN is the sender who decides the destination
>of a message.
>>
>>> Thank you very much!
>>>
>>
>> Regards,
>> Pedro
>>
>> --
>> Pedro Martinez-Julia
>[email-masked]://www.irtf.org/mailman/listinfo/icnrg
>
>