Subject: Re: [icnrg] First draft on ICN baseline scenarios

From: Dirk Trossen <[email-masked]>
Date: Thu, 1 Nov 2012 11:51:18 +0000

Hi Konstantinos,

thanks for the document. It is a good start into a difficult area.

You describe it as baseline scenario for a possible (experimental) comparison. At this stage, it seems however more like a survey of what the different efforts have their work being placed into (which could be a start, I admit). An area such as "content dissemination", however, then ends up to be so broad that it hardly provides a basis for comparison as such. Hence, the document will ultimately need to converge more in a description of scenarios that can indeed by replicated in setups for experiments etc. 

As a possible contribution or inspiration (if you will), let me point to two pieces that might be useful:
1) at the start of the PSIRP project (the predecessor to the currently ongoing PURSUIT project in the EU's FP7) in 2008, we asked project members to write down "stories" of the beautiful new ICN world that we/they envisioned, the stories largely centred around the idea of "information at your fingertips". The outcome can be found at http://www.psirp.org/files/Deliverables/PSIRP-TR08-0001_Vision.pdf (skip over the vision part and jump straight to the stories)

2) for the content dissemination aspect, we looked into something in this area that is more than "making CDNs better" (personally, I have doubts that this proposition would fly in any case, given the high engineering efforts to make CDNs better, faster, grander, ...). We identified the area of highly personalised and interactive media. Here, the delivered 'content' is highly similar in underlying media assets but still highly personalised (e.g., towards regions, markets, location, specific end users,...). Working with content producers (our project partner CTVC from London is one such producers), we identified that such high degree of personalisation poses a significant burden on production and delivery of the content. While standards such as MPEG DASH attempt to provide solutions for this at the application level, we see the fairly 'low level' realisation in an ICN as a potential differentiator in this particular "scenario space", e.g., through the usage of caching, the exposure of metadata at a low level of the infrastructure that allows for optimising the delivery, ... For more information, we have created small videos with an intro into the current work on this - hope this might help. You can find the videos at http://www.fp7-pursuit.eu/PursuitWeb/?p=837

Best,

Dirk
On 31 Oct 2012, at 19:05, Konstantinos Pentikousis wrote:

> Dear all,
> 
> Börje and I made a first attempt to capture some of the ICN scenarios already published in the literature. The document is available from our wiki at 
> http://trac.tools.ietf.org/group/irtf/trac/attachment/wiki/IcnBaselineScenarios/draft-pentikousis-icn-scenarios-00.txt
> 
> I also cleaned up http://trac.tools.ietf.org/group/irtf/trac/wiki/IcnBaselineScenarios and updated the table of contents to reflect the changes. Of course, feel free to edit and add to the wiki page. We're looking forward to your comments, updates, text contributions, further references, and so on for the draft as well.
> 
> Best Regards,
> 
> Kostas
> 
> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Konstantinos Pentikousis <[email-masked]>
Date: Tue, 6 Nov 2012 19:57:11 +0000

Hi Dirk, all,

  |thanks for the document. It is a good start into a difficult area.

Many thanks for your kind words and quick reply. Apologies for my late reply, it has been a busy week.
 
  |You describe it as baseline scenario for a possible (experimental)
  |comparison. At this stage, it seems however more like a survey of what
  |the different efforts have their work being placed into (which could
  |be a start, I admit).

Indeed, the starting point for this document is what people have already attempted to demonstrate. From this point onwards, I would expect that folks in the RG would start voicing their interest in shaping these scenarios further as well as actively contributing new ones.

  |An area such as "content dissemination",
  |however, then ends up to be so broad that it hardly provides a basis
  |for comparison as such. Hence, the document will ultimately need to
  |converge more in a description of scenarios that can indeed by
  |replicated in setups for experiments etc.

Couldn't agree more with you. I would however avoid overemphasizing this category, which is indeed too broad. Perhaps we should consider subcategories.

  |As a possible contribution or inspiration (if you will), let me point
  |to two pieces that might be useful:
  |1) at the start of the PSIRP project (the predecessor to the currently
  |ongoing PURSUIT project in the EU's FP7) in 2008, we asked project
  |members to write down "stories" of the beautiful new ICN world that
  |we/they envisioned, the stories largely centred around the idea of
  |"information at your fingertips". The outcome can be found at
  |http://www.psirp.org/files/Deliverables/PSIRP-TR08-0001_Vision.pdf
  |(skip over the vision part and jump straight to the stories)

Thanks for sharing! I think the scenarios in subsection 4.1-2 could enhance the social networking section, for example, although they're kind of covered already. Others, though, could form the foundation for new scenarios, esp. if there are related simulations/demos already available. Looking forward to some text for the draft :)

  |2) for the content dissemination aspect, we looked into something in
  |this area that is more than "making CDNs better" (personally, I have
  |doubts that this proposition would fly in any case, given the high
  |engineering efforts to make CDNs better, faster, grander, ...).

I think that the main point with ICN is that you can potentially offer all services without such a large infra and target different optimalities than those we go after today. CDNs are primarily serving large players. But I would really prefer to avoid having to continuously compare ICN with CDNs and what they can do today, or what they will be able to do tomorrow. I'm sure that a couple of decades ago many argued that circuit-switched was the only way to do voice. I hope we do not need to argue that CDN is the only way to do content dissemination in the future. 

<snip>
  |that such high degree of personalisation poses a significant burden on
  |production and delivery of the content. While standards such as MPEG
  |DASH attempt to provide solutions for this at the application level,
  |we see the fairly 'low level' realisation in an ICN as a potential
  |differentiator in this particular "scenario space", e.g., through the

I would be very interested to hear more about this, perhaps a paper/presentation?

Best Regards,

Kostas

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 6 Nov 2012 20:44:26 +0000

Hi Konstantinos,

> I think that the main point with ICN is that you can potentially offer all services without such a large infra and target different optimalities than those we go after today. CDNs are primarily ser…

Agree which is why I suggested the story-based delivery. The high degree of personalisation is something that could be an interesting spin to the content dissemination angle, posing interesting problems to the aspect of 'reachability' for publishers of such individual media assets.

> I would be very interested to hear more about this, perhaps a paper/presentation?

Nothing published as of yet but working on a submission as we speak. The videos I posted as links give an insight into the current work, though. Sorry that it is so little for now.

Best,

Dirk