Subject: [icnrg] draft-mockapetris-tschudin-dnsr-00.txt

From: [email-masked]
Date: Tue, 1 Apr 2014 09:12:48 +0200 (CEST)

When we speak about clean slate, an interesting exploration is to go 
back in time and indentify when ICN was first showing up in network 
architecture. I reckon that it must have been 1983 or earlier and that 
content centric networking has been part of TCP/IP since then, hiding in 
plain sight for over three decades!

Best regards,
christian

---
Prof. Dr. Christian F. Tschudin
Uni Basel | Computer Networks Group | cn.cs.unibas.ch

---

From: <[email-masked]>
Date: Tue, 1 Apr 2014 18:06:31 +0000

Actually, one could go back much further, if you want to stretch the ICN concept —

============
Mockapetris, P.~V.  (1978), Design considerations for the arpa lni name table, Technical Report~92, Univ. California Irvine, Dept. Information and Computer Science. [this is a hard paper to find online — I have a paper copy of it]
============

Interest/Object protocol (page 9): “First message: ‘do you have file X?’, second message: ‘Yes I do.’ or ‘Never heard of X.’”.

Naming data (page 10): “Suppose process names consist of four components: color, size, shape, and small.  A process might wish to send a message to those process for which color=red and shape=round.  It would be implemented by sending a message to color=red, size=*, shape=round, and small=*”.

============
Mark Weiser, L. Peter Deutsch and Peter B. Kessler, "UNIX Needs A True Integrated Environment:  CASE Closed”, PARC CSL-89-4 January 1989
============

Self-certified names (content object hash): "You can imagine a UNIX system that did allow the naming of things. In most cases, it would be file contents that would cause us a problem, so let's just consider naming them (and leave the naming  of system data structures for another time). Suppose every UNIX file had an extra unique number associated with it--a 64-bit hash of the contents with the last write time, say, such that this hash was  always different from other hashes whenever the file was different from other files. The hash, together with the filename, would name the contents of the file.  … New programs that wanted to name contents-not containers-would use the filename and the hash, and so have a way to build up relationships among objects, not just containers."

Marc

On Apr 1, 2014, at 12:12 AM, <[email-masked]> <[email-masked]> wrote:

> When we speak about clean slate, an interesting exploration is to go back in time and indentify when ICN was first showing up in network architecture. I reckon that it must have been 1983 or earlier and that content centric networking has been part of TCP/IP since then, hiding in plain sight for over three decades!
> 
> Best regards,
> christian
> 
> ---
> Uni Basel | Computer Networks Group | cn.cs.unibas.ch<draft-mockapetris-tschudin-dnsr-00.txt>_______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg