Subject: [icnrg] Example building automation system payloads

From: <[email-masked]>
Date: Wed, 14 Jan 2015 15:20:10 +0000

All,

There was a question related to the 802.15.4 talk about how big are actual IoT packets.  BACnet (bacnet.org<http://bacnet.org>) is an established building automation system (based on asn.1).  WireShark has some example BACnet traces.  Most of the packets are 20-30 bytes of UDP payload, some are larger file transfers.

http://wiki.wireshark.org/Protocols/bacnet

So, it appears feasible to wrap something like this inside CCN/NDN over 802.15.4 with a 1+1 or 1+0 encoding.  Of course, one would need to really look at the protocol and figure out how to map it to names, and part of what is currently in the payload would likely move to a name.

Marc

---

From: Ibrahim ABDULLAHI <[email-masked]>
Date: Thu, 15 Jan 2015 10:23:13 +0800

Dear all,
>From our team here, there were few questions on INTEREST and DATA in
CCN/NDN; are they of the same size in terms of memory required.
Logically, one may reason that INTEREST should require or use lesser memory
than the DATA.

Please looking forward to your answers.

[email-masked]

On Wed, Jan 14, 2015 at 11:20 PM, <[email-masked]> wrote:

>  All,
>
>  There was a question related to the 802.15.4 talk about how big are
> actual IoT packets.  BACnet (bacnet.org) is an established building
> automation system (based on asn.1).  WireShark has some example BACnet
> traces.  Most of the packets are 20-30 bytes of UDP payload, some are
> larger file transfers.
>
>  So, it appears feasible to wrap something like this inside CCN/NDN over
> 802.15.4 with a 1+1 or 1+0 encoding.  Of course, one would need to really
> look at the protocol and figure out how to map it to names, and part of
> what is currently in the payload would likely move to a name.
>
>  Marc
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>
>

-- 

*Regards.*

******************************************************************

*Ibrahim ABDULLAHI*

*B.Sc (UDU), M.Sc (ABU)*
*PhD Research Student, *

*InterNetworks Research Laboratory,*

*School of Computing; College of Arts and Sciences,*

*Universiti Utara Malaysia, UUM 06010 Sintok, Kedah, Darul Aman.*

*M A L A Y S I A (+60169290804)*

[email-masked]

[email-masked] <[email-masked]> *

******************************************************************

*Department of Mathematics/Computer Science.*

*Faculty of Natural Science, P.M.B 11*

*Ibrahim Badamasi Babangida University, Lapai.*

*Niger State. Nigeria.*

*NIGERIA: (+2348035991532) *

[email-masked] <[email-masked]>*

******************************************************************

******************************************************************