Subject: [icnrg] ICNRG Last Call on CCNx Drafts

From: "David Oran" <[email-masked]>
Date: Tue, 27 Jun 2017 08:23:11 -0400

The chairs are declaring an ICNRG last call on the two CCNx protocol 
documents:

https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxmessages/
https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxsemantics/

Please indicate your support or non-support, along with comments and 
justifications, in the next two weeks.
The last call will close on July 11 in order to assess the results 
before the ICNRG interim meeting on Sunday  July 16 in Prague.
We will have a discussion if needed as part of the Sunday agenda.

If the results of the last call are positive, we will progress the 
documents to IRTF last call.

Please give these documents your attention. They have been worked on for 
quite a while and need to be moved forward if feasible.

Thanks,

Dave, Dirk, & Börje.

---

From: Christopher Wood <[email-masked]>
Date: Tue, 27 Jun 2017 09:46:25 -0700

Naturally, I support these two documents. They are mature and have
been implemented by several different parties. They are ready to go.

Best,
Chris

On Tue, Jun 27, 2017 at 5:23 AM, David Oran <[email-masked]> wrote:
> The last call will close on July 11 in order to assess the results before
> the ICNRG interim meeting on Sunday  July 16 in Prague.
> If the results of the last call are positive, we will progress the documents
> to IRTF last call.
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Luca Muscariello <[email-masked]>
Date: Tue, 27 Jun 2017 19:02:55 +0200

Hi,

I strongly support that we move forward with these Internet drafts.

The CICN project partially implements these drafts and it would be
useful to have experimental RFCs as reference.

My experience with the implementation of these drafts is positive
and having them published as RFCs would let the ICNRG group focusing
on new protocols and tools associated to the core documents.

Thanks
Luca

---

From: Alberto Compagno <[email-masked]>
Date: Tue, 27 Jun 2017 19:54:06 +0200

Hi,

I’ve been using these documents as reference for then CCNx specification in my work, therefore I support them. 
I agree with Luca and Christopher that these documents are mature and ready for the next step.

Thanks,
Alberto

> On 27 Jun 2017, at 19:02, Luca Muscariello <[email-masked]> wrote:
> 
> Hi,
> 
> On Tue, Jun 27, 2017 at 2:23 PM, David Oran <[email-masked] <mailto:[email-masked]>> wrote:
> The chairs are declaring an ICNRG last call on the two CCNx protocol documents:
> 
> https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxmessages/ <https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxmessages/>
> https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxsemantics/ <https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxsemantics/>
> 
> Please indicate your support or non-support, along with comments and justifications, in the next two weeks.
> The last call will close on July 11 in order to assess the results before the ICNRG interim meeting on Sunday  July 16 in Prague.
> If the results of the last call are positive, we will progress the documents to IRTF last call.
> 
> Please give these documents your attention. They have been worked on for quite a while and need to be moved forward if feasible.
> 
> Thanks,
> 
> Dave, Dirk, & Börje.
> 
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/icnrg <https://www.irtf.org/mailman/listinfo/icnrg>
>

---

From: Ignacio Solis <[email-masked]>
Date: Tue, 27 Jun 2017 13:46:12 -0700

+1 to the docs!

Wishing I could make it to the next meeting to give in-person +1s too.

Nacho

-- 
Nacho - Ignacio Solis - [email-masked]

---

From: "Giovanna Carofiglio (gcarofig)" <[email-masked]>
Date: Tue, 27 Jun 2017 23:06:51 +0000

Hi all,

I also believe these documents have reached a good level of maturity and therefore support to move forward.

Regards
Giovanna 

> Il giorno 27 giu 2017, alle ore 13:46, Ignacio Solis <[email-masked]> ha scritto:
> 
> +1 to the docs!
>

---

From: Jim Gibson <[email-masked]>
Date: Wed, 28 Jun 2017 18:33:48 -0400

Support advancing these documents.

  * Experience includes involvement in multiple implementation based on
    these drafts.

On 6/27/17 8:23 AM, David Oran wrote:
> Please give these documents your attention. They have been worked on 
> for quite a while and need to be moved forward if feasible.
>
> Thanks,
>
> Dave, Dirk, & Börje.
>

---

From: "Jacques Samain (jsamain)" <[email-masked]>
Date: Wed, 28 Jun 2017 22:40:57 +0000

Hi all,

+1 for these documents.

Cheers,
Jacques

From: icnrg <[email-masked]> on behalf of "Jim Gibson (gibson)" <[email-masked]>
Date: Thursday, 29 June 2017 at 00:33
To: "[email-masked]" <[email-masked]>
Subject: Re: [icnrg] ICNRG Last Call on CCNx Drafts

  *   Experience includes involvement in multiple implementation based on these drafts.

Thanks,

Dave, Dirk, & Börje.

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: GTS <[email-masked]>
Date: Wed, 28 Jun 2017 17:19:18 -0700

I support adoption of these two drafts.

Cheers,
Gene Tsudik

> ---------- Forwarded message ----------
> From: David Oran <[email-masked]>
> Date: Tue, Jun 27, 2017 at 5:23 AM
> Subject: [icnrg] ICNRG Last Call on CCNx Drafts
>
>
>

---

From: Kazuaki Ueda <[email-masked]>
Date: Thu, 29 Jun 2017 10:39:51 +0900

Hi all,

I also support adoption of these documents.

Thanks,
Kazuaki

-- 
----------------------------------------------
       　　 < KDDI Research, Inc.>
　Business Vision: Challenge for the future
----------------------------------------------------
　　　　　　　　　au BLUE CHALLENGE
　KDDI/au supports for Japan National Football Team.
　　　　　　https://www.au.com/pr/soccer/
----------------------------------------------------
============================================================
植田 一暁（Kazuaki Ueda）
Associate Research Engineer
Future Communication System Lab.
KDDI Research, Inc.
E-mail: [email-masked]
============================================================

---

From: Jungha Hong <[email-masked]>
Date: Thu, 29 Jun 2017 08:58:34 +0000

Hi all,

I also support these two documents.

We have been using them as references in developing our project system.

Thanks,

Jungha Hong

________________________________
보낸 사람 : "David Oran" <[email-masked]>
보낸 날짜 : 2017-06-27 21:23:28 ( +09:00 )
받는 사람 : icnrg <[email-masked]>
참조 :
제목 : [icnrg] ICNRG Last Call on CCNx Drafts

documents:

Thanks,

Dave, Dirk, & Börje.

icnrg mailing list

[email-masked]

---

From: Cesar Ghali <[email-masked]>
Date: Thu, 29 Jun 2017 14:55:05 +0000

Hi all,

I support adopting these two drafts as well.

Cesar

On Thu, Jun 29, 2017 at 01:59 Jungha Hong <[email-masked]> wrote:

> ------------------------------
> *보낸 사람 : *"David Oran" <[email-masked]>
> *보낸 날짜 : *2017-06-27 21:23:28 ( +09:00 )
> *받는 사람 : *icnrg <[email-masked]>
> *참조 : *
> *제목 : *[icnrg] ICNRG Last Call on CCNx Drafts
>
>

---

From: Angelo MANTELLINI <[email-masked]>
Date: Thu, 29 Jun 2017 15:21:17 +0000

+1 for the documents
Angelo
________________________________
Da: icnrg <[email-masked]> per conto di Cesar Ghali <[email-masked]>
Inviato: giovedì 29 giugno 2017 16:55:05
A: David Oran; Jungha Hong; icnrg
Oggetto: Re: [icnrg] ICNRG Last Call on CCNx Drafts

Hi all,

Cesar

On Thu, Jun 29, 2017 at 01:59 Jungha Hong <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Thanks,

Jungha Hong

________________________________
보낸 사람 : "David Oran" <[email-masked]<mailto:[email-masked]>>
보낸 날짜 : 2017-06-27 21:23:28 ( +09:00 )
받는 사람 : icnrg <[email-masked]<mailto:[email-masked]>>
참조 :
제목 : [icnrg] ICNRG Last Call on CCNx Drafts

documents:

Thanks,

Dave, Dirk, & Börje.

icnrg mailing list

---

From: Andrea Detti <[email-masked]>
Date: Thu, 29 Jun 2017 19:00:23 +0200

+1 for the documents.

Andrea

On 29/06/2017 17:21, Angelo MANTELLINI wrote:
> +1 for the documents
> Angelo
> ------------------------------------------------------------------------
> *Da:* icnrg <[email-masked]> per conto di Cesar Ghali 
> <[email-masked]>
> *Inviato:* giovedì 29 giugno 2017 16:55:05
> *A:* David Oran; Jungha Hong; icnrg
> *Oggetto:* Re: [icnrg] ICNRG Last Call on CCNx Drafts
> Hi all,
>
>     ------------------------------------------------------------------------
>     *보낸 사람 : *"David Oran" <[email-masked]
>     <mailto:[email-masked]>>
>     *받는 사람 : *icnrg <[email-masked] <mailto:[email-masked]>>
>     *참조 : *

---

From: Greg White <[email-masked]>
Date: Fri, 30 Jun 2017 21:30:20 +0000

I support these drafts.

-Greg

On 6/27/17, 6:23 AM, "icnrg on behalf of David Oran" <[email-masked] on behalf of [email-masked]> wrote:

    

    
    Thanks,
    
    Dave, Dirk, & Börje.

---

From: Cenk Gündoğan <[email-masked]>
Date: Sat, 1 Jul 2017 00:54:19 +0200

Hello all,

In general, I also support both documents as they provide an
implementation-independent reference.
So, +1 from me.

I have some (more or less editorial) minor comments / nits, though:

* In [1], the ABNF seems to have an error in:
  ` ValidationAlg := RSA-SHA256 HMAC-SHA256 CRC32C`
  this should probably be:
  ` ValidationAlg := RSA-SHA256 / HMAC-SHA256 / CRC32C`

* Furthermore, the ABNF makes a distinction between `FirstSegment` and
  `Segment`. The definition of `Segment` allows a segment to be an empty
  string, however, I could not think of an advatange for this (?) IMO,
  `FirstSegment` and `Segment` can be merged to `Segment`, hence
  reducing the ABNF a little.

* In [2], the overall packet format is defined.
  - both `PacketLength` and `HeaderLength` include the fixed-header size
    of `8 bytes`. What is the advantage of recording the fixed-header
    size in those fields? Less CPU cycles during forwarding? When
    instead this size is assumed while parsing the header, then both
    fields would be able to address 8 bytes more of actual data.
  - To me, having a total packet length (`PacketLength`) field seems
    redundant, because it also includes the `HeaderLength`. If this
    field would instead record the PacketPayload length, then more data
    could be addressed. The total packet length would then be *8 bytes
    fixed header (assumed) + PacketPayloadLength + HeaderLength*

[1] https://tools.ietf.org/html/draft-irtf-icnrg-ccnxsemantics-03#section-2.1
[2] https://tools.ietf.org/html/draft-irtf-icnrg-ccnxmessages-04#section-3.1

Cheers,
Cenk

-- 
Cenk Gündoğan

Hamburg University of Applied Sciences
Dept. of Computer Science / Internet Technologies Group
Berliner Tor 7, 20099 Hamburg, Germany
Fon: +49 40 42875 - 8426
Mail: [email-masked]
Web: https://www.inet.haw-hamburg.de/

---

From: Christopher Wood <[email-masked]>
Date: Fri, 30 Jun 2017 22:04:40 -0700

>   ` ValidationAlg := RSA-SHA256 / HMAC-SHA256 / CRC32C`

Thanks for the catch. We will fix this.

>   reducing the ABNF a little.

Technically, yes, though we left the FirstSegment distinct to allow
for special processing if so desired. If others think we can (should)
change it, this is also trivial.

>     fixed header (assumed) + PacketPayloadLength + HeaderLength*

Others might have different thoughts about this, but the current
scheme was chosen because the header Length field in protocols such as
UDP traditionally includes the length. Saving an extra 8 bytes doesn't
seem like it's worth breaking a long-standing contract. (Though,
again, I'm not bound to one way or the other.)

Best,
Chris

---

From: Luca Muscariello <[email-masked]>
Date: Sat, 01 Jul 2017 05:46:43 +0000

The day we will have  optional fixed-header fields, having the size of the
fixed header
included will help.

For the time being I would suggest to keep the current approach. Unless
there are very good reasons to change it.