Subject: [icnrg] I-D Action: draft-irtf-icnrg-ccnxsemantics-08.txt

From: [email-masked]
Date: Wed, 20 Jun 2018 14:05:24 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Information-Centric Networking RG of the IRTF.

        Title           : CCNx Semantics
        Authors         : Marc Mosko
                          Ignacio Solis
                          Christopher A. Wood
	Filename        : draft-irtf-icnrg-ccnxsemantics-08.txt
	Pages           : 35
	Date            : 2018-06-20

Abstract:
   This document describes the core concepts of the Content Centric
   Networking (CCNx) architecture and presents a network protocol based
   on two messages: Interests and Content Objects.  It specifies the set
   of mandatory and optional fields within those messages and describes
   their behavior and interpretation.  This architecture and protocol
   specification is independent of a specific wire encoding.

   The protocol also uses a Control message called an InterestReturn,
   whereby one system can return an Interest message to the previous hop
   due to an error condition.  This indicates to the previous hop that
   the current system will not respond to the Interest.

   This document is a product of the Information Centric Networking
   research group (ICNRG).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxsemantics/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-icnrg-ccnxsemantics-08
https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-ccnxsemantics-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-ccnxsemantics-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Wed, 20 Jun 2018 21:13:19 +0000

All,

We have updated the CCNx Semantics document to address feedback from the -07 draft and to give it some general editing.  Here is a summary of the differences.  You can see the exact diffs from the tracker.

Please review and send me feedback so we can hopefully address any remaining concerns before Montreal.

  1.  Removed comparisons to NDN, only left NDN as a citation.   There is a very short comparison to CCNx 0.x.
  2.  Some general style, spelling, and English grammar edits.
  3.  The message ABNF grammar did not include the concept of Vendor-specific data.  I added it.  It was already baked in to the messages document.
  4.  There was an unlinked reference to key trust that was not in the Bibliography, so I added a reference to Chris’ paper.
  5.  In the HopLimit section, I added some more text explaining that a loop is also terminated by a PIT entry or having the content in the Content Store.  I also added an example HopLimit processing pipeline.
  6.  In the Interest Aggregation section, I added text that if a new Interest has a larger HopLimit than the PIT entry, it must be forwarded (not aggregated).
  7.  In the Content Store section, I re-arranged some of the text to make it clearer that checking signatures is not required, but if not done it results in cache miss for Interests that restrict the KeyId.

Marc

On Jun 20, 2018, at 2:05 PM, [email-masked]<mailto:[email-masked]> wrote:

       Title           : CCNx Semantics
       Authors         : Marc Mosko
                         Ignacio Solis
                         Christopher A. Wood

Abstract:

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 20 Jun 2018 14:26:37 -0700

Note to RG participants: this is the candidate revision to send to the 
IRSG for final approval poll and if successful submission to the RFC 
editor for publication.

On 20 Jun 2018, at 14:13, [email-masked] wrote:

> All,
>
> We have updated the CCNx Semantics document to address feedback from 
> the -07 draft and to give it some general editing.  Here is a summary 
> of the differences.  You can see the exact diffs from the tracker.
>
>   3.  The message ABNF grammar did not include the concept of 
> Vendor-specific data.  I added it.  It was already baked in to the 
> messages document.
>   4.  There was an unlinked reference to key trust that was not in the 
> Bibliography, so I added a reference to Chris’ paper.
>   5.  In the HopLimit section, I added some more text explaining that 
> a loop is also terminated by a PIT entry or having the content in the 
> Content Store.  I also added an example HopLimit processing pipeline.
>   6.  In the Interest Aggregation section, I added text that if a new 
> Interest has a larger HopLimit than the PIT entry, it must be 
> forwarded (not aggregated).
>   7.  In the Content Store section, I re-arranged some of the text to 
> make it clearer that checking signatures is not required, but if not 
> done it results in cache miss for Interests that restrict the KeyId.
>
>
> Marc
>
> On Jun 20, 2018, at 2:05 PM, 
> [email-masked]<mailto:[email-masked]> wrote:
>
>

DaveO

---

From: Luca Muscariello <[email-masked]>
Date: Thu, 21 Jun 2018 11:04:32 +0200

Marc,

minor comments:
- Is Chris email address and affiliation the right one?
- This reference seems outdated [CCN] PARC, Inc., "CCNx Open Source", 2007,
<http://www.CCNx.org <http://www.ccnx.org/>>.
and BTW it is never used in the draft.
-  RFC3552, RFC3986  are never cited in the draft but appear in the
references
Either cite them in the text or remove from references?

Thanks for revision, it looks good to me.

Luca

On Wed, Jun 20, 2018 at 11:13 PM <[email-masked]> wrote:

> All,
>
> We have updated the CCNx Semantics document to address feedback from the
> -07 draft and to give it some general editing.  Here is a summary of the
> differences.  You can see the exact diffs from the tracker.
>
>    Vendor-specific data.  I added it.  It was already baked in to the messages
>    document.
>    5. In the HopLimit section, I added some more text explaining that a
>    loop is also terminated by a PIT entry or having the content in the Content
>    Store.  I also added an example HopLimit processing pipeline.
>    Interest has a larger HopLimit than the PIT entry, it must be forwarded
>    (not aggregated).
>    make it clearer that checking signatures is not required, but if not done
>    it results in cache miss for Interests that restrict the KeyId.
>
>
> Marc
>
> On Jun 20, 2018, at 2:05 PM, [email-masked] wrote:
>
>

---

From: <[email-masked]>
Date: Thu, 21 Jun 2018 17:11:21 +0000

Thank you!  I’ll generate a new draft on Monday 25th with these fixes.

I’ll confirm with Chris, but that was the last address he put in.

The CICN reference should have replaced the CCN, so I likely forgot to remove the bibliography.  I’ll check on the RFC 3552, that might need to be in the security section.

We do need to petition for the ccnx: URI.  We have a draft on the URI usage, so I think we have everything needed.

Marc

On Jun 21, 2018, at 2:04 AM, Luca Muscariello <[email-masked]<mailto:[email-masked]>> wrote:

Marc,

minor comments:
- Is Chris email address and affiliation the right one?
- This reference seems outdated [CCN] PARC, Inc., "CCNx Open Source", 2007, <http://www.CCNx.org<http://www.ccnx.org/>>.
and BTW it is never used in the draft.
-  RFC3552, RFC3986  are never cited in the draft but appear in the references
Either cite them in the text or remove from references?

Luca

On Wed, Jun 20, 2018 at 11:13 PM <[email-masked]<mailto:[email-masked]>> wrote:
All,

Marc

       Title           : CCNx Semantics
       Authors         : Marc Mosko
                         Ignacio Solis
                         Christopher A. Wood

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg