Subject: [Id-event] Fwd: New Version Notification for draft-hunt-idevent-token-03.txt

From: Phil Hunt <[email-masked]>
Date: Thu, 18 Aug 2016 09:10:20 -0700

Draft 03 has been published.

This includes editorial clarifications to:
* Define the outer layer as a SET “envelope”, vs embedded JSON as “payload”
* Clarify that only a single event should be conveyed plus optional extensions.
* General edits to improve readability
* Register the “events” claim as a  JWT attribute (see IANA considerations)

Many thanks to Mike and Sarah and who contributed significant editorial feedback.

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-hunt-idevent-token-03.txt
> Date: August 18, 2016 at 9:03:35 AM PDT
> To: "Michael B. Jones" <[email-masked]>, "William Denniss" <[email-masked]>, "Phil Hunt" <[email-masked]>, "Morteza Ansari" <[email-masked]>, "Michael Jones" <[email-masked]>
> 
> 
> A new version of I-D, draft-hunt-idevent-token-03.txt
> has been successfully submitted by Phil Hunt and posted to the
> IETF repository.
> 
> Name:		draft-hunt-idevent-token
> Revision:	03
> Title:		Security Event Token (SET)
> Document date:	2016-08-18
> Group:		Individual Submission
> Pages:		16
> URL:            https://www.ietf.org/internet-drafts/draft-hunt-idevent-token-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-hunt-idevent-token/
> Htmlized:       https://tools.ietf.org/html/draft-hunt-idevent-token-03
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-hunt-idevent-token-03
> 
> Abstract:
>   This specification defines the Security Event token, which may be
>   distributed via a protocol such as HTTP.  The Security Event Token
>   (SET) specification profiles the JSON Web Token (JWT) and may be
>   optionally signed and/or encrypted.  A SET describes a statement of
>   fact that may be shared by an event publisher with event subscribers.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Vladimir Dzhuvinov <[email-masked]>
Date: Fri, 19 Aug 2016 17:41:56 +0300

I just went through the new version, the text has a much better
structure and clarity now.

Thanks everyone!

On 18/08/16 19:10, Phil Hunt via Openid-specs-ab wrote:
> _______________________________________________
> Openid-specs-ab mailing list
> [email-masked]
> http://lists.openid.net/mailman/listinfo/openid-specs-ab

-- 
Vladimir Dzhuvinov :: [email-masked]

---

From: Kiran Ayyagari <[email-masked]>
Date: Sun, 21 Aug 2016 07:41:28 +0530

Is there any specific reason for making "events" attribute an array of
event URIs?

If not, can this be turned into an object containing <event-uri,
event-data> pairs?

Thank you.

On Thu, Aug 18, 2016 at 9:40 PM, Phil Hunt <[email-masked]> wrote:

> www.independentid.com
> [email-masked]
> *From: [email-masked]
> *Subject: **New Version Notification for draft-hunt-idevent-token-03.txt*
> *Date: *August 18, 2016 at 9:03:35 AM PDT
> *To: *"Michael B. Jones" <[email-masked]>, "William Denniss" <
> [email-masked]>, "Phil Hunt" <[email-masked]>, "Morteza Ansari"
> <[email-masked]>, "Michael Jones" <[email-masked]>
>
>
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event
>
> Kiran Ayyagari