Subject: [Id-event] Use case document

From: Dick Hardt <[email-masked]>
Date: Wed, 3 May 2017 15:56:23 -0700

Phil / Marius

At the Chicago meeting, the two of you agreed to work on a document
containing use cases you considered to be relevant for secevent so that the
WG could decide which ones were in scope and which ones were out of scope.

Checking in on the status of the use case document. Would you provide an
update when you have a chance?

/Dick

---

From: Phil Hunt <[email-masked]>
Date: Wed, 3 May 2017 16:16:47 -0700

My understanding was you wanted informal cases not IDs. The SCIM cases have been posted to the mailing list. I believe Marius is close on the RISC cases.

Phil

Oracle Corporation, Identity Cloud Services Architect & Standards
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>
> On May 3, 2017, at 3:56 PM, Dick Hardt <[email-masked]> wrote:
> 
> Phil / Marius
> 
> At the Chicago meeting, the two of you agreed to work on a document containing use cases you considered to be relevant for secevent so that the WG could decide which ones were in scope and which ones were out of scope.
> 
> Checking in on the status of the use case document. Would you provide an update when you have a chance?
> 
> /Dick
> 
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=HWdy4Q9fHAYB3f-DZ2GWUJnaZDGcZQRaMexC2oHuR7g&s=JTwCxbXPzY_A62IiywTMIjRB-XsMY8UPafBs4oPwOTc&e=

---

From: Dick Hardt <[email-masked]>
Date: Wed, 3 May 2017 16:31:09 -0700

Hi Phil

per

https://mailarchive.ietf.org/arch/msg/id-event/FGuz9IsUMKqKeq2OjEBjCZ9cBcI

you offered to put them in a WG doc (see quate below). Would that not be an
ID. Also, as I read over the document, it is hard to follow what the use
cases are as it is very verbose.

On Tue, Apr 18, 2017 at 11:27 AM, Phil Hunt <[email-masked]>
<[email-masked]&gt>; wrote:

> All,
>
> Dick asked me if I would enumerate the SCIM use cases.  Here is the SCIM
> case. Happy to put these somewhere in a working group document.

On Wed, May 3, 2017 at 4:16 PM, Phil Hunt <[email-masked]> wrote:

> My understanding was you wanted informal cases not IDs. The SCIM cases
> have been posted to the mailing list. I believe Marius is close on the RISC
> cases.
>
> Phil
>
> www.independentid.com
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=
> RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=
> JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=HWdy4Q9fHAYB3f-
> DZ2GWUJnaZDGcZQRaMexC2oHuR7g&s=JTwCxbXPzY_A62IiywTMIjRB-
> XsMY8UPafBs4oPwOTc&e=
>
>
>

-- 
Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn about
projects I am working on!

---

From: Phil Hunt <[email-masked]>
Date: Wed, 3 May 2017 16:39:24 -0700

Depends on what the WG wants.

Email cases,
Github posted document,
Individual IDs posted to the working group, or
an ID that gets adopted as a WG draft to end up as RFC (e.g. JOSE has RFC7165, and SCIM itself had RFC7642, Oauth had a WG draft https://tools.ietf.org/html/draft-ietf-oauth-use-cases-03).

Let us know what form and what format.

We can also use one for OpenID Backchannel Logout.  This is particularly important because it will be triggered by (or is related to) SCIM and by RISC events such as account resets, authentication factor changes etc.

Phil

> On May 3, 2017, at 4:31 PM, Dick Hardt <[email-masked]> wrote:
> 
> Hi Phil
> 
> per 
> 
> https://mailarchive.ietf.org/arch/msg/id-event/FGuz9IsUMKqKeq2OjEBjCZ9cBcI <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_id-2Devent_FGuz9IsUMKqKeq2OjEBjCZ9cBcI&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=ebhqgdwBfmclFpVn-cScD6uoiYqkmZVlRpC3XXk91Es&e=>
> 
> you offered to put them in a WG doc (see quate below). Would that not be an ID. Also, as I read over the document, it is hard to follow what the use cases are as it is very verbose.
> 
> On Tue, Apr 18, 2017 at 11:27 AM, Phil Hunt <[email-masked]> <mailto:[email-masked]&gt>; wrote:
> 
> > All,
> >
> On Wed, May 3, 2017 at 4:16 PM, Phil Hunt <[email-masked] <mailto:[email-masked]>> wrote:
> www.independentid.com <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.independentid.com&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=nBNO3_d_Mw4enpU54VxuTcoqCJSXkSSzg8LnXIkI5bg&e=>[email-masked] <mailto:[email-masked]>
>> On May 3, 2017, at 3:56 PM, Dick Hardt <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Phil / Marius
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=HWdy4Q9fHAYB3f-DZ2GWUJnaZDGcZQRaMexC2oHuR7g&s=JTwCxbXPzY_A62IiywTMIjRB-XsMY8UPafBs4oPwOTc&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=HWdy4Q9fHAYB3f-DZ2GWUJnaZDGcZQRaMexC2oHuR7g&s=JTwCxbXPzY_A62IiywTMIjRB-XsMY8UPafBs4oPwOTc&e=> 
> 
> 
> 
> 
> -- 
> Subscribe to the HARDTWARE <https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=uVstd9R0_1UCdJ6s_rcX7xhYo6fyGuk22APkiwL0vpI&e=> mail list to learn about projects I am working on!
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=fzkXYKa7l9vPc2VrpDeaBZo7bH9cDrk9wUethVbuCS8&e=

---

From: Dick Hardt <[email-masked]>
Date: Wed, 3 May 2017 16:45:55 -0700

As the more experienced chair, I will defer to Yaron for guidance.

So far no one has expected it to be adopted as an RFC

On Wed, May 3, 2017 at 4:39 PM, Phil Hunt <[email-masked]> wrote:

> an ID that gets adopted as a WG draft to end up as RFC (e.g. JOSE has
> RFC7165, and SCIM itself had RFC7642, Oauth had a WG draft
> https://tools.ietf.org/html/draft-ietf-oauth-use-cases-03).
>
> We can also use one for OpenID Backchannel Logout.  This is particularly
> important because it will be triggered by (or is related to) SCIM and by
> RISC events such as account resets, authentication factor changes etc.
>
> Phil
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_id-2Devent_FGuz9IsUMKqKeq2OjEBjCZ9cBcI&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=ebhqgdwBfmclFpVn-cScD6uoiYqkmZVlRpC3XXk91Es&e=>
>
> you offered to put them in a WG doc (see quate below). Would that not be
> an ID. Also, as I read over the document, it is hard to follow what the use
> On Tue, Apr 18, 2017 at 11:27 AM, Phil Hunt <[email-masked]> <[email-masked]&gt>; wrote:
>
> > All,
> >
>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.independentid.com&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=nBNO3_d_Mw4enpU54VxuTcoqCJSXkSSzg8LnXIkI5bg&e=>
>> [email-masked]
>>
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iet
>> f.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHv
>> lZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivz
>> jWwlNKe4C_lLIGk&m=HWdy4Q9fHAYB3f-DZ2GWUJnaZDGcZQRaMexC2oHuR7
>> g&s=JTwCxbXPzY_A62IiywTMIjRB-XsMY8UPafBs4oPwOTc&e=
>>
>>
>>
>
>
> --
> Subscribe to the HARDTWARE
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=uVstd9R0_1UCdJ6s_rcX7xhYo6fyGuk22APkiwL0vpI&e=>
> mail list to learn about projects I am working on!
> JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=
> bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=
> fzkXYKa7l9vPc2VrpDeaBZo7bH9cDrk9wUethVbuCS8&e=
>
>
>

---

From: Justin Richer <[email-masked]>
Date: Wed, 3 May 2017 21:57:04 -0700

In fact, I’m going to ask that we *not* push a use cases document toward RFC. Use case documents are wonderful tools for guiding development, but should be discarded as artifacts of that process once said process is completed (or even well on its way).

As such, RFC, wiki, blog post, or anything referenced from the list and easily findable works.

 — Justin

> On May 3, 2017, at 4:45 PM, Dick Hardt <[email-masked]> wrote:
> 
> On Wed, May 3, 2017 at 4:39 PM, Phil Hunt <[email-masked] <mailto:[email-masked]>> wrote:
> an ID that gets adopted as a WG draft to end up as RFC (e.g. JOSE has RFC7165, and SCIM itself had RFC7642, Oauth had a WG draft https://tools.ietf.org/html/draft-ietf-oauth-use-cases-03 <https://tools.ietf.org/html/draft-ietf-oauth-use-cases-03>).
> 
>> On May 3, 2017, at 4:31 PM, Dick Hardt <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Phil
>> 
>> per 
>> 
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=fzkXYKa7l9vPc2VrpDeaBZo7bH9cDrk9wUethVbuCS8&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=fzkXYKa7l9vPc2VrpDeaBZo7bH9cDrk9wUethVbuCS8&e=> 
> 
> 
> 
> 
> -- 
> Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn about projects I am working on!
> https://www.ietf.org/mailman/listinfo/id-event <https://www.ietf.org/mailman/listinfo/id-event>

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 4 May 2017 13:36:10 +0300

My strong preference would be an individual I-D that (as Justin says) 
will NOT be pushed to RFC. Why an I-D at all? Because this is what IETF 
folks are used to, and it is referenced from the WG agenda and minutes.

Thanks,

     Yaron

On 04/05/17 07:57, Justin Richer wrote:
> In fact, I’m going to ask that we *not* push a use cases document 
> toward RFC. Use case documents are wonderful tools for guiding 
> development, but should be discarded as artifacts of that process once 
> said process is completed (or even well on its way).
>
>> On May 3, 2017, at 4:45 PM, Dick Hardt <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> On Wed, May 3, 2017 at 4:39 PM, Phil Hunt<[email-masked] 
>> <mailto:[email-masked]>>wrote:
>>
>>     an ID that gets adopted as a WG draft to end up as RFC (e.g. JOSE
>>     has RFC7165, and SCIM itself had RFC7642, Oauth had a WG
>>     drafthttps://tools.ietf.org/html/draft-ietf-oauth-use-cases-03
>>     <https://tools.ietf.org/html/draft-ietf-oauth-use-cases-03>).
>>
>>     We can also use one for OpenID Backchannel Logout.  This is
>>     particularly important because it will be triggered by (or is
>>     related to) SCIM and by RISC events such as account resets,
>>     authentication factor changes etc.
>>
>>     Phil
>>
>>     www.independentid.com <http://www.independentid.com/>
>>     [email-masked] <mailto:[email-masked]>
>>
>>>     you offered to put them in a WG doc (see quate below). Would
>>>     that not be an ID. Also, as I read over the document, it is hard
>>>     to follow what the use cases are as it is very verbose.
>>>
>>>     On Wed, May 3, 2017 at 4:16 PM, Phil Hunt<[email-masked]
>>>     <mailto:[email-masked]>>wrote:
>>>
>>>         My understanding was you wanted informal cases not IDs. The
>>>         SCIM cases have been posted to the mailing list. I believe
>>>         Marius is close on the RISC cases.
>>>
>>>         Phil
>>>
>>>         [email-masked] <mailto:[email-masked]>
>>>
>>>>         On May 3, 2017, at 3:56 PM, Dick Hardt
>>>>         <[email-masked] <mailto:[email-masked]>> wrote:
>>>>
>>>>         Phil / Marius
>>>>
>>>>         At the Chicago meeting, the two of you agreed to work on a
>>>>         document containing use cases you considered to be relevant
>>>>         for secevent so that the WG could decide which ones were in
>>>>         scope and which ones were out of scope.
>>>>
>>>>         Checking in on the status of the use case document. Would
>>>>         you provide an update when you have a chance?
>>>>
>>>>         /Dick
>>>>
>>>>         <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=HWdy4Q9fHAYB3f-DZ2GWUJnaZDGcZQRaMexC2oHuR7g&s=JTwCxbXPzY_A62IiywTMIjRB-XsMY8UPafBs4oPwOTc&e=>
>>>
>>>
>>>
>>>
>>>     --
>>>     Subscribe to theHARDTWARE
>>>     <https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=uVstd9R0_1UCdJ6s_rcX7xhYo6fyGuk22APkiwL0vpI&e=>mail
>>>     list to learn about projects I am working on!
>>>     <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=fzkXYKa7l9vPc2VrpDeaBZo7bH9cDrk9wUethVbuCS8&e=>
>>
>>
>>
>>
>> --
>> Subscribe to theHARDTWARE <http://hardtware.com/>mail list to learn 
>> about projects I am working on!
>> https://www.ietf.org/mailman/listinfo/id-event
>

---

From: Marius Scurtescu <[email-masked]>
Date: Thu, 4 May 2017 08:25:19 -0700

Do we need one document for all use cases (all profiles) or one for each
profiles?

I am happy to create the one document or the one for RISC (if one per
profile).

Marius

On Thu, May 4, 2017 at 3:36 AM, Yaron Sheffer <[email-masked]> wrote:

> My strong preference would be an individual I-D that (as Justin says) will
> NOT be pushed to RFC. Why an I-D at all? Because this is what IETF folks
> are used to, and it is referenced from the WG agenda and minutes.
>
> Thanks,
>
>     Yaron
>
> In fact, I’m going to ask that we *not* push a use cases document toward
> RFC. Use case documents are wonderful tools for guiding development, but
> should be discarded as artifacts of that process once said process is
> completed (or even well on its way).
>
>>> lZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzj
>>> WwlNKe4C_lLIGk&m=HWdy4Q9fHAYB3f-DZ2GWUJnaZDGcZQRaMexC2oHuR7g
>>> &s=JTwCxbXPzY_A62IiywTMIjRB-XsMY8UPafBs4oPwOTc&e=
>>>
>>>
>>>
>>
>>
>> --
>> jWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4
>> Q&s=fzkXYKa7l9vPc2VrpDeaBZo7bH9cDrk9wUethVbuCS8&e=
>>
>>
>>
>
>
> --

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 4 May 2017 21:28:23 +0300

Whatever works for you - and that's the whole point of *individual* I-Ds.

Thanks,

     Yaron

On 04/05/17 18:25, Marius Scurtescu wrote:
> Do we need one document for all use cases (all profiles) or one for 
> each profiles?
>
> On Thu, May 4, 2017 at 3:36 AM, Yaron Sheffer <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     My strong preference would be an individual I-D that (as Justin
>     says) will NOT be pushed to RFC. Why an I-D at all? Because this
>     is what IETF folks are used to, and it is referenced from the WG
>     agenda and minutes.
>
>     Thanks,
>
>         Yaron
>
>
>>     development, but should be discarded as artifacts of that process
>>     once said process is completed (or even well on its way).
>>
>>>         an ID that gets adopted as a WG draft to end up as RFC (e.g.
>>>         JOSE has RFC7165, and SCIM itself had RFC7642, Oauth had a
>>>         WG
>>>         particularly important because it will be triggered by (or
>>>         is related to) SCIM and by RISC events such as account
>>>         resets, authentication factor changes etc.
>>>
>>>         Phil
>>>
>>>>         On May 3, 2017, at 4:31 PM, Dick Hardt
>>>>         you offered to put them in a WG doc (see quate below).
>>>>         Would that not be an ID. Also, as I read over the document,
>>>>         it is hard to follow what the use cases are as it is very
>>>>         verbose.
>>>>
>>>>         On Wed, May 3, 2017 at 4:16 PM, Phil
>>>>         Hunt<[email-masked] <mailto:[email-masked]>>wrote:
>>>>
>>>>             My understanding was you wanted informal cases not IDs.
>>>>             The SCIM cases have been posted to the mailing list. I
>>>>             believe Marius is close on the RISC cases.
>>>>
>>>>             Phil
>>>>
>>>>>             At the Chicago meeting, the two of you agreed to work
>>>>>             on a document containing use cases you considered to
>>>>>             be relevant for secevent so that the WG could decide
>>>>>             which ones were in scope and which ones were out of scope.
>>>>>
>>>>>             Checking in on the status of the use case document.
>>>>>             Would you provide an update when you have a chance?
>>>>>
>>>>>             /Dick
>>>>>
>>>     Subscribe to theHARDTWARE <http://hardtware.com/>mail list to
>>>     learn about projects I am working on!
>>>     <https://www.ietf.org/mailman/listinfo/id-event>
>>
>
>

---

From: Marius Scurtescu <[email-masked]>
Date: Wed, 31 May 2017 17:22:41 -0700

Here is an initial use case document, for now it has only the RISC use
cases we discussed so far. When Phil gets back I will coordinate with him
to add SCIM use cases to this same I-D. I will get this into a decent shape
for the IETF meeting.

Marius

On Thu, May 4, 2017 at 11:28 AM, Yaron Sheffer <[email-masked]>
wrote:

>>> WwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q
>>> &s=fzkXYKa7l9vPc2VrpDeaBZo7bH9cDrk9wUethVbuCS8&e=
>>>
>>>
>>>
>>
>>
>> --

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Wed, 31 May 2017 21:33:47 -0300

Marius,

Go ahead an submit as an individual draft. I will submit scim cases in a separate draft. 

Afaik there is no plan to have this he a single wg document. 

Phil

> On May 31, 2017, at 9:22 PM, Marius Scurtescu <[email-masked]> wrote:
> 
> Here is an initial use case document, for now it has only the RISC use cases we discussed so far. When Phil gets back I will coordinate with him to add SCIM use cases to this same I-D. I will get this into a decent shape for the IETF meeting.
> 
> Marius
> 
>> On Thu, May 4, 2017 at 11:28 AM, Yaron Sheffer <[email-masked]> wrote:
>>> Do we need one document for all use cases (all profiles) or one for each profiles?
>>> 
>>> I am happy to create the one document or the one for RISC (if one per profile).
>>> 
>>> Marius
>>> 
>>>> My strong preference would be an individual I-D that (as Justin says) will NOT be pushed to RFC. Why an I-D at all? Because this is what IETF folks are used to, and it is referenced from the WG agenda and minutes.
>>>> 
>>>> Thanks,
>>>> 
>>>>     Yaron
>>>> 
>>>>>>>> On Tue, Apr 18, 2017 at 11:27 AM, Phil Hunt <[email-masked]>; wrote:
>>>>>>>> 
>>>>>>>> > All,
>>>>>>>> >
>>>>>>>> Subscribe to the HARDTWARE mail list to learn about projects I am working on!
>>>>>> Subscribe to the HARDTWARE mail list to learn about projects I am working on!
> <draft-scurtescu-secevent-use-cases.txt>
> <draft-scurtescu-secevent-use-cases.pdf>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=t5e3IvZ_e-KRHUBVMfjtwKEs74yLZva4z-6OkkgmSjo&e=

---

From: Dick Hardt <[email-masked]>
Date: Wed, 31 May 2017 18:24:02 -0700

Agreed. There is no requirement for these to be in the same document.

On Wed, May 31, 2017 at 5:33 PM, Phil Hunt (IDM) <[email-masked]>
wrote:

>>>> https://tools.ietf.org/html/draft-ietf-oauth-use-cases-03
>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Doauth-2Duse-2Dcases-2D03&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=_t4GRDPaCMns1jW640uMNo_o5BHH8kJCCQXUTLi9Qak&e=>
>>>> ).
>>>>
>>>> particularly important because it will be triggered by (or is related to)
>>>> SCIM and by RISC events such as account resets, authentication factor
>>>> changes etc.
>>>>
>>>> Phil
>>>>
>>>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.independentid.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=5rKXnv7GYvvsJ5huPmoGI3PpP85fUnQZrrKByzbbmYA&e=>
>>>> [email-masked]
>>>>
>>>> you offered to put them in a WG doc (see quate below). Would that not
>>>> be an ID. Also, as I read over the document, it is hard to follow what the
>>>> use cases are as it is very verbose.
>>>>
>>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=vljaqeEQFcDwsi_zNO5R2uecLv2B3VE8QvdEVBRHIGI&e=>
>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=t5e3IvZ_e-KRHUBVMfjtwKEs74yLZva4z-6OkkgmSjo&e=>
>>>
>>>
>>>
>>>
>>
>>
> JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-
> LWrcrcTS6Ly1w14yDo0vk&s=t5e3IvZ_e-KRHUBVMfjtwKEs74yLZva4z-6OkkgmSjo&e=
>
>