Subject: [Id-event] Secevents IETF 100 discussion (minutes)

From: Phil Hunt <[email-masked]>
Date: Thu, 30 Nov 2017 18:32:07 -0800

Over the week at IETF100 there was initially the official wg meeting plus a number of daily side meetings.  

I have not seen the minutes yet, so here are some of my thoughts on the new draft from Annabelle. 

The change in direction is substantial (a totally new format and design principle) and I recommend strongly that people read the new draft from Annabelle. 

I am aware of some people that could not attend that would like to catch up with minutes before commenting.

A key design difference is the new individual draft acts more as a command message. A SET event is singular and expresses specific intent by the issuer that may be more easily understood. In contrast, the WG draft describes a set of event statements (eg one or more state changes) by the issuer where the receiver decides meaning and action if any within its own context. 

I will provide further commentary later. For now I am very concerned with the change in design that suggests SETs be more like structured commands by transmitters to receiving parties. 

Best regards,

Phil

---

From: Dick Hardt <[email-masked]>
Date: Fri, 01 Dec 2017 04:41:20 +0000

I will be posting a summary of the side meetings real-soon-now.

Per an earlier post, I’ll be posting some questions looking to get
consensus on a number of topics.

On Thu, Nov 30, 2017 at 6:32 PM Phil Hunt <[email-masked]> wrote:

> The change in direction is substantial (a totally new format and design
> principle) and I recommend strongly that people read the new draft from
> Annabelle.
>
> A key design difference is the new individual draft acts more as a command
> message. A SET event is singular and expresses specific intent by the
> issuer that may be more easily understood. In contrast, the WG draft
> describes a set of event statements (eg one or more state changes) by the
> issuer where the receiver decides meaning and action if any within its own
> context.
>
> I will provide further commentary later. For now I am very concerned with
> the change in design that suggests SETs be more like structured commands by
> transmitters to receiving parties.
>
> Best regards,
>
> Phil
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event
>
-- 
Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn about
projects I am working on!