Subject: [Id-event] Plan for the Week

From: Luke Camery <[email-masked]>
Date: Tue, 14 Nov 2017 03:45:09 +0000

*Future Meetings*
Wednesday - 10:30-12:00 in Butterworth on Annabelle's Alternative SET
Proposal
Thursday - 15:30-18:00 in the Atrium on Marius' Control Plane
Friday - 10:00-18:00 at Google Singapore (70 Pasir Panjang Road, #03-71,
117371) on Work Session

-- 

*  •  **Luke Camery*
*  •  *Associate Product Manager
*  •  *Federated Identity

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Tue, 14 Nov 2017 04:11:09 +0000

Correction: the Wednesday meeting is from 10:30 to 12:30.

Sent from my iPhone

On Nov 14, 2017, at 11:46 AM, Luke Camery <[email-masked]<mailto:[email-masked]>> wrote:

Future Meetings
Wednesday - 10:30-12:00 in Butterworth on Annabelle's Alternative SET Proposal
Thursday - 15:30-18:00 in the Atrium on Marius' Control Plane
Friday - 10:00-18:00 at Google Singapore (70 Pasir Panjang Road, #03-71, 117371) on Work Session

--
[http://i.imgur.com/Ya4Rhss.gif]

  *  Luke Camery
  *  Associate Product Manager
  *  Federated Identity

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Tue, 14 Nov 2017 14:54:07 +0000

Here is the draft I will be presenting during tomorrow’s meeting: https://github.com/richanna/secevent/blob/set-alt/draft-richanna-secevent-token.txt

Highlights:

  *   Section 2 is almost completely rewritten, with the following major changes:
     *   I stripped out redundant text within the draft and between it and RFC 7519.
     *   Makes more explicit the idea of a SET envelope and an event payload. Nudges Profiling Specs toward defining event payload claims.
     *   “events” claim is now “event”
     *   I pulled in the Subject Identifier concept defined in https://tools.ietf.org/html/draft-scurtescu-secevent-event-stream-mgmt-api-00, as it helps to define how the “sub” event payload claim should work. This spec defines Subject Identifier Types for email, phone number, and issuer and subject, and has a big ole’ TODO for an IANA registry for these.
  *   Added section defining a Related Events event, along the lines of the proposal Justin posted to the list earlier today.
     *   There’s a lot of language there around making clear the requirements for SETs containing this event, trying to minimize ambiguity and clarify requirements. We’ll want to take a good look at this.
  *   Added sub-section on event extensions, giving guidance on how to play nice with one another.

I listed all the authors from the -03 draft on this one, since I started from -03 and pared down/edited to get to this one, but I’m honestly not sure what the etiquite is here, e.g. leave people as authors on something they haven’t had input into yet or move them to acknowledgements? Feel free to let me know if you want me to remove you as an author. Currently, the authors listed are myself, Phil, William, Morteza, and Mike.

--
Annabelle Richard Backman
Amazon – Identity Services

From: Id-event <[email-masked]> on behalf of "Richard Backman, Annabelle" <[email-masked]>
Date: Tuesday, November 14, 2017 at 12:11 PM
To: Luke Camery <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Id-event] Plan for the Week

  •  Luke Camery
  •  Associate Product Manager
  •  Federated Identity