Subject: [Id-event] Version -04 of "Push-Based SET Delivery Using HTTP"

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Thu, 24 Jan 2019 17:09:30 +0000

The editors have published an update to “Push-Based Security Event Token (SET) Delivery Using HTTP” (draft-ietf-secevent-http-push<https://datatracker.ietf.org/doc/draft-ietf-secevent-http-push/>). This update includes changes based on feedback received in Bangkok, along with minor readability edits. Thank you to all those who commented on the -03 draft!

Notable changes:

  *   Replaced Error Codes with smaller set of meaningfully differentiated codes, and added more error response examples to demonstrate flexibility of `description` property.
  *   Added requirement that error descriptions and responses are UTF-8 encoded.
  *   Added error description language preferences and specification via `Accept-Language` and `Content-Language` headers.
  *   Added requirement for recipient to validate that the issuer of a received SET is one that they are willing to accept SETs from.
  *   Added time outs as an acceptable reason to resend a SET.

The -04 draft can be found here: https://tools.ietf.org/html/draft-ietf-secevent-http-push-04

--
Annabelle Richard Backman
AWS Identity

---

From: Dick Hardt <[email-masked]>
Date: Thu, 24 Jan 2019 10:07:02 -0800

Thanks Annabelle!

On Thu, Jan 24, 2019 at 9:09 AM Richard Backman, Annabelle <richanna=
[email-masked]> wrote:

> The editors have published an update to “Push-Based Security Event Token
> (SET) Delivery Using HTTP” (draft-ietf-secevent-http-push
> <https://datatracker.ietf.org/doc/draft-ietf-secevent-http-push/>). This
> update includes changes based on feedback received in Bangkok, along with
> minor readability edits. Thank you to all those who commented on the -03
> draft!
>
>
>
> Notable changes:
>
>    - Replaced Error Codes with smaller set of meaningfully differentiated
>    codes, and added more error response examples to demonstrate flexibility of
>    `description` property.
>    - Added requirement that error descriptions and responses are UTF-8
>    encoded.
>    - Added error description language preferences and specification
>    via `Accept-Language` and `Content-Language` headers.
>    - Added requirement for recipient to validate that the issuer of a
>    received SET is one that they are willing to accept SETs from.
>    - Added time outs as an acceptable reason to resend a SET.
>
>
>
> The -04 draft can be found here:
> https://tools.ietf.org/html/draft-ietf-secevent-http-push-04
>
>
>
> --
>
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event
>