Subject: member leaves the group in IGMPv3

From: Abdelkader Lahmadi <[email-masked]>
Date: Wed, 6 Jun 2001 13:03:56 +0200

hi,
 IGMv2  take the  care of sending a leave message, but in IGNPv3, there`nt this
kind of messages, so in IGMPv3 when the router know that a member leave a group
?
regards  -- 
---------------------------------------------
  Lahmadi Abdelkader
  LORIA - UHP NANCY I
  CAMPUS SCIENTIFIQUE B.P.239
  54506 VANDOEUVRE-LES-NANCY CEDEX
  E-mail : [email-masked]
---------------------------------------------

---

From: Ali Boudani <[email-masked]>
Date: Wed, 06 Jun 2001 14:56:01 +0200

More specific !!!!
there is a leave message from (S, G)

---

From: Christopher Thomas Brown <[email-masked]>
Date: Wed, 06 Jun 2001 11:37:57 -0400

The member leaving the group sends a V3 membership report for the group with
mode INCLUDE and sources NULL.

ctbrown

On Wed, 06 Jun 2001 13:03:56 +0200

---

From: Wilbert de Graaf <[email-masked]>
Date: Wed, 6 Jun 2001 09:49:39 -0700

Hi Lahmadi,

> kind of messages, so in IGMPv3 when the router know that a member leave a
group

There is something similar in IGMPv3, although there are two cases:
1) The host is in exclude mode, like ex {A}. Then it will send to_in {}
2) The host is in include mode, like inc {A}. Then it will send block {A}

So only for 1) it is similar to an IGMPv2 leave. For 2) it shouldn't matter
for the router. (For a layer 2 switch such a s ethernetswitch it's a little
bit more difficult I guess).

Wilbert