Subject: IGMP V2 (RFC2236) clarification

From: Theodoros Kallimanis <[email-masked]>
Date: Tue, 14 Oct 2003 11:41:48 +0300

Hello,

I will appreciate a lot if you can clarify a point in IGMP V2 RFC 2236. In the protocol description (ch. 3) the following phrase is mentioned:

" When a host joins a multicast group, it should immediately transmit an unsolicited Version 2 Membership Report for that group, in case it is the first member of that group on the network"

The phrase refers actually to the original join of the group by a non-memebr host. The undelined part of the phrase is the part where I need a clarification. How the "non-member" host can identify that it is the first member of the group? At the state machine diagram at chapter 6 / page 10, no reception of "join group" is shown at Non-Member state. The text at chapter 3 indicates that the Membership Report is sent immediately, so it is assumed that no response delay exists in the case of the initial membership reports sending. Can you clarify please if this is a valid point on the RFC and if it is how this is supposed to be realized?

Best Regards and thanks in advance for the assistance
================================
    Theodoros Kallimanis
     Systems and SW engineer
     INTRACOM SA
     Dept "Access & Transmission"
     tel : +30-210-6671961
================================

---

From: Bill Fenner <[email-masked]>
Date: Tue, 14 Oct 2003 08:52:10 -0700

Theodoros,

The host transmits the unsolicited report immediately and unconditionally
upon joining (the transition out of the bottom of the "Non-Member" state
in the state machine you referenced).  The "in case it is ..." phrase
is meant to be justification, not a conditional.

  Bill