Subject: Re: [idn] Report from the ACE design team

From: Kenneth Whistler <[email-masked]>
Date: Tue, 26 Jun 2001 14:15:54 -0700 (PDT)

[email-masked] wrote:

> Maurizio Codogno <[email-masked]> wrote:
> > > The following points are my main concern:
> > > 
> > > 1) Is 14-15 character is enough?
> > >    At least for Japanese domain names, name of a company or an
> > >    organization is sometimes quite long.

> 
> > Could you please give some example of a name of
> > a Japanese organization with a long string of characters? (actually the
> > number of characters in Japanese and a rough translation will suffice,
> > since I cannot read Japanese).
> 
> Sure.  I looked around and found two examples.  Both names exceed 15
> characters and DUDE cannot encode them, but other more space efficient
> ACEs can.
> 
> 1. JPNIC (the registry of .jp domain)
> JPNIC's official name consists of 25 characters.  Most of the characters
> are phonograms (Katakana), though.
> 
>   U+793E U+56E3 U+6CD5 U+4EBA U+65E5 U+672C U+30CD U+30C3 U+30C8 \
>   U+30EF U+30FC U+30AF U+30A4 U+30F3 U+30D5 U+30A9 U+30E1 U+30FC \
>   U+30B7 U+30E7 U+30F3 U+30BB U+30F3 U+30BF U+30FC

25 characters long, and would probably be too long for most of the
other ACE's, too, right?

> 
> 2. A helth-insurance organization in Tokyo
> This name also contains a few phonograms, but most are ideograms.
> 
>   U+6771 U+4EAC U+90FD U+60C5 U+5831 U+30B5 U+30FC U+30D3 U+30B9 \
>   U+7523 U+696D U+5065 U+5EB7 U+4FDD U+967A U+7D44 U+5408

Tookyooto joohoo saabisu sangyoo kenkoo hooken kumiai

"Tokyo City Information Service Industrial Health Insurance Association"

There is, of course, some question whether organizations with such
long names would be looking to register the complete name as an IDN,
in any case. I don't know about this particular one, of course, but
many organizations with very long official names regularly abbreviate
them for internal and external use, simply because an expression like
"Tookyooto joohoo saabisu sangyoo kenkoo hooken kumiai" is too much of
a mouthful for practical use, anyway. And count up, for a typical
Japanese input method, how many keystrokes it would take to input
this -- not practical for a domain name on that criterion either.

Note that the equivalent English:

Tokyo_City_Information_Service_Industrial_Health_Insurance_Association.jp

would be 70 characters long and too long for a domain name, too!

Other comparable English examples:

American College of Occupational and Environmental Medicine

   uses: acoem.org

New York Committee for Occupational Safety and Health

   uses: nycosh.org

Metropolitan Safety Council of the Greater New Orleans Area

   uses: metrosafety.org

And the exception that proves the rule:

Partner's Occupational Medical Services Ltd

   uses: partnersoccupationalmedicalservices.com   (ick!)

--Ken

---

From: "Soobok Lee" <[email-masked]>
Date: Wed, 27 Jun 2001 09:34:36 +0900

Compared with AMC-W and LDUDE,  
bare DUDE-02 seems to produce  roughly 20% longer ACE labels
for average-length (6 hangul syllables)  Hangul domain.

Shorter ACE labels benefits both the computer, network and humans:

 1. save momory resources
     shorter IDN zone file
     save memory space of  intermediate DNS/Web cache servers
     shorter log file for dns/web/mail transactions
     shorter X.509 v3 certificates
     shorter Http cookie cache entries
     shorter  MIME headers for multilingual email address

 2. reduce traffic
    shorter DNS queries
    shorter HTTP host: header value
    shorter SMTP session from to  and rcpt to: tags
    
 3. for humans
    more easy to transcript
    good for administrators to manage leaked ACE labels

For extreme cases of resulted ACE labels exceeding 63 octets limit,
we can enumerate several korean website addresses 
registered to kr.yahoo.com with their titles longer than 15
Hangul syllables.

 1. http://www.kyongnam.wo.to/  (19 hangul syllables )
 2. http://www.ilgi.or.kr/   ( 16 hangul )
 3. http://www.homeless.or.kr/ (  18 hangul )
 4. http://www.stims.or.kr/ ( 19 )
 5. http://guitar.zzo.net/ ( 18)
 6. http://home.hanmir.com/~edinfor/ ( 21 )

If you want to get thousands of more such cases, search 
http://kr.dir.yahoo.com/Education/Organizations/
http://kr.dir.yahoo.com/Society_and_Culture/Cultures_and_Groups/Teenagers/Organizations/
http://kr.dir.yahoo.com/Society_and_Culture/Environment_and_Nature/Organizations/
http://kr.dir.yahoo.com/Business_and_Economy/Organizations/Trade_Associations/
and its parent nodes.

Long hangul website names are often composed in these manner:
- (regional name)+(organization category name)  
- (natural sentence without white spaces).

Why do we restrict  these free naming conventions ?

With slight modification to DUDE, we can fullfil these needs.

Soobok Lee.
[email-masked]

---

From: Yoshiro YONEYA <[email-masked]>
Date: Wed, 27 Jun 2001 11:25:05 +0900 (JST)

Hi,

From: Kenneth Whistler <[email-masked]>
Subject: Re: [idn] Report from the ACE design team
Date: Tue, 26 Jun 2001 14:15:54 -0700 (PDT)

> 25 characters long, and would probably be too long for most of the

Yes.

> Tookyooto joohoo saabisu sangyoo kenkoo hooken kumiai

Good! Only one correction: s/hooken/hoken/ :-)

> a mouthful for practical use, anyway. 

Domain name registrant can have more than one domain names under many
TLDs.  For many reasons, many organizations have more than one domain
names in "short good" names and "exact" name.  I wrote following in
previous mail:

: From: Yoshiro YONEYA <[email-masked]>
: Subject: Re: [idn] Report from the ACE design team
: Date: Tue, 26 Jun 2001 11:42:13 +0900 (JST)
: 
: From my observation, many of long name organizations seem to register
: both "exact" name and "shorter" name.  I agree that shorter domain
: names are useful for end users.  While, I think it is also important
: for IDN to maximize possibility of representing organization's exact
: name.  The difficulty of remembering would depend on how much the name
: is popular.

> would be 70 characters long and too long for a domain name, too!

But not too long in Japanese :-)

-- 
Yoshiro YONEYA <[email-masked]>
           aka <[email-masked]>

---

From: Makoto Ishisone <[email-masked]>
Date: Wed, 27 Jun 2001 12:43:56 +0900

In message <[email-masked]>,
> > 25 characters long, and would probably be too long for most of the

Not exactly.  At least BRACE, AMC-ACE-{M,O,V,W} and MACE can handle this
long name, assuming 4-octet prefix or suffix.

						-- [email-masked]